AA_TL-MR3020-V1-02.jpg

© TP-Link Technologies Co., Ltd.

Den Mobile-Router TL-MR3020 aufmotzen

Der 1-Watt-Server

Mithilfe von OpenWRT befreien Sie den knuffigen kleinen Router TP-Link TL-MR3020 von seiner proprietären Firmware und bauen ihn zum Allround-Server fürs heimische Netz um.

Die Firma TP-Link [1] aus China produziert Router verschiedenster Leistungsklassen. Den TL-MR3020 (Abbildung 1) vermarktet der Hersteller als "Mobile Router", da er klein und leicht ist. Allerdings unterstützt er kein 3G (siehe Kasten "Die Hardware"), das lässt sich aber über den USB-Port nachrüsten.

Attraktiv ist der Router also vor allem für jene, die kein 3G brauchen oder sowieso schon einen UMTS-Stick haben und deshalb nicht in einen teuren UMTS-Mobile-Router investieren wollen. Hier soll aber nicht die "normale" Nutzung des Routers im Mittelpunkt stehen, sondern dessen Ausbau zu einem Mini-Server.

Dazu ersetzen wir die vorhandene Firmware durch OpenWRT [2], eine auf Kleinstgeräte spezialisierte Linux-Distribution. OpenWRT besitzt ein Paketmanagementsystem, das jenem der klassischen Distributionen in Nichts nachsteht, und so stehen den eigenen Vorstellungen nur die Grenzen der Hardware entgegen.

Die Hardware

Der TL-MR3020 ist ein kleines weißes Plastikkästchen (Abbildung 1) mit den Abmessungen 7,4 x 6,7 x 2,2 Zentimeter und einem Gewicht von nur 60 Gramm. Ein Mini-USB-Stecker dient der Stromversorgung, das beiliegende Netzteil liefert 1 Watt. Der Router funktioniert aber problemlos auch an einem USB-Port. Außerdem bringt der TL-MR3020 einen USB-2.0- und einen RJ45-Ethernet-Port (100 Mbit/s) mit. TP-Link liefert für Letzteren ein kurzes, flaches Patchkabel mit. Auf WLAN-Seite beherrscht der kleine Router IEEE 802.11b/g/n mit bis zu 150 Mbit/s.

Seinen Status signalisiert der TL-MR3020 über fünf LEDs, von denen sich vier programmieren lassen. Daneben gibt es einen für die WLAN-Einrichtung per WPS gedachten Taster sowie einen Schiebeschalter mit drei Positionen (3G/WISP/AP). Im Inneren des Routers werkelt eine mit 400 MHz getaktete ARM-CPU, der 32 MByte RAM zur Verfügung stehen. Das Betriebssystem residiert auf einem 4 MByte großen Flash-Chip. Der USB-Anschluss dient mit der originalen Firmware für den Anschluss eines UMTS-Sticks und den Betrieb als mobiler 3G-Router. Ohne Stick arbeitet das Gerät als WLAN-Access-Point.

Als nützlicher Zusatz zum TL-MR3020 empfiehlt sich ein Mini-USB-Hub von Pearl (Abbildung 1, rechts). Dieser integriert einen Micro-SDHC-Reader und stellt so auf einer Speicherkarte das im Artikel beschriebene erweiterte Root-Dateisystem bereit, ohne den USB-Port zu blockieren.

Die Platine des Routers enthält weitere Anschlüsse, die TP-Link aber nicht herausführt. Wer mit dem Lötkolben umgehen kann, nutzt weitere Komponenten wie eine serielle Konsole, eine I2C-Schnittstelle oder eine externe Antenne. Das OpenWRT-Wiki zeigt dazu auf seinen Seiten zum TL-MR3020 [3] einige Bilder und verlinkt zu entsprechenden Anleitungen.

Abbildung 1: Der TL-MR3020 von TP-Link (links) ist nicht größer als ein Handteller. Der Mini-USB-Hub von Pearl rechts daneben dient Erweiterungszwecken.

Auftakt

Der TL-MR3020 eignet sich aus zwei Gründen für unsere Zwecke gut: Einerseits kostet er mit 30 Euro nicht die Welt – falls Sie ihn einmal "bricken", dann tut das dem Geldbeutel nicht zu sehr weh. Andererseits baut der Hersteller keinerlei Hindernisse ein, welche die Installation einer fremden Firmware verhindern.

Laden Sie also die passende OpenWRT-Version herunter [3] und verbinden Sie sich gemäß der knappen, doch ausreichenden Anleitung des Routers mit der Weboberfläche des Geräts. Dort laden Sie die neue neue Firmware per Upload im Webformular auf den TL-MR3020 (Abbildung 2).

Abbildung 2: OpenWRT laden Sie als Firmware-Update über die originale Weboberfläche auf den TL-MR3020.

Dabei handelt es sich um den einzigen wirklich kritischen Schritt bei der ganzen Sache. Ein fehlerhaftes Firmware-Image sendet den Router ins Nirvana – nur wer löten kann, hat noch eine Chance. Lesen Sie deshalb vor dem Einspielen unbedingt noch einmal die einschlägigen Artikel im OpenWRT-Wiki [3] durch und beachten Sie die entsprechenden Hinweise.

Nach der Installation von OpenWRT steht zunächst die Basiskonfiguration an, insbesondere des Netzwerks. Als nächstes kommt das Einrichten einer Reihe von Softwarepaketen, welche die USB-Unterstützung von Datenspeichern (USB-Sticks oder Festplatten) nachrüsten. Dadurch kann der Router dann von einem externen Datenträger starten. Auf dem so erweiterten Root-Dateisystem landen dann weitere Softwarepakete aus dem OpenWRT-Repository für den eigentlichen Anwendungszweck.

Erster Kontakt

Nach dem Firmware-Upgrade und dem Neustart des Geräts verbinden Sie Ihren PC oder Laptop per Kabel mit dem Router, konfigurieren das Netzwerk (normalerweise sorgt der Netzwerkmanager dafür) und melden sich per Telnet auf der Adresse 192.168.1.1 an (auf dem Router läuft ein DHCP-Server, der den PC oder Laptop mit einer geeigneten Adresse versorgt).

Abbildung 3: Geschafft: Die erste Anmeldung an OpenWRT steht an.

An dieser Stelle setzen Sie ein Passwort für root. OpenWRT schaltet dann aus Sicherheitsgründen den Telnet-Server ab und fährt den SSH-Server hoch. Als nächstes passen Sie die Netzwerkkonfiguration so an, dass der Router im heimischen Netzwerk arbeitet, anschließend kommt zusätzliche Software auf den Rechner. Details zum Konfigurationssystem von OpenWRT lesen Sie im Kasten "OpenWRT konfigurieren" nach.

Da wir den Router als Server im Heimnetz nutzen wollen, sieht die Netzwerkkonfiguration so aus wie in Listing 1 (/etc/config/network) und Listing 2 (/etc/config/wireless) gezeigt. Die Zeilen 9 bis 15 von Listing 1 konfigurieren das WLAN-Interface. In Listing 2 sorgt die Zeile 19 dafür, dass der Server sich als WLAN-Client ins Netz integriert, nicht etwa als Access-Point beziehungsweise Router.

Nach einem beherzten Neustart findet sich das Gerät (hoffentlich) unter der konfigurierten Netzwerkadresse. Falls nicht, hilft der Notfall-Modus: Während des Bootens drücken Sie die WPS-Taste, sobald diese anfängt zu blinken. Wenn die LED-Lampe schneller blinkt, dann lassen Sie sie wieder los. Jetzt befindet sich das Gerät im sogenannten Failsafe-Modus, auf der vorgegebenen Adresse 192.168.1.1 läuft jetzt der Telnet-Daemon. Mit dem verbinden Sie sich und nehmen die notwendigen Korrekturen vor. Allerdings steht in diesem Modus auf dem Router kein DHCP-Server zur Verfügung: Sie müssen Ihrem eigenen Rechner per Hand eine passende IP-Adresse zuweisen.

Listing 1

# /etc/config/network -----------------
 config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'
 config interface 'wifi'
         option proto 'static'
         option ipaddr '192.168.3.100'
         option netmask '255.255.255.0'
         option gateway '192.168.3.1'
         list dns '192.168.3.1'
         list dns '8.8.8.8'

Listing 2

# /etc/config/wireless ---------------
 config wifi-device  radio0
    option type     mac80211
    option channel  11
    option macaddr 90:f6:52:e6:d7:b2
    option hwmode  11ng
    option htmode  HT20
    list ht_capab  SHORT-GI-20
    list ht_capab  SHORT-GI-40
    list ht_capab  RX-STBC1
    list ht_capab  DSSS_CCK-40
    # REMOVE THIS LINE TO ENABLE WIFI:
    # option disabled 1
 config wifi-iface
    option device     radio0
    option network    wifi
    option mode       sta
    option ssid       'meine-ssid'
    option encryption psk2
    option key        'geheim'

OpenWRT konfigurieren

Das Konfigurationsystem von OpenWRT ist über alle systemnahen Pakete hinweg sehr konsistent gehalten. Alle Konfigurationsdateien liegen unter /etc/config. Es handelt sich um einfach strukturierte Klartextdateien, die Sie am schnellsten per Editor ändern.

Für den späteren produktiven Betrieb des Routers eignet sich das Webinterface als Alternative zum Editor: Hier passen Sie bequem einzelne Konfigurationsparameter an und fragen den Systemstatus ab (Abbildung 4). Eine weitere Alternative bietet eine Schnittstelle für die Kommandozeile. Der Befehl:

$ uci get system.slider.handler

liest den Wert der Option handler des Abschnitts slider aus der Datei /etc/config/system. Für Skripte stellt die Bibliothek /lib/functions.sh ein paar Utilities bereit, die den Umgang mit Einstellungen deutlich erleichtern.

Abbildung 4: Über die Weboberfläche von OpenWRT lassen sich auch Konfigurationsdaten abfragen.

Diesen Artikel als PDF kaufen

Express-Kauf als PDF

Umfang: 7 Heftseiten

Preis € 0,99
(inkl. 19% MwSt.)

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 
TABLET & SMARTPHONE APPS
Bald erhältlich
Get it on Google Play

Deutschland

Ähnliche Artikel

  • WLAN-Router mit OpenWRT funktional ausbauen
    Mit der kostenlosen Firmware-Alternative OpenWRT erweitern Sie das Einsatzspektrum vieler WLAN-Router und Access-Points um zahlreiche Profi-Funktionen und viele nützliche Dienste.
  • OpenWrt in Version 8.09
    Mit etwa einem halben Jahr Verzögerung ist nun die freie Router-Firmware OpenWrt Kamikaze in Version 8.09 erschienen.
  • Gelinkt
    Linksys bewirbt den WLAN-Router WRT1900AC damit, dass er sich mit einer Open-Source-Firmware und OpenWrt betreiben lässt. Wir testen den Nachfolger des beliebten WRT54G auf Herz und Nieren.
  • Asus zeigt Memo, Transformer und Slider

    Mit dem 7-Zoll-Gerät Eee-Memo und die 10-Zoll-Tablets Slider und Transformer hat Asus bei der laufenden Consumer Electronics Show in Las Vegas drei Geräte mit Android-Betriebssystem angekündigt
  • Mit Samba ein kleines Netz einrichten
    Wer zu Hause ein Netzwerk mit heterogenen Clients betreibt, wünscht sich zentrale Dienste zum einfachen Zugriff auf Dateien und Peripheriegeräte. Samba bietet in diesem Fall genau das Richtige, und zudem lässt sich die Lösung mit allen gängigen Distributionen aufsetzen.
Kommentare

Infos zur Publikation

LU 10/2016: Kryptographie

Digitale Ausgabe: Preis € 0,00
(inkl. 19% MwSt.)

LinuxUser erscheint monatlich und kostet 5,95 Euro (mit DVD 8,50 Euro). Weitere Infos zum Heft finden Sie auf der Homepage.

Das Jahresabo kostet ab 86,70 Euro. Details dazu finden Sie im Computec-Shop. Im Probeabo erhalten Sie zudem drei Ausgaben zum reduzierten Preis.

Bei Google Play finden Sie digitale Ausgaben für Tablet & Smartphone.

HINWEIS ZU PAYPAL: Die Zahlung ist ohne eigenes Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!

Aktuelle Fragen

Probleme mit MPC/MPD
Matthias Göhlen, 27.09.2016 13:39, 2 Antworten
Habe gerade mein erstes Raspi Projekt angefangen, typisches Einsteigerding: Vom Raspi 3B zum Radi...
Soundkarte wird erkannt, aber kein Ton
H A, 25.09.2016 01:37, 6 Antworten
Hallo, Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linu...
Scannen nur schwarz-weiß möglich
Werner Hahn, 20.09.2016 13:21, 2 Antworten
Canon Pixma MG5450S, Dell Latitude E6510, Betriebssyteme Ubuntu 16.04 und Windows 7. Der Canon-D...
Meteorit NB-7 startet nicht
Thomas Helbig, 13.09.2016 02:03, 4 Antworten
Verehrte Community Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen. Beim Start ersch...
windows bootloader bei instalation gelöscht
markus Schneider, 12.09.2016 23:03, 1 Antworten
Hallo alle zusammen, ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...