gnome-desktop unaufgefordert installiert

h. kellermann - Sonntag, 28. Februar 2010 13:05:15 - 6 Antworten

Hi Linuxers,
(SUSE 11.2, KDE4.4.0) updater-applet hatte einen großen Schwung an neuen updates, die ich -unvorsichtigerweise- einfach übernommen habe. Nach einiger Zeit stellte ich fest, dass jede Menge gnome-Dateien installiert wurden. Allerdings habe ich KDE installiert und nicht gnome! Ich war bislang der Meinung, dass nur installierte Programme zum update kommen!?
Nach Abbruch hatte ich schon das komplette gnome installiert. Das habe ich dann in mühseliger Kleinarbeit -wegen der unendlich vielen Abhängigkeiten- deinstalliert. Nach erneuten update-Vorschlägen für gnome stelle ich fest, dass 4 gnome-Dateien existieren: libgnome-keyring0, glib2-branding openSUSE, bundle-lang-gnome-da und bundle-lang-gnome-extra-ca.
Weitere Deinstallation ist völlig unmöglich, da w/Abhängigkeiten jede Menge neuer Dateien installiert werden. Vor allem gconf2 wird grundsätzlich wieder installiert. So habe ich plötzlich wieder 15 gnome-Dateien.
Wer weiß, wie ich das gnome wieder komplett loswerden kann?
Besten Dank im Voraus für alle hilfreichen Tips.

Antworten
Abhängigkeiten über Abhängigkeiten
DieterD (unangemeldet), Sonntag, 28. Februar 2010 14:16:00
Ein/Ausklappen

Es gibt Programme, die laufen unter KDE, obwohl für Gnome geschrieben, brauchen aber die Libraŕies von Gnome. Umgekehrt gibt es Programme, die laufen unter Gnome, obwohl für KDE geschrieben, brauchen aber die Libraries von KDE (qt3 und qt4).



Bewertung: 298 Punkte bei 52 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Abhängigkeiten über Abhängigkeiten
GoaSkin (unangemeldet), Sonntag, 28. Februar 2010 15:49:10
Ein/Ausklappen

Diese Programme brauchen ein paar Bibliotheken von Gnome bzw. KDE, aber nicht gleich den ganzen Desktop. Dennoch passiert es recht schnell, dass ein ganzer Desktop samt Applikationen installiert wird, obwohl man nur ein kleines Programm installieren wollte. Dies aber nicht nur bei einzelnen Distributionen. Teilweise sind die Abhängigkeiten eben recht unsinnig gesetzt - insbesondere bei weniger bedeutsamen Paketen, die nicht jeder installiert. Manchmal passiert dies auch, um die Funktionalität einiger Features sicherzustellen - ganz unabhängig davon, ob man sie braucht. WINE bräuchte prinzipiell z.B. weder Samba noch SANE. Bei vielen Distributionen werden diese Pakete jedoch zwangsweise mitinstalliert, damit diese optionalen Features funktionieren.


Bewertung: 272 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Abhängigkeiten über Abhängigkeiten
h. kellermann, Montag, 01. März 2010 21:13:35
Ein/Ausklappen

Danke für die Infos.
Allerdings hatte ich bis zu diesem KDE-update kein Gnome-update-Problem. Kann mich nicht erinnern, sowas jemals angeboten bekommen zu haben.
Jetzt bekomme ich ständig updates für den gnome-desktop angeboten, was einfach lästig ist!
Die Frage ist: welche gnome-Dateien brauchen wir denn grundsätzlich, dass dieser Unsinn aufhört und nicht permanent die Gefahr besteht, wieder mal den gesamten gnome-desktop installiert zu bekommen. Das ist mehr als ärgerlich und absolut nicht akzeptabel!


Bewertung: 269 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Abhängigkeiten über Abhängigkeiten
Martin Weißhaupt, Dienstag, 02. März 2010 08:19:55
Ein/Ausklappen

Prinzipiell werden bei einem KDE-Desktop eigentlich gar keine Gnome-Dateien gebraucht.

Wenn jedoch Programme installiert sind, die sich in Gnome integrieren, dann werden diese Abhängigkeiten natürlich installiert. Das ist ja bei KDE-Programmen genau so.

Ich würde also erst einmal nach Gnome-Programmen gucken und überlegen ob man nicht doch lieber auf KDE-Alternativen umsteigen möchte.

Dass der komplette Desktop installiert wird klingt etwas eigenartig, evtl. ist das ein Bug.


Bewertung: 289 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Abhängigkeiten über Abhängigkeiten
GoaSkin (unangemeldet), Sonntag, 07. März 2010 15:30:57
Ein/Ausklappen

Ich nutze derzeit einen KDE4-Desktop unter OpenSuSE, aber mit ein paar Gnome-Anwendungen zur Grafikbearbeitung. Ich konnte es bislang verhindern, dass mir das System einen ganzen Gnome-Desktop installiert, allerdings wurde z.B. der Gnome-Texteditor 'gedit' installiert. Versuche ich den zu deinstallieren, bemängelt YaST, dass eine notwendige Abhängigkeit fehlen würde und schlägt vor, dass 38 weitere Pakete deinstalliert werden sollen.

Teilweise sind die Abhängigkeits-Pakete eben unsinnig zusammengestellt. Ich muss aber auch dazusagen, dass ich eine Menge Community-Repositories eingebunden habe und mir gut vorstellen kann, dass Keines der Pakete aus den Standard-Repositories gedit als Abhängigkeit braucht.



Bewertung: 286 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Abhängigkeiten über Abhängigkeiten
h. kellermann, Montag, 08. März 2010 20:10:17
Ein/Ausklappen

Ja, das ist wirklich undurchsichtig und schwierig.
Ich entdecke ja immer wieder Pakete, die ich absolut nicht brauche und die Installation nur unnötig aufblähen. Wir alle wollen ja ein möglichst schlankes und schnelles System. Aber die Deinstallation ist wegen der oft unzähligen Abhängigkeiten ziemlich unmöglich.
Habe auch schon erlebt, dass das Volumen der zu deinstallierenden Pakete durch zwingend erforderliche Ersatzinstallation anderer Pakete bei weitem übertroffen wurde.
Vielleicht gibt es da im System noch Optimierungspotential, bzw. wäre schon für die Grundinstallation ein möglichst schlankes System wünschenswert.


Bewertung: 275 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • News und Programme rund um GNOME
  • Riesiger Zwerg
    Ab Ende April erscheinen unter anderem von Ubuntu, Mandriva und Fedora neue Distributionen, die in der Gnome-Variante auf das aktuelle Gnome 2.30 setzen. Dieser Artikel zeigt, welche Neuerungen in dieser Gnome-Version stecken.
  • Alter Name, neuer Desktop: Gnome 3
    Der Wechsel auf Gnome 3 ist für Anwender ein großer Schritt: Konzept und Philosophie von Gnome 3 unterscheiden sich deutlich vom Vorgänger. Gnome-Freunde müssen sich entscheiden, ob sie erheblichen Lernaufwand in die Bedienung eines quasi neuen Desktops investieren oder sich mit der gleichen Energie besser der Konkurrenz KDE 4.7 zuwenden. Wir helfen bei der Entscheidung.
  • Alles muss rein!
    Ubuntu 9.10 kann über einen Mangel an neuen Features nicht klagen: Upstart, Palimpsest, Grub 2, Ubuntu One, Software-Center, die Liste geht weiter. Wir zeigen, ob das gut geht.
  • Desktop-Alternative GNOME 1.2
    Von vielen X11-Anwendern nicht beachtet und von manchen Distributoren gar vorzeitig abgeschrieben meldet sich die Desktop-Umgebung GNOME in einer neuen Version zurück. LinuxUser stellt Ihnen die wichtigsten Komponenten von Helix GNOME 1.2 vor und hilft Ihnen bei der Frage, ob sich ein Upgrade bzw. eine Neuinstallation lohnt.

Aktuelle Fragen

Samsung VG-KBD1500 - Bluetooth-Tastatur mit Touchpad mit Xubuntu 16.04.2 LTS
Linux- & BSD-UserGroup im Weserbergland, 16.08.2017 19:16, 0 Antworten
Bin grad mit "meinem Latein am Ende" darum hier mal so in den Raum geworfen. Samsung VG-KBD1500 -...
Tails verbindet nicht mit WLan
Georg Vogel, 30.07.2017 15:06, 5 Antworten
Hallo zusammen! Habe mir von Linux Mint aus einen Tails USB-Stick erstellt. Läuft soweit gut,...
Genivi for Raspberry Pi 3
Sebastian Ortmanns, 28.07.2017 10:37, 1 Antworten
I try to build a Genivi Development Platform for Rasberry Pi 3. But I always get the failures bel...
Bash awk Verständnis-Frage
Josef Federl, 22.07.2017 17:46, 2 Antworten
#!/bin/bash # Skriptdateiname = test.sh spaltennummer=10 wert=zehner awk '{ $'$spaltennummer'...
Bash - verschachtelte Variablenersetzung, das geht doch eleganter als meine Lösung?
Josef Federl, 18.07.2017 20:24, 3 Antworten
#!/bin/bash #Ziel des Skriptes wird sein die ID zu extrahieren hier nur als Consolentest: root@...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Internet Geschwindigkeit
Udo Teichmann, 19.08.2017 15:49
Am Samstag, den 05.08.2017, 18:20 +0200 schrieb Udo Teichmann: Liebe fleißige Helfer Vielen Dank für den Ti...
[EasyLinux-Ubuntu] Notebook wacht nicht mehr auf
Gerhard Blaschke, 19.08.2017 15:04
Hallo Liste, habe hier ein Notebook Acer Extensa 5630 mit Wheezy. Testweise habe ich es in den Ruhezustand...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 18.08.2017 08:52
Hallo Volker, Volker schrieb am 18.08.2017 um 07:33: > volker@volker-Aspire-E5-575:~$ echo $PWD &&am...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 18.08.2017 07:33
Hallo Uwe, Am 16.08.2017 um 21:56 schrieb Uwe Herrmuth: > > Dann hab ich eine ganz gewagte Vermutu...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 21:56
Hallo Volker, Volker Borst schrieb am 16.08.2017 um 19:22: > > echo $PS1 > > ${debian_chr...