410 Druckertreiber von IBM für Linuxprinting

Aufmacher News

410 Druckertreiber von IBM für Linuxprinting

Kurt Pfeifle
27.04.2002

OMNI Version 0.6.1 ist jetzt freigegeben. OMNI ist ein IBM-Projekt, das Druckertreiber für Linux entwickelt. Derzeit werden 410 Modelle unterstützt. Es steht unter der LPGL (Lesser General Public License).

OMNI ist entstanden aus dem KnowHow, das IBM bezüglich Druckertreibern für OS/2 angesammelt hat. Das Interessante daran ist der modulare Ansatz der OMNI-Architektur, die es ermöglicht, zusätzliche Modelle per "Plug-In" zu unterstützen.

Die wichtigsten Neuerungen dieser Release sind:

Anmerkungen zur Anbindung an die Linuxprinting.org-DB:

Nachdem dies bereits seit längerem durch Gimp-Print, und vor kurzem HP mit dem HPInkJet-Projekt erfolgt ist, mausert sich Linuxprinting.org, in den letzten 18 Monaten weitgehend in Eigenregie und Freizeitarbeit erstellt durch Grant Taylor (Autor des "Linux Printing HOWTO") und Till Kamppeter (MandrakeSoft Drucker-Guru), mehr und mehr zum de-Facto-Standard für alle Fragen rund um's Drucken.

Bereits heute ist diese Datenbank mit weit über 1.100 gelisteten Modellen (gut gegliedert, mit Einstufung der Linux-Unterstützung von "Paperweight" bis "Perfectly") weitaus aktueller und detaillierter bestückt als z.B. die SuSE-Datenbank, in der man derzeit Angaben zu nur 441 Druckermodellen findet.

Dass OMNI die Eigenschaften seiner Druckermodelle jetzt ebenfalls in der "Foomatic"-XML-Datenstruktur ablegt, wie sie bei Linuxprinting.org als Ausgangspunkt zur automatischen Erzeugung von Konfigurationsdateien für veschiedene Spooler (CUPS, PDQ, PPR, BSD-LPD, GNUlpr, LPRng, Direct-O-Matic) dient, erleichtert in Zukunft die Einbindung der unterstützten Drucker und deren automatische Vorkonfiguration mit sinnvollen und funktionierenden Einstellungen durch Linux-Distributionen erheblich.

Einige wichtige Linuxdistributionen verwenden bereits heute einen direkten Zugang zur Foomatic-Datenbank, um ihre Releases up-to-date zu halten. Distributionen, die sich von dieser Entwicklung abschotten und "eigene Brötchen backen" wollen, werden sicherlich mehr Aufwand treiben und Geld ausgeben müssen, wollen sie denselben Level an Service-Qualität erreichen oder halten, der durch eine Anbindung an Linuxprinting.org möglich wird.

Eine Liste der unterstützten Modelle ist auf der OMNI-Website zu finden.

Wer verzweifelt nach einem Treiber für sein Modell sucht, weil es bisher weder von Gimp-Print (GPL), noch von ESP PrintPro (kommerzielle CUPS-Version), HPIJS (Freie Software, BSD-artige Lizenz), Foomatic (GPL) oder TurboPrint (Shareware, z.T. kostenlos) unterstützt wird, hat vielleicht Erfolg, wenn er das OMNI-Formular "Request Support for a New Device" ausfüllt...

Ähnliche Artikel

Kommentare

Aktuelle Fragen

Internet abschalten
Karl-Heinz Hauser, 20.02.2018 20:10, 0 Antworten
In der Symbolleiste kann man das Kabelnetzwerk ein und ausschalten. Wie sicher ist die Abschaltu...
JQuery-Script läuft nicht mit Linux-Browsern
Stefan Jahn, 16.02.2018 12:49, 2 Antworten
Hallo zusammen, ...folgender goldener Code (ein jQuery-Script als Ergebnis verschiedener Exper...
XSane-Fotokopie druckt nicht mehr
Wimpy *, 30.01.2018 13:29, 1 Antworten
openSuse 42.3 KDE 5.8.7 Seit einem Software-Update druckt XSane keine Fotokopie mehr aus. Fehler...
TOR-Browser stürzt wegen Wikipedia ab
Wimpy *, 27.01.2018 14:57, 0 Antworten
Tor-Browser 7.5 based on Mozilla Firefox 52.8.0 64-Bit. Bei Aufruf von http: oder https://de.wi...
Wifikarte verhindert Bootvorgang
Maik Kühn, 21.01.2018 22:23, 1 Antworten
iwlwifi-7265D -26 failed to load iwlwifi-7265D -25 failed to load iwlwifi-7265D -24 failed to l...