Ubuntu/Debian im Textmodus booten

FragenUbuntu/Debian im Textmodus booten
Peter Flicker - Samstag, 22. Mai 2010 10:22 Uhr

Hallo zusammen.
Meine Grafik spinnt und ich sehe nach dem Hochfahren nur einenen schwarzen Bildschirm (auch keine virtuellen Konsolen). Unter OpenSuse kann man am Bootprompt eine 3 eingeben, um das System im Textmodus hochzufahren.

Wie mache ich das bei Ubuntu oder Debian, dass der X-Server gar nicht erst zu starten versucht?

1 Antwort
Holger Naujokat - Freitag, 28. Mai 2010 09:15 Uhr

Versuch mal strg-alt-F2, wenn der Bildschirm schwarz ist, so kommt man jedenfalls in den Textmodus. x-server dann stoppen mit
sudo /etc/init.d/gdm stop bzw. restart. Mit strg-alt-F7 kommt man zurück in die Grafik. Vielleicht hilft das ja was.

Peter Flicker - Dienstag, 01. Juni 2010 08:24 Uhr

Genau das ist ja mein Problem. Das geht eben nicht. Deshalb möchte ich Ubuntu so starten, dass der X-Server gar nicht erst zu starten versucht. Das muss doch irgendwie gehen…….

l8star - Montag, 06. September 2010 21:03 Uhr

das gleiche Problem hatte ich auch.
Ursache war bei mir ein Treiberkonflikt der Grafikkarte.

Gelöst habe ich es folgendermaßen

1.) single-use modus als root starten (siehe grub beim booten)
2.) mittels aptitude alles grafische deinstallieren also
flgrx-*
gdm3 (gdm)
gnome oder kde … alle komponenten runter
danach war im apitude alles rot markiert – unsolve dependencies
also habe ich alles bis auf kernel, netzwerk und aptitude
deinstalliert
3) auf einem anderen rechner habe ich den aktuellen ati-treiber
gedownloadet
4) ins homeverzeichnis des problem-pc’s dann den treiber rauf
5) reboot multiuser –
6) ergebnis schwarzer bildschirm
7) strg + alt + F2 in die console
8) mit aptitude kernel (linux-header und linux-image) upgedatet
9) gdm3, xorg und gnome neu installiert (aptitude)
10) /etc/init.d/gdm3 stop — sicherstellen dass Graphic off ist
11) als root sh .//ati-driver-version.run Treiber neu rauf
12) /etc/init.d/gdm3 start
13) und siehe da es lief wieder

Viele Grüsse
Olivier

Deine Antwort