Soundkarte wird erkannt, aber kein Ton

FragenSoundkarte wird erkannt, aber kein Ton
H A - Sonntag, 25. September 2016 01:37 Uhr

Hallo,

Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linux-Neuling bin konnte ich es nicht lösen. Zu meinem Problem. Ich habe neulich Debian auf meinem PC installiert. Die HDMI Soundkarte wird zwar erkannt und im pavucontrol wird auch angezeigt, dass sich ein Ton abspielt. Aber der Ton kommt an meinem Monitor nicht an. Ich nun auf eine Hilfe angewiesen. Ich hoffe dass ihr mir helfen könnt.

Vielen Dank.

1 Antwort
H A - Sonntag, 25. September 2016 02:12 Uhr

Was ich vielleicht noch erwähnen kann ist. Also es ist nicht nur beim Monitor der Fall, dass kein Ton kommt sonder auch beim Kopfhörer oder ähnliches.

Kai - Sonntag, 25. September 2016 12:17 Uhr

Das kann extrem viele Ursachen haben:

Bist du sicher, dass nur eine Soundkarte im Rechner steckt? Wenn du beispielsweise eine NVidia-Karte hast, kann es sein, dass deren HDMI-Einheit ebenfalls als Soundkarte erkennt wird.

Dann ganz banal: Sind die Lautstärkeregler hochgezogen? Schau auch mal, ob der Lautstärkemixer für jede Anwendung einen eigenen Lautstärkeregler anzeigt.

Was ist das für eine Soundkarte? Wird die überhaupt von Linux erkannt, sprich: Sind proprietäre Treiber notwendig? (Die Anzeige einer Audio-Wiedergabe alleine sagt darüber noch nichts aus.)

H A - Montag, 26. September 2016 00:04 Uhr

ja genau die Nvidia Karte wird auch als Soundkarte im terminal aufgelistet. Ich bekomme diese Ausgabe:
0 [PCH ]: HDA-Intel – HDA Intel PCH
HDA Intel PCH at 0xf7340000 irq 149
1 [NVidia ]: HDA-Intel – HDA NVidia
HDA NVidia at 0xf7080000 irq 17

Im Alsamixer habe ich nichts gefunden, was falsch eingestellt sein konnte.
Wie kann ich schauen ob Treiber notwendig sind ?

Kai - Montag, 26. September 2016 10:52 Uhr

Dann solltest du als erstes schauen, ob der Ton über die falsche Soundkarte ausgegeben wird. (Das war zumindest auf meinen Rechnern das häufigste Problem.)

Wobei ich jetzt aber ad hoc nicht sagen kann, wie man die auszugebende Soundkarte unter Debian auswählt…

Für den HDA-Intel PCH sollte Linux eigentlich einen passenden Treiber mitbringen. Du kannst per „dmesg“ in einem Terminal schauen, ob der Treiber beim Laden Probleme macht.

H A - Montag, 26. September 2016 15:28 Uhr

die Treiber sind soweit in Ordnung (glaube ich)
dsmeg gibt diese Ausgabe:
[ 1.381882] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1f.3/sound/card0/hdaudioC0D0/input8
[ 1.382386] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input9
[ 1.382570] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1f.3/sound/card0/input10
[ 1.382793] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1f.3/sound/card0/input11
[ 1.383077] input: HDA Intel PCH Line Out Front as /devices/pci0000:00/0000:00:1f.3/sound/card0/input12
[ 1.383261] input: HDA Intel PCH Line Out Surround as /devices/pci0000:00/0000:00:1f.3/sound/card0/input13
[ 1.384039] input: HDA Intel PCH Line Out CLFE as /devices/pci0000:00/0000:00:1f.3/sound/card0/input14
[ 1.384349] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1f.3/sound/card0/input15

H A - Montag, 26. September 2016 15:29 Uhr

ich weiß nicht wie ich dass jetzt geschafft habe. Aber jetzt funktioniert es 😀
Ich danke dir nochmals für deine Antworten.

Deine Antwort