mount Problem

Fragenmount Problem
Stefan Koch - Donnerstag, 11. August 2005 15:57 Uhr

Hallo,

ich versuche mein Siemens MC60 zu mounten, dies funktioniert wunderbar mit:

mount -t siefs /dev/ttyS0 /media/mobile

Das Problem: Ich kann nur als root auf /media/mobile zugreifen. Warum nicht als normaler user? Als normaler user ist /media/mobile nicht mehr sichtbar vor dem mounten schon.

System: SUSE Linux 9.3

Danke!

1 Antwort
Wiebke Schroeder - Donnerstag, 11. August 2005 16:38 Uhr

Hallo Stefan.

Hast Du mal einen Blick in die /etc/fstab geworfen?

Wenn Du da nach dem Eintrag /dev/ttyS0 suchst und dann die letzte oder vorletzte Spalte dabei betrachtest, dann wird da wahrscheinlich eine Einschränkung auf den User root drinstehen, die verhindert, dass Du das Laufwerk auch als Normaluser mounten kannst.

Gruß

Wiebke

lightmaker - Donnerstag, 11. August 2005 17:36 Uhr

Dabei gehst Du aber davon aus, das schon ein Eintrag in der /etc/fstab existiert. Unter Umständen muß dieser Eintrag aber erst erstellt werden.

Eine zusätzliche Zeile in der /etc/fstab sollte ungefähr so aussehen:

/dev/ttyS0 /media/mobile siefs user,noauto[,sonstige Optionen] 0 0

Dabei ist das „user“ die Option, die es dem normal User erlaubt externe Platten oder Systeme ins eigene System einzubinden.

Ich hoffe, das hilft weiter.

Stefan Koch - Donnerstag, 11. August 2005 21:18 Uhr

kann ich user nicht auch als option bei -o angeben?

Florian E.J. Fruth - Freitag, 12. August 2005 00:29 Uhr

ja kann man zb. mit mount -o uid=1000,gid=1000 /dev/foo /mnt/bar – aber dann musst du zum mounten root sein. wenn du in der /etc/fstab als option user eingibst kann man das device auch als user mounten.
fejf

Deine Antwort