Linux-resistenter PC ?

FragenLinux-resistenter PC ?
Christoph Brandl - Sonntag, 01. Januar 2012 23:14 Uhr

Ich krieg die Krise!
Versuche gerade auf einem nagelneuen PC mit
AMD A4-3400 auf einem Biostar Mainboard A55MH openSUSE 12.1 64 zu installieren.
Geht aber nicht. Nach der Auswahl der Sprache und „Installation“ kommt der grüne Bildschirm mit SUSE Logo. Dieser hat im mittleren Bereich einen Bildfehler (Pixelgewusel nur am oberen und unteren Bildschirmrand ist das Bild jeweils ein paar cm korrekt zu sehen.) Wenn ich ein wenig auf den Tasten rumdrücke, geht das ganze nach mehreren Minuten (!) weiter und ich komme zur Sprachauswahl. (Korrekte Darstellung.) Dann kommt der Bildschirm „Systemanalyse/Systemüberprüfung“. Dort läuft der grüne Balken bis 60% („Linux-Partitionen suchen“) bleibt dann nach einiger Zeit stehen und schaltet die Bildschirmausgabe komplett ab. (Monitor geht in Standby.)
Rein subjektiv würde ich sagen, der hat mit der Grafik massive Probleme. Die laufende Installer am PC friert nicht komplett ein, da er später noch mal auf die DVD zugreift und auch die NUM-LOCK LED lässt sich ein und aus schalten. Aber ich habe keine Ahnung, was ich machen soll. Ich habs auch mit Knoppix 6.7.1, Mint 12 und Ubuntu 11.10 64 probiert – immer dasselbe! Entweder wird der Bildschirm dunkel (oder der Monitor geht gleich in Standby) oder man sieht einfach ein wildes Pixelgewusel – und das war’s.
Hat jemand so was schon mal gehabt und wie gelöst?
Habe zum grundsätzlichen Hardwarecheck mal WinXP HP 32 installiert (jedoch nur bis zur Eingabe des Lizenz-Keys) das funktionierte soweit. Aber ich will ja SUSE und nicht Windows drauf haben. 🙁

1 Antwort
Werner Kowalek - Montag, 02. Januar 2012 02:10 Uhr

Und warum schreibst du nichts zu deiner Grafikkarte (Hersteller), wenn du sie schon in Verdacht hast? Aber egal, versuchen kannst du es.

Wenn du bei der Auswahl der Sprache bist, dann gebe in die Parameterzeile nomodeset ein. Beachte auch die F3-Taste. Hier kannst du es mit eine rniedrigeren Auflösung oder VESA versuchen.

Christoph Brandl - Montag, 02. Januar 2012 11:48 Uhr

Du bist super!
Das war’s! „nomodeset“ als Bootparameter und die Installation funzt!

Pardon, das ich nix zur Grafikkarte schrieb, aber ich hab gar keine drin. Nutze die Onchipgrafik der Prozessors.

Besten Dank!

Werner Kowalek - Montag, 02. Januar 2012 12:36 Uhr

Du musst nomodeset auch in der yast-Konfiguration/Bootloader/Bootloader-Einstellungen eintragen, sonst musst du es bei jedem Start angeben.

Auch eine onboard-grafik hat eine Bezeichnung.

Christoph Brandl - Mittwoch, 04. Januar 2012 19:59 Uhr

Das Eintragen als Bootloader-Option ist nicht erforderlich. Das installierte System läuft. (Ich habe aber jetzt nicht überprüft, ob das der Installer bereits selbst so konfiguriert hat, habe den PC nicht hier.)

Nein, es ist eine onchip-Grafik, keine onboard-Grafik. Das Mainboard stellt nur die Anschlüsse zur Verfügung, da die GPU auf dem CPU-Chip integriert ist.
Siehe auch:
http://www.amd.com/de/vision/learn/about/Pages/about.aspx

Aber du hast schon recht einen Namen hat die Grafik trotzdem:
Radeon HD6410D

Aber noch mal danke für den Hinweis.

Ulf B. - Donnerstag, 05. Januar 2012 00:17 Uhr

Hi Christoph,

mich würde interessieren ob openSUSE dieses automatisch in die /boot/grub/menu.lst eingetragen hat, oder ob dieses mit den nach der Installation verwendeten Grafiktreibern nicht mehr nötig ist (letzteres ist meine Vermutung – da die bei der Installation verwendeten Grafiktreiber doch arg abgespeckt sind).

> Radeon HD6410D
Sag doch gleich das Du einen FM1 verwendest – die Bezeichnungen dort sind mir noch nicht ganz so geläufig
http://de.wikipedia.org/wiki/AMD_Fusion#Modelle_f.C3.BCr_den_Desktop

Gruß
UIf

Christoph Brandl - Sonntag, 22. Januar 2012 20:11 Uhr

Hallo Ulf!

Ja, im fertig installierten System steht „nomodeset“ automatisch drin. Da es an erster Stelle steht, gehe ich aber davon aus, dass die Notwendigkeit nicht durch die Software ermittelt wurde, sondern es nur deshalb übernommen wurde, weil ich es dem Installer-System manuall mitgegeben habe.

Ich bezeiche die PC normalerweise anhand der Prozessoren und nicht anhand des Prozessorsockelnamens. Aber wenn du das so lieber siehst: ja es ist ein „FM1“.

Gruß
Christoph

Deine Antwort