KDE startet nicht mehr!!!

FragenKDE startet nicht mehr!!!
Klaus Weisbrich - Montag, 05. Juli 2010 21:20 Uhr

Liebe Community,
ich habe auf meinem Opensuse 11.2 die neue Version von K3b (2.0) aufgespielt. Dabei wurden zahlreiche kde-Pakete nachinstalliert – mit dem Ergebnis, dass KDE nicht mehr startet. Stattdessen kommt Icesowieso als GUI.
Ein kdeinit im Runlevel 3 brachte als Fehlermeldung : $DISPLAY is not set!!
Kann jemand helfen??

Gruß
Klaus

1 Antwort
max. - Dienstag, 06. Juli 2010 10:09 Uhr

vermutlich hast du mit dem K3b-Repo ein neues KDE-Repo aktiviert. Ich würde zunächst mal von einem Terminal aus mit

sudo zypper refresh
sudo zypper dup

sämtliche Pakete aktualisieren. Danach im Runlevel 3 mit dem Befehl

startkde

versuchen, KDE zu starten. Wenn das klappt, dann stimmt eventuell in der Datei /etc/sysconfig/displaymanager der Eintrag DISPLAYMANAGER=“kdm“ nicht. Sonst müsste eigentlich der Login-Bildschirm erscheinen, wo du KDE als Session auswählen kannst.

Klaus Weisbrich - Mittwoch, 07. Juli 2010 08:10 Uhr

Hallo Max,
zweimal zypper ist durchgelaufen. Allerdings wurden bei zwei Repos – irgendwas mit KDE4 – keine Metadateien gefunden, so dass diese nicht aktualisiert wurden.
Im Ergebnis startet KDE jetzt wieder – allerdings nicht vollständig. An allen sich öffenden Fenstern fehlt die Tietelleiste mit den Schalflächen rechts oben. Auch sind in der Kontrolleiste von mir angelegte Verknüpfungen zu **.desktop-Links nicht aktiv.
In der /etc/sysconf…-Datei steht kdm4, ändern auf kdm bringt keine Verbesserung.
Und der Versuch über startkde, kdeinit oder ähnliches bringt nur die oben genannte Fehlermeldung hervor: $DISPLAY not set …

Muss ich das ganze System noch `mal neu installieren?? Oder kann ich KDE sonst irgendiwe retten??

Gruß
Klaus

max. - Mittwoch, 07. Juli 2010 10:46 Uhr

Schau mal bei irgendeinem KDE-Programm in die Hilfe: Über KDE dort steht normalerweise die KDE-Version und die Programmversion (zum Beispiel Konqueror 4.4.4 unter KDE 4.5). Jetzt musst du dich entscheiden, welche KDE-Version du gerne hättest, danach die passenden Repos einbinden. Schick hier auch mal die Ausgabe von zypper lr, dann wissen wir mehr…

Klaus Weisbrich - Dienstag, 13. Juli 2010 22:32 Uhr

Hallo Max,
es scheint KDE 4.3.5 „release 0“ installiert zu sein.
Ausgabe zypper lr:
# | Alias | Name | Aktiviert | Aktualisieren
—+————————————-+——————————————————+———–+————–
1 | Education | Education | Nein | Ja
2 | KDE:KDE4:Community | KDE:KDE4:Community | Nein | Ja
3 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Nein | Ja
4 | OpenSuse11.2_64AddOn | OpenSuse11.2_64AddOn | Nein | Nein
5 | OpenSusee11.2 | OpenSuse11.2_64 | Nein | Nein
6 | devel:languages:misc | devel:languages:misc | Ja | Ja
7 | devel:languages:perl | devel:languages:perl | Ja | Ja
8 | download.opensuse.org-Community | openSUSE BuildService – KDE:KDE4:Community | Ja | Ja
9 | download.opensuse.org-Community_1 | openSUSE BuildService – Mono:Community | Ja | Ja
10 | download.opensuse.org-STABLE | openSUSE BuildService – OpenOffice.org | Ja | Ja
11 | download.opensuse.org-VirtualBox | openSUSE BuildService – Virtualisierung (VirtualBox) | Ja | Ja
12 | download.opensuse.org-mozilla | openSUSE BuildService – Mozilla | Ja | Ja
13 | download.opensuse.org-standard | Main Repository (Contrib) | Ja | Ja
14 | download.opensuse.org-xfce | openSUSE BuildService – XFCE | Ja | Ja
15 | download.videolan.org-SuSE | VideoLan Repository | Ja | Ja
16 | http://ftp.skynet.be-suse | Packman Repository | Ja | Ja
17 | hardware | hardware | Ja | Ja
18 | home:astrapi | home:astrapi | Ja | Ja
19 | home:astrapi:playground | home:astrapi:playground | Ja | Ja
20 | home:kkeil:ISDN | home:kkeil:ISDN | Ja | Ja
21 | home:mgerlach1:inkscape | home:mgerlach1:inkscape | Ja | Ja
22 | home:mrdocs | home:mrdocs | Ja | Ja
23 | http-download.opensuse.org-6267c1b9 | Aktualisierungen für openSUSE 11.2-0 | Ja | Ja
24 | openSUSE 11.2-0 | openSUSE 11.2-0 | Ja | Nein
25 | repo-debug | openSUSE-11.2-Debug | Nein | Ja
26 | repo-non-oss | openSUSE-11.2-Non-Oss | Ja | Ja
27 | repo-oss | openSUSE-11.2-Oss | Ja | Ja
28 | repo-source | openSUSE-11.2-Source | Ja | Ja
29 | www2.ati.com-suse | ATI Repository | Nein | Nein

Hilft uns das weiter??

Gruß
Klaus

DieterD - Sonntag, 25. Juli 2010 10:19 Uhr

Vermutllich hattest Du vorher eine andere KDE-Version aktiv. Die eigenenen Einstellungen befinden sich unter
/home/username/.kde/
/home/username/.kde/share/kde3
/home/username/.kde/share/kde4
und der Aufbau der Konfiguraionsdateien hat sich etwas geändert.

Wenn Du versuchst von kde3 etwas nach kde4 zu übernehmen, empfehle ich Dir einen zusätzlichen user (user_versuch) anzulegen und Dich unter diesem einzuloggen. Wenn es gänzlich schiefgeht unter
/home/user_versuch/.kde/share/kde4 (mit copy and paste)
ist das nicht weiter tragisch (löschen des user_versuch und wieder neu anlegen).

Deine Antwort