Geräte anstecken KDE – Fenster öffnet sich nicht mehr

FragenGeräte anstecken KDE – Fenster öffnet sich nicht mehr
Daniel Gultsch - Mittwoch, 22. Juli 2009 13:11 Uhr

Hallo,
wenn ich unter KDE 3.5 ein Gerät (Mass Storage (Ipod, Kamera, Externe Platte) dann ging bis vor kurzem immer ein kleines Fenster auf mit den Optionen im Dateimanager öffnen (und noch ein paar Sachen)) daraufhin wurde das Mass Storage gemountet. – Naja kennt ihr wahrscheinlich eh alle.

Jetzt kommt aber das Fenster nicht mehr. Und da ich nicht weiß, welche Technologien da hinter stecken hab ich keine Ahnung wie ich es Debuggen soll. Ich vermute mal HAL aber ich hab keine Ahnung. Also bitte ich mal um Hintergründe und Debug-Tips.

Gruß Daniel

3 Antworten
Daniel Gultsch - Mittwoch, 22. Juli 2009 13:33 Uhr

Ich bin’s direkt nochmal.

Hab vergessen zu sagen, dass das Device vom Kernel natürlich erstellt wird und ich es auch per Hand mounten kann.

Zusätzlich hab ich mal lshal –monitor laufen lassen. Auch dort wird das Device beim anstecken gelistet. HAL löst also Events aus, KDE ignoriert die aber.

ckpinguin - Mittwoch, 22. Juli 2009 20:39 Uhr

Hi
KDE 3.5 ist bei mir schon etwas länger her, aber ich erinnere mich, das Problem auch gehabt zu haben. Man kann es auf die üblichen zwei KDE-Arten lösen:
– Konfiguration der Aktionen für Wechselmedien (irgendwo in der KDE3 Systemsteuerung, sorry habe grad keins zur Hand)
– Löschen von .kde (womit Du aber auch ALLE KDE-releventen Einstellungen verlierst)
Leider ist die zweite Variante auch heute noch ab und zu (wenigstens nicht mehr so häufig) die einzige Variante bei seltsamen Problemen.

Greets

Chris

Gerd S. - Mittwoch, 22. Juli 2009 21:56 Uhr

Hallo,
ich vermute mal, Sie haben aus versehen das Häkchen „Die Auswahl für diesen Medientypen merken“ gesetzt und dabei den Eintrag „Nichts unternehmen“ markiert. Dann erscheint das Fenster nicht mehr.
Bei mir hat folgendes geholfen:
KDE Kontrollzentrum öffnen und auf „Zurücksetzen“ klicken. Dadurch werden alle Einstellungen zurückgesetzt. Aber das Fenster erscheint dann wieder.
Unter „Angeschlossene Geräte“ -> „Speichermedien“ können Sie nach Auswahl des Medientypes „Eingebundenes Wechsellaufwerk“ sehen, dass bei „Nichts unternehmen“ (Automatische Auswahl) dahintersteht, wenn Ihnen der o.g. Fehler passiert ist.

Hoffe geholfen zu haben.

MfG

Gerd

Daniel Gultsch - Donnerstag, 23. Juli 2009 11:14 Uhr

es funktioniert nun. Mein emerge hat hal neu gebaut und dann hats geklappt. Macht zwar irgendwie kein Sinn – es würde mehr sinn machen wenn er kded neu gebaut hätte weil sich die header files von HAL geändert haben – aber egal, hauptsache es geht nun.

Deine Antwort