beets bringt nur einen Fehler beim Starten

Fragenbeets bringt nur einen Fehler beim Starten
Christine F. - Montag, 17. Januar 2011 20:17 Uhr

Ich hab in der aktuellen LinuxUser von der Musikverwaltungssoftware beets gelesen, und wollte sie unbedingt ausprobieren. Mein Rechner läuft mit Ubuntu 10.04.

Ich hab also pip installiert, und dann mit pip beets installiert.
Dabei kam eine Warnung:
Running setup.py install for beets
WARNING: beetsplug is a namespace package, but its __init__.py does
not declare_namespace(); setuptools 0.7 will REQUIRE this!
(See the setuptools manual under „Namespace Packages“ for details.)

Skipping installation of /usr/local/lib/python2.6/dist-packages/beetsplug/__init__.py (namespace package)

(das ist ein Ausschnitt aus der Installationsausgabe)

Beim Start von beets mit „beet import ~/Musik“ kommt eine Fehlermeldung:
Traceback (most recent call last):
File „/usr/local/bin/beet“, line 9, in
load_entry_point(‚beets==1.0b5‘, ‚console_scripts‘, ‚beet‘)()
File „/usr/local/lib/python2.6/dist-packages/beets/ui/__init__.py“, line 441, in main
art_filename)
File „/usr/local/lib/python2.6/dist-packages/beets/library.py“, line 768, in __init__
self.conn = sqlite3.connect(self.path)
sqlite3.OperationalError: unable to open database file

Im Artikel ist aber nichts von sqlite drin gestanden. Jetzt bin ich etwas verloren.
Wie bekomme ich beets zum laufen? Oder soll ich mich besser nach einem anderen Programm umsehen, um meine Musiksammlung zu ordnen?

1 Antwort
Michael (Majestyx) Kappes - Freitag, 21. Januar 2011 18:37 Uhr

Hallo Christine,

Schau doch mal bitte hier

https://code.google.com/p/beets/

dort findest du sicher weitere Hilfe

Florian Effenberger - Montag, 24. Januar 2011 10:37 Uhr

Ich musste auf meinem System nichts nachinstallieren, aber möglicherweise wurde die sqlite-Datenbank schon durch ein anderes Programm vorinstalliert. Ich habe gerade mal nachgesehen, was bei mir installiert ist, und eventuell ist das Paket „libsqlite0“ bzw. „libsqlite3-0“ das, was du suchst. Versuch mal, das Paket nachzuinstallieren und lass mich wissen, ob es dann geht oder nicht. 🙂

Deine Antwort