Aktivlautsprecher unter LInux „still“ unter Windows gehen sie!

FragenAktivlautsprecher unter LInux „still“ unter Windows gehen sie!
Christian Lottmann - Montag, 02. Mai 2011 10:34 Uhr

Ich habe unter Windows funktionierende Aktivlautsprecher aber unter Linux Mint wollen sie nicht gehen – wie kann das sein?
Der Sound kommt unter Linux problemlos aus den Laptoplautsprechern – aber sobald ich den Klinkenstecker einstöpsle ist „Sendepause“. Die Lautsprecher sind – wie gesagt“ 100% in Ordnung – laufen perfekt unter dem ebenfalls installierten Windows….

Vielen Dank im Voraus für Hilfe!!

3 Antworten
Andrea - Dienstag, 03. Mai 2011 07:06 Uhr

– hat man überprüft, ob evtl. der Mixer auf 0/Mute steht? Mixer-Anwendung in der Taskleiste/Startmenü aufrufen bzw. Konsole öffnen –> alsamixer
– hat man mit einer Life-CD (Knoppix, Puppy Linux, Mandriva One) überprüft, ob bei einer anderen Linux-Distribution der Sound funktioniert?
– welcher Soundchip ist auf dem Board?

August Meier - Freitag, 06. Mai 2011 07:28 Uhr

Wenn beim Einstöpseln der Lautsprecher in die Ohrhörer-Buchse der Ton wegbleibt, liegt dies meist daran, dass in den Klang-Einstellungen ein Schalter „Headphone jack sense“, der eben dies erkennen soll, nicht umgelegt ist oder ein Kreuzchen in der entsprechenden „Checkbox“ fehlt.

Ergänzung zur Konsolenbasierten Anwendung „alsamixer“:
Unter („http://l4p.hackndev.org/node/133&#8220😉 findest Du folgende Anleitung nach dem Starten von „alsamixer“:

>When in alsamixer, turn up Headphones and unmute
>Headphones with the „m“ key. Next, turn on „PCM Playback to
>Headphone“ with the „m“ key.

Beste Grüsse

August Meier

Dieter D - Samstag, 14. Mai 2011 23:05 Uhr

Vermutlich ist die Ausgabe noch auf dem anderen Gerät. Zum Beispiel kann mit mplayer so auf verschiedene Geräte ausgegeben werden.

mplayer -af equalizer=5:3:1:0:0:0:0:-1:-2:-3 -af volume=0 -ao alsa:device=hw=0 song_nr1.mp3

mplayer -af equalizer=5:3:1:0:0:0:0:-1:-2:-3 -af volume=0 -ao alsa:device=hw=1 song_nr2.mp3

mplayer -af equalizer=5:3:1:0:0:0:0:-1:-2:-3 -af volume=0 -ao alsa:device=hw=2 song_nr3.mp3

Das funktioniert zum Beispiel mit dem internen Lautsprecher und zwei USB-Sound-Geräten. Auf jedem liegt so seperat ein anderer Sound. Das könnte helfen, die Ursache aufzuspüren.

Deine Antwort