Admin Probleme mit Q4os

FragenAdmin Probleme mit Q4os
Thomas Weiss - Montag, 30. März 2015 20:27 Uhr

Hallo Leute,

ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verlief ohne Probleme, beim einloggen werde nach Benutzername und Passwort gefragt soweit so gut.

Was mich nur wundert ist folgendes:
Wenn ich im Terminal einen Befehl mit sudo eingebe, wird das Passwort nicht abgefragt. Woran liegt das?

Als ich meinen Drücker mit localhost:631 installieren wollte, hat mein Rechner den Benutzername und Passwort nicht akzeptiert. Ich komme mit dem Login Benutzername und Passwort nicht weiter. Was mache ich falsch?

Vielen Dank für die Hilfe im Voraus!
Gruß
Thomas Weiss

1 Antwort
Thomas Weiss - Montag, 30. März 2015 20:37 Uhr

Hallo Leute,
ich bin auf Grund meiner Behinderung versehentlich auf Veröffentlichen gekommen, bevor ich mit der Überschrift fertig war!

Ich bitte Entschuldigung!
Gruß
Thomas

Tim Schürmann - Montag, 30. März 2015 23:18 Uhr

Ich habe die Überschrift angepasst.

Mit Q4OS kenne ich mich selbst zwar nicht aus, in der Regel merkt sich aber das System das eingegebene Passwort bei „sudo“. Man muss es dann nicht noch einmal eintippen.

Thomas Weiss - Dienstag, 31. März 2015 12:56 Uhr

Hallo Tim,

Vielen Dank fürs anpassen der Überschrift. Ich habe mich nur gewundert, denn bei Ubuntu muss man das Passwort eingeben sobald sudo benutzt.

Vielen Dank!
Thomas Weiss

Tim Schürmann - Dienstag, 31. März 2015 15:53 Uhr

Ja, immer beim ersten Mal. Dann merkt sich Ubuntu das Passwort für eine Weile.

Mir scheint, Q4OS macht da was anders. Wie hast du denn Q4OS installiert? Läuft das als Live-System? In dem Fall ist tatsächlich kein Passwort notwendig. Kannst du bei CUPS einfach die Felder (oder nur das Passwort-Feld) bei der Anmeldung leer lassen?

Thomas Weiss - Mittwoch, 01. April 2015 21:36 Uhr

Hallo Tim,

Ich habe einen neuen Benutzer angelegt unter Gruppe Admin hinzugefügt. Mit diesem Benutzer konnte meinen Drucker installieren.

Gruß
Thomas

Dieter Drewanz - Sonntag, 05. April 2015 21:26 Uhr

Wenn der Benutzer zur Gruppe Admin gehört, liegt der Verdacht nahe, dass es daran liegen könnte.

Die Zugehörigkeit zu verschiedenen Gruppen mit unterschiedlichen Rechten können abgefragt werden mit:

groups username

Die Info könnte weiterhelfen. Es gibt live-Versionen, bei denen genügt auch ein blankes sudo für Adminbefehle.

Tiefere Einblicke verschafft die Datei:
sudo cat /etc/sudoers

Und hier stehen die Bedeutungen und wie man diese editiert:
http://wiki.ubuntuusers.de/sudo/Konfiguration

Deine Antwort