Tripwire Konfigurationsscript

Aufmacher News

Tripwire Konfigurationsscript

Raphael Lechner
03.08.2003

So habe Tripwire heruntergeladen und es auf meinem debian vom Source installiert.Gut habe die Standart Konfigurationsdatei twpol.txt einwenig angepasst und die Datenbank erzeugt.
Also im Einzelnen:

Datenbank erzeugen:
#tripwire -m i

Tripwire nochmal alles checken lassen
#tripwire -m -c

Nur ist mir dann aufgefallen das er bei mir z.B. 180 Dateien als fehlend meldet weil es diese bei mir gar nicht gibt.Soweit das Problem und ich könnte jetzt jeden Eintrag einzeln in der twpol.txt suchen und ersetzen,naja schlechte lösung hab ich mir gedacht
So dann habe ich ein script geschrieben das genau das erledigt, es erwartet die Orginal twpol.txt vom "STDIN" und eine datei "changes" mit den Änderungen im Scriptverzeichniss ,die wir machen wollen und gibt das Ergebnis aus.
Gut dann erzeugen wir mal einen Report von Tripwire und schreiben das Ergebnis in die Datei Report:

Report generieren und Ergebnis in die /tmp/report schreiben
#tripwire -m c > /tmp/report

Gut dann schneiden wir alles was wir im Report nicht brauchen raus und erzeugen die Änderungsdatei:
#grep Filename /tmp/report | cut -b 16- > changes

Gut dann führen wir das script aus und schreiben das Ergebnis in die /tmp/twpol.txt
#cat /etc/tripwire/twpol.txt |./mcom.perl > /tmp/twpol.txt

Gut dann können wir die twpol.txt einfach wieder in ihr verzeichniss kopieren (bei mir /etc/tripwire) und die Policy von tripwire neuladen

Copy und Policy reload
#cp /tmp/twpol.txt /etc/tripwire/
#tripwire -m p /etc/tripwire/twpol.txt

So Tripwire prüft jetzt diese Dateien nicht mehr und manuell kann man jederzeit zu prüfende Dateien hinzuzufügen.(Policy Reload nicht vergessen)

So wünsche schönen Abend

Ähnliche Artikel

Kommentare
Re: Tripwire Konfigurationsscript
(unangemeldet), Montag, 17. November 2003 22:17:05
Ein/Ausklappen

Hallo,

ich habe eine Tripwire 2.3.1.2 auf SuSE 9.0 konfiguriert. Das Policyfile habe ich von Hand angepasst und die Tripwire - DB damit inititalisiert.
Führe ich jetzt den tripwire --check -v durch, steigt er mit mit
"Software interrupt forced exit: Segmentation Fault, Abort"
aus.
Das geschieht i.d.R an der /root/.ICEautorithy, /root/.Xauthority, /root/bash_history.
Hast Du eine Idee, ab es an der twpol.txt liegen kann, die Files sind alle als SIG_HI = 100 eingestuft oder liegt da irgendwo anders etwas im Argen?

Ich teste die Konfiguration als normaler User und dann mittels su.

Vielen Dank
Mario


Bewertung: 287 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Aktuelle Fragen

Soundkarte wird erkannt, aber kein Ton
H A, 25.09.2016 01:37, 2 Antworten
Hallo, Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linu...
Scannen nur schwarz-weiß möglich
Werner Hahn, 20.09.2016 13:21, 2 Antworten
Canon Pixma MG5450S, Dell Latitude E6510, Betriebssyteme Ubuntu 16.04 und Windows 7. Der Canon-D...
Meteorit NB-7 startet nicht
Thomas Helbig, 13.09.2016 02:03, 3 Antworten
Verehrte Community Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen. Beim Start ersch...
windows bootloader bei instalation gelöscht
markus Schneider, 12.09.2016 23:03, 1 Antworten
Hallo alle zusammen, ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...
Ubuntu 16 LTE installiert, neustart friert ein
Matthias Nagel, 10.09.2016 01:16, 3 Antworten
hallo und guten Abend, hab mich heute mal darangewagt, Ubuntu 16 LTE parallel zu installieren....