<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de-DE" lang="de-DE">
<head>
              
  
                                  
  
              
  
      

<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/core.css" />
<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/pagelayout.css" />
<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/content.css" />
<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/jquery.cluetip.css" />

        <link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/bootstrap.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/bootstrap-responsive.css" />
<link rel="stylesheet" type="text/css" href="/extension/ezjquerylightbox/design/standard/stylesheets/lightbox.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/style.css" />
<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/debug.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/bob.css" />
<link rel="stylesheet" type="text/css" href="/extension/lc/design/lc/stylesheets/search.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/block.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/ezflow.css" />
<link rel="stylesheet" type="text/css" href="/extension/lnm_upselling/design/bootstrap/stylesheets/upselling.css" />
<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/ezfind.css" />
<link rel="stylesheet" type="text/css" href="/extension/ezfind/design/ezwebin/stylesheets/ezajax_autocomplete.css" />


<!--[if IE]>
<style type="text/css">
pre {
  overflow:visible;
  overflow-x:auto;
  overflow-y:hidden;
  padding-bottom:15px;
}
#flattr {
  margin-top: -27px;
}
#loginarea {
  padding: 0px 0px 0px 50px;
}
#page { 
  padding-right:0;
}
</style>
<![endif]-->

<link rel="stylesheet" type="text/css" href="/extension/bootstrap/design/bootstrap/stylesheets/print.css" media="print" />
<link rel="alternate" type="application/rss+xml"  title="[LC] News und Artikel" href="/rss/feed/main" />
<link rel="alternate" type="application/rss+xml"  title="[LC] News" href="/rss/feed/news" />
<link rel="alternate" type="application/rss+xml"  title="[LC] Artikel" href="/rss/feed/artikel" />
<link rel="alternate" type="application/rss+xml"  title="[LC] Fragen" href="/rss/feed/fragen" />


<script type="text/javascript" src="/extension/ezclasslists/design/standard/javascript/classlists.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/lc-js.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/insertmedia.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/jquery.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/jquery.bigtarget.1.0.1.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/lightbox.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/ezjquerylightbox/design/standard/javascript/jquery.smooth-scroll.min.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/ezjquerylightbox/design/standard/javascript/jquery-ui-1.8.18.custom.min.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/article.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/lnm_upselling/design/bootstrap/javascript/unhide-mobile.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/ezjscore/design/standard/javascript/jquery-1.10.2.min.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/bootstrap/design/bootstrap/javascript/bootstrap.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/bootstrap/design/bootstrap/javascript/swfSize.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/bootstrap/design/bootstrap/javascript/detect.mobile.js" charset="utf-8"></script>
<script type="text/javascript" src="/extension/bootstrap/design/bootstrap/javascript/jquery.socialshareprivacy.universal.js" charset="utf-8"></script>
            	<script>
	    
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	    
	    ga('create', 'UA-15797199-1', 'auto');
	    ga('set', 'anonymizeIp', true);
	    ga('send', 'pageview');
	</script>
    
<script type="text/javascript">


$(document).ready(function() {
    $('.block-type-feed-reader').each(function() {
        var category = 'Feed-Block: ' + $(this).find('h2').text().replace(/^\s+|\s+$/g, '');
        $(this).find('a').each( function() {
            $(this).click(function(event) { // when someone clicks these links
                event.preventDefault(); // don't open the link yet
                var label=$(this).attr('href');
                //var label=$(this).text();
                var target = $(this).attr("target");
                var href = $(this).attr("href");
		ga('send', 'event', category, 'click', label, 0);
                setTimeout(function() { // now wait 300 milliseconds...
                    window.open(href,(!target?"_self":target)); // ...and open the link as usual
                    },300);
            });
        });
    });
});

</script>

    
    



                        	            <meta name="author" content="Tim Schürmann" />

    





<title>Nach über zwei Jahren liegt eine neue Version d... &raquo; LinuxCommunity</title>
                
    <link rel="canonical" href="http://www.linux-community.de/Internal/Nachrichten/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor" />
<meta name="description" content="Fast alle großen Distributionen setzen als Shell die beliebte Bash ein. Jetzt haben die Entwickler die neue Version 4.4 freigegeben, die unzählige..." />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><meta name="dcterms.rightsHolder" content="COMPUTEC MEDIA GmbH"><meta name="viewport" content="width=device-width, initial-scale=1.0" />


<meta name="revisit-after" content="1 days">

<meta property="og:description" content="Fast alle großen Distributionen setzen als Shell die beliebte Bash ein. Jetzt haben die Entwickler die neue Version 4.4 freigegeben, die unzählige..." />
<meta property="og:title" content="Nach über zwei Jahren liegt eine neue Version d... &raquo; LinuxCommunity" />
<meta property="og:url" content="http://www.linux-community.de/Internal/Nachrichten/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor" />
<meta property="og:site_name" content="LinuxCommunity" />


        	        	            <meta property="og:image" content="http://www.linux-community.de/var/ezwebin_site/storage/images/internal/nachrichten/nach-ueber-zwei-jahren-liegt-eine-neue-version-der-bash-vor/2943221-1-ger-DE/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor_opengraph_w.png" />
    <meta property="og:image:width" content="200" />
    <meta property="og:image:height" content="211" />
    <meta property="og:image:type" content="image/png" />
    <link rel="image_src" href="http://www.linux-community.de/var/ezwebin_site/storage/images/internal/nachrichten/nach-ueber-zwei-jahren-liegt-eine-neue-version-der-bash-vor/2943221-1-ger-DE/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor_opengraph_w.png" />
        

<!--[if lt IE 9 ]>
    <meta http-equiv="X-UA-Compatible" content="IE=8,chrome=1" />
<![endif]-->

<link rel="Alternate" type="application/rss+xml" title="RSS" href="/rss/feed/news" />
<link rel="Shortcut icon" href="/extension/lc/design/lc/images/favicon.ico" type="image/x-icon" />


<script type="text/javascript" src="https://script.ioam.de/iam.js"> </script>
<script type="text/javascript">
var Ads_BA_ADIDsite = "linux-community.de";var Ads_BA_ADIDsection = "rotation"; var Ads_BA_keyword = ""; 
</script>
<script type="text/javascript" src="/extension/lc/design/lc/javascript/adlib.js" charset="utf-8"></script>





</head>
<body >







        



<!-- SZM VERSION="2.0" -->
<script type="text/javascript">
var iam_data = {
    "st":"linuxcom", 
    "cp":"T_R_N_F_89", 
    "sv":"in", 
    "co":"" 
}
iom.c(iam_data);
</script>
<!-- /SZM -->
        <div id="stage">
      <div id="stage-leaderboard"><div id='Ads_BA_BS' ><script type='text/javascript'>Ads_BA_AD('BS');</script></div>
</div> 
      <div id="stage-skyscraper"><div id='Ads_BA_SKY' ><script type='text/javascript'>Ads_BA_AD('SKY');</script></div>
</div>
	<div id="stage-content">
	    
	    <!-- Complete page area: START -->
	    <div id="page">
		<!-- Header area: START -->
		<div id="header" class="float-break">
		    <div id="logo"><a href="/"><img src="/extension/lc/design/lc/images/lc.png" title="" alt="" /></a></div>
		    <div id="Newsletter"><div class="header newsletter">
    <form action="/mc/subscribe" method="post">
	<label>Newsletter</label>
		<input  onfocus="if (value == 'E-Mail-Adresse') {value=''}" onblur="if (value== '') {value='E-Mail-Adresse'}"  name="email" value="E-Mail-Adresse" id="newsletter" type="text" />
			    <input onclick="ga('send', 'event', 'header-newsletter', 'newsletter', 'image-link', 0)" type="submit" value="Abonnieren" />
	    </form>
</div>


</div>
		    <div id="Search"><div class="header search">
    <form action="/content/search">
        <label for="searchtext">Suche</label>
        <input id="searchtext" name="SearchText" type="text" value="" size="12" />
        <input id="searchbutton" type="submit" value="Suchen" alt="Submit" />
    </form>
</div>

</div>
        	    <div id="SocialIcons"><div class="social_icons">
        <div class="link"><a onclick="ga('send', 'header-social', 'rss', 'image-link')" href="http://www.linux-community.de/rss/feed/main" title="RSS-Feed der aktuellen Nachrichten/Artikel der LinuxCommunity" target="_blank"><img src="/extension/bootstrap/design/bootstrap/images/icons/feedIcon16.png" width="16" height="16" alt="RSS-Feed der aktuellen Nachrichten/Artikel der LinuxCommunity"/></a></div>    <div class="link"><a onclick="ga('send', 'header-social', 'facebook', 'image-link')" href="http://www.facebook.com/LinuxCommunity" target="_blank" title=""><img src="/extension/bootstrap/design/bootstrap/images/facebook_icon.png" width="16" height="16" alt=""/></a></div>    <div class="link"><a onclick="ga('send', 'header-social', 'twitter', 'image-link')" href="http://www.twitter.com/LinuxCommunity" target="_blank" title=""><img src="/extension/bootstrap/design/bootstrap/images/twitter_icon.png" width="16" height="16" alt=""/></a></div>        </div>

</div>
		    <p class="hide"><a href="#main">Skip to main content</a></p>
		</div>		<!-- Header area: END -->
		<!-- Top menu area: START -->
        	            <div id="TopThemen">
	<ul class="level1">
	    <li class="title">Hot:</li>
	    		<li class="menu-level-0">            	<a onclick="ga('send', 'event', 'topthemen_menue', 'LinuxUser', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/(m)/t">LinuxUser</a>
    </li>
	    		<li class="menu-level-0">            	<a onclick="ga('send', 'event', 'topthemen_menue', 'EasyLinux', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/EasyLinux/(m)/t">EasyLinux</a>
    </li>
	    		<li class="menu-level-0">            	<a onclick="ga('send', 'event', 'topthemen_menue', 'Ubuntu User', 'text-link', 0)" href="/Internal/Artikel/Online-Artikel/Ubuntu-User/(m)/t">Ubuntu User</a>
    </li>
	    	</ul>
    </div>
        	<div class="menue_space">&nbsp;</div>
        	<div id="TagMenue">                    <ul class="level1">
		    <li class="menu-level-0">            	<a onclick="ga('send', 'event', 'tagmenue', '[1] Digitale Ausgaben', 'text-link', 0)" href="/lnmshop/start">Digitale Ausgaben</a>
    </li>
		    <li class="menu-level-0">            	<a onclick="ga('send', 'event', 'tagmenue', '[1] Online-Artikel', 'text-link', 0)" href="/Internal/Artikel/Online-Artikel">Online-Artikel</a>
    </li>
		    <li class="menu-level-0">            	<a onclick="ga('send', 'event', 'tagmenue', '[1] Fragen', 'text-link', 0)" href="/Community/Fragen">Fragen</a>
    </li>
		    <li class="menu-level-0">            	<a onclick="ga('send', 'event', 'tagmenue', '[1] Jobs', 'text-link', 0)" href="/Community/Jobs">Jobs</a>
    </li>
		    </ul>
        
</div>
        	<div id="Breadcrumb"><div itemscope itemtype="http://data-vocabulary.org/Breadcrumb">

    
                	    	    
	    
	    	    	    	    	        	        	        <span class="path" itemprop="url"><span itemprop="title">            	<a onclick="ga('send', 'event', 'breadcrumb', '[1] Home', 'text-link', 0)" href="/">Home</a>
    </span></span>
	    		            	    		&nbsp;<span class="separator">&#187;</span>&nbsp;
	    	        	    	    
	    
	    	    	    	    	        	        	        <span class="path" itemprop="url"><span itemprop="title">            	<a onclick="ga('send', 'event', 'breadcrumb', '[2] Internal', 'text-link', 0)" href="/Internal">Internal</a>
    </span></span>
	    		            	    		&nbsp;<span class="separator">&#187;</span>&nbsp;
	    	        	    	    
	    
	    	    	    	    	        	        	        <span class="path" itemprop="url"><span itemprop="title">            	<a onclick="ga('send', 'event', 'breadcrumb', '[3] Nachrichten', 'text-link', 0)" href="/Internal/Nachrichten">Nachrichten</a>
    </span></span>
	    		            	    		&nbsp;<span class="separator">&#187;</span>&nbsp;
	    	        	    	    
	    
	    	    	    	    	        <span class="path" itemprop="url"><span itemprop="title">            	<a onclick="ga('send', 'event', 'breadcrumb', '[4] Nach über zwei Jahren liegt eine neue Version der Bash vor', 'text-link', 0)" href="#">Nach über zwei...</a>
    </span></span>
	    		                        	<div class="link"><a href="/user/login">Login</a></div>
	<div class="link"><a href="/user/register" title="Registrierung">Registrierung</a></span> <span style="color:#43a4c4">|</div>
    </div>

</div>

      
    <div class="billboard"><div id='Ads_BA_FLB' ><script type='text/javascript'>Ads_BA_AD('FLB');</script></div>
</div>
	<!-- Columns area: START -->
	<table id="mainTable"><tbody><tr>
	    <!-- Centre area: START -->
	    <td>
				<div id="mainWin" class="float-break">
    		    <div class="overflow-fix">
    			<!-- Main area content: START -->
    			
    	
    
<div class="news full">
            <h2>Nach über zwei Jahren liegt eine neue Version der Bash vor</h2>
            <div class="attribute-image">
							

    
    
    
    
                                                                                                                                    <a href="/var/ezwebin_site/storage/images/internal/nachrichten/nach-ueber-zwei-jahren-liegt-eine-neue-version-der-bash-vor/2943221-1-ger-DE/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor_imagelarge.png" title="Nach über zwei Jahren liegt eine neue Version der Bash vor"  rel="lightbox[gallery]"><img src="/var/ezwebin_site/storage/images/internal/nachrichten/nach-ueber-zwei-jahren-liegt-eine-neue-version-der-bash-vor/2943221-1-ger-DE/Nach-ueber-zwei-Jahren-liegt-eine-neue-Version-der-Bash-vor_medium.png" width="190" height="200"  style="border: 0px  ;" alt="Nach über zwei Jahren liegt eine neue Version der Bash vor" title="Nach über zwei Jahren liegt eine neue Version der Bash vor" /></a>    
    
    
    	    </div>
    <h1>Bash 4.4. veröffentlicht</h1>
    <div class="attribute-author">    Tim Schürmann</div>
                        <div class="attribute-short">
		 
		<span class="date">
		    			16.09.2016
		    		</span>
                    Fast alle großen Distributionen setzen als Shell die beliebte Bash ein. Jetzt haben die Entwickler die neue Version 4.4 freigegeben, die unzählige kleinere Änderungen mitbringt.            </div>
            <br />
                        <div class="attribute-body">    <p >
So verstehen jetzt alle eingebauten Kommandos den Parameter „--help“, über den sie jeweils eine kleine Hilfe ausgeben. Das eingebaute „ulimit“-Kommando kennt die beiden neuen Parameter „-k“ (kqueues) und „-P“ (pseudoterminals). Des Weiteren erlaubt die Bash den Ausdruck „time ; andereskommando“ um Null-Kommandos zu auszustoppen. Die Anweisung:
</p>
    <pre>printf -v var &quot;&quot;</pre><p >
setzt die Variable „var“ auf den leeren String. Es gibt zudem eine neu Operator-Familie
</p>
    <pre>${parameter@spec}</pre><p >
um den Wert von „parameter“ zu transformieren. „set -i“ ist ab sofort nicht mehr erlaubt. Die Bash 4.4 exportiert nur noch Funktionen, deren Namen nicht die Zeichen „/“ und „=“ enthalten.
</p>
<p >
Obendrauf gibt es noch neue Umgebungsvariablen. Dazu zählt unter anderem „EXECIGNORE“: Diese Variable nimmt eine mit Semikolons getrennte Liste von Mustern auf. Sofern die Bash nach Kommandos sucht, ignoriert sie alle Dateinamen, die diesen Mustern entsprechen.
</p>
<p >
Das eingebaute „kill“-Kommando kennt ab sofort den Parameter „-L“. Dieser führt zum gleichen Ergebnis wie „-l“. Die Entwickler haben ihn eingeführt, um mit dem Linux-Standard-Kill-Befehl kompatibel zu werden.
</p>
<p >
Neben den genannten Neuerungen gibt es zahlreiche weitere kleinere, die das <a href="http://git.savannah.gnu.org/cgit/bash.git/diff/NEWS?id=a0c0a00fc419b7bc08202a79134fcd5bc0427071" target="_blank">Changelog</a> auflistet.
</p></div>
        
                
		
		    	    	                            	        	            	
        
    
    <script type="text/javascript">
    jQuery(document).ready(
	function($){
	    if($('#socialshareprivacy').length > 0){
		$('#socialshareprivacy').socialSharePrivacy({
		    services : {
			facebook : {
			    'status' : 'on',
			    'perma_option'  : 'off',
			    'action' : 'like',
			    'dummy_img' : '/extension/bootstrap/design/bootstrap/images/socialshareprivacy/dummy_facebook.png'
			},
			twitter : {
			    'status' : 'on',
			    'perma_option'  : 'off',
			    'dummy_img' : '/extension/bootstrap/design/bootstrap/images/socialshareprivacy/dummy_twitter.png'
			},
			gplus : {
			    'status' : 'on',
			    'perma_option'  : 'off',
			    'dummy_img' : '/extension/bootstrap/design/bootstrap/images/socialshareprivacy/dummy_gplus.png'
			}
		    }
		}
	    );}
	}
    );
    </script>
    
    <div id="socialshareprivacy"></div>	            <div class="attribute-relatedcontent">
    <h2>Ähnliche Artikel</h2>
    <ul>
		            	<li class="float-break">
		            					    									<div class="attribute-image">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4', 'image-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4" title="Im Innern der Muschel">

    
    
    
    
                                                                                                                                    <img src="/var/ezwebin_site/storage/images/internal/artikel/print-artikel/linuxuser/2010/06/im-innern-der-muschel/aa_shell_timobalk_sxc_1190362.jpg/1015347-1-ger-DE/AA_shell_timobalk_sxc_1190362.jpg1_small.jpg" width="75" height="113"  style="border: 0px  ;" alt="AA_shell_timobalk_sxc_1190362.jpg" title="AA_shell_timobalk_sxc_1190362.jpg" />    
    
    
    </a>
			    			</div>
									        		    <a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4" title="Im Innern der Muschel">Im Innern der Muschel</a>
			                        			    <div class="attribute-intro">    Mit der Version 4 erhält die Bourne Again Shell (Bash) neue Funktionen, die sie einmal mehr als leistungsfähige Programmierschnittstelle zum System und zu Applikationen qualifiziert.</div>
                        			<div class="more">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4', 'more-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2010/06/Neue-Programmiertechniken-und-Funktionen-in-Bash-4" title="Im Innern der Muschel">mehr &raquo;</a>
			    			</div>
		            	    <!--100-->
        	</li>
        		    		            	<li class="float-break">
		            											        		    <a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2006/07/Tricks-fuer-die-Bash', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2006/07/Tricks-fuer-die-Bash" title="Tricks für die Bash">Tricks für die Bash</a>
			                        			    <div class="attribute-intro">    Mit ein paar grundlegenden Kniffen bringen Sie Schwung und Farbe in die Arbeit auf der Kommandozeile.</div>
                        			<div class="more">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2006/07/Tricks-fuer-die-Bash', 'more-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2006/07/Tricks-fuer-die-Bash" title="Tricks für die Bash">mehr &raquo;</a>
			    			</div>
		            	    <!--74-->
        	</li>
        		    		            	<li class="float-break">
		            											        		    <a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2005/02/Einfuehrung-in-die-Bash-Programmierung', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2005/02/Einfuehrung-in-die-Bash-Programmierung" title="Einführung in die Bash-Programmierung">Einführung in die Bash-Programmierung</a>
			                        			    <div class="attribute-intro">    Skripte sollen meist wiederkehrende oder lästige Arbeiten automatisieren. Die Standard-Shell Bash stellt Ihnen dazu eine ganze Reige von Funktionen bereit. Dieser Artikel erklärt, wie Sie ihre eigenen Shell-Skripte schreiben.</div>
                        			<div class="more">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2005/02/Einfuehrung-in-die-Bash-Programmierung', 'more-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2005/02/Einfuehrung-in-die-Bash-Programmierung" title="Einführung in die Bash-Programmierung">mehr &raquo;</a>
			    			</div>
		            	    <!--73-->
        	</li>
        		    		            	<li class="float-break">
		            					    									<div class="attribute-image">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden', 'image-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden" title="Demontage">

    
    
    
    
                                                                                                                                    <img src="/var/ezwebin_site/storage/images/internal/artikel/print-artikel/linuxuser/2009/02/demontage/aa_demolition_sxc_1085143.jpg/606001-1-ger-DE/AA_demolition_sxc_1085143.jpg_small.jpg" width="75" height="56"  style="border: 0px  ;" alt="AA_demolition_sxc_1085143.jpg" title="AA_demolition_sxc_1085143.jpg" />    
    
    
    </a>
			    			</div>
									        		    <a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden" title="Demontage">Demontage</a>
			                        			    <div class="attribute-intro">    Unter Windows laufen Sie stets Gefahr, mit unachtsamen Mausklicks das gesamte System irreparabel zu zerstören. Aber auch das freie Betriebssystem befördern Sie ruck, zuck ins Jenseits – wie, das zeigt der gefährlichste Artikel in der Geschichte des LinuxUser.</div>
                        			<div class="more">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden', 'more-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2009/02/Gefaehrliche-Kommandos-erkennen-und-vermeiden" title="Demontage">mehr &raquo;</a>
			    			</div>
		            	    <!--72-->
        	</li>
        		    		            	<li class="float-break">
		            											        		    <a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2000/12/Teil-1-Grundlagen-der-BASH', 'text-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2000/12/Teil-1-Grundlagen-der-BASH" title="Teil 1: Grundlagen der BASH">Teil 1: Grundlagen der BASH</a>
			                        			    <div class="attribute-intro">    Haben Sie auch schon einmal am Computer gesessen und sich über immer wiederkehrende Arbeit geärgert, die man mit einem kleinen Programm vereinfachen könnte? Im ersten Teil unseres Programming Corners steigen wir in die Welt der Programmierung ein.</div>
                        			<div class="more">
			    			            			<a onclick="ga('send', 'event', 'related-content', 'Internal/Artikel/Print-Artikel/LinuxUser/2000/12/Teil-1-Grundlagen-der-BASH', 'more-link', 0)" href="/Internal/Artikel/Print-Artikel/LinuxUser/2000/12/Teil-1-Grundlagen-der-BASH" title="Teil 1: Grundlagen der BASH">mehr &raquo;</a>
			    			</div>
		            	    <!--72-->
        	</li>
        		    	    </ul>
</div>
		    <!-- Comments Section /-->     
	    <p>      <!--  Comments Section //-->
        
        	     <table class="list forum recurse" id="comments">
            <tr>
                <th class="message">
                    Kommentare
                 </th>

            </tr>
	      		  		                   	 </table>
       	 



		
		
		
				
																
        	         <form method="post" action="/content/action">
	               <input class="button forum-new-reply" type="submit" name="NewButton" value="Neuen Kommentar erstellen" />
	               <input type="hidden" name="ContentNodeID" value="200107" />
	               <input type="hidden" name="ContentObjectID" value="301319" />
	               <input type="hidden" name="NodeID" value="200107" />
	               <input type="hidden" name="NewButton.x" value="2" />
	               <input type="hidden" name="NewButton.y" value="2" />
	               <input type="hidden" name="ClassIdentifier" value="comment" />
	               <input type="hidden" name="ContentLanguageCode" value="ger-DE" />
	         </form>
	
         </p>
	    <!-- End Comments Section /-->
	    </div>
</div>


    			<!-- Main area content: END -->
    		    </div>
		</div>
	    </td>
	    <!-- Centre area: END -->
	        	    <td width="336" valign="top" id="td_rightcolumn">
		<!-- Right Sidebar area: START -->
    		<!-- Extra content: START -->
        	

  			 
        
  		    

  			 
        		      <div class="banner-box">
        <div id='Ads_BA_CAD' ><script type='text/javascript'>Ads_BA_AD('CAD');</script></div>
      </div>
		    

  			 
    
          		  	
  

  			 
                   

  			 
	  <!--cbB020-->
    <div class="border-box">
	<div class="border-mc">
	    


<!-- side:1 generated by uri: /Community/Fragen/Meteorit-NB-7-startet-nicht -->
<div class = "boxClass">
<h3>
Aktuelle Fragen
</h3>

  
<table>			<tr class="boxitem0">
		<td>
		
			
<a style="display: block;" href="/Community/Fragen/Meteorit-NB-7-startet-nicht#200023start">
       Meteorit NB-7 startet nicht
   <br />
   
   <span style="font-size:x-small">
   		Thomas Helbig,
   		13.09.2016 02:03,
   		   		1 Antworten
   </span></a>   
   <div style="font-weight:normal">
      Verehrte Community
Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen.
Beim Start ersch...
   	</div>		
		</td>
		</tr>
                			<tr class="boxitem1">
		<td>
		
			
<a style="display: block;" href="/Community/Fragen/windows-bootloader-bei-instalation-geloescht#200021start">
       windows bootloader bei instalation gelöscht 
   <br />
   
   <span style="font-size:x-small">
   		markus Schneider,
   		12.09.2016 23:03,
   		   		1 Antworten
   </span></a>   
   <div style="font-weight:normal">
      Hallo alle zusammen, 

ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...
   	</div>		
		</td>
		</tr>
                			<tr class="boxitem0">
		<td>
		
			
<a style="display: block;" href="/Community/Fragen/Ubuntu-16-LTE-installiert-neustart-friert-ein#199997start">
       Ubuntu 16 LTE installiert, neustart friert ein
   <br />
   
   <span style="font-size:x-small">
   		Matthias Nagel,
   		10.09.2016 01:16,
   		   		3 Antworten
   </span></a>   
   <div style="font-weight:normal">
      hallo und guten Abend,

hab mich heute mal darangewagt, Ubuntu 16 LTE parallel zu installieren....
   	</div>		
		</td>
		</tr>
                			<tr class="boxitem1">
		<td>
		
			
<a style="display: block;" href="/Community/Fragen/LibreOffice-Writer-Ububtu-16.04-DELL-Latitude-E6510#199961start">
       LibreOffice Writer / Ububtu 16.04 / DELL Latitude E6510
   <br />
   
   <span style="font-size:x-small">
   		Werner Hahn,
   		06.09.2016 17:26,
   		   		2 Antworten
   </span></a>   
   <div style="font-weight:normal">
      Beim Schreiben oder Kopieren in LibreOffice Writer erschien bisher die Seite in Displaymitte, war...
   	</div>		
		</td>
		</tr>
                			<tr class="boxitem0">
		<td>
		
			
<a style="display: block;" href="/Community/Fragen/KWord-Quiz#199899start">
       KWord Quiz
   <br />
   
   <span style="font-size:x-small">
   		Carl Garbe,
   		30.08.2016 16:19,
   		   		0 Antworten
   </span></a>   
   <div style="font-weight:normal">
      KWord Quiz lässt sich bei mir (nach einem update auf Ubuntu 16.04 LTS) nicht mehr speichern, kann...
   	</div>		
		</td>
		</tr>
                	</table>
</div>

	</div>
	<div class="clear"></div>
    </div>


    		<!-- Extra content: END -->
	    </td>
	    <!-- Right Sidebar area: END -->
        <!-- Columns area: END -->
    </tr></tbody>
</table>    	    	    		    	    	        <div class="footerbanner"><div id='Ads_BA_FOOT' ><script type='text/javascript'>Ads_BA_AD('FOOT');</script></div>
</div> 
        													<p class="footer">
    	[<a href="/Internal/Impressum">Impressum</a>]&nbsp;[<a href="/Internal/Mission/">Mission</a>]&nbsp;<br /><br /> 
        <a href="http://www.businessad.de/" target="_blank"><img src="/extension/businessad/design/base/images/BA_Logo.jpg" style="vertical-align:middle;"/></a> 
    <br /><br />
    <a href="//www.linux-magazin.de/static/public/Computec_Media_GmbH_Datenschutzerklärung_Oktober_2014.pdf" class="themen">Datenschutzerkl&auml;rung</a>&nbsp;&nbsp; | 
    &copy; 2016 <a href="http://www.computec.de" class="themen" target="_blank">COMPUTEC MEDIA GmbH</a>
</p>
</div>
<!-- Complete page area: END -->    </div>
</div>
<div style="clear:both;"></div>

</body>
</html> 
