Open-Suse-Problem mit Radeon

LinuxUser 02/2007: Wirklich eine flotte und problemlose Installation der neuen Open Suse 10.2 von der LinuxUser DVD-Edition 02.07. Endlich wieder ein Suse System mit brauchbarer Softwareverwaltung, und als Bonbon das neue Startmenü … dachte ich mir: Zu früh gefreut, zumindest als Besitzer einer ATI Radeon RV280 5960 (aka 9250). Denn diese Karte wird vom aktuellen ATI-Treiber nicht mehr unterstützt. X.org 7.2 benötigt aber offensichtlich eben diesen Treiber. Die Folge: Das Grafiksystem startet nach der Installation nicht; per SaX2 ist eine Auflösung von maximal 800 x 600 Pixel einstellbar, alles andere führt dazu, dass der X-Server kommentarlos abschmiert. Nach einigen Stunden vergeblicher Konfigurationsversuche habe ich entnervt aufgegeben. Achim Hecht

LinuxUser: Mit dem freien Radeon-Treiber funktioniert die Karte problemlos. Beim Booten tippen Sie eine "3" ein, damit das System ohne Grafik hochfährt. Danach geben Sie als root den Befehl sax2 -m 0=radeon ein. (mhi)

Experiment mit X.org

LinuxUser 02/2007, S. 28: Vielen Dank für den informativen und ausführlichen Schwerpunkt zum Thema 3D-Desktop. Dazu hätte ich noch einen Tipp für alle experimentierfreudigen Leser. Nicht selten startet nach einer Änderung an der Konfiguration ja der X-Server nicht mehr, das System bleibt auf der Kommandozeile stehen.

Deshalb lege ich vor Experimenten mit der xorg.conf stets eine Kopie der funktionierenden Konfiguration an, erst dann verändere ich etwas:

cd /etc/X11/
cp xorg.conf xorg.conf.working

Um anschließend nicht funktionierende und experimentelle Konfigurationen hin und her kopieren zu müssen, verknüpfe ich meine unterschiedlichen Varianten von xorg.conf.test als symbolischen Link mit xorg.conf:

ln -sf xorg.conf.test xorg.conf

So kann ich den neuen Versionen einen selbsterklärende Namen geben und weiß auch später noch, was ich mit den unterschiedlichen Dateien gemacht habe. Außerdem kann ich recht schnell von einer fehlerhaften xorg.conf.test zu einer funktionierenden xorg.conf zurückkehren:

cd /etc/X11/
ln -sf xorg.conf.working xorg.conf

Danach brauche ich nur noch den X-Server neu zu starten (startx), und alles funktioniert wieder. Raimund Mödlhammer

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 

Ähnliche Artikel

Kommentare

Infos zur Publikation

Mit der Zeitschrift LinuxUser sind Sie als Power-User, Shell-Guru oder Administrator im kleinen Unternehmen monatlich auf dem aktuelle Stand in Sachen Linux und Open Source.

Sie sind sich nicht sicher, ob die Themen Ihnen liegen? Im Probeabo erhalten Sie drei Ausgaben zum reduzierten Preis. Einzelhefte, Abonnements sowie digitale Ausgaben erwerben Sie ganz einfach in unserem Online-Shop.

NEU: DIGITALE AUSGABEN FÜR TABLET & SMARTPHONE

HINWEIS ZU PAYPAL: Die Zahlung ist auch ohne eigenes Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!       

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 2 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 4 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...
Linux und W7 im Netz finden sich nicht
Oliver Zoffi, 06.02.2015 11:47, 3 Antworten
Hallo! Ich verwende 2 PCs, 1x mit W7prof 64 Bit und einmal mit Linux Mint 17 64 Bit, welches ich...
Rootpasswort
Jutta Naumann, 29.01.2015 09:14, 1 Antworten
Ich habe OpenSuse 13.2 installiert und leider nur das Systempasswort eingerichtet. Um Änderungen,...