Open-Suse-Problem mit Radeon

LinuxUser 02/2007: Wirklich eine flotte und problemlose Installation der neuen Open Suse 10.2 von der LinuxUser DVD-Edition 02.07. Endlich wieder ein Suse System mit brauchbarer Softwareverwaltung, und als Bonbon das neue Startmenü … dachte ich mir: Zu früh gefreut, zumindest als Besitzer einer ATI Radeon RV280 5960 (aka 9250). Denn diese Karte wird vom aktuellen ATI-Treiber nicht mehr unterstützt. X.org 7.2 benötigt aber offensichtlich eben diesen Treiber. Die Folge: Das Grafiksystem startet nach der Installation nicht; per SaX2 ist eine Auflösung von maximal 800 x 600 Pixel einstellbar, alles andere führt dazu, dass der X-Server kommentarlos abschmiert. Nach einigen Stunden vergeblicher Konfigurationsversuche habe ich entnervt aufgegeben. Achim Hecht

LinuxUser: Mit dem freien Radeon-Treiber funktioniert die Karte problemlos. Beim Booten tippen Sie eine "3" ein, damit das System ohne Grafik hochfährt. Danach geben Sie als root den Befehl sax2 -m 0=radeon ein. (mhi)

Experiment mit X.org

LinuxUser 02/2007, S. 28: Vielen Dank für den informativen und ausführlichen Schwerpunkt zum Thema 3D-Desktop. Dazu hätte ich noch einen Tipp für alle experimentierfreudigen Leser. Nicht selten startet nach einer Änderung an der Konfiguration ja der X-Server nicht mehr, das System bleibt auf der Kommandozeile stehen.

Deshalb lege ich vor Experimenten mit der xorg.conf stets eine Kopie der funktionierenden Konfiguration an, erst dann verändere ich etwas:

cd /etc/X11/
cp xorg.conf xorg.conf.working

Um anschließend nicht funktionierende und experimentelle Konfigurationen hin und her kopieren zu müssen, verknüpfe ich meine unterschiedlichen Varianten von xorg.conf.test als symbolischen Link mit xorg.conf:

ln -sf xorg.conf.test xorg.conf

So kann ich den neuen Versionen einen selbsterklärende Namen geben und weiß auch später noch, was ich mit den unterschiedlichen Dateien gemacht habe. Außerdem kann ich recht schnell von einer fehlerhaften xorg.conf.test zu einer funktionierenden xorg.conf zurückkehren:

cd /etc/X11/
ln -sf xorg.conf.working xorg.conf

Danach brauche ich nur noch den X-Server neu zu starten (startx), und alles funktioniert wieder. Raimund Mödlhammer

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 
TABLET & SMARTPHONE APPS
Bald erhältlich
Get it on Google Play

Deutschland

Ähnliche Artikel

Kommentare

Infos zur Publikation

LU 10/2016: Kryptographie

Digitale Ausgabe: Preis € 0,00
(inkl. 19% MwSt.)

LinuxUser erscheint monatlich und kostet 5,95 Euro (mit DVD 8,50 Euro). Weitere Infos zum Heft finden Sie auf der Homepage.

Das Jahresabo kostet ab 86,70 Euro. Details dazu finden Sie im Computec-Shop. Im Probeabo erhalten Sie zudem drei Ausgaben zum reduzierten Preis.

Bei Google Play finden Sie digitale Ausgaben für Tablet & Smartphone.

HINWEIS ZU PAYPAL: Die Zahlung ist ohne eigenes Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!

Aktuelle Fragen

Probleme mit MPC/MPD
Matthias Göhlen, 27.09.2016 13:39, 2 Antworten
Habe gerade mein erstes Raspi Projekt angefangen, typisches Einsteigerding: Vom Raspi 3B zum Radi...
Soundkarte wird erkannt, aber kein Ton
H A, 25.09.2016 01:37, 6 Antworten
Hallo, Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linu...
Scannen nur schwarz-weiß möglich
Werner Hahn, 20.09.2016 13:21, 2 Antworten
Canon Pixma MG5450S, Dell Latitude E6510, Betriebssyteme Ubuntu 16.04 und Windows 7. Der Canon-D...
Meteorit NB-7 startet nicht
Thomas Helbig, 13.09.2016 02:03, 4 Antworten
Verehrte Community Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen. Beim Start ersch...
windows bootloader bei instalation gelöscht
markus Schneider, 12.09.2016 23:03, 1 Antworten
Hallo alle zusammen, ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...