K(r)ampf mit DSL

Als unerwartet problematisch erwies sich die Abschaltung des DSL-Zugangs - sei es, weil der Provider gekündigt hat, oder in Folge eines Umzugs. Wir konnten zwar die Zugangsdaten verändern, das komplette Abschalten von Kinternet war aber ohne manuelle Eingriffe in die Konfigurationsdateien nicht möglich. Es half auch nichts, mittels ISDN-Modul des YaST die Sedlbauer SpeedFax PCI einzurichten - Kinternet wollte den ISDN-Zugang nicht erkennen, sondern beharrte auf DSL: Wir kamen nicht mehr ins Netz.

Nach Löschen der Datei /etc/sysconfig/network/provider/dsl-provider0 war es immerhin möglich, einen ISDN-Provider zusätzlich einzurichten, auch wenn Kinternet auf DSL als Standard-Einstellung beharrte. Selbst die Neuinstallation von Kinternet löste das Problem nicht vollständig.

Update-Problematik

Das Update auf SuSE 8.0 ist, wie schon in der Vergangenheit, kein Kinderspiel. Als Update-Basis sollten Sie - wenn überhaupt - SuSE 7.3 Personal verwenden, bei älteren Versionen gibt es erfahrungsgemäß noch mehr Probleme. Für den Test verwendeten wir eine Standard-Installation der SuSE 7.3 Personal Edition mit allen YOU-Updates, die bei Redaktionsschluss erhältlich waren. Zudem installierten wir Kernel 2.2.19 vom SuSE-FTP-Server.

Das Update auf Version 8.0 lief zunächst ohne Auffälligkeiten. Nach Start des fertigen Systems erwartete uns jedoch ein englisches KDE 3.0 - obwohl alle Umgebungsvariablen für Sprache und Ländereinstellung korrekt gesetzt waren (Abbildung 5). Beim Update hat YaST vergessen, das Paket kde3-i18n-de mit der deutschen Sprachunterstützung für KDE zu installieren. Die manuelle Nachinstallation brachte wieder ein deutschsprachiges KDE zum Vorschein.

Abbildung 5: YaST vergaß beim Update die deutsche Sprachunterstützung für KDE. Das Kontrollzentrum und alle KDE-Applikationen waren nur in Englisch verfügbar. Auch die ISDN-Konfiguration war leicht beschädigt

Weitere Probleme gab es mit dem eingebauten ATAPI-CD-RW-Laufwerk. Es war bereits bei der Installation der SuSE 7.3 korrekt eingerichtet worden und lief in der üblichen IDE-SCSI-Emulation. Der ursprüngliche Zugriff auf das Laufwerk erfolgt ohne Emulation über /dev/hdc, innerhalb der SCSI-Emulation muss aber über /dev/sr0, /dev/scd0 oder /dev/cdrecorder zugegriffen werden.

YaST hatte zwar das Icon auf dem KDE-Desktop korrekt mit Zugriff auf /dev/cdrecorder angelegt, benutzte zur Nachinstallation der Pakete jedoch hartnäckig /dev/hdc, was in der SCSI-Emulation nicht mehr zur Verfügung steht (Abbildung 6). Es half auch nichts, als Installationsquelle wieder "CD-ROM" anzugeben, der Fehler blieb. Im Ergebnis war YaST zur Paket-Installation unbrauchbar geworden, einzig nach Abschalten der IDE-SCSI-Emulation konnte der Brenner von YaST angesprochen werden.

Abbildung 6: Obwohl YaST den ATAPI-CD-Brenner eigenhändig mit IDE-SCSI-Emulation eingerichtet hat, greift die Paket-Installation nach dem Update auf SuSE 8.0 auf das ungültige IDE-Gerät /dev/hdc zu. Damit war YaST zur Nachinstallation unbrauchbar

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 

Ähnliche Artikel

Kommentare

Infos zur Publikation

title_2014_10

Digitale Ausgabe: Preis € 4,95
(inkl. 19% MwSt.)

Mit der Zeitschrift LinuxUser sind Sie als Power-User, Shell-Guru oder Administrator im kleinen Unternehmen monatlich auf dem aktuelle Stand in Sachen Linux und Open Source.

Sie sind sich nicht sicher, ob die Themen Ihnen liegen? Im Probeabo erhalten Sie drei Ausgaben zum reduzierten Preis. Einzelhefte, Abonnements sowie digitale Ausgaben erwerben Sie ganz einfach in unserem Online-Shop.

NEU: DIGITALE AUSGABEN FÜR TABLET & SMARTPHONE

HINWEIS ZU PAYPAL: Die Zahlung ist auch ohne eigenes Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!       

Tipp der Woche

Schnell Multi-Boot-Medien mit MultiCD erstellen
Schnell Multi-Boot-Medien mit MultiCD erstellen
Tim Schürmann, 24.06.2014 12:40, 0 Kommentare

Wer mehrere nützliche Live-Systeme auf eine DVD brennen möchte, kommt mit den Startmedienerstellern der Distributionen nicht besonders weit: Diese ...

Aktuelle Fragen

Windows 8 startet nur mit externer Festplatte
Anne La, 10.09.2014 17:25, 4 Antworten
Hallo Leute, also, ich bin auf folgendes Problem gestoßen: Ich habe Ubuntu 14.04 auf meiner...
Videoüberwachung mit Zoneminder
Heinz Becker, 10.08.2014 17:57, 0 Antworten
Hallo, ich habe den ZONEMINDER erfolgreich installiert. Das Bild erscheint jedoch nicht,...
internes Wlan und USB-Wlan-Srick
Gerhard Blobner, 04.08.2014 15:20, 2 Antworten
Hallo Linux-Forum: ich bin ein neuer Linux-User (ca. 25 Jahre Windows) und bin von WIN 8 auf Mint...
Server antwortet mit falschem Namen
oin notna, 21.07.2014 19:13, 1 Antworten
Hallo liebe Community, Ich habe mit Apache einen Server aufgesetzt. Soweit, so gut. Im Heimnet...
o2 surfstick software für ubuntu?
daniel soltek, 15.07.2014 18:27, 1 Antworten
hallo zusammen, habe mir einen o2 surfstick huawei bestellt und gerade festgestellt, das der nic...