LibreOffice-Tipps

Besser arbeiten mit LibreOffice

Die LibreOffice-Tipps verraten unter anderem, wie Sie in Calc einen Datumsbereich richtig formatieren und Zelleninhalte mit der Maus löschen. Außerdem geben wir Tipps zum Arbeiten mit Tabellen in Writer und zu farbigem Text.

Tipp: Calc: Eingabezeile optimal konfigurieren

Enthalten Ihre Tabellen nicht nur Formeln und Berechnungen, sondern auch Spalten mit Text, und sind dabei welche, die ungewöhnlich lang sind, reicht oft der Platz in der Eingabezeile der Rechenleiste nicht aus. Um ihren kompletten Inhalt anzuzeigen, klicken Sie auf den nach unten gerichteten Pfeil am rechten Rand (Abbildung 1). Das Feld klappt nun nach unten aus. Passt der Text immer noch nicht vollständig in den Bereich, nutzen Sie einfach die Bildlaufleiste am rechten Rand, um darin zu blättern. Alternativ können Sie die Eingabezeile vergrößern, indem Sie sie mit der Maus nach unten aufziehen. Ein erneuter Klick auf den kleinen Pfeil verkleinert die Eingabezeile auf ihre ursprüngliche Größe.

Abbildung 1: Langen Text in einer Spalte können Sie in der Eingabezeile betrachten, wenn Sie diese ausklappen.

Tipp: Calc: Dynamische Blattbezüge in Formeln

Angenommen, Sie haben eine Arbeitsmappe mit vier Tabellenblättern: Januar, Februar, März und Ergebnis. Letzteres ist dazu gedacht, die Daten der anderen Blätter auszuwerten. Es enthält beispielsweise Formeln, um die Summe der Zellen B3:B34 aus dem Monatsblatt Januar zu berechnen:

=SUMME(Januar.$B$3:$B$34)

Da die Datenblätter für die Monate identisch aufgebaut sind, können Sie für die Ergebnisse im Prinzip dieselben Zellbezüge und Formeln verwenden. Lästig ist nur, dass Sie immer alle Verweise auf die Blattnamen ändern müssen. So wird aus dem Bezug Januar.$B$3:$B$34 dann etwa Februar.$B$3:$B$34, oder aus Februar.$B$10:$B$20 wird März.$B$10:$B$20.

Mit der INDIREKT()-Funktion gestalten Sie Ihre Formeln dynamisch und sparen so Tipparbeit. Dazu schreiben Sie den Namen des gewünschten Tabellenblatts in eine Zelle und machen die Formeln der Auswertungstabelle dann von diesem Verweis abhängig. Im Beispiel soll der Monatsname in Zelle A2 des Ergebnis-Blatts erscheinen. Dazu tragen Sie folgende Formel in eine andere Zelle der Auswertungstabelle ein:

=SUMME(INDIREKT("'"&$A$2&"'.$B$3:$B$34"))

Dabei repräsentiert INDIREKT("'"&$A$2&"'. den Blattnamen. Die Funktion holt sich diesen aus der Zelle A2, und zwar so, dass die Summenfunktion diesen gleich auswerten kann (Abbildung 2). Damit Calc auch Blattnamen mit Leerzeichen erfasst, schließen Sie den Ausdruck in Anführungszeichen ein. Beachten Sie, dass die INDIREKT()-Funktion als Argument einen Textwert verwendet. Es ist somit nicht möglich, sie bei gleichzeitiger Anpassung der relativen Zellbezüge in andere Zellbereiche zu kopieren, da das Textargument immer unverändert erhalten bleibt.

Abbildung 2: Mit dynamischen Formelbezügen und der "INDIREKT()"-Funktion können Sie sich viel Tipparbeit sparen.

Diesen Artikel als PDF kaufen

Express-Kauf als PDF

Umfang: 4 Heftseiten

Preis € 0,99
(inkl. 19% MwSt.)

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 
TABLET & SMARTPHONE APPS
Bald erhältlich
Get it on Google Play

Deutschland

Ähnliche Artikel

  • LibreOffice-Tipps
    Die LibreOffice-Tipps verraten in dieser Folge unter anderem, wie Sie leere Tabellenzellen farblich unterlegen und wie Sie Writer-Tabellen mit der Tastatur eingeben. Außerdem zeigen wir wie Sie mit Draw schicke Deckblätter designen und Fontwork-Objekte aufpeppen.
  • LibreOffice-Tipps
    Wir zeigen diesmal in den LibreOffice-Tipps, wie Sie die Durchschnittsnote eines Schulfaches errechnen, Tabellentext automatisch formatieren, Sonderzeichen und Umlaute ersetzen und einiges mehr.
  • Besser arbeiten mit LibreOffice
    Die LibreOffice-Tipps verraten unter anderem, wie Sie Videos in Präsentationen einfügen, die Folienübergänge gestalten, mit dem Thesaurus arbeiten und PDF-Dateien erzeugen. Außerdem zeigen wir, wie Sie mit Writer Formulare erzeugen.
  • Besser arbeiten mit LibreOffice
    Die LibreOffice-Tipps stellen unter anderem Shortcuts für Linien in Writer und Funktionen zum Verbinden von Calc-Zellen vor. Außerdem beschreiben wir neue Funktionen in LibreOffice 5.2.
  • LibreOffice-Tipps
    In dieser Ausgabe der LibreOffice-Tipps erfahren Sie, wie Sie Fließtext mit Bildern hinterlegen, Zahlenausgaben auf einen bestimmten Bereich reduzieren und Zellen automatisch numerieren.
Kommentare

Infos zur Publikation

EL 02/2018-04/2018: Distributionen - freie Auswahl

Digitale Ausgabe: Preis € 9,80
(inkl. 19% MwSt.)

EasyLinux erscheint vierteljährlich und kostet 9,80 Euro. Weitere Infos zum Heft finden Sie auf der Homepage.

Das Jahresabo kostet ab 33,30 Euro. Details dazu finden Sie im Computec-Shop.

Bei Google Play finden Sie digitale Ausgaben für Tablet & Smartphone.

HINWEIS ZU PAYPAL: Die Zahlung ist ohne Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!      

Stellenmarkt

Aktuelle Fragen

Internet abschalten
Karl-Heinz Hauser, 20.02.2018 20:10, 0 Antworten
In der Symbolleiste kann man das Kabelnetzwerk ein und ausschalten. Wie sicher ist die Abschaltu...
JQuery-Script läuft nicht mit Linux-Browsern
Stefan Jahn, 16.02.2018 12:49, 2 Antworten
Hallo zusammen, ...folgender goldener Code (ein jQuery-Script als Ergebnis verschiedener Exper...
XSane-Fotokopie druckt nicht mehr
Wimpy *, 30.01.2018 13:29, 2 Antworten
openSuse 42.3 KDE 5.8.7 Seit einem Software-Update druckt XSane keine Fotokopie mehr aus. Fehler...
TOR-Browser stürzt wegen Wikipedia ab
Wimpy *, 27.01.2018 14:57, 0 Antworten
Tor-Browser 7.5 based on Mozilla Firefox 52.8.0 64-Bit. Bei Aufruf von http: oder https://de.wi...
Wifikarte verhindert Bootvorgang
Maik Kühn, 21.01.2018 22:23, 1 Antworten
iwlwifi-7265D -26 failed to load iwlwifi-7265D -25 failed to load iwlwifi-7265D -24 failed to l...