Tipp: Calc: Zeichenzahl in Tabellenbereichen ermitteln

Angenommen, Sie erstellen häufig Gliederungen und Berichtsübersichten. Für eine Abrechnung möchten Sie wissen, wie viele Zeichen die bearbeiteten Texte umfassen. Die Zeichenanzahl einer Zelle inklusive Leerzeichen ermittelt Calc mit der Funktion LÄNGE("Text"). So gibt die folgende Formel z. B. Auskunft über die Zeichenanzahl in Zelle A1:

=LÄNGE(A1)

Sie könnten nun für jede Zelle Ihrer Gliederung oder Berichtsübersicht eine eigene Formel anlegen und am Ende die Summe aus allen Einzelergebnissen bilden – komfortabler geht's allerdings mit einer Matrixformel, die alle Schritte kombiniert. Haben Sie Ihren Text z. B. in den Bereich A1 bis A200 eingegeben, suchen Sie rechts daneben eine freie Tabellenzelle (etwa C1) aus und geben hier diese Formel ein:

=SUMME(LÄNGE(A1:A200))

Beenden Sie danach die Formeleingabe nicht über einen Druck auf die Eingabetaste. Damit Calc die Formel als Matrixformel erkennt, drücken Sie stattdessen [Strg]+[Umschalt]+[Eingabe]. In der Eingabezeile am oberen Rand sehen Sie, dass die Formel nun von geschweiften Klammern umgeben ist, die eine Matrixformel kennzeichnen:

{=SUMME(LÄNGE(A1:A200))}

In der Zelle selbst sehen Sie als Ergebnis die Gesamtsumme aller Zeichen aus dem Bereich A1 bis A200.

Tipp: Calc: Komfortable Navigation per Tastatur

Möchten Sie in Calc mehrere Zeilen, z. B. den Bereich B2 bis F17 mit Daten füllen, beginnen Sie in der Regel bei B2, drücken nach der Eingabe die Tabulatortaste und befinden sich anschließend in C2. Dort geben Sie den nächsten Wert ein, drücken erneut [Tab] und so weiter. Sobald Sie in F2 angelangt sind, führt die Taste Sie allerdings in die Zelle G2 – Sie möchten allerdings in B3 weitermachen. Der Trick: Schließen Sie die Eingabe in F2 einfach mit [Eingabe] ab, springt Calc automatisch in die nächste Zeile nach B3.

Diesen Artikel als PDF kaufen

Express-Kauf als PDF

Umfang: 5 Heftseiten

Preis € 0,99
(inkl. 19% MwSt.)

LinuxCommunity kaufen

Einzelne Ausgabe
 
Abonnements
 
TABLET & SMARTPHONE APPS
Bald erhältlich
Get it on Google Play

Deutschland

Ähnliche Artikel

  • LibreOffice-Tipps
    In dieser Ausgabe der LibreOffice-Tipps erfahren Sie, wie Sie Fließtext mit Bildern hinterlegen, Zahlenausgaben auf einen bestimmten Bereich reduzieren und Zellen automatisch numerieren.
  • LibreOffice-Tipps
    Die LibreOffice-Tipps verraten unter anderem, wie Sie die automatische Silbentrennung in Dokumentenvorlagen nutzen, Lesezeichen in Writer einsetzen und Text auf den Kopf stellen. Außerdem stellen wir die Arbeit mit versteckten Tabellenblättern und anderen nützlichen Calc-Funktionen vor.
  • LibreOffice-Tipps
    Wir zeigen diesmal in den LibreOffice-Tipps, wie Sie die Durchschnittsnote eines Schulfaches errechnen, Tabellentext automatisch formatieren, Sonderzeichen und Umlaute ersetzen und einiges mehr.
  • Besser arbeiten mit LibreOffice
    Die LibreOffice-Tipps dieser Ausgabe verraten unter anderem, wie Sie die Häufigkeit von Suchbegriffen in einer Tabelle ermitteln, bei doppelten Einträgen in einer Spalte eine Warnung erzeugen und in Writer automatische Textersetzungen in die Schranken weisen.
  • Besser arbeiten mit LibreOffice
    Die LibreOffice-Tipps stellen unter anderem Shortcuts für Linien in Writer und Funktionen zum Verbinden von Calc-Zellen vor. Außerdem beschreiben wir neue Funktionen in LibreOffice 5.2.
Kommentare

Infos zur Publikation

title_2018_07

Digitale Ausgabe: Preis € 9,80
(inkl. 19% MwSt.)

EasyLinux erscheint vierteljährlich und kostet 9,80 Euro. Weitere Infos zum Heft finden Sie auf der Homepage.

Das Jahresabo kostet ab 33,30 Euro. Details dazu finden Sie im Computec-Shop.

Bei Google Play finden Sie digitale Ausgaben für Tablet & Smartphone.

HINWEIS ZU PAYPAL: Die Zahlung ist ohne Paypal-Konto ganz einfach per Kreditkarte oder Lastschrift möglich!      

Stellenmarkt

Aktuelle Fragen

added to access control list
Ingrid Kroll, 27.03.2018 07:59, 10 Antworten
Hallo allerseits, bin einfache Nutzerin und absolut Linux-unwissend............ Beim ganz norm...
Passwortsicherheit
Joe Cole, 15.03.2018 15:15, 2 Antworten
Ich bin derzeit selbständig und meine Existenz hängt am meinem Unternehmen. Wahrscheinlich verfol...
Brother drucker einrichten.
Achim Zerrer, 13.03.2018 11:26, 1 Antworten
Da mein Rechner abgestürzt war, musste ich das Betriebssystem neu einrichten. Jetzt hänge ich wi...
Internet abschalten
Karl-Heinz Hauser, 20.02.2018 20:10, 2 Antworten
In der Symbolleiste kann man das Kabelnetzwerk ein und ausschalten. Wie sicher ist die Abschaltu...
JQuery-Script läuft nicht mit Linux-Browsern
Stefan Jahn, 16.02.2018 12:49, 2 Antworten
Hallo zusammen, ...folgender goldener Code (ein jQuery-Script als Ergebnis verschiedener Exper...