opensuse-box.jpg

© open-slx.de

Nach all den Jahren

Test der Boxversion von OpenSuse 11.4 – Bericht Nr. II

12.04.2011
Da ich mich vor rund vier Jahren von SUSE in Richtung von Debian et al. verabschiedet hatte, bot sich durch die Überlassung einer Boxed-Version von openSUSE 11.4 die Gelegenheit, einen alten Bekannten wiederzutreffen.

Das Paket enthält zwei DVDs sowie ein kleines Handbuch von knapp 130 Seiten. Das mitgelieferte Live-System bietet sich natürlich als Schnelltest an. Und siehe da, alles Wichtige funktioniert: Spracheinstellung, Tastaturbelegung, Touchpad, Bildschirmdarstellung, LAN, WLAN. Eine Installation aus dem Live-Betrieb heraus ist möglich und sollte der erste Schritt zu Weiterem sein.

Die Live-DVD

Zwar ist der Live-Installer etwas abgespeckt, sodass keine Auswahl der Desktopumgebung und der Softwarepakete im Allgemeinen möglich ist. Auch können weder Rechner- noch Domainname festgelegt werden. Aber das kann man ja dem Postinstall überlassen.

Deutlich ärgerlicher ist da schon, dass bei der Einrichtung von GRUB aus dem Stand keines der bereits installierten System (mit Ausnahme von Windows) gefunden wird. Aufgrund der einigermaßen unverständlichen Eingabemaske zur Aufnahme weiterer Menüpunkte und der hilflosen Hilfe hierzu (auch das Handbuch schweigt sich aus) wurde auch dieses auf später verschoben.

Ansonsten läuft die Installation glatt durch und ich finde mich nach einem Neustart an der Oberfläche von KDE wieder. Aber halt! Hatte ich nicht während der Installation einen Auto-Login ausdrücklich abgelehnt? Erster Minuspunkt. Und die Verwunderung geht weiter: Das gesamte System präsentiert sich, die Installationseinstellungen ignorierend, Englisch, Länder- und Tastatureinstellungen auf US. Nach Umstellung des Ganzen sollten nun die ersten Screenshots folgen. Und schon das nächste Rätsel: Die Bilder können auf die ordnungsgemäß gemountete Datenpartition nicht geschrieben werden. Über einige Umwege entdeckte ich eher zufällig die Lösung: Der Benutzer, der hier automatisch angemeldet wird, ist nicht etwa derjenige, der in der Installation angelegt wurde, sondern einer des Namens "linux", der aus dem Live-System übrig geblieben ist. Nicht schön. Aber immer noch nicht unlösbar.

Es konnten also einige weitere Tests folgen: So wird der Zwei-Monitor-Betrieb vorbildlich unterstützt und die 3D-Beschleunigung läuft Out-Of-The-Box.

Es war nun an der Zeit für einige administrative Aufgaben. Oder besser: Es wäre an der Zeit gewesen. Würden Programme wie YAST, die Root-Rechte benötigen nicht genau diesen Zugang wegen eines angeblich fehlenden su (tatsächlich ist es sehr wohl vorhanden) verweigern.

Abbildung 1: KDE findet das Programm su nicht.

Damit war ein Terminal gefragt. Und das Desaster perfekt: Konsole nimmt keine Eingaben entgegen und Xterm startet gar nicht erst. Da auf kurzem Wege keine Abhilfe möglich war, wurde der Test hier abgebrochen.

Abbildung 2: Das absolut sichere Terminal zeigt nicht einmal eine Eingabeaufforderung an.

Zweiter Versuch

Der zweite Versuch sollte nun über die reguläre Installations-DVD erfolgen. Wegen der genannten Gründe wurde GRUB gar nicht erst installiert – die Konfiguration habe ich meinem Standardsystem überlassen. Auch die Unübersichtlichkeit bei der Netzwerkkonfiguration wurde durch Auswahl der "Automatischen Konfiguration" übergangen. Als Desktop-Umgebung kam dieses Mal XFCE zum Zuge. Der Prozess verlief reibungslos. Allerdings ließ auch hier eine Überraschung nicht lange auf sich warten: Beim normalen Einbooten in den Login-Manager zeigt dieser ein nicht enden wollendes Beschäftigt-Symbol als Cursor. Und obwohl bereits hier der zweite Monitor berücksichtigt wird, lässt er sich trotz entsprechender Auswahlmöglichkeit nicht brauchbar konfigurieren. Erst der Weg über ein nachträgliches xrandr brachte den gewünschten Erfolg.

Abbildung 3: Das Dualhead-Setup funktioniert – wenn auch erst im zweiten Anlauf.

Alle weitere relevante Hardware funktioniert aber auch hier auf Anhieb, die Paketaktualisierung verlief problemlos, sodass ich zu demjenigen Testkriterium übergehen konnte, welches mich traditionell am meisten interessiert: Der Paketverwaltung. Allerdings diejenige per Kommandozeile. Hier bietet SUSE ja seit einiger Zeit zypper an, der mich beim Erstkontakt maßlos enttäuscht hatte, da er es bei Installation einfacher Pakete fertiggebracht hatte, das gesamte System lahmzulegen. Aber tatsächlich wurden alle Hürden (Suche, Info, (De)Installation, Quellenverwaltung) problemlos genommen.

Abbildung 4: Zypper in Aktion. Das Kommandozeilentool hält, was es verspricht.

Äußerst erfreulich, da der Weg über YAST nach wie vor ein gerüttelt Maß Geduld erfordert. Und gerne auch in interessanten Fehlermeldungen endet. Leider ist allerdings die standardmäßige Paketauswahl nicht besonders üppig. Zumindest, wenn man etwas abseits des Mainstreams forscht.

Abbildung 5: Q statt G: YaST weiß nicht, welches Frontend es starten soll.
Abbildung 6: Abseits bekannter Pfade – Kein Treffer bei der Suche nach Haskell.

LinuxCommunity kaufen

Einzelne Ausgabe
 

Ähnliche Artikel

Kommentare
ich war eher negativ überrascht von openSUSE 11.4
Dujan (unangemeldet), Dienstag, 12. April 2011 22:27:00
Ein/Ausklappen


Ich habe nicht die Box-Version, sondern die Download- Variante (aus dem Sonderheft von linuxuser).

networkmanager funktionierte nicht mit umts und lief dann nach erheblichem aufwand nur unzufriedenstellend,

policykit buggy oder megaschlecht vorkonfiguriert,

Energieverwaltung absolut buggy auf Netbook

beim Desktoprechner geht für kurze Zeit der Bildschirm aus...

etc.
etc.
etc

für Anfänger nicht geeignet.
habe mich jetzt gegen openSUSE entschieden


Bewertung: 322 Punkte bei 59 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: ich war eher negativ überrascht von openSUSE 11.4
jungejunge (unangemeldet), Montag, 18. April 2011 12:48:21
Ein/Ausklappen

So viel Müll in 3 Zeilen...

frag mal jemanden, der sich damit auskennt.


Bewertung: 76 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Richtige Version?
l1zard (unangemeldet), Dienstag, 12. April 2011 12:51:53
Ein/Ausklappen

Ich habe ihren Artikel gelesen und bei mir trat keiner der von Ihnen beschriebenen Fehler auf. Ich bin mir nicht sicher was sie da getestet haben, aber es war auf keinen Fall die BoxVersion oder die Stabile Version.

Das klingt für mich eher nach dem M5 von Opensuse 11.4. Dort traten die von Ihnen beschriebenen Fehler nämlich noch auf, waren aber in der finalen Version beseitigt.


Bewertung: 202 Punkte bei 18 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Richtige Version?
jb from ctu (unangemeldet), Mittwoch, 13. April 2011 10:46:16
Ein/Ausklappen

also bei mir gab es diese probs auch nicht, lief alles auf anhieb.

es gibrt nur ein kleines problem, welches ich früher schin mal hatte.
ich bekomme aufs verrec....n keine wlan-verbindung mit meinem "offnen WLAN" hin. ansonsten eine sehr gelungene distri.

das "tumbleweed-repo" ist zu empfehlen.


Bewertung: 128 Punkte bei 9 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Richtige Version?
René Franke, Donnerstag, 14. April 2011 15:48:13
Ein/Ausklappen

"Ich bin mir nicht sicher was sie da getestet haben, aber es war auf keinen Fall die BoxVersion oder die Stabile Version."

Die Testversion wurde mir originalverpackt von OpenSLX zugesandt. Und entsprechend konnte ich keinen Hinweis darauf entdecken, dass es sich um eine, wie auch immer geartete, Vorabversion handeln könnte. Auch die Registrierungsoption inkl. Installationssupport deutet eher auf eine finale Version hin.

René Franke



Bewertung: 97 Punkte bei 6 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Tipp der Woche

Schnell Multi-Boot-Medien mit MultiCD erstellen
Schnell Multi-Boot-Medien mit MultiCD erstellen
Tim Schürmann, 24.06.2014 12:40, 0 Kommentare

Wer mehrere nützliche Live-Systeme auf eine DVD brennen möchte, kommt mit den Startmedienerstellern der Distributionen nicht besonders weit: Diese ...

Aktuelle Fragen

Videoüberwachung mit Zoneminder
Heinz Becker, 10.08.2014 17:57, 0 Antworten
Hallo, ich habe den ZONEMINDER erfolgreich installiert. Das Bild erscheint jedoch nicht,...
internes Wlan und USB-Wlan-Srick
Gerhard Blobner, 04.08.2014 15:20, 2 Antworten
Hallo Linux-Forum: ich bin ein neuer Linux-User (ca. 25 Jahre Windows) und bin von WIN 8 auf Mint...
Server antwortet mit falschem Namen
oin notna, 21.07.2014 19:13, 1 Antworten
Hallo liebe Community, Ich habe mit Apache einen Server aufgesetzt. Soweit, so gut. Im Heimnet...
o2 surfstick software für ubuntu?
daniel soltek, 15.07.2014 18:27, 1 Antworten
hallo zusammen, habe mir einen o2 surfstick huawei bestellt und gerade festgestellt, das der nic...
Öhm - wozu Benutzername, wenn man dann hier mit Klarnamen angezeigt wird?
Thomas Kallay, 03.07.2014 20:30, 1 Antworten
Hallo Team von Linux-Community, kleine Zwischenfrage: warum muß man beim Registrieren einen Us...