suse9.2 centrino wlan - Problem

Charles O. - Freitag, 11. Februar 2005 21:26:31 - 9 Antworten

Hallo Leute, ich bin hier noch ganz neu und brauche Hilfe happy
Problem: Wlan vom CentrinoNotebook (X10 Samsung). Keine Verbindung zum Router.

(Habe sowohl die Probs hier im Forum gelesen wie auch das SamsungX10-Howto, aber es funzt dennoch nicht.)

Hier einige Infos zu meiner Config.
WLan ist eth1-Schnittstelle.
Alles über Yast eingestellt (auch Verschlüsselungskey mit '-' versucht).
WEP-Verschlüsselung mit 128Bit


dmesg-Output:

Linux version 2.6.8-24.11-default (geeko@buildhost) (gcc version 3.3.4 (pre 3.3.
5 20040809)) #1 Fri Jan 14 13:01:26 UTC 2005

ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, 0.56
ipw2100: Copyright(c) 2003-2004 Intel Corporation
ACPI: PCI interrupt 0000:02:07.0[A] -> GSI 5 (level, low) -> IRQ 5
ipw2100: 0000:02:07.0: Detected at mem: 0xC0000000-0xC0000FFF -> f8852000, irq:
5
eth1: Using hotplug firmware load.
eth1: Bound to 0000:02:07.0

eth1: Associated with 'ChessNet' at 11Mbps, channel 6 (BSSID=00:00:00:00:00:00

martian source 192.168.0.255 from 192.168.0.2, on dev eth1
ll header: ff:ff:ff:ff:ff:ff:00:e0:7d:88:bc:24:08:00
printk: 3 messages suppressed.
martian source 192.168.0.255 from 192.168.0.2, on dev eth1
ll header: ff:ff:ff:ff:ff:ff:00:e0:7d:88:bc:24:08:00

------------
Bin für jede Hilfe dankbar, Danke.
Charles

Antworten
Re: suse9.2 centrino wlan - Problem
Vinzenz Schmid, Samstag, 12. Februar 2005 15:00:49
Ein/Ausklappen

Mit Suse 9.2 und Dell Inspiron 8600 funzt wlan out of the box. Aber ich mache es ohne Verschlüsselung und achte wie Martin schon geschrieben hat, darauf, dass netzwerkkarte z.B. per Yast nicht konfiguriert ist.
Ich würde dir vorschlagen, die wlan verbindung ohne Verschlüsselung zu testen und herausfinden, was z.B. kwifimanager (im kde) sagt: Stärke der Verbindung, Ip-Nummer, usw.
Wenn du eine Verbindung so ohne Verschlüsselung schaffst, dann kannst du Verschlüsselung testen.


Bewertung: 123 Punkte bei 36 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: suse9.2 centrino wlan - Problem
Martin Zeller, Samstag, 12. Februar 2005 14:52:36
Ein/Ausklappen

hi,
ich tippe auf routing-probs.
poste mal die ausgabe von route und teste mal kurz ob es nach
"ifconfig eth0 down" geht.
wenn du die normale lan-karte nicht brauchst deaktiviere sie einfach in yast.
wenn nicht würde ich erstmal wep, mac-filter usw. abschalten bis die
verbindung klappt, danach eins nach dem anderen zuschalten.
was gibt eigentlich iwconfig aus?
kannst du der wlan-karte mit ifconfig der karte eine fixe ip zuweisen?
achso, in yast den key ohne trenner also ohne - oder : eingeben und
hexadezimal anklicken.
wenn yast nicht will machs mal von hand mit iwconfig
iwconfig eth1 mode managed
iwconfig eth1 enc 1111-2222-......
iwconfig eth1 essid deine_id


martin


Bewertung: 151 Punkte bei 38 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Charles O., Dienstag, 15. Februar 2005 14:35:15
Ein/Ausklappen

ES FUNZT! ...sogar verschlüsselt...

Martin hatte mit allem Recht!!!
Mein Vorgehen:
1)
Habe normale Netzkarte unter Yast entfernt und Routing für WLan auch abgestellt.
Dann mit iwconfig (wie ifconfig fürs WLan) die Verschlüsselung ausgestellt
#iwconfig eth1 enc off

2)
In meinem Netgear-Router Verschlüsselung ausgeschaltet

3)
mit route meinen Netgear-Router(Adresse 192.168.0.1) als default-gateway (gw) für mein WLan-Interface (eth1) gesetzt
#route add default gw 192.168.0.1 dev eth1

4)
Test funzt.
$ping -c 3 192.168.0.1

5)
-- Verschlüsselung --
In meinem Router WEP-Verschl. mit 128 Bit gewählt.
!!!!!!!!!!! Wichtig !!!!!!!!!!!!!!!!
Authentifizierungstyp = automatisch (NICHT offenes Sys.,sonst gehts zumindest bei mir nicht!(Netgearspez. Problem?))
!!!!!!!!!!! Wichtig !!!!!!!!!!!!!!!!

6)
Kartenconfig. (encoding in hexaddezimal - identisch zu Routereinstellung):
#iwconfig eth1 enc 86A7-75BD-2B03-AA42-55DF-4421-32

7)
Verbindung testen ..ok


Merke: Diese Änderungen müssen nun natürlich noch dauerhaft gemacht werden, sonst sind sie beim nächsten Neustart verloren

Nochmals vielen Dank für die prompte Hilfe und viel Erfolg, hoffe der Thread ist auch für andere hilfreich :)



Bewertung: 125 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Martin Zeller, Dienstag, 15. Februar 2005 15:26:20
Ein/Ausklappen

Hi,
schön zu hören wenns geklappt hat!

Martin


Bewertung: 118 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Charles O., Dienstag, 15. Februar 2005 16:47:48
Ein/Ausklappen

Thx
--hier nun das Skript um das Wlan zu starten und somit das normale Lan-Interface runterzufahren (ansonsten gibts Probleme).--

szenario: eth0 ist Lan und eth1 ist Wlan --> Wenn ich eth0 als Interface zum router verwende (192.168.0.1) funzt Wlan nicht wenn ich das Kabel rausziehe und NUR Wlan hab.
Aber wenn ich eth1 als Interface zum router verwende laufen alle Pakete übers WLan (langsamer) und wenn WLan aus ist dann geht nix mehr!

Daher 2 versch. Konfigurationen:
1) Default ist eth0 (jederzeit wiederaktivierbar mit #rcnetwork restart)

2) Wlan ist startbar mit diesem Skript :

#!/bin/sh
# loescht default route (ueber eth0)
route del default

# alle pakete ueber eth1 zu gw 192.168.0.1
route add default gw 192.168.0.1 dev eth1

# Verschlüsselungsstring (hex) setzen (besser als Yast)
iwconfig eth1 enc 7CD2-322D-2B03-AAAA-BBBF-4CC3-11

# fahre dev eth0 runter - wichtig
# besser immer nur 1 aktives Net-Interface (für Newbies wie mich :)
ifconfig eth0 down

# Test
ping -c 3 192.168.0.1

echo "eth1 - WLAN-Interface ist nun aktiv"
echo "eth0 - Lan-Interface ist nun down"

--------------------------------------------
Hoffe es hilft, Charles.


Bewertung: 222 Punkte bei 32 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Martin Zeller, Dienstag, 15. Februar 2005 20:02:48
Ein/Ausklappen

Hi,
ich bin zuanfang auch über so ein script gegangen da es mit Yast erst nicht
ging. Irgend wann habe ich es nochmal probiert und dann gings einfach. Das war
aber mit Suse 9.1.

Hast du in Yast das Modul ipw2100 angegeben?

Hast du mal probiert die von Yast erzeugte Datei von Hand zu editieren und
dann mit "ifup eth1" die config zu laden?

Denn eigentlich werden die Werte nur als Variablen verwendet die dann von den
Startscripten ausgelesen werden.

Achso, da ich die LAN-Karte nicht benötige habe ich sie im Bios abgeschaltet.
Somit wird bei mir die Wlan-Karte zu eth0.

Martin


Bewertung: 98 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Martin Zeller, Dienstag, 15. Februar 2005 20:35:30
Ein/Ausklappen

Hi,
hier meine Config-Datei.

BOOTPROTO='static'
BROADCAST='192.168.0.255'
IPADDR='192.168.0.2'
MTU=''
NETMASK='255.255.255.0'
NETWORK='192.168.0.0'
REMOTE_IPADDR=''
STARTMODE='auto'
UNIQUE='GA8e.zosBAd2HjH5'
USERCONTROL='no'
WIRELESS_AP='xx:xx:xx:xx:xx:xx'
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='meine_id'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='11112222.......' (26 Stellig)
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK=''
_nm_name='bus-pci-0000:02:01.0'

Martin


Bewertung: 103 Punkte bei 31 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: suse9.2 centrino wlan - Problem
Charles O., Dienstag, 15. Februar 2005 23:44:02
Ein/Ausklappen

Naja, die Konfiguration über Yast hat nicht recht klappen wollen. Egal. Der Wechsel zwischen WLAN und LAN ist ja nur 1 Befehl in der Konsole. Zudem benötige ich beide Interfaces, da mir WLan für grosse Kopieraktionen in meinem eigenen Netz zuu lahm sind.

Mit nur 1 Karte gehts bestimmt auch über Yast. Nochmals danke.
Charles.


Bewertung: 110 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: suse9.2 centrino wlan - Problem
Martin Zeller, Mittwoch, 16. Februar 2005 16:20:03
Ein/Ausklappen

hi,
ich würde die Wlan-Karte als Standartkarte, die beim booten konfiguriert wird,
einstellen und die Lan-Karte auf manuelles starten stellen, dann ist die
Configdatei vorhanden und du brauchst nur "ifup eth0" eingeben um sie zu
starten. Dadurch sollte die defaultroute auf die Wlan-Karte (eth1) zeigen.

Martin


Bewertung: 107 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Mit Firewire Videos improtieren?
Werner Hahn, 09.06.2016 11:06, 5 Antworten
Ich besitze den Camcorder Panasonic NV-GS330, bei dem die Videos in guter Qualität nur über den 4...
lidl internetstick für linux mint
rolf meyer, 04.06.2016 14:17, 3 Antworten
hallo zusammen ich benötige eure hilfe habe einen lidl-internetstick möchte ihn auf linux mint i...
thema ändern
a b, 29.05.2016 16:34, 0 Antworten
Hallo Linuxer zuerst alle eine schönen Sonntag, bevor ich meine Frage stelle. Ich habe Ubuntu 1...
Ideenwettbewerb
G.-P. Möller, 28.05.2016 10:57, 0 Antworten
Liebe User, im Rahmen eines großen Forschungsprojekts am Lehrstuhl für Technologie- und Innova...
Welche Drucker sind Linux-mint kompatibel?
Johannes Nacke, 20.05.2016 07:32, 6 Antworten
Hallo Ihr Lieben, ich bitte um mitteilung welche Drucker Kompatibel sind mit Linux-Mint. LG Joh...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Raspi 3: Hostname
Alexander McLean, 26.06.2016 09:31
Am Samstag, den 25.06.2016, 19:30 +0200 schrieb Matthias Müller: Hallo Matthias >  > Das sieht...
Re: [EasyLinux-Ubuntu] Raspi 3: Hostname
Matthias, 25.06.2016 19:30
Hallo Am Samstag, 25. Juni 2016, 17:56:27 schrieb Alexander McLean: > Am Samstag, den 25.06.2016, 17:11...
Re: [EasyLinux-Ubuntu] Raspi 3: Hostname
Alexander McLean, 25.06.2016 17:56
Am Samstag, den 25.06.2016, 17:11 +0200 schrieb Matthias Müller: Hallo Matthias > > Antwortet dein...
Re: [EasyLinux-Ubuntu] Raspi 3: Hostname
Matthias, 25.06.2016 17:11
Am Samstag, 25. Juni 2016, 16:10:23 schrieb Alexander McLean: > Hallo Liste > > Gebe ich dem Ra...
Re: [EasyLinux-Suse] [gelöst]_Plattenzugriff
Matthias, 25.06.2016 16:56
Hallo, Am Samstag, 25. Juni 2016, 05:08:33 schrieb Horst Schwarz: Snip > Ich werde mich auch nicht wei...