rndc reload zone - failed bad zone

Autor

Montag, 06. Februar 2012 16:08:34

Schönen guten Tag,

ich habe folgendes Problem. Immer wenn ich folgendes Kommando ausführen bekomme ich eine Fehlermeldung:
root@gosa:/#rndc reload test-domain.de
rndc: 'reload' failed: bad zone

Nun weiß ich nicht mehr weiter! Hier eine Konfigurationsdateien. Er sagt bei `named`, dass er die addresse 127.0.01#953 immer benutzt und er die Zone zweckst Fehlern nicht laden kann. Ich verstehe aber nicht weshalb und wieso? Hier noch ein paar Konfigs:

root@gosa:/etc/bind# named -p 53 -g
06-Feb-2012 15:38:56.805 starting BIND 9.7.0-P1 -p 53 -g
06-Feb-2012 15:38:56.805 built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-dlz-postgres=no' '--with-dlz-mysql=no' '--with-dlz-bdb=yes' '--with-dlz-filesystem=yes' '--with-dlz-ldap=yes' '--with-dlz-stub=yes' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions' 'CPPFLAGS='
06-Feb-2012 15:38:56.805 adjusted limit on open files from 1024 to 1048576
06-Feb-2012 15:38:56.805 found 1 CPU, using 1 worker thread
06-Feb-2012 15:38:56.805 using up to 4096 sockets
06-Feb-2012 15:38:56.811 loading configuration from '/etc/bind/named.conf'
06-Feb-2012 15:38:56.811 reading built-in trusted keys from file '/etc/bind/bind.keys'
06-Feb-2012 15:38:56.812 using default UDP/IPv4 port range: [1024, 65535]
06-Feb-2012 15:38:56.812 using default UDP/IPv6 port range: [1024, 65535]
06-Feb-2012 15:38:56.814 listening on IPv6 interfaces, port 53
06-Feb-2012 15:38:56.815 binding TCP socket: address in use
06-Feb-2012 15:38:56.815 listening on IPv4 interface lo, 127.0.0.1#53
06-Feb-2012 15:38:56.815 binding TCP socket: address in use
06-Feb-2012 15:38:56.815 listening on IPv4 interface eth0, 192.168.0.183#53
06-Feb-2012 15:38:56.816 binding TCP socket: address in use
06-Feb-2012 15:38:56.816 generating session key for dynamic DNS
06-Feb-2012 15:38:56.819 automatic empty zone: 254.169.IN-ADDR.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 2.0.192.IN-ADDR.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: D.F.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 8.E.F.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: 9.E.F.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: A.E.F.IP6.ARPA
06-Feb-2012 15:38:56.819 automatic empty zone: B.E.F.IP6.ARPA
06-Feb-2012 15:38:56.823 /etc/bind/named.conf:19: couldn't add command channel 127.0.0.1#953: address in use
06-Feb-2012 15:38:56.823 ignoring config file logging statement due to -g option
06-Feb-2012 15:38:56.824 zone 0.in-addr.arpa/IN: loaded serial 1
06-Feb-2012 15:38:56.824 zone 127.in-addr.arpa/IN: loaded serial 1
06-Feb-2012 15:38:56.825 zone 0.168.192.in-addr.arpa/IN: NS '192.168.0.183.0.168.192.in-addr.arpa' has no address records (A or AAAA)
06-Feb-2012 15:38:56.825 zone 0.168.192.in-addr.arpa/IN: not loaded due to errors.
06-Feb-2012 15:38:56.825 zone 255.in-addr.arpa/IN: loaded serial 1
06-Feb-2012 15:38:56.827 zone test-domain.de/IN: NS '192.168.0.183.test-domain.de' has no address records (A or AAAA)
06-Feb-2012 15:38:56.827 zone test-domain.de/IN: not loaded due to errors.
06-Feb-2012 15:38:56.827 zone localhost/IN: loaded serial 2
06-Feb-2012 15:38:56.828 running
06-Feb-2012 15:39:57.358 no longer listening on ::#53
06-Feb-2012 15:39:57.358 no longer listening on 127.0.0.1#53
06-Feb-2012 15:39:57.358 no longer listening on 192.168.0.183#53
06-Feb-2012 15:39:57.365 exiting




/etc/bind/test-domain.de.

$TTL 300
@ IN SOA 192.168.0.183 gosa.test-domain.de. (
2012020210 ; Serialnumber
3600 ; Refresh
1800 ; Retry
720000 ; Expire
6400 ) ; Minimum TTL
NS 192.168.0.183
MX 20 mail.test-domain.de
tux07 A 192.168.0.17
ldap A 192.168.0.183
gosa A 192.168.0.183


/etc/bind/0.168.192.in-addr.arpa.
$TTL 300
@ IN SOA 192.168.0.183 gosa.test-domain.de. (
2012020210 ; Serialnumber
3600 ; Refresh
1800 ; Retry
720000 ; Expire
6400 ) ; Minimum TTL
NS 192.168.0.183
MX 20 mail.test-domain.de.
17 PTR tux07.test-domain.de.
183 PTR ldap.test-domain.de.
PTR gosa.test-domain.de.
3 PTR mail.test-domain.de.

/etc/bind/named.conf
include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
#include "/etc/bind/named.conf.ldap2zone";

key "rndc-key" {
algorithm hmac-md5;
secret "y2Tkhbr7i8V8A4UBm8ZBHA==";
};
controls {
inet 127.0.0.1 port 953
allow { 127.0.0.1; } keys { "rndc-key"; };
};


/etc/named.conf.local
zone "test-domain.de" {
type master;
file "/etc/bind/test-domain.de.";
};

zone "0.168.192.in-addr.arpa" {
type master;
file "/etc/bind/0.168.192.in-addr.arpa.";
};


Ich hoffe ihr könnte mir weiterhelfen. Danke!

Gruß,
Ludwig

Ludwig jun. B.

2 Antworten


Antworten
NS Records erfordern den Domainname, nicht die IP-Adresse
Harald Geiger, Dienstag, 07. Februar 2012 21:21:17
Ein/Ausklappen

Hallo Ludwig!

Die "address in use" Fehler kommen daher, dass Du den
named startest, obwohl schon einer läuft, der sich an die
Ports gebunden hat.

> und er die Zone zweckst Fehlern nicht laden kann.
> Ich verstehe aber nicht weshalb und wieso?

Der Grund steht doch direkt in den Logmeldungen:
"zone test-domain.de/IN: NS '192.168.0.183.test-domain.de' has no address records (A or AAAA)"

Ein NS Record erfordert die Angabe eines Domainnamens. Hier
darf keine IP-Adresse stehen.

Also statt
" NS 192.168.0.183"
sollte es heißen:
" NS gosa.test-domain.de"

Viele Grüße,
Harald


Bewertung: 132 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: NS Records erfordern den Domainname, nicht die IP-Adresse
Ludwig jun. B., Mittwoch, 08. Februar 2012 08:32:47
Ein/Ausklappen

Hallo Harald,

danke für deine Antwort! Das war eines der Fehler die ich gemacht habe... Ein weiterer war bei Alias Einträgen den Punkt am Ende vergessen zu haben... Nun funktioniert es - Herzlichen Dank :-)

Gruß,
Ludwig


Bewertung: 90 Punkte bei 11 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • pdnsd als lokaler Nameserver
    Viele kleine Netzwerke verwenden zur Namensauflösung die hosts-Tabelle. Dabei hat der Einsatz eines Nameservers viele Vorteile und muss gar nicht kompliziert sein.
  • Stets gut informiert
    Deutsche Webseiten bieten meist ein Impressum mit wichtigen Informationen zum Anbieter – das gilt aber nicht immer, und für ausländische Seiten erst recht nicht. Kommandozeilentools für Linux geben die gesuchte Auskunft.
  • Ein Blick hinter die Kulissen: dig und DNS
    Der Domain Name Service (DNS) übersetzt zwischen benutzerfreundlichen Rechnernamen und computerfreundlichen IP-Adressen. Diesmal wollen wir uns nicht ansehen, wie man das einrichtet, sondern einen Blick hinter die Kulissen werfen. Ein kleines Programm spielt für uns Spion.
  • Zone Key Tool 1.0 vereinfacht DNSSEC-Verwaltung

    Die Tools, die sich um die Verwaltungswerkzeuge für sichere Namensauflösung im ISC Bind 9.3 kümmern, gelten als kompliziert zu benutzen, besonders wenn Admins bei Internet Service Providern viele Domänen zu verwalten haben. Die Kommandozeilentoolsammlung ZKT will das ändern.
  • Verzeichnisdienst whois
    Das Internet bietet eine Fülle von Informationen. Dazu gehören auch Auskünfte über den zugehörigen Anbieter in Form von Kontaktinformationen zu Domains und IP-Adressen. Freilich sollte man wissen, wie man darauf zugreift.

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 0 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 0 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Opwera_öffnet_Seite_nicht
Hartmut Haase, 30.06.2015 09:45
Hallo Heiko, > Der FF hat kein noscript. meiner ja, und ich komme soweit: http://picpaste.de/mathe1-U6...
Re: [EasyLinux-Ubuntu] [Erledigt] PDF Datei, Typ: Dokument (application/pdf)
Hartmut Haase, 30.06.2015 09:31
Hallo Heiko, > Hab ich mir schlimmer vorgestellt,ist aber keine Officedatei. bei meiner txt-Version sind...
Re: [EasyLinux-Ubuntu] [Erledigt] PDF Datei, Typ: Dokument (application/pdf)
Hartmut Haase, 30.06.2015 09:24
Hallo Alfred, > Was fehlt ist das richtige Spalten-Format. das ist bei mir auch so, -- Viele Grüße,...
Re: [EasyLinux-Ubuntu] Mounten - policykit
Willi Zelinka, 30.06.2015 09:17
Hallo Joachim, Am Montag, 29. Juni 2015, 22:58:44 schrieb Joachim Puttkammer: > Am Montag, 29. Juni 2015...
Re: [EasyLinux-Ubuntu] [Erledigt] PDF Datei, Typ: Dokument (application/pdf)
Heiko, 29.06.2015 23:16
Am Montag, 29. Juni 2015, 18:22:12 schrieb Hartmut Haase: Hallo Hartmut und Alfred., > > > prim...