openSuse 11.1 und die Kommandozeile

Heinz Kolbe - Montag, 16. Februar 2009 15:28:23 - 9 Antworten

Hallo an alle Helfer,
nach der Installation von openSuse 11.1 (vorher 11.0) lande ich auf der Kommandozeile. Kann mich dort als root mit Kennwort einloggen,
finde aber keinen Befehl der mich auf den KDE-Desktop bringt.
Bei der Installation habe ich KDE-Desktop 3.5 gewählt.
Die Tasten-Kombination -Alt-F....... habe ich ausprobiert.
Warum lande ich überhaupt auf der Kommandozeile?
Wie komm ich da wieder heraus?
Im Voraus besten Dank.
Heinz Kolbe

Antworten
Sax2
Marcel Hilzinger, Montag, 16. Februar 2009 16:36:39
Ein/Ausklappen

Hallo Heinz,
vermutlich hat das Setup des X-Servers nicht geklappt, dann kannst du mit startx auch keinen X-Server starten.

Wenn du als Root eingeloggt bist, folgende Befehle eingeben:

init 3
sax2

init 3 wechselt in den Textmodus, falls der X-Server abgestürzt sein sollte, ist das wichtig. Sax2 ist eine GUI für das Setup der grafischen Oberfläche. In Sax kannst du gleich auf Speichern/OK klicken oder Konfiguration ändern wählen, um die Auflösung, Farbtiefe etc. einzustellen.

Zeigt Sax eine grafische Oberfläche an, dann die Konfiguration speichern und zurück auf der Kommandozeile

init 5

eingeben. Jetzt startet automatisch KDE.


Bewertung: 239 Punkte bei 62 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe (unangemeldet), Montag, 16. Februar 2009 17:44:11
Ein/Ausklappen

Hallo MarKre, Hallo Herr Hilzinger!
recht vielen Dank für die Hilfe, bin momentan wieder zu -openSuse -11.0- zurückgekehrt. In Kürze werde ich 11.1 neu anpacken um Ihre
Tipps umzusetzen.
Heinz Kolbe mit Grüßen aus Schleswig-Holstein














Bewertung: 208 Punkte bei 68 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe (unangemeldet), Mittwoch, 18. Februar 2009 15:19:39
Ein/Ausklappen

Hallo Herr Hilzinger,
nach erneuter Installation von openSuse 11.1 habe ich Ihre
Tipps angewandt, daraufhin kam die Meldung, dass der
x-Server nicht gestartet werden kann bzw. nicht läuft.
Mehrere Textzeilen wurden aufgelistet, letztendlich fand ich mich
auf dem Login-Promt wieder.
Nun bin ich erneut bei 11.0 und möchte dort auch bleiben.
M.f.G. Heinz Kolbe



Bewertung: 280 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
arvo (unangemeldet), Mittwoch, 18. Februar 2009 18:26:09
Ein/Ausklappen

Dasselbe Problem hatte ich einmal bei einem Update von OpenSuse 10.1 auf 10.3. Ich kenne leider nicht die Installationsinterna von OpenSuse, denke aber, dass das System während der Installation die Hardware daraufhin überprüft, ob ein Grafikmodus sinnvoll betrieben werden kann. Ist die Antwort negativ, wird erst gar kein X-Server installiert, der Benutzer arbeitet dann am boot-prompt. Leider wird während der Installationsroutine an keiner Stelle eine entsprechende Warnung ausgegeben. Eine um einiges umfangreichere Knoppix-Live-Distribution startete auf demselben Rechner aber ohne weiteres im Grafik-Modus.


Bewertung: 199 Punkte bei 71 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe, Donnerstag, 19. Februar 2009 16:13:30
Ein/Ausklappen

Hallo Aivo,
an Deiner Diagnose könnte etwas dran sein.
Da mein -PC- mit 11.0 noch einwandfrei läuft,
ist meine integrierte Grafikkarte für 11.1 vielleicht
zu schlicht gestrickt.
Heinz Kolbe


Bewertung: 221 Punkte bei 58 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe, Samstag, 21. Februar 2009 15:59:21
Ein/Ausklappen

Erfolgsmeldung an alle Helfer !
Habe heute eine Grafikkarte eingebaut.
Die auf dem Mainboard integrierte ist nicht mehr angeschlossen.
Danach openSuse 11.0 gestartet, unerwartet kam ich auf die
Kommandozeile. Dort konnte ich die Tipps von Marcel Hilzinger anwenden und den x-Server starten.
Anschließend habe ich 11.1 installiert, und man glaubt es kaum,
die grafische KDE-Oberfläche war auf dem Bildschirm.
Den Beteiligten danke ich
Heinz Kolbe



Bewertung: 236 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Sax2
Klaus Weisbrich (unangemeldet), Donnerstag, 19. Februar 2009 21:15:45
Ein/Ausklappen

Hallo Heinz Kolbe
was steht denn in den "aufgelisteten Textzeilen"? so ist das ganze doch nur ein Stochern im Nebel.
MfG
Klaus


Bewertung: 203 Punkte bei 69 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kommandozeile
MarKre (unangemeldet), Montag, 16. Februar 2009 16:04:24
Ein/Ausklappen

Bin zwar kein Profi, glaube aber irgendwo gelesen zu haben, daß man mit dem Befehl "startX" das grafische Konfigurationssystem erreicht. Dort kann man dann die Grafikkarte auswählen oder den Standard-Treiber aktivieren.

root -> passswort -> startx




Bewertung: 250 Punkte bei 49 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Kommandozeile
lilalu (unangemeldet), Dienstag, 17. Februar 2009 18:01:45
Ein/Ausklappen

startx startet nur die GUI (graphisches User Interface)

sowie Marcel Hilzinger, es geschrieben hat ist es richtig.



Bewertung: 252 Punkte bei 52 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Develop Drucker
Jürgen Kos, 27.02.2017 18:15, 0 Antworten
Hallo Comunity. Ich habe nen älteren Developdrucker D3550iD und wollte ihn ins Netzwerk einbin...
Probleme mit der Maus
Thomas Roch, 21.02.2017 13:43, 1 Antworten
Nach 20 Jahren Windows habe ich mich zu Linux Ubuntu probeweise durchgerungen!!! Installation - k...
KWin stürzt ab seit Suse Leap 42.2
Wimpy *, 21.02.2017 09:47, 4 Antworten
OpenSuse 42.2 KDE 5.8.3 Framework 5.26.0 QT 5.6.1 Kernel 4.4.46-11-default 64-bit Open-GL 2....
Shell-Befehl zur Installation von Scanner-Treiber
Achim Zerrer, 15.02.2017 12:13, 10 Antworten
Hallo, ich habe Einen Brother Drucker mit Scanner. Nachdem ich mit Hilfe der Community den Druck...
kiwix öffnet ZIM Datei nicht
Adrian Meyer, 13.02.2017 18:23, 1 Antworten
Hi, ich nutze Zim Desktop für mein privates Wiki. Fürs Handy habe ich mir kiwix heruntergelade...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Installation von Mint 18.1 geht nicht
Matthias, 27.02.2017 22:05
Hallo Heiko, Am Montag, 27. Februar 2017, 03:49:33 schrieb Heiko Ißleib: Snip > Zitat von einem langjä...
Re: [EasyLinux-Ubuntu] Installation von Mint 18.1 geht nicht
Rainer, 27.02.2017 08:51
Hallo Heiko, Am Mon, 27 Feb 2017 02:10:18 +0100 schrieb Heiko Ißleib : > > > > Ich denke,...
Re: [EasyLinux-Ubuntu] Installation von Mint 18.1 geht nicht
Heiko, 27.02.2017 03:49
Am Samstag, 25. Februar 2017, 17:46:52 schrieb Uwe Herrmuth: Hallo Uwe, hallo Gerhard,hallo an alle, >...
Re: [EasyLinux-Ubuntu] Installation von Mint 18.1 geht nicht
Heiko, 27.02.2017 02:10
Am Montag, 27. Februar 2017, 01:04:01 schrieb Rainer: Hallo. > Am Mon, 27 Feb 2017 00:33:34 +0100 >...
Re: [EasyLinux-Ubuntu] Installation von Mint 18.1 geht nicht
Rainer, 27.02.2017 01:04
Am Mon, 27 Feb 2017 00:33:34 +0100 schrieb Alfred Zahlten : > >> > >> Installation von...