openSuse 11.1 und die Kommandozeile

Heinz Kolbe - Montag, 16. Februar 2009 15:28:23 - 9 Antworten

Hallo an alle Helfer,
nach der Installation von openSuse 11.1 (vorher 11.0) lande ich auf der Kommandozeile. Kann mich dort als root mit Kennwort einloggen,
finde aber keinen Befehl der mich auf den KDE-Desktop bringt.
Bei der Installation habe ich KDE-Desktop 3.5 gewählt.
Die Tasten-Kombination -Alt-F....... habe ich ausprobiert.
Warum lande ich überhaupt auf der Kommandozeile?
Wie komm ich da wieder heraus?
Im Voraus besten Dank.
Heinz Kolbe

Antworten
Sax2
Marcel Hilzinger, Montag, 16. Februar 2009 16:36:39
Ein/Ausklappen

Hallo Heinz,
vermutlich hat das Setup des X-Servers nicht geklappt, dann kannst du mit startx auch keinen X-Server starten.

Wenn du als Root eingeloggt bist, folgende Befehle eingeben:

init 3
sax2

init 3 wechselt in den Textmodus, falls der X-Server abgestürzt sein sollte, ist das wichtig. Sax2 ist eine GUI für das Setup der grafischen Oberfläche. In Sax kannst du gleich auf Speichern/OK klicken oder Konfiguration ändern wählen, um die Auflösung, Farbtiefe etc. einzustellen.

Zeigt Sax eine grafische Oberfläche an, dann die Konfiguration speichern und zurück auf der Kommandozeile

init 5

eingeben. Jetzt startet automatisch KDE.


Bewertung: 217 Punkte bei 57 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe (unangemeldet), Montag, 16. Februar 2009 17:44:11
Ein/Ausklappen

Hallo MarKre, Hallo Herr Hilzinger!
recht vielen Dank für die Hilfe, bin momentan wieder zu -openSuse -11.0- zurückgekehrt. In Kürze werde ich 11.1 neu anpacken um Ihre
Tipps umzusetzen.
Heinz Kolbe mit Grüßen aus Schleswig-Holstein














Bewertung: 191 Punkte bei 64 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe (unangemeldet), Mittwoch, 18. Februar 2009 15:19:39
Ein/Ausklappen

Hallo Herr Hilzinger,
nach erneuter Installation von openSuse 11.1 habe ich Ihre
Tipps angewandt, daraufhin kam die Meldung, dass der
x-Server nicht gestartet werden kann bzw. nicht läuft.
Mehrere Textzeilen wurden aufgelistet, letztendlich fand ich mich
auf dem Login-Promt wieder.
Nun bin ich erneut bei 11.0 und möchte dort auch bleiben.
M.f.G. Heinz Kolbe



Bewertung: 272 Punkte bei 42 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
arvo (unangemeldet), Mittwoch, 18. Februar 2009 18:26:09
Ein/Ausklappen

Dasselbe Problem hatte ich einmal bei einem Update von OpenSuse 10.1 auf 10.3. Ich kenne leider nicht die Installationsinterna von OpenSuse, denke aber, dass das System während der Installation die Hardware daraufhin überprüft, ob ein Grafikmodus sinnvoll betrieben werden kann. Ist die Antwort negativ, wird erst gar kein X-Server installiert, der Benutzer arbeitet dann am boot-prompt. Leider wird während der Installationsroutine an keiner Stelle eine entsprechende Warnung ausgegeben. Eine um einiges umfangreichere Knoppix-Live-Distribution startete auf demselben Rechner aber ohne weiteres im Grafik-Modus.


Bewertung: 184 Punkte bei 66 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe, Donnerstag, 19. Februar 2009 16:13:30
Ein/Ausklappen

Hallo Aivo,
an Deiner Diagnose könnte etwas dran sein.
Da mein -PC- mit 11.0 noch einwandfrei läuft,
ist meine integrierte Grafikkarte für 11.1 vielleicht
zu schlicht gestrickt.
Heinz Kolbe


Bewertung: 211 Punkte bei 54 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Sax2
Heinz Kolbe, Samstag, 21. Februar 2009 15:59:21
Ein/Ausklappen

Erfolgsmeldung an alle Helfer !
Habe heute eine Grafikkarte eingebaut.
Die auf dem Mainboard integrierte ist nicht mehr angeschlossen.
Danach openSuse 11.0 gestartet, unerwartet kam ich auf die
Kommandozeile. Dort konnte ich die Tipps von Marcel Hilzinger anwenden und den x-Server starten.
Anschließend habe ich 11.1 installiert, und man glaubt es kaum,
die grafische KDE-Oberfläche war auf dem Bildschirm.
Den Beteiligten danke ich
Heinz Kolbe



Bewertung: 218 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Sax2
Klaus Weisbrich (unangemeldet), Donnerstag, 19. Februar 2009 21:15:45
Ein/Ausklappen

Hallo Heinz Kolbe
was steht denn in den "aufgelisteten Textzeilen"? so ist das ganze doch nur ein Stochern im Nebel.
MfG
Klaus


Bewertung: 189 Punkte bei 64 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kommandozeile
MarKre (unangemeldet), Montag, 16. Februar 2009 16:04:24
Ein/Ausklappen

Bin zwar kein Profi, glaube aber irgendwo gelesen zu haben, daß man mit dem Befehl "startX" das grafische Konfigurationssystem erreicht. Dort kann man dann die Grafikkarte auswählen oder den Standard-Treiber aktivieren.

root -> passswort -> startx




Bewertung: 241 Punkte bei 45 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Kommandozeile
lilalu (unangemeldet), Dienstag, 17. Februar 2009 18:01:45
Ein/Ausklappen

startx startet nur die GUI (graphisches User Interface)

sowie Marcel Hilzinger, es geschrieben hat ist es richtig.



Bewertung: 243 Punkte bei 48 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Scannen nicht möglich
Werner Hahn, 19.08.2016 22:33, 3 Antworten
Laptop DELL Latitude E6510 mit Ubuntu 16,04, Canon Pixma MG5450. Das Drucken funktioniert, Scann...
Wie kann man das berichtigen
Udo Muelle, 17.07.2016 20:39, 1 Antworten
Fehlschlag beim Holen von http://extra.linuxmint.com/dists/rosa/main/binary-i386/Packages Hash-S...
Installation Genimotion
Horst Müller, 15.07.2016 17:00, 1 Antworten
Hallo, ich kann Genimotion nicht installieren. Folgende Fehlermeldung habe ich beim Aufruf erh...
Probleme beim Hochfahren der Terastaion 5400 mit Unix-Distrib
Sheldon Cooper, 10.07.2016 09:32, 0 Antworten
Hallo ihr lieben, habe seit zwei Tagen das Problem, das das NAS (Raid5) nicht mehr sauber hoch...
Mit Firewire Videos improtieren?
Werner Hahn, 09.06.2016 11:06, 5 Antworten
Ich besitze den Camcorder Panasonic NV-GS330, bei dem die Videos in guter Qualität nur über den 4...

Jetzt auf den Mailinglisten

[EasyLinux-Ubuntu] Wetteranzeige defekt?
Rainer, 24.08.2016 17:06
Hallo zusammen, seit den jüngsten Aktualisierungen ist unter Ubuntu 14.04 die Wetteranzeige verschwunden (a...
Re: [EasyLinux-Suse] Kein Booten von opensuse Leap42
Udo Teichmann, 24.08.2016 15:32
Mir ist nicht ganz verständlich, worauf Du hinaus willst?Ich habe nach dem letzten Zusammenbruch ...
Re: [EasyLinux-Ubuntu] Ubuntu 16.04 LTS starten sehr langsam
Uwe Herrmuth, 24.08.2016 08:00
Hallo Reinhard, Reinhard schrieb am 19.08.2016 um 17:02: > reinhard@reinhard-P45A01:~$ sudo tune2fs -l /...
Re: [EasyLinux-Suse] Kein Booten von opensuse Leap42
Heiko, 23.08.2016 22:30
Am Dienstag, 23. August 2016, 19:49:53 schrieb Udo Teichmann: Hallo Udo > > Seit vorgestern bootet...
[EasyLinux-Suse] Kein Booten von opensuse Leap42
Udo Teichmann, 23.08.2016 19:49
Hallo Liste Seit vorgestern bootet der Laptop mit opensuse Leap42 nicht mehr.Wenn ich das Bild beim Booten...