nvivia- Treiber funzt nicht mehr

TillDawn - Donnerstag, 10. Februar 2005 12:15:37 - 4 Antworten

Hallo zusammen,
nachdem ich am Samstag, dem 05.02.05 ein Online- Update des Suse- Kernels gefahren habe, blieb der Bildschirm nach dem Starten von Suse-Linux schwarz. Eine Eingabe war in keiner Weise möglich. Die letzte Bildschirmausgabe ist/ war STARTING SERVICE KDM. Die Repair- Funktion der Distribution brachte keine Ergebnis. Mit dem Rescue- System kenne ich mich zugegebener Maßen nicht besonders gut aus.
Also habe ich die Update- Funktion genutzt. Hier bekomme ich wieder einen Bildschirm, jedoch ohne 3D- Beschleunigung. Sobald ich den nvidia- Treiber update ist der Bildschirm wieder schwarz, wobei es egal ist, welchen kernel ich installiert habe.

Wer kann mir aus der Misere helfen?


System:
AMD Athlon 2200 +
Geforce FX 5200
Suse 9.1


Antworten
Re: nvivia- Treiber funzt nicht mehr
Georg E. Schwarzwälder, Donnerstag, 10. Februar 2005 13:24:40
Ein/Ausklappen

Hi,

bei jedem Kernel-Update muß eine Neuinstallation des Nvidia-Treibers erfolgen
(Kernel-Modul).

Ich habe bisher nie das vorgeschlagene Nvidia Treiber-Update installiert, sondern stets
das Paket NVIDIA-Linux-x86-1.0-xxxx-pkg1.run gezogen und installiert. Beim Installieren
allerdings das Selbstkompilieren des Kernel-Moduls angegeben und habe damit nie
Probleme gehabt (doch einmal, als mit Kernel 2.6.x die 4KB kernel stack pages neu
hinzukamen).

Selber machen ist besser als auf den Distri (wer auch immer) vertrauen.

/r
Georg


Bewertung: 221 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: nvivia- Treiber funzt nicht mehr
Harald Nikolisin, Donnerstag, 10. Februar 2005 15:01:36
Ein/Ausklappen

wie mein vorgänger schon erwähnt hat, ist der grafiktreiber von NVidia ein Kernelmodul, welches an den Kernel immer angepasst werden muss. Ganz selten gehts auch noch wenn der Kernel nur minimal modifiziert worden ist.

Im Prinzip macht man bei jedem Kernelupdate das gleiche:

System im runlevel 3 hochfahren (eine "3" beim bootprompt eingeben)
als root einloggen
cd /usr/src/linux
make cloneconfig
make modules_prepare
MEINPFAD/nvidia-linux-x86-1.0-6629-pkg1.run


Es wurde vorrausgesetzt, dass die kernel-sourcen installiert sind und das paket nvidia-linux-x86-1.0-6629-pkg1.run heruntergeladen wurde und in MEINPFAD liegt.


Bewertung: 253 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: nvivia- Treiber funzt nicht mehr
TillDawn , Samstag, 12. Februar 2005 09:11:44
Ein/Ausklappen

ganz wunderbar, der treiber funzt wieder. vielen dank für eure schnelle hilfe.
nur eine Frage hätte ich da noch: wieso ist das problem erst jetzt bei mir aufgetreten?
ich hatte ja nun schon immer einen kernel >=2.6.1 und die updates sowie das nvidia patch über yast funktionierten bis vor einer woche immer einwandfrei. Nur wegen des verständnis wegen: was ist passiert, was nicht hätte passieren sollen?




Bewertung: 183 Punkte bei 45 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: nvivia- Treiber funzt nicht mehr
Martin Luetzelberger, Donnerstag, 10. Februar 2005 12:39:42
Ein/Ausklappen

Lass mich raten: Du hast Kernel 2.6.10 und den Nvidia 1.0-6629 Treiber installiert?! Der Fehler ist bekannt und betrifft alle Kernel >= 2.6.10.
Wie man dieses Problem löst ist bereits im Nvidia Linux Forum beschrieben [1].
Der naechste Nvidia Treiber soll dieses Problem beheben, es ist aber nicht bekannt wann er freigegeben wird. In der Zwischenzeit bleibt nur die Moeglichkeit den Treiber selbst zu patchen wie im Forum beschrieben, oder den X.org "nv" Treiber zu verwenden.


[1] http://www.nvnews.net/vbulletin/forumdisplay.php?f=14



Bewertung: 243 Punkte bei 55 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Samsung VG-KBD1500 - Bluetooth-Tastatur mit Touchpad mit Xubuntu 16.04.2 LTS
Linux- & BSD-UserGroup im Weserbergland, 16.08.2017 19:16, 0 Antworten
Bin grad mit "meinem Latein am Ende" darum hier mal so in den Raum geworfen. Samsung VG-KBD1500 -...
Tails verbindet nicht mit WLan
Georg Vogel, 30.07.2017 15:06, 5 Antworten
Hallo zusammen! Habe mir von Linux Mint aus einen Tails USB-Stick erstellt. Läuft soweit gut,...
Genivi for Raspberry Pi 3
Sebastian Ortmanns, 28.07.2017 10:37, 1 Antworten
I try to build a Genivi Development Platform for Rasberry Pi 3. But I always get the failures bel...
Bash awk Verständnis-Frage
Josef Federl, 22.07.2017 17:46, 2 Antworten
#!/bin/bash # Skriptdateiname = test.sh spaltennummer=10 wert=zehner awk '{ $'$spaltennummer'...
Bash - verschachtelte Variablenersetzung, das geht doch eleganter als meine Lösung?
Josef Federl, 18.07.2017 20:24, 3 Antworten
#!/bin/bash #Ziel des Skriptes wird sein die ID zu extrahieren hier nur als Consolentest: root@...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Internet Geschwindigkeit
Udo Teichmann, 19.08.2017 15:49
Am Samstag, den 05.08.2017, 18:20 +0200 schrieb Udo Teichmann: Liebe fleißige Helfer Vielen Dank für den Ti...
[EasyLinux-Ubuntu] Notebook wacht nicht mehr auf
Gerhard Blaschke, 19.08.2017 15:04
Hallo Liste, habe hier ein Notebook Acer Extensa 5630 mit Wheezy. Testweise habe ich es in den Ruhezustand...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 18.08.2017 08:52
Hallo Volker, Volker schrieb am 18.08.2017 um 07:33: > volker@volker-Aspire-E5-575:~$ echo $PWD &&am...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 18.08.2017 07:33
Hallo Uwe, Am 16.08.2017 um 21:56 schrieb Uwe Herrmuth: > > Dann hab ich eine ganz gewagte Vermutu...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 21:56
Hallo Volker, Volker Borst schrieb am 16.08.2017 um 19:22: > > echo $PS1 > > ${debian_chr...