nvivia- Treiber funzt nicht mehr

TillDawn - Donnerstag, 10. Februar 2005 12:15:37 - 4 Antworten

Hallo zusammen,
nachdem ich am Samstag, dem 05.02.05 ein Online- Update des Suse- Kernels gefahren habe, blieb der Bildschirm nach dem Starten von Suse-Linux schwarz. Eine Eingabe war in keiner Weise möglich. Die letzte Bildschirmausgabe ist/ war STARTING SERVICE KDM. Die Repair- Funktion der Distribution brachte keine Ergebnis. Mit dem Rescue- System kenne ich mich zugegebener Maßen nicht besonders gut aus.
Also habe ich die Update- Funktion genutzt. Hier bekomme ich wieder einen Bildschirm, jedoch ohne 3D- Beschleunigung. Sobald ich den nvidia- Treiber update ist der Bildschirm wieder schwarz, wobei es egal ist, welchen kernel ich installiert habe.

Wer kann mir aus der Misere helfen?


System:
AMD Athlon 2200 +
Geforce FX 5200
Suse 9.1


Antworten
Re: nvivia- Treiber funzt nicht mehr
Georg E. Schwarzwälder, Donnerstag, 10. Februar 2005 13:24:40
Ein/Ausklappen

Hi,

bei jedem Kernel-Update muß eine Neuinstallation des Nvidia-Treibers erfolgen
(Kernel-Modul).

Ich habe bisher nie das vorgeschlagene Nvidia Treiber-Update installiert, sondern stets
das Paket NVIDIA-Linux-x86-1.0-xxxx-pkg1.run gezogen und installiert. Beim Installieren
allerdings das Selbstkompilieren des Kernel-Moduls angegeben und habe damit nie
Probleme gehabt (doch einmal, als mit Kernel 2.6.x die 4KB kernel stack pages neu
hinzukamen).

Selber machen ist besser als auf den Distri (wer auch immer) vertrauen.

/r
Georg


Bewertung: 214 Punkte bei 45 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: nvivia- Treiber funzt nicht mehr
Harald Nikolisin, Donnerstag, 10. Februar 2005 15:01:36
Ein/Ausklappen

wie mein vorgänger schon erwähnt hat, ist der grafiktreiber von NVidia ein Kernelmodul, welches an den Kernel immer angepasst werden muss. Ganz selten gehts auch noch wenn der Kernel nur minimal modifiziert worden ist.

Im Prinzip macht man bei jedem Kernelupdate das gleiche:

System im runlevel 3 hochfahren (eine "3" beim bootprompt eingeben)
als root einloggen
cd /usr/src/linux
make cloneconfig
make modules_prepare
MEINPFAD/nvidia-linux-x86-1.0-6629-pkg1.run


Es wurde vorrausgesetzt, dass die kernel-sourcen installiert sind und das paket nvidia-linux-x86-1.0-6629-pkg1.run heruntergeladen wurde und in MEINPFAD liegt.


Bewertung: 243 Punkte bei 45 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: nvivia- Treiber funzt nicht mehr
TillDawn , Samstag, 12. Februar 2005 09:11:44
Ein/Ausklappen

ganz wunderbar, der treiber funzt wieder. vielen dank für eure schnelle hilfe.
nur eine Frage hätte ich da noch: wieso ist das problem erst jetzt bei mir aufgetreten?
ich hatte ja nun schon immer einen kernel >=2.6.1 und die updates sowie das nvidia patch über yast funktionierten bis vor einer woche immer einwandfrei. Nur wegen des verständnis wegen: was ist passiert, was nicht hätte passieren sollen?




Bewertung: 162 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: nvivia- Treiber funzt nicht mehr
Martin Luetzelberger, Donnerstag, 10. Februar 2005 12:39:42
Ein/Ausklappen

Lass mich raten: Du hast Kernel 2.6.10 und den Nvidia 1.0-6629 Treiber installiert?! Der Fehler ist bekannt und betrifft alle Kernel >= 2.6.10.
Wie man dieses Problem löst ist bereits im Nvidia Linux Forum beschrieben [1].
Der naechste Nvidia Treiber soll dieses Problem beheben, es ist aber nicht bekannt wann er freigegeben wird. In der Zwischenzeit bleibt nur die Moeglichkeit den Treiber selbst zu patchen wie im Forum beschrieben, oder den X.org "nv" Treiber zu verwenden.


[1] http://www.nvnews.net/vbulletin/forumdisplay.php?f=14



Bewertung: 241 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Wie kann man das berichtigen
Udo Muelle, 17.07.2016 20:39, 1 Antworten
Fehlschlag beim Holen von http://extra.linuxmint.com/dists/rosa/main/binary-i386/Packages Hash-S...
Installation Genimotion
Horst Müller, 15.07.2016 17:00, 1 Antworten
Hallo, ich kann Genimotion nicht installieren. Folgende Fehlermeldung habe ich beim Aufruf erh...
Probleme beim Hochfahren der Terastaion 5400 mit Unix-Distrib
Sheldon Cooper, 10.07.2016 09:32, 0 Antworten
Hallo ihr lieben, habe seit zwei Tagen das Problem, das das NAS (Raid5) nicht mehr sauber hoch...
Mit Firewire Videos improtieren?
Werner Hahn, 09.06.2016 11:06, 5 Antworten
Ich besitze den Camcorder Panasonic NV-GS330, bei dem die Videos in guter Qualität nur über den 4...
lidl internetstick für linux mint
rolf meyer, 04.06.2016 14:17, 3 Antworten
hallo zusammen ich benötige eure hilfe habe einen lidl-internetstick möchte ihn auf linux mint i...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Neuer Linux UBUNTU 16.04 LTs Benutzer
Uwe Herrmuth, 27.07.2016 21:30
Hallo Karl, Karl schrieb am 27.07.2016 um 20:36: > Ich habe es geschafft Linux UBUNTU 16.04 LTS neu zu I...
Re: [EasyLinux-Ubuntu] seltsame Mail im Postfach
Uwe Herrmuth, 27.07.2016 21:16
Hallo Karl-Heinz, Karl-Heinz schrieb am 27.07.2016 um 19:28: > seit heute bekomme ich alle 5 Minuten (da...
Re: [EasyLinux-Ubuntu] Neuer Linux UBUNTU 16.04 LTs Benutzer
Karl Bertsche, 27.07.2016 20:36
???????????????????????????????????????????????????16??4????????????????????????????????????????2??????????????...
[EasyLinux-Ubuntu] seltsame Mail im Postfach
Karl-Heinz, 27.07.2016 19:28
Hallo zusammen, seit heute bekomme ich alle 5 Minuten (dann holt Fechtmail die E-Mails ab) diese Mail in Po...
Re: [EasyLinux-Ubuntu] DICOM-Bilder umwandeln
Karl-Heinz, 27.07.2016 19:08
Am Wed, 27 Jul 2016 15:25:30 +0200 schrieb Hartmut Haase : Hallo Hartmut, > gibt es ein Programm, um D...