mount Problem

Stefan Koch - Donnerstag, 11. August 2005 15:57:34 - 4 Antworten

Hallo,

ich versuche mein Siemens MC60 zu mounten, dies funktioniert wunderbar mit:

mount -t siefs /dev/ttyS0 /media/mobile

Das Problem: Ich kann nur als root auf /media/mobile zugreifen. Warum nicht als normaler user? Als normaler user ist /media/mobile nicht mehr sichtbar vor dem mounten schon.

System: SUSE Linux 9.3

Danke!

Antworten
Re: mount Problem
Wiebke Schroeder, Donnerstag, 11. August 2005 16:38:34
Ein/Ausklappen

Hallo Stefan.

Hast Du mal einen Blick in die /etc/fstab geworfen?

Wenn Du da nach dem Eintrag /dev/ttyS0 suchst und dann die letzte oder vorletzte Spalte dabei betrachtest, dann wird da wahrscheinlich eine Einschränkung auf den User root drinstehen, die verhindert, dass Du das Laufwerk auch als Normaluser mounten kannst.

Gruß

Wiebke




Bewertung: 240 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
lightmaker , Donnerstag, 11. August 2005 17:36:15
Ein/Ausklappen

Dabei gehst Du aber davon aus, das schon ein Eintrag in der /etc/fstab existiert. Unter Umständen muß dieser Eintrag aber erst erstellt werden.

Eine zusätzliche Zeile in der /etc/fstab sollte ungefähr so aussehen:

/dev/ttyS0 /media/mobile siefs user,noauto[,sonstige Optionen] 0 0

Dabei ist das "user" die Option, die es dem normal User erlaubt externe Platten oder Systeme ins eigene System einzubinden.

Ich hoffe, das hilft weiter.


Bewertung: 209 Punkte bei 36 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Stefan Koch, Donnerstag, 11. August 2005 21:18:23
Ein/Ausklappen

kann ich user nicht auch als option bei -o angeben?


Bewertung: 131 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Florian E.J. Fruth, Freitag, 12. August 2005 00:29:03
Ein/Ausklappen

ja kann man zb. mit mount -o uid=1000,gid=1000 /dev/foo /mnt/bar - aber dann musst du zum mounten root sein. wenn du in der /etc/fstab als option user eingibst kann man das device auch als user mounten.
fejf


Bewertung: 208 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Samsung VG-KBD1500 - Bluetooth-Tastatur mit Touchpad mit Xubuntu 16.04.2 LTS
Linux- & BSD-UserGroup im Weserbergland, 16.08.2017 19:16, 0 Antworten
Bin grad mit "meinem Latein am Ende" darum hier mal so in den Raum geworfen. Samsung VG-KBD1500 -...
Tails verbindet nicht mit WLan
Georg Vogel, 30.07.2017 15:06, 5 Antworten
Hallo zusammen! Habe mir von Linux Mint aus einen Tails USB-Stick erstellt. Läuft soweit gut,...
Genivi for Raspberry Pi 3
Sebastian Ortmanns, 28.07.2017 10:37, 1 Antworten
I try to build a Genivi Development Platform for Rasberry Pi 3. But I always get the failures bel...
Bash awk Verständnis-Frage
Josef Federl, 22.07.2017 17:46, 2 Antworten
#!/bin/bash # Skriptdateiname = test.sh spaltennummer=10 wert=zehner awk '{ $'$spaltennummer'...
Bash - verschachtelte Variablenersetzung, das geht doch eleganter als meine Lösung?
Josef Federl, 18.07.2017 20:24, 3 Antworten
#!/bin/bash #Ziel des Skriptes wird sein die ID zu extrahieren hier nur als Consolentest: root@...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Internet Geschwindigkeit
Udo Teichmann, 19.08.2017 15:49
Am Samstag, den 05.08.2017, 18:20 +0200 schrieb Udo Teichmann: Liebe fleißige Helfer Vielen Dank für den Ti...
[EasyLinux-Ubuntu] Notebook wacht nicht mehr auf
Gerhard Blaschke, 19.08.2017 15:04
Hallo Liste, habe hier ein Notebook Acer Extensa 5630 mit Wheezy. Testweise habe ich es in den Ruhezustand...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 18.08.2017 08:52
Hallo Volker, Volker schrieb am 18.08.2017 um 07:33: > volker@volker-Aspire-E5-575:~$ echo $PWD &&am...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Volker Borst, 18.08.2017 07:33
Hallo Uwe, Am 16.08.2017 um 21:56 schrieb Uwe Herrmuth: > > Dann hab ich eine ganz gewagte Vermutu...
Re: [EasyLinux-Ubuntu] bash Leerzeichen vor dem Curser
Uwe Herrmuth, 16.08.2017 21:56
Hallo Volker, Volker Borst schrieb am 16.08.2017 um 19:22: > > echo $PS1 > > ${debian_chr...