mount Problem

Autor

Donnerstag, 11. August 2005 15:57:34

Hallo,

ich versuche mein Siemens MC60 zu mounten, dies funktioniert wunderbar mit:

mount -t siefs /dev/ttyS0 /media/mobile

Das Problem: Ich kann nur als root auf /media/mobile zugreifen. Warum nicht als normaler user? Als normaler user ist /media/mobile nicht mehr sichtbar vor dem mounten schon.

System: SUSE Linux 9.3

Danke!

Stefan Koch

4 Antworten


Antworten
Re: mount Problem
Wiebke Schroeder, Donnerstag, 11. August 2005 16:38:34
Ein/Ausklappen

Hallo Stefan.

Hast Du mal einen Blick in die /etc/fstab geworfen?

Wenn Du da nach dem Eintrag /dev/ttyS0 suchst und dann die letzte oder vorletzte Spalte dabei betrachtest, dann wird da wahrscheinlich eine Einschränkung auf den User root drinstehen, die verhindert, dass Du das Laufwerk auch als Normaluser mounten kannst.

Gruß

Wiebke




Bewertung: 256 Punkte bei 28 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
lightmaker , Donnerstag, 11. August 2005 17:36:15
Ein/Ausklappen

Dabei gehst Du aber davon aus, das schon ein Eintrag in der /etc/fstab existiert. Unter Umständen muß dieser Eintrag aber erst erstellt werden.

Eine zusätzliche Zeile in der /etc/fstab sollte ungefähr so aussehen:

/dev/ttyS0 /media/mobile siefs user,noauto[,sonstige Optionen] 0 0

Dabei ist das "user" die Option, die es dem normal User erlaubt externe Platten oder Systeme ins eigene System einzubinden.

Ich hoffe, das hilft weiter.


Bewertung: 225 Punkte bei 26 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Stefan Koch, Donnerstag, 11. August 2005 21:18:23
Ein/Ausklappen

kann ich user nicht auch als option bei -o angeben?


Bewertung: 120 Punkte bei 29 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Florian E.J. Fruth, Freitag, 12. August 2005 00:29:03
Ein/Ausklappen

ja kann man zb. mit mount -o uid=1000,gid=1000 /dev/foo /mnt/bar - aber dann musst du zum mounten root sein. wenn du in der /etc/fstab als option user eingibst kann man das device auch als user mounten.
fejf


Bewertung: 209 Punkte bei 26 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 20.04.2015 00:27
Hallo Hartmut, Am Sun, 19 Apr 2015 17:26:01 +0200 schrieb Hartmut Haase : > > Allerdings stimmt bei...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 20.04.2015 00:21
Hallo Alfred, Am Sun, 19 Apr 2015 22:11:18 +0200 schrieb Alfred Zahlten : > > > beim Versuch,...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Alfred Zahlten, 19.04.2015 22:11
Am 19.04.2015 um 12:45 schrieb Rainer: Hallo Rainer, > beim Versuch, mehrseitige Dokumente bei *automati...
Re: [EasyLinux-Ubuntu] wie_als_root_ausführen?
Alfred Zahlten, 19.04.2015 21:48
Am 19.04.2015 um 20:03 schrieb Gerhard Blaschke: Hallo Gerhard, wenn du es elegant haben willst starte doch...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Alfred Zahlten, 19.04.2015 21:13
Am 19.04.2015 um 15:59 schrieb Gerhard Blaschke: Hallo Gerhard, kennst du die Seite? http://permalink.gma...