mount Problem

Stefan Koch - Donnerstag, 11. August 2005 15:57:34 - 4 Antworten

Hallo,

ich versuche mein Siemens MC60 zu mounten, dies funktioniert wunderbar mit:

mount -t siefs /dev/ttyS0 /media/mobile

Das Problem: Ich kann nur als root auf /media/mobile zugreifen. Warum nicht als normaler user? Als normaler user ist /media/mobile nicht mehr sichtbar vor dem mounten schon.

System: SUSE Linux 9.3

Danke!

Antworten
Re: mount Problem
Wiebke Schroeder, Donnerstag, 11. August 2005 16:38:34
Ein/Ausklappen

Hallo Stefan.

Hast Du mal einen Blick in die /etc/fstab geworfen?

Wenn Du da nach dem Eintrag /dev/ttyS0 suchst und dann die letzte oder vorletzte Spalte dabei betrachtest, dann wird da wahrscheinlich eine Einschränkung auf den User root drinstehen, die verhindert, dass Du das Laufwerk auch als Normaluser mounten kannst.

Gruß

Wiebke




Bewertung: 249 Punkte bei 29 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
lightmaker , Donnerstag, 11. August 2005 17:36:15
Ein/Ausklappen

Dabei gehst Du aber davon aus, das schon ein Eintrag in der /etc/fstab existiert. Unter Umständen muß dieser Eintrag aber erst erstellt werden.

Eine zusätzliche Zeile in der /etc/fstab sollte ungefähr so aussehen:

/dev/ttyS0 /media/mobile siefs user,noauto[,sonstige Optionen] 0 0

Dabei ist das "user" die Option, die es dem normal User erlaubt externe Platten oder Systeme ins eigene System einzubinden.

Ich hoffe, das hilft weiter.


Bewertung: 232 Punkte bei 29 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Stefan Koch, Donnerstag, 11. August 2005 21:18:23
Ein/Ausklappen

kann ich user nicht auch als option bei -o angeben?


Bewertung: 123 Punkte bei 32 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: mount Problem
Florian E.J. Fruth, Freitag, 12. August 2005 00:29:03
Ein/Ausklappen

ja kann man zb. mit mount -o uid=1000,gid=1000 /dev/foo /mnt/bar - aber dann musst du zum mounten root sein. wenn du in der /etc/fstab als option user eingibst kann man das device auch als user mounten.
fejf


Bewertung: 209 Punkte bei 26 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Soundkarte wird erkannt, aber kein Ton
H A, 25.09.2016 01:37, 2 Antworten
Hallo, Ich weiß, dass es zu diesem Thema sehr oft Fragen gestellt wurden. Aber da ich ein Linu...
Scannen nur schwarz-weiß möglich
Werner Hahn, 20.09.2016 13:21, 2 Antworten
Canon Pixma MG5450S, Dell Latitude E6510, Betriebssyteme Ubuntu 16.04 und Windows 7. Der Canon-D...
Meteorit NB-7 startet nicht
Thomas Helbig, 13.09.2016 02:03, 3 Antworten
Verehrte Community Ich habe vor Kurzem einen Netbook-Oldie geschenkt bekommen. Beim Start ersch...
windows bootloader bei instalation gelöscht
markus Schneider, 12.09.2016 23:03, 1 Antworten
Hallo alle zusammen, ich habe neben meinem Windows 10 ein SL 7.2 Linux installiert und musste...
Ubuntu 16 LTE installiert, neustart friert ein
Matthias Nagel, 10.09.2016 01:16, 3 Antworten
hallo und guten Abend, hab mich heute mal darangewagt, Ubuntu 16 LTE parallel zu installieren....

Jetzt auf den Mailinglisten

Re: [EasyLinux-Suse] PConverter
Horst Schwarz, 25.09.2016 10:58
Hallo Heiko, vielen Dank für deine Hinweise!Irgendetwas mache ich aber falsch. Das automatische Programm, d...
Re: [EasyLinux-Suse] [gelöst_-_Wine]PConverter
Horst Schwarz, 25.09.2016 10:24
Danke Richi, Wine ist raus! Vielleicht probiere ich später mit der Profi-Software von Wine. GrußHorst Am Fre...
Re: [EasyLinux-Suse] Aufhaenger beim herunter fahren
Andreas Klopfleisch, 25.09.2016 09:21
Guten Morgen > Es gab da wohl ein paar Probleme und ein neuer Admin, der da noch nicht > ganz durchge...
Re: [EasyLinux-Suse] Aufhaenger beim herunter fahren
Richard Kraut, 24.09.2016 19:13
Am Samstag, den 24.09.2016, 18:51 +0200 schrieb Andreas Klopfleisch: > Leider scheint die offizielle Deut...
Re: [EasyLinux-Suse] PConverter
Richard Kraut, 24.09.2016 19:07
Am Freitag, den 23.09.2016, 12:36 +0200 schrieb Horst Schwarz: > ich nutze Leap42.1 mit firefox. > Fi...