dpkg-reconfigure xserver-xorg bricht ab + Grafikkarte

Autor

Freitag, 18. Dezember 2009 09:18:52

Hallo Community!

Auf meine Rechner ist eine ATI Radeon 2400XT Grafikkarte verbaut. Da es Anfangs unter Debian Etch keine Open Source Treiber für die Grafikkarte gab, hatte ich den proprietären Treiber von ATI installiert. Um Grafikprobleme beim Upgrade auf Lenny zu vermeiden, schaltete ich mittels "dpkg-reconfigure xserver-xorg" die 3D-Beschleunigung ab und stellte wieder auf VESA um. Nach dem Upgrade installierte ich das Paket 'xserver-xorg-video-radeonhd-dt', das nun die Radeon 2400 unterstützen soll. Ein anschließendes "dpkg-reconfigure xserver-xorg" brach aber nach den Einstellungen der Tastatur mit der Meldung ab: overwriting possible-customised configuration ... und es wurde eine neue Sicherungsdatei xorg-Datum.conf unter /etc/X11 angelegt.
Warum bricht "dpkg-reconfigure xserver-xorg" nach den Eingaben der Tastaturoptionen ab? Wie kann ich die 3D-Beschleunigung mit dem Debian-Treiber einschalten? Wie konfiguriert man die Grafikkarte?

Vielen Dank für eure Hilfe.

Gruß Hermann

Hermann Kieweg

6 Antworten


Antworten
3D Beschleunigung
Rico Rommel, Sonntag, 20. Dezember 2009 08:10:41
Ein/Ausklappen

Hallo,

um die 3D Beschleunigung aktivieren zu können brauchst du mindestens Kernel 2.6.32 und Mesa 7.6.1 RC3 aus sid und am besten xserver-xorg-video-radeon.

Alle fglrx-Pakete müssen entfernt werden.

In xorg.conf trägst du in der Sektion Device bei Driver "radeon" ein.

Vor dem Start von X muss das Kernelmodul radeon geladen werden. Bei mir passiert das nicht automatisch, ich musste es in /etc/modules eintragen.

Anschließend müssen noch die Benutzer, denen 3D-Beschleunigung zur Verfügung stehen soll, in die Gruppe video aufgenommen werden.

glxinfo sollte nach einem Neustart von X (das Modul radeon nicht vergessen zu laden) nun
direct rendering: yes

melden und irgendwo sollte etwas in der Art von

Mesa DRI R600 (RV610 94C3) 20090101 TCL

auftauchen.



Steht da etwas von software rendering oder so kann mit

LIBGL_DEBUG="verbose" glxinfo

der Fehler gesucht werden.


Rico


Bewertung: 114 Punkte bei 22 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
machs per hand
Daniel Gultsch, Freitag, 18. Dezember 2009 10:08:04
Ein/Ausklappen

Editier die /etc/X11/xorg.conf am besten per Hand.
In der Device Section trägst du bei Driver "readonhd" ein. (Persönlich würde ich aber eher zum ati Treiber greifen. Zumindest in der aktuellen Version ist das der, den man nehmen willl. Allerdings hab ich keine Ahnung wie alt die Versionen in Debian sind.)
3D Unterstützung sollte dann aktiv sein wenn oben Load "dri" steht.

Alternativ: Lösch die /etc/X11/xorg.conf und benutz dann das reconfigure tool.


Bewertung: 141 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
Hermann Kieweg, Freitag, 18. Dezember 2009 21:17:00
Ein/Ausklappen

Hallo Daniel,

erst mal vielen Dank für deine Hilfe.
Das editieren der xorg.conf bringt leider nichts und das reconfigure-tool bricht ab. Was ja leider mein Hauptproblem zu sein scheint. Unter Etch war es ja so, dass ein 'dpkg-reconfigure xserver-xorg' mir eine neue xorg.conf erzeugt hat.

Gruß

Hermann



Bewertung: 95 Punkte bei 22 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
DieterD (unangemeldet), Sonntag, 03. Januar 2010 14:25:18
Ein/Ausklappen

Du könntest folgendes probieren:
dpkg-reconfigure -phigh xserver-xorg
oder
Xorg -configure
erzeugt eine neue xorg.conf.

Oder den proprietären Treiber von ATI verwenden. (Auch wenn proprietär und ohne Quellcodeveröffentlichung ist es positiv zu beurteilen, wenn eine Firma Treiber für Linux macht.)





Bewertung: 102 Punkte bei 10 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
Hermann Kieweg, Sonntag, 03. Januar 2010 19:21:18
Ein/Ausklappen

Hallo Zusammen!

Vielen Dank für Eure Hilfe.
Mit dpkg-reconfigure xserver-xorg kann unter Lenny anscheinend nur noch die Tastatur eingestellt werden. Die Grafikkarte/Treiber soll/wird automatisch erkannt.
Die Lösung für mein Problem zur 3D-Unterstützung der Radeon-Karte habe ich hier gefunden:
http://debianforum.de/forum/viewtopic.php?f=2&t=104164.

Viele Grüße

Hermann




Bewertung: 147 Punkte bei 10 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
DieterD (unangemeldet), Montag, 04. Januar 2010 17:41:09
Ein/Ausklappen

Bravo! So sollte es Jeder machen - was am Ende das Problem löste, anzugeben.



Bewertung: 122 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 2 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 4 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...
Linux und W7 im Netz finden sich nicht
Oliver Zoffi, 06.02.2015 11:47, 3 Antworten
Hallo! Ich verwende 2 PCs, 1x mit W7prof 64 Bit und einmal mit Linux Mint 17 64 Bit, welches ich...
Rootpasswort
Jutta Naumann, 29.01.2015 09:14, 1 Antworten
Ich habe OpenSuse 13.2 installiert und leider nur das Systempasswort eingerichtet. Um Änderungen,...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Speedport W 700V
Rainer, 02.03.2015 12:04
Hallo Alfred, Am Sun, 01 Mar 2015 23:36:36 +0100 schrieb Alfred Zahlten : > >> > > Nur m...
Re: [EasyLinux-Ubuntu] [SuSE 13.2] fetchmail lock
Uwe Herrmuth, 02.03.2015 09:03
Hallo Stefan, H.-Stefan Neumeyer schrieb am 01.03.2015 um 19:13: > Ich fahre meinen Haupt-Arbeitsrechner...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Alfred Zahlten, 01.03.2015 23:36
Am 01.03.2015 um 20:58 schrieb Rainer: Hallo Rainer, > [..] > >> Ich bin sicher, die Teleko...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Rainer, 01.03.2015 20:58
Hallo Alfred, Am Sun, 01 Mar 2015 20:42:14 +0100 schrieb Alfred Zahlten : [..] > Ich bin sicher, die...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Alfred Zahlten, 01.03.2015 20:46
Am 01.03.2015 um 18:56 schrieb Matthias Müller: Hallo Matthias, siehe meine Mail an Gerhard. Der Chromium...