dpkg-reconfigure xserver-xorg bricht ab + Grafikkarte

Autor

Freitag, 18. Dezember 2009 09:18:52

Hallo Community!

Auf meine Rechner ist eine ATI Radeon 2400XT Grafikkarte verbaut. Da es Anfangs unter Debian Etch keine Open Source Treiber für die Grafikkarte gab, hatte ich den proprietären Treiber von ATI installiert. Um Grafikprobleme beim Upgrade auf Lenny zu vermeiden, schaltete ich mittels "dpkg-reconfigure xserver-xorg" die 3D-Beschleunigung ab und stellte wieder auf VESA um. Nach dem Upgrade installierte ich das Paket 'xserver-xorg-video-radeonhd-dt', das nun die Radeon 2400 unterstützen soll. Ein anschließendes "dpkg-reconfigure xserver-xorg" brach aber nach den Einstellungen der Tastatur mit der Meldung ab: overwriting possible-customised configuration ... und es wurde eine neue Sicherungsdatei xorg-Datum.conf unter /etc/X11 angelegt.
Warum bricht "dpkg-reconfigure xserver-xorg" nach den Eingaben der Tastaturoptionen ab? Wie kann ich die 3D-Beschleunigung mit dem Debian-Treiber einschalten? Wie konfiguriert man die Grafikkarte?

Vielen Dank für eure Hilfe.

Gruß Hermann

Hermann Kieweg

6 Antworten


Antworten
3D Beschleunigung
Rico Rommel, Sonntag, 20. Dezember 2009 08:10:41
Ein/Ausklappen

Hallo,

um die 3D Beschleunigung aktivieren zu können brauchst du mindestens Kernel 2.6.32 und Mesa 7.6.1 RC3 aus sid und am besten xserver-xorg-video-radeon.

Alle fglrx-Pakete müssen entfernt werden.

In xorg.conf trägst du in der Sektion Device bei Driver "radeon" ein.

Vor dem Start von X muss das Kernelmodul radeon geladen werden. Bei mir passiert das nicht automatisch, ich musste es in /etc/modules eintragen.

Anschließend müssen noch die Benutzer, denen 3D-Beschleunigung zur Verfügung stehen soll, in die Gruppe video aufgenommen werden.

glxinfo sollte nach einem Neustart von X (das Modul radeon nicht vergessen zu laden) nun
direct rendering: yes

melden und irgendwo sollte etwas in der Art von

Mesa DRI R600 (RV610 94C3) 20090101 TCL

auftauchen.



Steht da etwas von software rendering oder so kann mit

LIBGL_DEBUG="verbose" glxinfo

der Fehler gesucht werden.


Rico


Bewertung: 104 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
machs per hand
Daniel Gultsch, Freitag, 18. Dezember 2009 10:08:04
Ein/Ausklappen

Editier die /etc/X11/xorg.conf am besten per Hand.
In der Device Section trägst du bei Driver "readonhd" ein. (Persönlich würde ich aber eher zum ati Treiber greifen. Zumindest in der aktuellen Version ist das der, den man nehmen willl. Allerdings hab ich keine Ahnung wie alt die Versionen in Debian sind.)
3D Unterstützung sollte dann aktiv sein wenn oben Load "dri" steht.

Alternativ: Lösch die /etc/X11/xorg.conf und benutz dann das reconfigure tool.


Bewertung: 141 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
Hermann Kieweg, Freitag, 18. Dezember 2009 21:17:00
Ein/Ausklappen

Hallo Daniel,

erst mal vielen Dank für deine Hilfe.
Das editieren der xorg.conf bringt leider nichts und das reconfigure-tool bricht ab. Was ja leider mein Hauptproblem zu sein scheint. Unter Etch war es ja so, dass ein 'dpkg-reconfigure xserver-xorg' mir eine neue xorg.conf erzeugt hat.

Gruß

Hermann



Bewertung: 87 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
DieterD (unangemeldet), Sonntag, 03. Januar 2010 14:25:18
Ein/Ausklappen

Du könntest folgendes probieren:
dpkg-reconfigure -phigh xserver-xorg
oder
Xorg -configure
erzeugt eine neue xorg.conf.

Oder den proprietären Treiber von ATI verwenden. (Auch wenn proprietär und ohne Quellcodeveröffentlichung ist es positiv zu beurteilen, wenn eine Firma Treiber für Linux macht.)





Bewertung: 128 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
Hermann Kieweg, Sonntag, 03. Januar 2010 19:21:18
Ein/Ausklappen

Hallo Zusammen!

Vielen Dank für Eure Hilfe.
Mit dpkg-reconfigure xserver-xorg kann unter Lenny anscheinend nur noch die Tastatur eingestellt werden. Die Grafikkarte/Treiber soll/wird automatisch erkannt.
Die Lösung für mein Problem zur 3D-Unterstützung der Radeon-Karte habe ich hier gefunden:
http://debianforum.de/forum/viewtopic.php?f=2&t=104164.

Viele Grüße

Hermann




Bewertung: 147 Punkte bei 10 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: machs per hand
DieterD (unangemeldet), Montag, 04. Januar 2010 17:41:09
Ein/Ausklappen

Bravo! So sollte es Jeder machen - was am Ende das Problem löste, anzugeben.



Bewertung: 122 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 2 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 0 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Opwera_öffnet_Seite_nicht
Hartmut Haase, 03.07.2015 10:42
Hallo Heiko, > Man kann aberdas Plugin auch konfigurieren. > > http://picpaste.de/Bildschirmfoto...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Hartmut Haase, 03.07.2015 10:11
Hallo Heiko, unter Win7 gibt ein Java-Einstellungsmenü, in dem ich die Seite trotz Sicherheitsbedenken als...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Hartmut Haase, 02.07.2015 11:01
Hallo Heiko, > Ist denn icedtea-7-plugin installiert und openjdk-7-jre oder das Java > von Oracle dir...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Heiko Ißleib, 02.07.2015 10:21
Hallo Hartmut. Ist denn icedtea-7-plugin installiert und openjdk-7-jre oder das Java von Oracle direkt,was...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
Hartmut Haase, 02.07.2015 09:46
Hallo Heiko, danke für die Hinweise, aber ich komme mit dem Krempel nicht klar. Und wenn man so viele Klim...