YaST-Software-Installation von SuSE 9.1 startet nicht

Autor

Donnerstag, 13. Januar 2005 09:19:45

hallo,

für die installation eines suse 9.1 rechners, der im netzwerk hängt, hatte ich ein dvd laufwerk (normalerweise ist nur ein cd vorhanden) angeschlossen und davon installiert. nun haben ich (nur) die .rpm-dateien von i586, i686 und noarch auf einen fileserver gelegt und die entsprechenden verzeichnisse im linux gemountet. es sind auch nur noch diese drei verzeichnisse als installationsquelle im yast eingetragen. trotzdem startet yast die software installation nicht. yast auf der konsole liefert folgendes zurück:

"Segmentation fault at /usr/share/YaST2/clients/sw_single.ycp:162

/sbin/yast: line 185: 3062 Speicherzugriffsfehler $ybindir/y2base menu ncurses"

es scheint, er versucht, trotz der einträge der installationsquellen immer noch auf die cd/dvd zuzugreifen. wie oder wo kann ich dieses zugreifen unterbinden. die einträge unter yast installationsquellen reichen anscheinend nicht.

danke für eure hilfe!

gruss,
stefan

stef2707

5 Antworten


Antworten
Re: YaST-Software-Installation von SuSE 9.1 startet nicht
Andreas Matthus, Donnerstag, 13. Januar 2005 18:34:15
Ein/Ausklappen

Hallo Stefan,

solche "mystischen" Effekte kenne ich von fehlerhaften Medien. Schau mal in
/var/log/messages
ob während des Kopierens von der DVD Meldungen über fehlerhafte Sektoren oder so was auftraten.
Vergleiche die DVD-Dateien und die Dateien auf der Platte mit
diff /cdrom/Dateiname /pfad_auf_platte/Dateiname
Wenn nichts kommt, sind sie gleich.
Könnte es sein, dass schon bei der Installation Systemdateien nicht richtig übertragen wurden? (Hatte mal eine zerkratzte CD - im grafischen Modus waren die Fehlermeldungen nicht zu sehen).

mfg
Andreas


Bewertung: 163 Punkte bei 22 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: YaST-Software-Installation von SuSE 9.1 startet nicht
stef2707 , Montag, 17. Januar 2005 10:18:25
Ein/Ausklappen

Die DVD ist zwar etwas zerkratzt aber, wenn ich alle Dateien auf ein Netzwerkdrive kopiere, dann klappt es. Scheinen ein paar "Steuerungsdateien" dabei zu sein, die er für die Std.-pakete braucht. Bei Zusatzpaketen, sprich bei downgeloadedem "Zeugs", hat ein Eintrag der Quellverzeichnisse ohne Probleme funktioniert...

Hab ich wieder etwas gelernt. Vielen Dank!!!

Gruss,
Stefan


Bewertung: 132 Punkte bei 21 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: YaST-Software-Installation von SuSE 9.1 startet nicht
Stefan Kießling, Dienstag, 07. Februar 2006 11:00:01
Ein/Ausklappen

Hallo,

nun, die hier geposteten Lösungsvorschläge scheinen mir allerdings nicht wirklich Lösungen zu sein. Denselben Fehler bei Yast habe ich seit kurzer Zeit bei mir auch:

sbin/yast: line 207: 17132 Speicherzugriffsfehler $ybindir/y2base menu ncurses

Aber er kommt nicht nur, wenn ich Software installieren/deinstallieren will, sondern auch bei anderen Konfigurationstools innerhalb von Yast. Habe schon versucht, Yast manuell neu zu installieren - ohne Erfolg. Da es sich beim Rechner um meinen Server handelt, der ohne grafische Oberfläche und ohne Monitor arbeitet, kann ich auch die KDE-Variante von Yast nicht benutzen.
Hat jemand diesen Fehler schon mal abstellen können?

Danke und Gruß!


Bewertung: 180 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: YaST-Software-Installation von SuSE 9.1 startet nicht
Marc Rintsch, Donnerstag, 13. Januar 2005 16:24:07
Ein/Ausklappen

Woran siehst Du, dass das Programm versucht auf die DVD zuzugreifen? Deine
Fehlermeldung sieht nach einem Programmabsturz aus.


Bewertung: 159 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: YaST-Software-Installation von SuSE 9.1 startet nicht
Martin Zeller, Donnerstag, 13. Januar 2005 15:05:29
Ein/Ausklappen

hi,
ich habe die gesamte dvd nach /local/install kopiert. der eintrag in der
datei /etc/exports sieht so aus
/local/install 192.168.0.4(ro)
in yast habe ich die installquelle ganz oben und der eintrag sieht so aus
nfs://192.168.0.2//local/install

und es geht prob.-los.
achso, natürlich muss auf dem server der nfsserver gestartet sein.

zur kontrolle kannst du ja mal deine installquelle von hand mounten mit z.b.
"mount ip_server:/quellpfad /zielpfad"
wenn das klappt sollte es eigentlich ohne weiteres gehn.

martin


Bewertung: 141 Punkte bei 24 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Yast auf der Kommandozeile
    Das Installations- und Konfigurationstool der Suse-Distribution, Yast, hat sich über die Jahre zu einem äußerst mächtigen Werkzeug gemausert. Dumm nur, dass so manches nützliche Feature zu unbekannt ist, um oft zur Anwendung zu kommen.
  • Es grünt so grün
    Mit OpenSuse 10.3 ist den Nürnbergern trotz zahlreicher Neuerungen eine durchaus solide Distribution gelungen. Dieser Artikel zeigt Ihnen, wie Sie das Linux-System von der Heft-DVD aufsetzen und was sich seit Version 10.2 geändert hat.
  • SuSE 9.3: YaST Installationsquellen erweitern, 4.4GB-32bit ISO erstellen und einbinden
  • Blaumann
    Das Acer Aspire 7540G hat den neuen Turion II X2 und bietet ordentlich Ausstattung fürs Geld.
  • Software-Management mit YaST erklärt
    OpenSuse bringt auf der DVD schon sehr viele Anwendungen mit. Um allerdings das Bestmögliche aus der Distribution herauszuholen, benötigen Sie ein paar Programme aus dem Internet. Dieser Artikel zeigt Ihnen, wie das funktioniert und stellt dabei das Software-Management vor.

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Zu wenig Speicherplatz auf /boot unter MATE
Patrick Obenauer, 25.05.2015 14:28, 1 Antworten
Hallo zusammen, ich habe Ubuntu 14.10 mit MATE 1.8.2 (3.16-37) mit Standardeinstellungen aufgese...
Konsole / Terminal in Linux Mint 17.1 deutsch
Dirk Resag, 09.05.2015 23:39, 12 Antworten
Hallo an die Community, ich habe vor kurzem ein älteres Notebook, Amilo A1650G, 1GB Arbeitsspe...
Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...

Jetzt auf den Mailinglisten

[EasyLinux-Ubuntu] Mandriva zu Ende und [OT]-Gedanken
Gerhard Blaschke, 28.05.2015 09:50
Hallo Liste, habe es zwar nie verwendet, weiß aber, dass es auf der Liste einige Anwender gibt. http://ww...
Re: [EasyLinux-Suse] Yast
Heiko, 27.05.2015 23:52
Am Mittwoch, 27. Mai 2015, 22:58:58 schrieb Daniel Hegenbarth: Mit Hannes Hegen verwandt?Nö,oder? > Das...
Re: [EasyLinux-Ubuntu] Durcheinander mit 32/64-Bit
Matthias Müller, 27.05.2015 23:10
Hallo, Am Dienstag, 26. Mai 2015 schrieb Gerhard Blaschke: snip > > "dpkg --add-architecture i...
Re: [EasyLinux-Suse] Yast
Heiko, 27.05.2015 23:07
Am Mittwoch, 27. Mai 2015, 22:58:58 schrieb Daniel Hegenbarth: > Das kann ich nicht alles ab tippen (Smart...
Re: [EasyLinux-Suse] Yast
Daniel Hegenbarth, 27.05.2015 22:58
Das kann ich nicht alles ab tippen (Smartphone). Es endet aber mit Medienquelle 'http://download.opensuse.o...