Wlan unter Ubuntu 9.04/WPA2-Verschlüsselung

Edgar Ujhely - Sonntag, 24. Mai 2009 14:08:25 - 6 Antworten

Hallo,

habe mir eine Wlan PCI Karte von D-Link DWA-547 und einen UMTS-Router von Dovado angeschafft.
Läuft problemlos, wurde sofort erkannt, auch auf allen anderen Distributionen wie SUSE 11.1, Kubuntu 9.04, Fedora 10, bloß bei Debian 5.0 mußte beim Treiber ( Madwifi) noch nach geholfen werden.
Aber jetzt kommt die Verschlüsselung und da gibt es Probleme.
Egal ob ich den Router direkt verschlüsselt habe oder über Networkmanager oder WICD verschlüsseln wollte, danach bekam ich keine Verbindung mehr.
Habe mir die Linux-User 07/08, Easy-Linux 02/09 durch gearbeitet und ziemlich viel im Internet gesucht, bloß hat alles irgendwie nicht gepaßt.
Bei wpa_supplicant blicke ich nicht so recht durch.

Meine iwconfig sieht so aus:

edgar@sonne:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bgn ESSID:"DOVADO"
Mode:Managed Frequency:2.452 GHz Access Point: 00:16:A6:10:42:3C
Bit Rate=1 Mb/s Tx-Power=20 dBm
Retry min limit:7 RTS thromgff Fragment thr=2352 B
Power Managementomgff
Link Quality=64/70 Signal level=-46 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

Und die iwlist scan:

edgar@sonne:~$ iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:16:A6:10:42:3C
Channel:9
Frequency:2.452 GHz (Channel 9)
Quality=64/70 Signal level=-46 dBm
Encryption keyomgff
ESSID:"DOVADO"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=00000000696f3f02
Extra: Last beacon: 100ms ago
IE: Unknown: 0006444F5641444F
IE: Unknown: 010482848B96
IE: Unknown: 030109
IE: Unknown: 2A0104
IE: Unknown: 32080C1218243048606C
IE: Unknown: DD07000C4301000000

Das Einzige was ging, das ich die MAC-List am Router einstellen konnte.

Ich hoffe es kann mir wer weiterhelfen.


Antworten
iwlist scan
Jörg Luther, Sonntag, 24. Mai 2009 15:25:48
Ein/Ausklappen

Laut der von Dir geposteten Ausgabe verschlüsselt der Router gar nicht ('encryption key: off'). Kannst Du mal die Verschlüsselung aktivieren, noch mal scannen und die Ausgabe posten? Da müsste sowas auftauchen wie:

IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

Beste Grüße,
Jörg


Bewertung: 266 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: iwlist scan
Edgar Ujhely, Sonntag, 24. Mai 2009 20:37:07
Ein/Ausklappen

Hallo Jörg,

habe direkt am Router die Verschlüsselung eingestellt und folgende Meldung kam:

edgar@sonne:~$ iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:16:A6:10:42:3C
Channel:9
Frequency:2.452 GHz (Channel 9)
Quality=67/70 Signal level=-43 dBm
Encryption key:on
ESSID:"DOVADO"
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Mode:Master
Extra:tsf=00000000033621d9
Extra: Last beacon: 52ms ago
IE: Unknown: 0006444F5641444F
IE: Unknown: 010482848B96
IE: Unknown: 030109
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
IE: Unknown: 050402030000
IE: Unknown: 2A0104
IE: Unknown: 32080C1218243048606C
IE: Unknown: DD07000C4301000000

edgar@sonne:~$

Nur mußte ich danach den Router wieder reseten damit ich Dir schreiben kann.Irgendwie kommt keine Verbindung zustande.
Wenn ich die Verschlüsselung über WICD einstelle bleibt bei Encryption key auf off, aber die Verbindung bleibt trotzdem aus.

Vielen Dank

Edgar






Bewertung: 272 Punkte bei 52 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: iwlist scan
Edgar Ujhely, Sonntag, 24. Mai 2009 22:28:44
Ein/Ausklappen

Hallo nochmal,

da ich mit SUSE 11.1nicht so gute Erfahrungen gemacht habe, habe ich es dennoch probiert ins Netz zu kommen.
Und siehe da es klappte auf Anhieb mit dem Networkmanager.
Kann es sein das es ein Problem mit Ubuntu gibt.

Die iwlist von Suse sieht so aus:

linux-69l4:/home/edgar # iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:16:A6:10:42:3C
ESSID:"DOVADO"
Mode:Master
Channel:9
Frequency:2.452 GHz (Channel 9)
Quality=56/100 Signal level:-59 dBm Noise level=-95 dBm
Encryption key:on
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Preauthentication Supported
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000008992d0de
Extra: Last beacon: 172ms ago

linux-69l4:/home/edgar #

Werde es nochmal bei Ubuntu mit dem NM probieren.

Gruß

Edgar


Bewertung: 245 Punkte bei 50 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: iwlist scan
Edgar Ujhely, Sonntag, 24. Mai 2009 22:56:37
Ein/Ausklappen

Hallo,

hab es gerade nochmal mit Ubuntu probiert, mit dem NM, und auf einmal läuft es. Was ich vorher tagelang probiert geht auf einmal.
Das Dumme daran ist, ich weiß nicht warum das Ganze jetzt geht.
Auf alle Fälle läuft es jetzt und die beiden Hardwareteile funktionieren
unter Suse und Ubuntu, jetzt kommt noch Debian 5.0 und Kubuntu dran, mal schauen wie es da geht.
Die Kaufentscheidung für PCI Wlan Karte war die Empfehlung aus dem Linux-User Heft 07/08.

Gruß

Edgar


Bewertung: 283 Punkte bei 44 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: iwlist scan
Jörg Luther, Montag, 25. Mai 2009 11:34:32
Ein/Ausklappen

Hi Edgar,

ja, das Problem kenne ich -- ich verdächtige aber da im Zweifelsfall die Hardware / Treiber. Erratische Verbindungsverweigerung tritt bei mir oft auf, wenn ich zuletzt mit Kismet oder ähnlichen Sniffern gearbeitet habe und dann wieder ans reguläre Netz will. Klappt manchmal, aber nicht immer.

Der Gnome-Network-Manager ist aber unschuldig: Wenn der es nicht mehr schafft, klappts auch auf der CLI nicht mehr. Da hilft dann bei mir (Jaunty, AR242x) nur noch ein Kaltstart, um das Interface wieder auf die Reihe zu bringen.

Grüße,
Jörg


Bewertung: 246 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: iwlist scan
Edgar Ujhely, Montag, 25. Mai 2009 11:52:42
Ein/Ausklappen

Hallo Jörg,

alles klar, ist gut zu wissen das der Networkmanager nicht schuld ist.

Vielen Dank für Deine Hilfe.

Gruß

edgar


Bewertung: 255 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Sieben USB WLAN-Adapter im Test
    Elektronikgeräte werden immer kleiner, so auch WLAN-Adapter, die es neuerdings auch als USB-Sticks gibt. Dieser Artikel zeigt Ihnen, worauf Sie beim Kauf achten sollten, und wie Sie die unterstützten Geräte in Betrieb nehmen.
  • Treiber für Wireless-LAN-Karten
    Die Distributoren haben Wireless LAN noch nicht für sich entdeckt, auf ihren CDs findet man meist nur die alt gedienten PCMCIA Card Services. Deshalb ist bei aktuellen Wireless-LAN-Karten viel Handarbeit erforderlich.
  • Moderne Dauerwellen
    Fast alle Distributionen bringen mittlerweile grafische Tools mit, um WLAN einzurichten. Doch taugen die grafischen Konfiguratoren auch etwas? Wir stellen die wichtigsten vor.
  • Open-Source-WLAN-Router von Netgear
  • Schwerpunkt Wireless LAN
    Es gibt eine Alternative zum Durchbrechen von Wänden, Anschrauben etlicher Meter Kabelschacht und Crimpen von Netzwerkkabeln: Drahtlose Netze verbinden ohne Bauarbeiten Desktop und Laptop im ganzen Haus mit dem Internet.

Aktuelle Fragen

Irgend ein Notebook mit Linux Mint - vllt der Dell Latitude 3480???
Universit Freiburg, 26.06.2017 13:51, 0 Antworten
Hey Leute, bin am Verzweifeln weil ich super gerne auf Linux umsteigen würde aber kein Noteboo...
scannen mit LINUXMINT 18.0 - Brother DCP - 195 C
Christoph-J. Walter, 21.06.2017 08:47, 4 Antworten
Seit LM 18.0 kann ich nicht mehr direkt scannen. Obwohl ich die notwendigen Tools von der Brothe...
Anfänger Frage
Klaus Müller, 24.05.2017 14:25, 2 Antworten
Hallo erstmal. Habe von linux nicht so viel erfahrung müsste aber mal ne doofe frage stellen. A...
Knoppix-Live-CD (8.0 LU-Edition) im Uefiboot?
Thomas Weiss, 26.04.2017 20:38, 4 Antworten
Hallo, Da mein Rechner unter Windows 8.1/64Bit ein Soundproblem hat und ich abklären wollte, o...
Grub2 reparieren
Brain Stuff, 26.04.2017 02:04, 7 Antworten
Ein Windows Update hat mir Grub zerschossen ... der Computer startet nicht mehr mit Grub, sondern...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] VLC spielt Videos ohne Bild
Schahram Sanawi Garrousi, 26.06.2017 12:39
Das war es Heiko. Danke Gruß Schahram -- 4.10.0-24-generic x86_64 * Kubuntu 17.04 * KDE 5.9.4 Es gehör...
Re: [EasyLinux-Ubuntu] Soundconverter:_Qualitätsgrade
Heiko, 26.06.2017 12:33
Am Dienstag, 13. Juni 2017, 20:04:01 CEST schrieb Rainer: Hallo Rainer, > > Am Tue, 13 Jun 2017 19...
Re: [EasyLinux-Ubuntu] VLC spielt Videos ohne Bild
Heiko, 26.06.2017 11:58
Am Sonntag, 25. Juni 2017, 20:16:20 CEST schrieb Schahram Sanawi Garrousi: Hallo Schahram. > > Mei...
[EasyLinux-Ubuntu] VLC spielt Videos ohne Bild
Schahram Sanawi Garrousi, 25.06.2017 20:16
Hallo Liste Mein VLC media player 2.2.4 spielt kein Bild mehr. Der Ton ist aber zu hören. Hat jemand auch d...
Re: [EasyLinux-Ubuntu] Soundconverter:_Qualitätsgrade
Rainer, 13.06.2017 20:04
Hallo Heiko, Am Tue, 13 Jun 2017 19:50:04 +0200 schrieb "Heiko Ißleib" : > > > >...