Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.

Autor

Dienstag, 18. Januar 2005 20:48:01

Ok, es gab hier schon ähnlich Threads, aber die haben alle nicht so gepasst.
<em>Falls ich zu blöd war dass Richtige zu erkennen, sorry.</em>

Also, ich habe meine Dualboot System mit Suse 9.0 und WinXP auf Suse 9.2 Upgedated, dazu habe ich von der Downloadbaren 9.2 Pro DVD gebootet, das hat alles sehr gut geklappt. Habe alle Packete rausgehauen mit denen es Konflikte gab. Nach dem Update, musste ich zwar hier und da noch etwas Hand anlegen und neue Packete installieren, deren ältere Versionen vorher entfernt wurden, aber ich war insgesamt positiv überrascht.

<em>Bis auf eine Sache, ich kann beim besten willen die beiden Fat32 Partitionen, mit denen ich vorher unter 9.0 super arbeiten konnte, mounten.</em>
Weder lassen sie sich automatisch beim booten, noch später manuell als root mounten. Ich hab schon fleissig rumprobiert und der einzige Weg ist über Yast > System > Partitionieren, Danach kann ich die Partition als root auch fröhlich umounten und mounten ohne Fehler. Allerdings ist nach einem neuen booten wieder alles wie vorher, obwohl der eintrag ja in der fstab nicht mehr geändert wurde.
Interessant fand ich auch, das nach der Neuinstallation all die schönen Automount-Symbole vom Desktop verschwunden waren, aber das stört ja nicht weiter.

Also, bin am verzweifeln und hoffe auf etwas Hilfe oder einen guten Tip, da ich nicht auf diesen Laufwerkzugriff verzichten möchte.

Jhappy


P.S.
Die Fehlermeldung sieht beim manuellen mounten als root so aus:
mount: wrong fs type, bad option, bad superblock on /dev/sda6,
or too many mounted file systems
mount: wrong fs type, bad option, bad superblock on /dev/sda7,
or too many mounted file systems

fdisk -l liefert:
Platte /dev/sda: 80.0 GByte, 80026361856 Byte
255 Köpfe, 63 Sektoren/Spuren, 9729 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 1 1275 10241406 7 HPFS/NTFS
/dev/sda2 4090 9729 45303300 f W95 Erw. (LBA)
/dev/sda3 1276 1406 1052257+ 82 Linux swap / Solaris
/dev/sda4 * 1407 4089 21551197+ 83 Linux
/dev/sda5 4090 5361 10217308+ 7 HPFS/NTFS
/dev/sda6 5362 6652 10369926 b W95 FAT32
/dev/sda7 6653 9729 24715971 b W95 FAT32

jaroschi

5 Antworten


Antworten
Re: Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.
jaroschi , Donnerstag, 20. Januar 2005 23:21:35
Ein/Ausklappen

Ok, danke erst einmal für die Reaktionen.

Dummerweise geht es jetzt und was noch übler ist, ich kann nicht genau sagen, was der Grund dafür ist.

Die mtab hab ich jedenfalls nicht verändert höchstens mal nachgesehen, was drin steht, aber das war alle ok. Das ist ja auch der Hacken gewesen, es gab keinen offensichtlichen Fehler.

> sowas passiert, wenn das Dateisystem falsch/nicht erkannt wird oder der Treiber dazu nicht geladen werden kann.

Das ist klar, sagt die Fehlermeldung ja auch, aber Dateisystem und Treiber passten.

Das manuelle Mounten hatte ich übrigens mit folgendem Befehlen versucht:
mount /mnt/_dein_mount_punkt6 bzw. mount /windows/E
wobei dann immer der besagte Fehler auftrat, auch mit
mount -t smbfs /dev/sda6 /windows/E
kam das selbe raus.

Das einzige was half, war die beiden Fat32 Laufwerke in Yast unter System > Partitionieren als Partition mit entsprechendem Mountpoint einzubinden. Danach waren sie allerdings nur les- und nicht beschreibbar. Das habe ich mit
mount -o rw,remount /windows/E bzw.
mount -o rw,remount /windows/F
korrigiert.

Danach war's dann so wie ich es haben wollte. Jedoch, nach einem Neustart waren die Laufwerke wieder nicht automatisch gemountet worden aber mittlerweile funktioniert das auch, warum auch immer.

Die Einträge in der fstab sehen übrigens jetzt so aus:
/dev/sda6 /windows/E vfat auto,rw,iocharset=iso8859-1,codepage=437,users,gid=users,umask=0002, 0 0
/dev/sda7 /windows/F vfat auto,rw,iocharset=iso8859-1,codepage=437,users,gid=users,umask=0002, 0 0

Ich glaube das Einzige was ich gegenüber vorher geändert habe ist, dass ich die 'auto' Option hinzugefügt habe, aber die war unter 9.0 auch nie erforderlich und ich habe mittlerweile das System von UTF-8 wieder auf iso8859-1 umgestellt, was aber keinen Einfluss haben dürfte.

Einziger Wehrmutstropfen ist, dass nach dem Start von KDE immer noch eine Fehlermeldung kommt:
Prozess Aufruf des Ein/Ausgabe-Moduls nicht möglich.
klauncher meldet: Unbekanntes Protokoll "devices".
lässt sich nicht starten
aber das schau ich mir erst noch mal genauer an.

Naja es funzt!
mfg
jaroschi


Bewertung: 145 Punkte bei 18 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.
Andreas Matthus, Freitag, 21. Januar 2005 07:05:45
Ein/Ausklappen

Hallo jaroschi,

schön, wenn es jetzt klappt. Trotzdem will ich nochmal erklären _warum_ es jetzt klappt:

> Das manuelle Mounten hatte ich übrigens mit folgendem Befehlen versucht:
> mount /mnt/_dein_mount_punkt6 bzw. mount /windows/E
> wobei dann immer der besagte Fehler auftrat, auch mit
> mount -t smbfs /dev/sda6 /windows/E
> kam das selbe raus.

Mit den Befehl aus der ersten Zeile wird ausschließlich auf die Einstellungen aus der /etc/fstab zugegriffen, die offensichtlich zunächst fehlerhaft waren.
Die zweite Zeile (-t smbfs) konnte nicht gehen, da so nur samba- bzw. Windoofs-Freigaben gemountet werden. Man könnte von-Hinten-durch-die-Brust-ins-Auge so auf eine lokale Partition zugreifen - aber nur wenn sie schon gemountet ist ;-)) und mit samba frei gegeben wurde. Ist also sinnlos.

> Ich glaube das Einzige was ich gegenüber vorher geändert habe ist, dass ich die 'auto' Option hinzugefügt

Genau richtig! Das ist der Punkt, der besagt, dass beim Hochfahren die Partition automatisch gebunden wird und nicht auf einen eigenen mount-Befehl wartet.

> Einziger Wehrmutstropfen ist, dass nach dem Start von KDE immer noch eine
> Fehlermeldung kommt:
> Prozess Aufruf des Ein/Ausgabe-Moduls nicht möglich.
> klauncher meldet: Unbekanntes Protokoll "devices".
> lässt sich nicht starten
Was lässt sich nicht starten? KDE? klauncher ist ein Teilprozess, der von kdeinit gestartet wird.
Kommt der Fehler auch bei einem neu angelegten Nutzer?

mfg
Andreas




Bewertung: 184 Punkte bei 19 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.
jaroschi , Freitag, 21. Januar 2005 11:58:09
Ein/Ausklappen

> Die zweite Zeile (-t smbfs) konnte nicht gehen, da so nur samba- bzw.
> Windoofs-Freigaben gemountet werden.
Oh man, bin ich ein Depp, das ist mir irgendwie gar nicht klar geworden. Aber ja, jetzt fällt es mir wie schuppen von den Augen! :-D

> Was lässt sich nicht starten?
Ok, ich hab's jetzt, diese Fehler Meldung wird von der 'Geräte-Symbole anzeigen' Option unter KDE 'Einrichten - Arbeitsfläche' verursacht. Wenn ich die Option aktiviere bekomme ich die Fehlermeldung und leider keinerlei Symbole, wenn sie deaktiviert ist natürlich nicht. Externe Laufwerke werden aber problemlos nach dem Anschliessen automatisch unter /media/BEZEICHNUNG gemountet.
Ich vermute mal, da ist vielleicht noch ein altes Modul von 9.0 übrig geblieben, hab aber leider keine Ahnung welches.
Das ist zwar keine grosses Problem, aber die Symbole auf dem Desktop haben mir schon gefallen ;-)

Ahoi,
jaroschi


Bewertung: 170 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.
Andreas Matthus, Mittwoch, 19. Januar 2005 12:18:05
Ein/Ausklappen

Hallo,

> mount: wrong fs type, bad option, bad superblock on /dev/sda6,
> or too many mounted file systems

sowas passiert, wenn das Dateisystem falsch/nicht erkannt wird oder der Treiber dazu nicht geladen werden kann.

Wie sind die Eintargungen in der /etc/fstab (nicht /etc/matb ! Da hat man normaler Weise nicht drin zu ändern!)? Wird die fstab vielleicht von SuSE beim nächsten Start wieder "angepasst"? (Mal reinschauen)
Welcher "manuelle" mount-Befehl wird ausgeführt, bevor die Fehlermeldung kommt?

Versuch des mal mit
mount -t vfat /dev/sda6 /mnt/_dein_mount_punkt6
wobei /mnt/_dein_mount_punkt6 natürlich mit einem angepassten Wert zu ersetzen ist.

mfg
Andreas




Bewertung: 134 Punkte bei 24 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Update von SuSE 9.0 auf 9.2 -> Fat32 Partitionen lassen sich nicht mehr mounten.
Peter Jaguttis, Mittwoch, 19. Januar 2005 11:53:34
Ein/Ausklappen

Hi,
hatte die gleiche Fehlermeldung. Ursache war, dass die entsprechende Partition
nicht in der /etc/mtab eingetragen war. Nachdem ich das nachgeholt hatte,
funktionierte es.
HTH
Peter


Bewertung: 62 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Manuelle Ablage
    Datensicherung gelingt am schnellsten in der Shell, wenn Sie die passenden Kommandos kennen – dieser Artikel stellt sie vor und präsentiert zudem ein kleines Skript für inkrementelle Backups.
  • Inode in Not
    Mit den richtigen Werkzeugen fühlen Sie Ihrem Dateisystem auf den Zahn, beseitigen Inkonsistenzen und restaurieren beschädigte Dateien.
  • HowTo: Wie ändere ich das Filesystem einer Partition von ext3 auf ext4?
  • Zu Befehl
    In der letzten "Zu Befehl"-Folge haben Sie erste Informationen zu Partitionen, Dateisystemen und deren Auslastung bekommen. In diesem Zusammenhang fiel auch kurz der Begriff "mounten". Mit dem Befehl mount machen Sie einen Datenträger (z. B. Festplatte, Diskette, CD usw.) für Linux verfügbar. Anders als unter DOS und Windows gibt es unter Unix/Linux keine Laufwerksbuchtaben, vielmehr wird jede Partition irgendwo unterhalb des sogenannten Root-Verzeichnisses (Wurzelverzeichnis) eingebunden. In diesem Artikel geht es um Tipps und Tricks zu mount, die den Zugriff auf Datenträger erleichtern und in einigen Fällen sogar helfen, Geld zu sparen.
  • Umstieg auf das Ext3-Dateisystem
    Dateisysteme mit Journal erleichtern den Umgang mit Linux: Stürzt der Rechner ab, muss man beim Neustart nicht die langwierige Überprüfung der Dateisysteme mit "fsck" abwarten. Wir helfen bei der Umstellung auf Ext3fs und zeigen auch den Weg zurück.

Tipp der Woche

Schnell Multi-Boot-Medien mit MultiCD erstellen
Schnell Multi-Boot-Medien mit MultiCD erstellen
Tim Schürmann, 24.06.2014 12:40, 0 Kommentare

Wer mehrere nützliche Live-Systeme auf eine DVD brennen möchte, kommt mit den Startmedienerstellern der Distributionen nicht besonders weit: Diese ...

Aktuelle Fragen

Videoüberwachung mit Zoneminder
Heinz Becker, 10.08.2014 17:57, 0 Antworten
Hallo, ich habe den ZONEMINDER erfolgreich installiert. Das Bild erscheint jedoch nicht,...
internes Wlan und USB-Wlan-Srick
Gerhard Blobner, 04.08.2014 15:20, 2 Antworten
Hallo Linux-Forum: ich bin ein neuer Linux-User (ca. 25 Jahre Windows) und bin von WIN 8 auf Mint...
Server antwortet mit falschem Namen
oin notna, 21.07.2014 19:13, 1 Antworten
Hallo liebe Community, Ich habe mit Apache einen Server aufgesetzt. Soweit, so gut. Im Heimnet...
o2 surfstick software für ubuntu?
daniel soltek, 15.07.2014 18:27, 1 Antworten
hallo zusammen, habe mir einen o2 surfstick huawei bestellt und gerade festgestellt, das der nic...
Öhm - wozu Benutzername, wenn man dann hier mit Klarnamen angezeigt wird?
Thomas Kallay, 03.07.2014 20:30, 1 Antworten
Hallo Team von Linux-Community, kleine Zwischenfrage: warum muß man beim Registrieren einen Us...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
flecralf, 27.08.2014 21:15
Am 27.08.2014 21:14, schrieb flecralf: > Am 27.08.2014 20:12, schrieb Richard Kraut: >> Am Mittwoc...
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
flecralf, 27.08.2014 21:14
Am 27.08.2014 20:12, schrieb Richard Kraut: > Am Mittwoch, den 27.08.2014, 19:55 +0200 schrieb Heiko Ißlei...
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
Heiko, 27.08.2014 21:02
Am Mittwoch, 27. August 2014, 20:18:58 schrieb H.-Stefan Neumeyer: Hallo Stefan. > > > Grundfun...
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
"H.-Stefan Neumeyer", 27.08.2014 20:18
Am Mittwoch, 27. August 2014, 19:03:43 sprach Heiko Ißleib (und nicht Zarathustra): Hallo Heiko >...
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
Richard Kraut, 27.08.2014 20:12
Am Mittwoch, den 27.08.2014, 19:55 +0200 schrieb Heiko Ißleib: > Wenn China jetzt von windows 8 abrät und...