Ubuntu/Debian im Textmodus booten

Autor

Samstag, 22. Mai 2010 10:22:01

Hallo zusammen.
Meine Grafik spinnt und ich sehe nach dem Hochfahren nur einenen schwarzen Bildschirm (auch keine virtuellen Konsolen). Unter OpenSuse kann man am Bootprompt eine 3 eingeben, um das System im Textmodus hochzufahren.

Wie mache ich das bei Ubuntu oder Debian, dass der X-Server gar nicht erst zu starten versucht?

Peter Flicker

3 Antworten


Antworten
Textmodus Ubuntu/Debian
Holger Naujokat (unangemeldet), Freitag, 28. Mai 2010 09:15:43
Ein/Ausklappen

Versuch mal strg-alt-F2, wenn der Bildschirm schwarz ist, so kommt man jedenfalls in den Textmodus. x-server dann stoppen mit
sudo /etc/init.d/gdm stop bzw. restart. Mit strg-alt-F7 kommt man zurück in die Grafik. Vielleicht hilft das ja was.



Bewertung: 55 Punkte bei 48 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Textmodus Ubuntu/Debian
Peter Flicker, Dienstag, 01. Juni 2010 08:24:17
Ein/Ausklappen

Genau das ist ja mein Problem. Das geht eben nicht. Deshalb möchte ich Ubuntu so starten, dass der X-Server gar nicht erst zu starten versucht. Das muss doch irgendwie gehen.......


Bewertung: 36 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Textmodus Ubuntu/Debian
l8star (unangemeldet), Montag, 06. September 2010 21:03:41
Ein/Ausklappen

das gleiche Problem hatte ich auch.
Ursache war bei mir ein Treiberkonflikt der Grafikkarte.

Gelöst habe ich es folgendermaßen

1.) single-use modus als root starten (siehe grub beim booten)
2.) mittels aptitude alles grafische deinstallieren also
flgrx-*
gdm3 (gdm)
gnome oder kde ... alle komponenten runter
danach war im apitude alles rot markiert - unsolve dependencies
also habe ich alles bis auf kernel, netzwerk und aptitude
deinstalliert
3) auf einem anderen rechner habe ich den aktuellen ati-treiber
gedownloadet
4) ins homeverzeichnis des problem-pc's dann den treiber rauf
5) reboot multiuser -
6) ergebnis schwarzer bildschirm
7) strg + alt + F2 in die console
8) mit aptitude kernel (linux-header und linux-image) upgedatet
9) gdm3, xorg und gnome neu installiert (aptitude)
10) /etc/init.d/gdm3 stop -- sicherstellen dass Graphic off ist
11) als root sh ./<path>/ati-driver-version.run Treiber neu rauf
12) /etc/init.d/gdm3 start
13) und siehe da es lief wieder

Viele Grüsse
Olivier



Bewertung: 142 Punkte bei 16 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Solide Konstruktion
    Das Debian-Projekt hat ein zweites Update für die derzeit stabile Version "Etch" veröffentlicht. Diese behebt einige Probleme und Sicherheitslöcher.
  • Knoppix und Ubuntu
    Knoppix und Ubuntu Linux basieren auf Debian – wir verraten Tricks und Kniffe, welche die Arbeit unter diesen Distributionen angenehmer machen.
  • Fernsehen aus der Tüte
    Wem die Installation von MythTV zu kompliziert erscheint, der weicht auf Knoppmyth oder Mythbuntu aus und setzt mit wenigen Mausklicks einen Videoserver auf.
  • Damn Small Linux auf Live-CD
    Dank seines geringen Ressourcenverbrauches ist Damn Small Linux die ideale Distribution für betagtere Rechner. Eine grafische Oberfläche und eine Vielzahl an Programmen bieten für fast jeden Zweck das richtige Werkzeug.
  • Knoppix und Ubuntu
    Ubuntu und Knoppix basieren auf Debian – wir verraten Tricks und Kniffe, welche die Arbeit auf diesen Distributionen angenehmer machen.

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Claws Mail: Export von Adressen
Alfred Zahlten, 18.04.2015 22:51
Am 18.04.2015 um 11:46 schrieb Joerg Guenther: Hallo Joerg, > Adressbuch - Extras - Exportieren im neuen...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Heiko, 18.04.2015 20:57
Am Samstag, 18. April 2015, 17:58:57 schrieb Gerhard Blaschke: > Ich bastle immer noch an der Medion-MM-Ki...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Richard Kraut, 18.04.2015 20:09
Am Samstag, den 18.04.2015, 17:58 +0200 schrieb Gerhard Blaschke: > Ich bastle immer noch an der Medion-M...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 18.04.2015 17:58
Ich bastle immer noch an der Medion-MM-Kiste. Am 10.04.2015 um 10:19 schrieb Gerhard Blaschke: > Hallo L...
Re: [EasyLinux-Ubuntu] Aushängen_von_Speicherkarte
Richard Kraut, 18.04.2015 15:56
Am Samstag, den 18.04.2015, 10:24 +0200 schrieb Hartmut Haase: > klar, aber ich möchte herausfinden, warum...