Ubuntu 13.10 überschreibt immer Windows 8 Bootmanager

Autor

Samstag, 15. März 2014 19:20:59

Hallo Leute,
ich hoffe das ich richtig bin. Ich habe einen Dell Insipron 660 Ich möchte gerne Ubuntu 13.10 (64 bit.) Installieren. Ich habe eine Live-Version von Ubuntu auf einen USB-Stick kopiert und dann im gebootet (UEFI). Die Installation verlauft ohne Probleme. Auch der bootloader (Linux) wird gestartet und die Eintrage für Ubuntu und Windows 8 sind vorhanden.
Ubuntu 13.10 lässt sich anstandslos starten. Aber wenn ich, versuche Windows 8 zu starten wird sofort der Reparaturmodus von Windows 8 aktive. Danach läuft Windows 8 aber Ubuntu läuft nicht mehr. Ich habe ins Setup vom nachgesehen, der UEFI Eintrag für Ubuntu wurde durch den von Windows ersetzt.. In einem Windows 8 Buch, habe ich gelesen, dass der Windows 8 Bootmanager keine Startoptionen für alternative OS anbietet. Dafür bracht man z.B EasyBCD, stimmt das und wie müsste ich Ubuntu damit installieren? Ubuntu sollte auf einer zweiten internen Festplatte installiert werden.

Vielen Dank für die Hilfe!

Gruß
Thomas

Thomas Weiss

8 Antworten


Antworten
Prinzipiell richtig
Kai (unangemeldet), Samstag, 15. März 2014 23:23:52
Ein/Ausklappen

Du hast eigentlich alles richtig gemacht:

Ubuntu 13.10 richtet einen eigenen Bootmanager ein. Der erscheint, wenn du das System startest. Wenn du dann den Eintrag "Windows" auswählst, startet der Bootmanager von Windows, der dann wiederum Windows 8 bootet.

Diese Kette ist notwendig, weil Windows nichts mit anderen Betriebssystemen anfangen kann.

Windows dürfte aber nicht den Reparaturmodus starten. Irgendwas läuft an der Stelle schief. Meiner Meinung nach ist daher das Problem bei Windows zu suchen.

Dazu ein paar Fragen:
- Secure Boot ist abgeschaltet?
- Windows 8 startet auch nicht im Schnellstartmodus? (Den musst du unbedingt deaktivieren, bevor du Ubuntu installierst.)
- Gibt es irgendein Recovery-System auf deinem Notebook? Beispielsweise von Dell?


Bewertung: 151 Punkte bei 6 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Thomas Weiss, Sonntag, 16. März 2014 17:22:07
Ein/Ausklappen

Hallo Kai,
erst mal vielen für die Hilfe, das mit der Kette habe ich versanden. Ich habe das System erst neu, deshalb meine Frage, der Windows 8 Bootmanager wie sieht der aus, kommt da auch ein grafisches Menü? Bei mir kommt nur der Bootmanager von Linux? Wenn ich mit F12 ins BIOS (Bootlader) gehe, seht vor der Ubuntu Installation ein Windows Eintrag zur Auswahl. Danach ist der Eintrag weg und durch Ubuntu ersetzt. Hier müssten doch zwei Einträge stehen einer für Windows und der andere für Ubuntu oder? Sobald ich Windows 8 über den Bootmanager starte, wird dieser Eintrag auf Windows zurückgesetzt und Ubuntu läuft nicht mehr. Wenn im Internet nach dem Problem Dualboot und Ubuntu sucht, ist das genau anders herum, Windows läuft nach der Ubuntu Installation aber Ubuntu nicht.

Zum Deinen Fragen:
Der Secure Boot ist deaktiviert
Ich habe Recovery CD von Dell und eine Recovery auf Platte, aber das funktioniert nach der Ubuntu Installation nicht mehr richtig. Die Wiederherstellungsartion wird nicht gefunden.

Wo deaktiviert man den Schnellstartmodus? In Bios kann ich nichts finden. (Aptio American Megatrens Bios Revision A 11, Build Date 10/14/2013

Vielen Dank!
Gruß
Thomas



Bewertung: 67 Punkte bei 18 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Kai (unangemeldet), Sonntag, 16. März 2014 18:23:43
Ein/Ausklappen

Den Windows-Bootmanager bekommst du normalerweise nicht zu Gesicht, weil er direkt Windows 8 startet.

Was meinst du mit F12? Damit gelangst du in die BIOS-*Einstellungen*?

Über eine der F-Tasten müsstest du auch noch ein separates Boot-Menü aufrufen können. Normalerweise F8. Dieses Bootmenü ist das des BIOS (Ja, noch eines :)). Tauchen in diesem Menü Ubuntu und Windows 8 auf?

UEFI ist an sich ziemlich verwirrend: Jedes Betriebssystem hinterlegt im UEFI (also im BIOS) einen Eintrag. Der verweist auf seinen Bootmanager auf der Festplatte. UEFI startet jetzt den von dir als Standard-Boot-Manager im BIOS eingestellten Boot-Manager. Es sollten also in der Tat im BIOS zwei Einträge auftauchen.

Wenn UEFI dann den Boot-Manager von Ubuntu gestartet hat, bietet dir der wiederum ebenfalls an, Windows zu installieren.

Du merkst schon, dass das Ganze extrem verwirrend ist. Deshalb muss auch ich noch einmal zurückfragen:

Was passiert jetzt genau, wenn du den Rechner einschaltest und nichts machst? Startet dann sofort Windows 8? Beschreib mal den Ablauf möglichst kleinschrittig.

Zum Schnellstart findest du hier eine Information zum Abschalten:
http://praxistipps.chip.de/...s-8-fast-boot-abschalten_10116

Allgemeines zum Thema UEFI und Ubuntu findest du hier:
http://wiki.ubuntuusers.de/EFI_Bootmanagement




Bewertung: 100 Punkte bei 12 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Thomas Weiss, Montag, 17. März 2014 18:59:26
Ein/Ausklappen

Hallo Kai,

ich kann mich nur für deine Hilfe bedanken. Mit F12 komme ich in das Bootmenü vom BIOS. Hier ist immer nur ein Eintrag vorhanden, nach der Ubuntu Installation seht da Ubuntu und nach der Reparatur wieder Windows 8. Aber es sind nie zwei Eintrage vorhanden. Wenn ich Ubuntu installiert habe, kommt automatisch der Bootmanager von Linux. Dann kann ich ohne Schwierigkeiten Ubuntu starten. Das geht solange gut, bis ich Windows 8 aufrufe, danach wird der Reparaturmodus durchgeführt. Der Reparaturmodus stellt den alten Windows-Eintrag wieder her und Windows nach dem Neustart automatisch aufgerufen. Aber ohne zweit Einträge im Bootmenü, kann das doch funktionieren oder?
Wenn ich Ubuntu über den USB-Stick boote, wird doch auch automatisch Eintrag generiert. Was ist denn wenn ich die Windowsplatte kurz vom System abklemme und Ubuntu auf der zweiten Platte installiere. Danach hänge die Windows wieder ein. Kann ich damit, das gegenseitige Überschreiben verhindern. Kann man den Bootmanager nachträglich Installieren?

Gruß
Thomas


Bewertung: 89 Punkte bei 9 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Kai (unangemeldet), Dienstag, 18. März 2014 11:24:05
Ein/Ausklappen

Ich verstehe nicht, warum dein Windows den Reparaturmodus anwirft. Das dürfte eigentlich nicht sein. Dazu zwei wichtige Fragen:

- Hast du Secure Boot nachträglich deaktiviert?
- Hast du Ubuntu im EFI-Modus oder im BIOS-Modus installiert?

Zu deinen Fragen: Das BIOS des Rechners zeigt in seinem eigenen Boot-Menü zum einen die installierten Betriebssysteme an. Zusätzlich bietet es dir an von den externen Speichermedien zu starten. Wenn du also einen USB-Stick mit Ubuntu ansteckst, bietet dir das Boot-Menü automatisch auch den zum Start an.

Wenn Windows den Boot-Manager von Ubuntu auf der Festplatte überschreibt, kann das BIOS dort Ubuntu jedoch nicht starten; auf deinem USB-Stick mit Ubuntu ist ja ein Boot-Manager von Ubuntu drauf.

Das Abklemmen kannst du ausprobieren, es gibt aber keine Sicherheit, dass dein BIOS die zweite Platte als startfähig erkennt. Zur Begründung: Die Bootmanager von Windows und Ubuntu liegen normalerweise auf *einer* Festplatte auf einer eigenen, versteckten Partition (ja, UEFI ist grausam und hirnzermaternd).

Den Bootmanager kann man aber auch nachträglich installieren. Das ist allerdings nicht ganz einfach:

http://wiki.ubuntuusers.de/...r#Reparatur-mittels-Desktop-CD

Dann habe ich noch das hier gefunden:
http://wiki.ubuntuusers.de/...ehebung#Probleme-und-Loesungen

Probiere mal die Anleitungen in den Abschnitten "Der Windows-Bootmanager" und "Mein Ubuntu ist nicht im EFI-Menü"






Bewertung: 117 Punkte bei 5 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Thomas Weiss, Dienstag, 18. März 2014 15:03:26
Ein/Ausklappen

Hallo Kai,

erstmal vielen Dank für die Geduld, den Secure Boot habe vor der Ubuntu Installation deaktiviert? Die Installation ist im EFI-Modus erfolgt.

Im Moment bin ich ratlos und das ist nicht mein erster Rechner (mein erster war ein Schneider PC 1512 SD). Ich werde mir mal die links ansehen und mich wieder melden!

Gruß
Thomas


Bewertung: 103 Punkte bei 6 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Kai (unangemeldet), Dienstag, 18. März 2014 15:42:29
Ein/Ausklappen

Das Problem ist, dass ich ebenfalls etwas ratlos bin; für genauere Diagnosen würde ich deinen Rechner benötigen.

Problematisch ist aber immer Secure Boot *nachträglich* abzuschalten. Windows 8 wurde mit Secure Boot installiert. Ich vermute mal, dass es deshalb einfach immer Sicherheitsmechanismen zündet.

Im Netz finde ich auf Anhieb mehrere Problemberichte, bei denen nach dem Abschalten von Secure Boot das System nicht mehr richtig funktioniert(e).

Die radikalste Lösung wäre deshalb: Secure Boot abschalten, Windows 8 neu installieren, dann Ubuntu neu installieren (in dieser Reihenfolge). Vielleicht fällt mir aber noch etwas ein.


Bewertung: 111 Punkte bei 5 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Prinzipiell richtig
Thomas Weiss, Dienstag, 18. März 2014 17:05:56
Ein/Ausklappen

Hallo Kai,

vielen Dank ich werde das System neu aufsetzen ohne Secure Boot und dann Ubuntu neu installieren. Ich bin mal gespannt, was mein Rechner sich noch einfallen lässt um sich Ubuntu zu verweigern.

Vielen Dank für die Hilfe noch mal!

Gruß
Thomas


Bewertung: 119 Punkte bei 7 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Schnell Multi-Boot-Medien mit MultiCD erstellen
Schnell Multi-Boot-Medien mit MultiCD erstellen
Tim Schürmann, 24.06.2014 12:40, 0 Kommentare

Wer mehrere nützliche Live-Systeme auf eine DVD brennen möchte, kommt mit den Startmedienerstellern der Distributionen nicht besonders weit: Diese ...

Aktuelle Fragen

Artikelsuche
Erwin Ruitenberg, 09.10.2014 07:51, 1 Antworten
Ich habe seit einige Jahre ein Dugisub LinuxUser. Dann weiß ich das irgendwann ein bestimmtes Art...
Windows 8 startet nur mit externer Festplatte
Anne La, 10.09.2014 17:25, 6 Antworten
Hallo Leute, also, ich bin auf folgendes Problem gestoßen: Ich habe Ubuntu 14.04 auf meiner...
Videoüberwachung mit Zoneminder
Heinz Becker, 10.08.2014 17:57, 0 Antworten
Hallo, ich habe den ZONEMINDER erfolgreich installiert. Das Bild erscheint jedoch nicht,...
internes Wlan und USB-Wlan-Srick
Gerhard Blobner, 04.08.2014 15:20, 2 Antworten
Hallo Linux-Forum: ich bin ein neuer Linux-User (ca. 25 Jahre Windows) und bin von WIN 8 auf Mint...
Server antwortet mit falschem Namen
oin notna, 21.07.2014 19:13, 1 Antworten
Hallo liebe Community, Ich habe mit Apache einen Server aufgesetzt. Soweit, so gut. Im Heimnet...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Recoll: Fehler bei Indizierung
Heiko, 25.10.2014 19:22
Am 25.10.2014, 17:53 Uhr, schrieb Wilhelm Boltz : Hallo Wilhelm, > wie hast Du die denn gefunden? Aktuel...
Re: [EasyLinux-Ubuntu] (gelöst)_Speedport_Konfiguration_Passwort_geht_nicht
Rainer, 25.10.2014 19:03
Hallo Kerl-Heinz, Am Sat, 25 Oct 2014 18:50:52 +0200 schrieb Karl-Heinz : > > > Von WinXP mit ei...
Re: [EasyLinux-Ubuntu] (gelöst)_Speedport_Konfiguration_Passwort_geht_nicht
Karl-Heinz, 25.10.2014 18:57
Am Sat, 25 Oct 2014 18:50:52 +0200 schrieb Karl-Heinz : Nachtrag: > Jetzt hab ich gerade die LÖSUNG ge...
Re: [EasyLinux-Ubuntu] (gelöst)_Speedport_Konfiguration_Passwort_geht_nicht
Karl-Heinz, 25.10.2014 18:50
Am Sat, 25 Oct 2014 18:02:24 +0200 schrieb Rainer : Hallo Rainer, > > Von WinXP mit einem alten IEx...
Re: [EasyLinux-Ubuntu] Speedport Konfiguration Passwort geht nicht
Rainer, 25.10.2014 18:02
Hallo Karl-Heinz, Am Sat, 25 Oct 2014 17:39:56 +0200 schrieb Karl-Heinz : > Hallo zusammen, >...