Suse 11.1 - was bremst (manchmal) graphische Anwendungen?

Jürgen G. - Dienstag, 13. Januar 2009 18:40:10 - 7 Antworten

Hallo zusammen,

wie beschreibe ich mein Problem am besten? Ich versuche es einfach mal. Auf meinem Laptop läuft als einziges Betriebssystem openSUSE 11.1 (x86_64) mit KDE 3.5.
Mir fiel auf, dass mitunter bestimmte Anwendungen sehr langsam starten und laufen, unabhängig davon, ob das System schon eine Weile läuft und ich demnach schon verschiedene Programme benutzt habe, oder das System frisch gestartet ist.

Bester Indikator für das Phänomen ist das Patience-Kartenspiel von KDE, das quälende Sekunden zum Aufbau braucht, vom Umblättern der Karten gar nicht zu reden. Auffallend sind aber auch Verzögerungen beim K-Menü oder bei Kmail.

Hier ein paar Eckdaten zu meiner Hardware:

Laptop HP dv5-1140eg
Intel Core Duo Prozessor P7350
250 GB Festplatte - home-Partition zu 2 % benutzt
3072 MB DDR2 SDRAM
Grafikkarte nVidia GeForce 9600M GT (Treiber nvidia, 3D-Unterstützung)

Ein paar selbst ergoogleten Hinweisen folend, habe ich Beagle und das Online-Updater-Applet entfernt, jedoch ohne Erfolg.

Mein Verdacht geht nun in Richtung Grafikkarte. Damit kenne ich mich nun aber gar nicht aus, und weiß auch nicht, welche Ausgabe welches Diagnosetools für die Community hilfreich wäre, um mein Problem einzukreisen.

Einen anderen Ansatz liefert vielleicht noch das KDE-Infozentrum. Dort wird mir unter "Speicher" angezeigt, dass ich +/- 84% freien physikalischen Speicher habe, und +/- 9% Festplattenspeicher. Der Hilfstext dort sagt mir aber, dass ein optimal eingerichtetes System wenig freien physischen Speicher und viel Festplattenspeicher zur Verfügung hat.

Ich wäre dankbar für Ideen und Lösungsansätze! Anmerken möchte ich noch, dass ich kein Linux-Profi bin, sondern nur ein - wenn auch langjähriger - Anwender.

Gruß, Jürgen

Antworten
Bremser gefunden; anderes Problem(chen)
Jürgen G., Montag, 11. Mai 2009 19:11:37
Ein/Ausklappen

Hallo, mein Ursprungsproblem scheint behoben zu sein. Mein Verdacht ging ja schon in Richtung Grafikkarte, und tatsächlich läuft nach einem Update der Pakete

nvidia-gfxG02-kmp-default
x11-video-nvidiaG02

fast alles rund; die periodisch auftretenden Grafikverzögerungen sind hoffentlich dauerhaft weg.

Dafür habe ich jetzt beim Start von KDE kleine Bildstörungen: Vom login bis zum Splashscreen sehe ich große, treppenförmige Artefakte in schwarz/grau auf dem Monitor. Wenn KDE erst mal läuft, sehe ich mein normales Hintergrundbild und bin deshalb nicht übermäßig besorgt, aber so richtig gesund kann die "Treppe" ja auch nicht sein?

Wenn es hilft, kann ich die "Treppe" mal im passenden Moment abfotografieren und hier einstellen.

Gruß, Jürgen


Bewertung: 167 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Nochmal hochgeholt
Jürgen G., Dienstag, 03. März 2009 17:51:58
Ein/Ausklappen

Hallo Gemeinde,

nicht, dass sich an der Problematik aus meiner Ausgangsfrage etwas geändert hätte, aber ich glaube mittlerweile, eine gewisse Systematik zu erkennen.

Die geschilderten Verzögerungen treten nach jedem dritten, maximal vierten Bootvorgang auf.

Nach dreimaligem Neustart des Rechners ist dann wieder alles normal.

Mysteriös da ganze, oder? Wo könnte man da noch ansetzen?

Gruß, Jürgen


Bewertung: 205 Punkte bei 35 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Probier mal folgendes
Benjamin Quest, Dienstag, 13. Januar 2009 21:38:14
Ein/Ausklappen

Öffne doch mal eine Konsole am Anfang der Arbeit und führe das Progrämmchen "top" aus. Es sollte bei einer Standardinstallation dabei sein, wenn nicht einfach nachinstallieren, dann aber besser die erweiterte Version "htop".

(h)top ist ein Systemmonitor, der Dir die aktuell laufenden Prozesse anzeigt. Wenn Dein System sich mal wieder "entschleunigt", einfach mal ins laufende (h)top schauen, evtl. "schwimmt" der Übeltäter in der Liste obenauf.

Wenn der Prozess nicht gerade "Xorg" heisst: kannst Du probieren den Prozess mit dem Befehl "killall prozessname" abzuschießen. (Falls Du nicht direkt wissen solltest, was der evtl. das System ausbremsende Prozess bedeutet, bitte vorher alle Arbeitsergebnisse speichern). Geht das System dann wieder ist der Schuldige wahrscheinlich überführt. Lösung des Problems hängt dann vom Übeltäter ab.

Schaun mer mal ... ;-)


Bewertung: 243 Punkte bei 54 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Probier mal folgendes
Ergebnis von "top": (unangemeldet), Dienstag, 13. Januar 2009 22:44:38
Ein/Ausklappen

Danke! Das folgende Chaos erklärt sich daraus, dass ich noch nicht gelernt habe, wie man hier Dateien aller Art einfügt...

top - 22:24:31 up 3 min, 3 users, load average: 0.44, 0.60, 0.27
Tasks: 121 total, 2 running, 119 sleeping, 0 stopped, 0 zombie
Cpu(s): 12.7%us, 0.7%sy, 0.0%ni, 86.2%id, 0.5%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3084452k total, 482432k used, 2602020k free, 15508k buffers
Swap: 2104472k total, 0k used, 2104472k free, 295872k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2980 root 20 0 361m 25m 10m S 23 0.9 0:31.22 X
3749 gringmut 20 0 181m 18m 12m R 7 0.6 0:04.90 kicker
2886 root 20 0 8908 500 372 S 1 0.0 0:00.08 irqbalance
3891 gringmut 20 0 144m 15m 11m S 1 0.5 0:00.72 konsole
3902 gringmut 20 0 8608 1144 844 R 1 0.0 0:00.24 top
1 root 20 0 1064 388 324 S 0 0.0 0:00.64 init
2 root 15 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0 0.0 0:00.00 ksoftirqd/0
5 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/1
6 root 15 -5 0 0 0 S 0 0.0 0:00.00 ksoftirqd/1
7 root 15 -5 0 0 0 S 0 0.0 0:00.00 events/0
8 root 15 -5 0 0 0 S 0 0.0 0:00.04 events/1
9 root 15 -5 0 0 0 S 0 0.0 0:00.00 khelper
10 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/0
11 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/1
12 root 15 -5 0 0 0 S 0 0.0 0:00.00 kblockd/0



Bewertung: 276 Punkte bei 48 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Probier mal folgendes
Jürgen G., Montag, 19. Januar 2009 21:39:05
Ein/Ausklappen

Hmm, gibt es vielleicht noch weitere Ideen? Ich hatte jetzt für drei Tage ein laufendes, schnelles System (ohne etwas an den Konfigurationen geändert zu haben) - die Ausgabe von top scheint euch keine Hinweise geliefert zu haben.

Heute ging es wieder los wie anfangs beschrieben.

Mich macht halt stutzig, dass das Problem nicht dauerhaft da ist, sondern *mal so, mal so*.


Bewertung: 249 Punkte bei 55 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
was vergessen
Jürgen G., Dienstag, 13. Januar 2009 18:45:10
Ein/Ausklappen

In der Überschrift meiner Frage steht (manchmal), weil das Problem leider nicht nachvollziehbar immer dann auftaucht, wenn ich dieses oder jenes mache, sondern eben nur zeitweise - manchmal läuft auch alles so schnell, wie ich das erwarte.


Bewertung: 302 Punkte bei 43 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: was vergessen
Dieter (unangemeldet), Montag, 19. Januar 2009 22:36:50
Ein/Ausklappen

Du könntest auch mal "ps ax" im Terminal/Konsole versuchen. Bei mir laufen manchmal auch Prozesse im Hintergrund. So gibt es einen Prozess betreffend des Dateiverzeichnisses. Wenn dieser läuft, sehe ich dort einen Eintrag mit "find ....". Bei meinem langsamen Notebook, merkt man das an der Geschwindigkeit schon mit Suse 10.1. Diese Prozesse werden über "cron" aufgerufen. Laufen also auch zeitweise und waren zu merken trotz entsprechenden Wert für "nice" des Prozesses.
Die Prozesse vom "beagle" und "bonobo" hatten bei mir zeitweise einiges an Rechenzeit verbraucht.


Bewertung: 264 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Samba-Server für Win-Daten & Linux-Dateirechte
Gerd Grundmann, 12.01.2017 18:25, 0 Antworten
Hallo Gemeinde, ich habe ewig gegooo.. aber nicht wirklich gefunden, was ich suche. Auf mei...
LM Cinnamon 18.1Serena 64 bit
Herwig Ameisbichler, 11.01.2017 13:02, 6 Antworten
Hallo an alle. Bin Linux Neuling.Habe auf meiner SSD neben W10 (finde ich nicht mehr)LM17.2 auch...
Bilder in E-Mail einbinden?
Werner Hahn, 23.12.2016 12:18, 4 Antworten
Dell Latitude E6510, Ubuntu 16.04, Mozilla Firefox Ich bitte um eine leicht verständliche Anle...
Linux Mint 17.2
Herwig Ameisbichler, 17.12.2016 11:19, 4 Antworten
Wer kann mir helfen? Hab seit gestern Linux am Pc.Wie kann ich diese Miniaturschrift im Menü,Lei...
Linux 17.2 Treiber f. PC Drucker installieren
Ernst Malitzki, 11.12.2016 13:04, 7 Antworten
Habe einen PC Drucker von HP. Möchte diesen PC Drucker an meinen PC anschließen. Hierzu benötige...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] adobe_flash_player_für_android
Wolfgang Voelker, 19.01.2017 18:34
Hallo Hartmut, daß du im Playstore dazu was findest, liegt daran, daß es Flash ja mal bis Android Gingerbread...
Re: [EasyLinux-Ubuntu] adobe_flash_player_für_android
Hartmut Haase, 19.01.2017 16:23
Hallo Wolfgang, > klares nein. Hat Google schon lange verboten. verstanden. Spaßig ist nur: wenn man im...
Re: [EasyLinux-Ubuntu] Streams_übertragen
Frank von Thun, 19.01.2017 05:54
Am 18.01.2017 um 19:53 schrieb alfred: > Am 18.01.2017 um 18:02 schrieb Frank von Thun: >> Am 18.0...
Re: [EasyLinux-Ubuntu] Streams_übertragen
Heiko, 18.01.2017 22:48
Am Mittwoch, 18. Januar 2017, 19:53:08 CET schrieb alfred: Hallo Alfred. > > OK, geht und holt die...
Re: [EasyLinux-Ubuntu] adobe_flash_player_für__android
Karl-Heinz, 18.01.2017 18:54
Am Wed, 18 Jan 2017 17:09:23 +0100 schrieb Hartmut Haase : Hallo Hartmut, such einfach mal nach "Fla...