Suse 11.1 - was bremst (manchmal) graphische Anwendungen?

Jürgen G. - Dienstag, 13. Januar 2009 18:40:10 - 7 Antworten

Hallo zusammen,

wie beschreibe ich mein Problem am besten? Ich versuche es einfach mal. Auf meinem Laptop läuft als einziges Betriebssystem openSUSE 11.1 (x86_64) mit KDE 3.5.
Mir fiel auf, dass mitunter bestimmte Anwendungen sehr langsam starten und laufen, unabhängig davon, ob das System schon eine Weile läuft und ich demnach schon verschiedene Programme benutzt habe, oder das System frisch gestartet ist.

Bester Indikator für das Phänomen ist das Patience-Kartenspiel von KDE, das quälende Sekunden zum Aufbau braucht, vom Umblättern der Karten gar nicht zu reden. Auffallend sind aber auch Verzögerungen beim K-Menü oder bei Kmail.

Hier ein paar Eckdaten zu meiner Hardware:

Laptop HP dv5-1140eg
Intel Core Duo Prozessor P7350
250 GB Festplatte - home-Partition zu 2 % benutzt
3072 MB DDR2 SDRAM
Grafikkarte nVidia GeForce 9600M GT (Treiber nvidia, 3D-Unterstützung)

Ein paar selbst ergoogleten Hinweisen folend, habe ich Beagle und das Online-Updater-Applet entfernt, jedoch ohne Erfolg.

Mein Verdacht geht nun in Richtung Grafikkarte. Damit kenne ich mich nun aber gar nicht aus, und weiß auch nicht, welche Ausgabe welches Diagnosetools für die Community hilfreich wäre, um mein Problem einzukreisen.

Einen anderen Ansatz liefert vielleicht noch das KDE-Infozentrum. Dort wird mir unter "Speicher" angezeigt, dass ich +/- 84% freien physikalischen Speicher habe, und +/- 9% Festplattenspeicher. Der Hilfstext dort sagt mir aber, dass ein optimal eingerichtetes System wenig freien physischen Speicher und viel Festplattenspeicher zur Verfügung hat.

Ich wäre dankbar für Ideen und Lösungsansätze! Anmerken möchte ich noch, dass ich kein Linux-Profi bin, sondern nur ein - wenn auch langjähriger - Anwender.

Gruß, Jürgen

Antworten
Bremser gefunden; anderes Problem(chen)
Jürgen G., Montag, 11. Mai 2009 19:11:37
Ein/Ausklappen

Hallo, mein Ursprungsproblem scheint behoben zu sein. Mein Verdacht ging ja schon in Richtung Grafikkarte, und tatsächlich läuft nach einem Update der Pakete

nvidia-gfxG02-kmp-default
x11-video-nvidiaG02

fast alles rund; die periodisch auftretenden Grafikverzögerungen sind hoffentlich dauerhaft weg.

Dafür habe ich jetzt beim Start von KDE kleine Bildstörungen: Vom login bis zum Splashscreen sehe ich große, treppenförmige Artefakte in schwarz/grau auf dem Monitor. Wenn KDE erst mal läuft, sehe ich mein normales Hintergrundbild und bin deshalb nicht übermäßig besorgt, aber so richtig gesund kann die "Treppe" ja auch nicht sein?

Wenn es hilft, kann ich die "Treppe" mal im passenden Moment abfotografieren und hier einstellen.

Gruß, Jürgen


Bewertung: 160 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Nochmal hochgeholt
Jürgen G., Dienstag, 03. März 2009 17:51:58
Ein/Ausklappen

Hallo Gemeinde,

nicht, dass sich an der Problematik aus meiner Ausgangsfrage etwas geändert hätte, aber ich glaube mittlerweile, eine gewisse Systematik zu erkennen.

Die geschilderten Verzögerungen treten nach jedem dritten, maximal vierten Bootvorgang auf.

Nach dreimaligem Neustart des Rechners ist dann wieder alles normal.

Mysteriös da ganze, oder? Wo könnte man da noch ansetzen?

Gruß, Jürgen


Bewertung: 199 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Probier mal folgendes
Benjamin Quest, Dienstag, 13. Januar 2009 21:38:14
Ein/Ausklappen

Öffne doch mal eine Konsole am Anfang der Arbeit und führe das Progrämmchen "top" aus. Es sollte bei einer Standardinstallation dabei sein, wenn nicht einfach nachinstallieren, dann aber besser die erweiterte Version "htop".

(h)top ist ein Systemmonitor, der Dir die aktuell laufenden Prozesse anzeigt. Wenn Dein System sich mal wieder "entschleunigt", einfach mal ins laufende (h)top schauen, evtl. "schwimmt" der Übeltäter in der Liste obenauf.

Wenn der Prozess nicht gerade "Xorg" heisst: kannst Du probieren den Prozess mit dem Befehl "killall prozessname" abzuschießen. (Falls Du nicht direkt wissen solltest, was der evtl. das System ausbremsende Prozess bedeutet, bitte vorher alle Arbeitsergebnisse speichern). Geht das System dann wieder ist der Schuldige wahrscheinlich überführt. Lösung des Problems hängt dann vom Übeltäter ab.

Schaun mer mal ... ;-)


Bewertung: 239 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Probier mal folgendes
Ergebnis von "top": (unangemeldet), Dienstag, 13. Januar 2009 22:44:38
Ein/Ausklappen

Danke! Das folgende Chaos erklärt sich daraus, dass ich noch nicht gelernt habe, wie man hier Dateien aller Art einfügt...

top - 22:24:31 up 3 min, 3 users, load average: 0.44, 0.60, 0.27
Tasks: 121 total, 2 running, 119 sleeping, 0 stopped, 0 zombie
Cpu(s): 12.7%us, 0.7%sy, 0.0%ni, 86.2%id, 0.5%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 3084452k total, 482432k used, 2602020k free, 15508k buffers
Swap: 2104472k total, 0k used, 2104472k free, 295872k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
2980 root 20 0 361m 25m 10m S 23 0.9 0:31.22 X
3749 gringmut 20 0 181m 18m 12m R 7 0.6 0:04.90 kicker
2886 root 20 0 8908 500 372 S 1 0.0 0:00.08 irqbalance
3891 gringmut 20 0 144m 15m 11m S 1 0.5 0:00.72 konsole
3902 gringmut 20 0 8608 1144 844 R 1 0.0 0:00.24 top
1 root 20 0 1064 388 324 S 0 0.0 0:00.64 init
2 root 15 -5 0 0 0 S 0 0.0 0:00.00 kthreadd
3 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/0
4 root 15 -5 0 0 0 S 0 0.0 0:00.00 ksoftirqd/0
5 root RT -5 0 0 0 S 0 0.0 0:00.00 migration/1
6 root 15 -5 0 0 0 S 0 0.0 0:00.00 ksoftirqd/1
7 root 15 -5 0 0 0 S 0 0.0 0:00.00 events/0
8 root 15 -5 0 0 0 S 0 0.0 0:00.04 events/1
9 root 15 -5 0 0 0 S 0 0.0 0:00.00 khelper
10 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/0
11 root 15 -5 0 0 0 S 0 0.0 0:00.00 kintegrityd/1
12 root 15 -5 0 0 0 S 0 0.0 0:00.00 kblockd/0



Bewertung: 272 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Probier mal folgendes
Jürgen G., Montag, 19. Januar 2009 21:39:05
Ein/Ausklappen

Hmm, gibt es vielleicht noch weitere Ideen? Ich hatte jetzt für drei Tage ein laufendes, schnelles System (ohne etwas an den Konfigurationen geändert zu haben) - die Ausgabe von top scheint euch keine Hinweise geliefert zu haben.

Heute ging es wieder los wie anfangs beschrieben.

Mich macht halt stutzig, dass das Problem nicht dauerhaft da ist, sondern *mal so, mal so*.


Bewertung: 245 Punkte bei 54 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
was vergessen
Jürgen G., Dienstag, 13. Januar 2009 18:45:10
Ein/Ausklappen

In der Überschrift meiner Frage steht (manchmal), weil das Problem leider nicht nachvollziehbar immer dann auftaucht, wenn ich dieses oder jenes mache, sondern eben nur zeitweise - manchmal läuft auch alles so schnell, wie ich das erwarte.


Bewertung: 299 Punkte bei 42 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: was vergessen
Dieter (unangemeldet), Montag, 19. Januar 2009 22:36:50
Ein/Ausklappen

Du könntest auch mal "ps ax" im Terminal/Konsole versuchen. Bei mir laufen manchmal auch Prozesse im Hintergrund. So gibt es einen Prozess betreffend des Dateiverzeichnisses. Wenn dieser läuft, sehe ich dort einen Eintrag mit "find ....". Bei meinem langsamen Notebook, merkt man das an der Geschwindigkeit schon mit Suse 10.1. Diese Prozesse werden über "cron" aufgerufen. Laufen also auch zeitweise und waren zu merken trotz entsprechenden Wert für "nice" des Prozesses.
Die Prozesse vom "beagle" und "bonobo" hatten bei mir zeitweise einiges an Rechenzeit verbraucht.


Bewertung: 259 Punkte bei 46 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Brother Drucker DCP-J4120
Achim Zerrer, 09.12.2016 18:08, 0 Antworten
Hallo, ich wollte unter Leap 42.1 den Brother Drucker installieren und dazu das PPD- Datei vom do...
Drucker Epson XP-332 unter ubuntu 14.04 einrichten
Andrea Wagenblast, 30.11.2016 22:07, 2 Antworten
Hallo, habe vergeblich versucht mein Multifunktionsgerät Epson XP-332 als neuen Drucker unter...
Apricity Gnome unter Win 10 via VirtualBox
André Driesel, 30.11.2016 06:28, 2 Antworten
Halo Leute, ich versuche hier schon seit mehreren Tagen Apricity OS Gnome via VirtualBox zum l...
EYE of Gnome
FRank Schubert, 15.11.2016 20:06, 2 Antworten
Hallo, EOG öffnet Fotos nur in der Größenordnung 4000 × 3000 Pixel. Größere Fotos werden nic...
Kamera mit Notebook koppeln
Karl Spiegel, 12.11.2016 15:02, 2 Antworten
Hi, Fotografen ich werde eine SONY alpha 77ii bekommen, und möchte die LifeView-Möglichkeit nu...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Ubuntu Nachrichtensammlung, Band 129, Eintrag 4
Hans, 08.12.2016 13:30
Hallo Scharam, einmal Tante Guurgel und da habe ich Pooka Email Client gefunden. Gruß Jörg Am 8. Dezem...
[EasyLinux-Ubuntu] Ein Mailprogramm in Java
Schahram Sanawi Garrousi, 07.12.2016 23:02
Hallo Liste Gibt es ein Mailprogramm in Java? Gruß Schahram -- 4.4.0-53-generic x86_64 * Kubuntu 16.04...
Re: [EasyLinux-Ubuntu] WLAN Adressenbereich
"Michael R. Moschner", 02.12.2016 17:54
Am Samstag, 26. November 2016, 00:54:07 schrieb Richard Kraut: Hallo Richard und alle anderen Danke für die...
Re: [EasyLinux-Ubuntu] [erledigt?] xubuntu 16.04: unvollständige_Aktualisierung
Hartmut Haase, 30.11.2016 18:16
Hallo Liste, > 0% [Verbindung mit security.ubuntu.com (2001:67c:1560:8001::11)] wenn man das Ganze lang...
Re: [EasyLinux-Ubuntu] xubuntu_16.04:_unvollständige_Aktualisierung
Hartmut Haase, 30.11.2016 16:28
Hallo Frank, > Habe ich auch gerade? > Root hat noch 3GB frei. ich habe noch knapp 10GB frei. Dara...