[SuSE 9.1] Routing-Problem bzgl. Routing ins Internet

Autor

Samstag, 08. Januar 2005 12:17:00

OS: SuSE Linux 9.1
Netzwerk: eth0 (192.168.182.21) WLAN-Karte, manuell installiert (nicht in Yast angezeigt)
eth1 (keine IP zugewiesen) LAN-Karte, über Yast konfigurierbar, jedoch deaktiviert
Router (192.168.182.1)
versuchte Problemlösungen: [1] (nicht erfolgreich, siehe unten)

Die Code-Snippets lassen sich unter [2] besser lesen.

nach dem Hochfahren

<strong>linux:/home/Lars # route   </strong>
            Kernel IP Routentabelle   
            Ziel            Router          Genmask         Flags Metric Ref    Use             Iface   
            192.168.182.0   *               255.255.255.0   U     0      0        0             eth0   
            loopback        *               255.0.0.0       U     0      0        0             lo   

                          <strong>linux:/home/Lars # ifconfig </strong>  
            eth0      Protokoll:Ethernet  Hardware Adresse 00:80:5A:32:27:87   
                      inet Adresse:192.168.182.21  Bcast:192.168.182.255              Maske:255.255.255.0   
                      inet6 Adresse: fe80::280:5aff:fe32:2787/64             Gültigkeitsbereich:Verbindung   
                      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1   
                      RX packets:157 errors:0 dropped:0 overruns:0 frame:0   
                      TX packets:55 errors:10 dropped:10 overruns:0 carrier:0   
                      Kollisionen:25 Sendewarteschlangenlänge:1000   
                      RX bytes:19113 (18.6 Kb)  TX bytes:5864 (5.7 Kb)   
                      Interrupt:10 Basisadresse:0xf000   

                          lo        Protokoll:Lokale Schleife   
                      inet Adresse:127.0.0.1  Maske:255.0.0.0   
                      inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine   
                      UP LOOPBACK RUNNING  MTU:16436  Metric:1   
                      RX packets:18 errors:0 dropped:0 overruns:0 frame:0   
                      TX packets:18 errors:0 dropped:0 overruns:0 carrier:0   
                      Kollisionen:0 Sendewarteschlangenlänge:0   
                      RX bytes:1080 (1.0 Kb)  TX bytes:1080 (1.0 Kb) 
  
                          <strong>linux:/home/Lars # iwconfig</strong>   
            lo        no wireless extensions.   

                          eth0      RT2500 Wireless  ESSID:"linuxrockt"   
                      Mode:Managed  Channel=11  Access Point: 00:04:0E:2E:6E:6B             
                      Bit Rate:11Mb/s   
                      RTS thr=2312 B   Fragment thr=2312 B   
                      Encryption key:3337-3738-3234-3438-3034-3431-36   Security            modeomgpen   
                      Link Quality:0/70  Signal level:-209 dBm  Noise level:-256 dBm             
                      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0   
                      Tx excessive retries:0  Invalid misc:0   Missed beacon:0             

                          sit0      no wireless extensions.   

                          eth1      no wireless extensions.


Wie ihr seht, ist keine Standardroute definiert. Über Yast schlägt das deshalb fehl, weil Yast die Karte eth0 nicht kennt und deshalb immer versucht, über eth1 (kabelgebunden) zu routen.

<strong>linux:/home/Lars # route add default gw 192.168.182.1</strong>   
            linux:/home/Lars # route   
            Kernel IP Routentabelle   
            Ziel            Router          Genmask         Flags Metric Ref    Use             Iface   
            192.168.182.0   *               255.255.255.0   U     0      0        0             eth0   
            loopback        *               255.0.0.0       U     0      0        0             lo   
            default         fritz.slwlan.bo 0.0.0.0         UG    0      0        0             eth0


Soweit so gut, nur ins Internet bringt mich das leider auch nicht. Ich kann weiterhin keine Internetseiten aufrufen. Den Router (Konfiguration, etc.) erreiche ich jedoch.

Wo liegt der Fehler?

[1] http://www.linux-club.de/viewtopic.php?t=21559
[2] http://www.linux-club.de/viewtopic.php?p=123837

Lars I.

0 Antworten


Antworten

Ähnliche Artikel

  • Netzwerk in der Shell
  • Netzwerkdiagnose-Tools
    Linux hat die richtigen Tools an Bord, um Fehler im Netz aufzuspüren und den Datenpaketen den Weg wieder frei zu machen.
  • Linux im LAN
    Ob man einmal einen Rechner in ein Netzwerk einbindet oder dies wie bei einem Laptop – mal zu Hause, mal im Büro – öfter tut; die dahinter steckenden Mysterien bleiben dieselben.
  • PPPoE mit 2.4er Kernel
    Seit fast zwei Jahren ist DSL verfügbar. Wer aber unter Linux in den Genuss des breitbandigen Surfens kommen will, muss selbst Hand anlegen. Wenn die eigene Distribution auf einem Kernel der 2.4er Serie aufbaut, gilt es dabei andere Wege zu beschreiten als mit Kernel 2.2.x.
  • Dr. Linux

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 0 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Suse] Steam_läuft_nicht_mehr_rund
"d.blanke@gmx.net", 28.03.2015 01:39
Matthias Müller schrieb: > xhost + Hallo Matthias, beide Eingaben führen leider auch nicht zum Erfolg....
Re: [EasyLinux-Ubuntu] Notebook als Monitor
Gerhard Blaschke, 27.03.2015 23:34
Hallo Stefan und Wolfgang, Am 27.03.2015 um 11:13 schrieb Wolfgang Voelker: > Hallo Gerhard, > &...
[EasyLinux-Ubuntu] Backup vom entfernten Rechner (im lokalen Netzwerk)
Joachim Puttkammer, 27.03.2015 16:50
Hallo, auf den entfernten PC (Raspberry) kann ich per ssh oder NFS zugreifen. Ist es egal oder bestehen Unt...
Re: [EasyLinux-Suse] Meine beiden Anfagen abgeschlossen
Heiko, 27.03.2015 12:12
Am Freitag, 27. März 2015, 10:11:20 schrieb H.-Stefan Neumeyer: Hallo Stefan. > > Netinstall? &g...
Re: [EasyLinux-Suse] Dualboot Windows7 Opensuse Update KB 3033929
Heiko, 27.03.2015 11:25
Am Freitag, 27. März 2015, 00:36:44 schrieb Tobias Buchberger: Hallo Tobias, > > versuch doch mal...