[SuSE 9.1] Routing-Problem bzgl. Routing ins Internet

Lars I. - Samstag, 08. Januar 2005 12:17:00 - 0 Antworten

OS: SuSE Linux 9.1
Netzwerk: eth0 (192.168.182.21) WLAN-Karte, manuell installiert (nicht in Yast angezeigt)
eth1 (keine IP zugewiesen) LAN-Karte, über Yast konfigurierbar, jedoch deaktiviert
Router (192.168.182.1)
versuchte Problemlösungen: [1] (nicht erfolgreich, siehe unten)

Die Code-Snippets lassen sich unter [2] besser lesen.

nach dem Hochfahren
<strong>linux:/home/Lars # route   </strong>
            Kernel IP Routentabelle   
            Ziel            Router          Genmask         Flags Metric Ref    Use             Iface   
            192.168.182.0   *               255.255.255.0   U     0      0        0             eth0   
            loopback        *               255.0.0.0       U     0      0        0             lo   

                          <strong>linux:/home/Lars # ifconfig </strong>  
            eth0      Protokoll:Ethernet  Hardware Adresse 00:80:5A:32:27:87   
                      inet Adresse:192.168.182.21  Bcast:192.168.182.255              Maske:255.255.255.0   
                      inet6 Adresse: fe80::280:5aff:fe32:2787/64             Gültigkeitsbereich:Verbindung   
                      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1   
                      RX packets:157 errors:0 dropped:0 overruns:0 frame:0   
                      TX packets:55 errors:10 dropped:10 overruns:0 carrier:0   
                      Kollisionen:25 Sendewarteschlangenlänge:1000   
                      RX bytes:19113 (18.6 Kb)  TX bytes:5864 (5.7 Kb)   
                      Interrupt:10 Basisadresse:0xf000   

                          lo        Protokoll:Lokale Schleife   
                      inet Adresse:127.0.0.1  Maske:255.0.0.0   
                      inet6 Adresse: ::1/128 Gültigkeitsbereich:Maschine   
                      UP LOOPBACK RUNNING  MTU:16436  Metric:1   
                      RX packets:18 errors:0 dropped:0 overruns:0 frame:0   
                      TX packets:18 errors:0 dropped:0 overruns:0 carrier:0   
                      Kollisionen:0 Sendewarteschlangenlänge:0   
                      RX bytes:1080 (1.0 Kb)  TX bytes:1080 (1.0 Kb) 
  
                          <strong>linux:/home/Lars # iwconfig</strong>   
            lo        no wireless extensions.   

                          eth0      RT2500 Wireless  ESSID:"linuxrockt"   
                      Mode:Managed  Channel=11  Access Point: 00:04:0E:2E:6E:6B             
                      Bit Rate:11Mb/s   
                      RTS thr=2312 B   Fragment thr=2312 B   
                      Encryption key:3337-3738-3234-3438-3034-3431-36   Security            modeomgpen   
                      Link Quality:0/70  Signal level:-209 dBm  Noise level:-256 dBm             
                      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0   
                      Tx excessive retries:0  Invalid misc:0   Missed beacon:0             

                          sit0      no wireless extensions.   

                          eth1      no wireless extensions.


Wie ihr seht, ist keine Standardroute definiert. Über Yast schlägt das deshalb fehl, weil Yast die Karte eth0 nicht kennt und deshalb immer versucht, über eth1 (kabelgebunden) zu routen.

<strong>linux:/home/Lars # route add default gw 192.168.182.1</strong>   
            linux:/home/Lars # route   
            Kernel IP Routentabelle   
            Ziel            Router          Genmask         Flags Metric Ref    Use             Iface   
            192.168.182.0   *               255.255.255.0   U     0      0        0             eth0   
            loopback        *               255.0.0.0       U     0      0        0             lo   
            default         fritz.slwlan.bo 0.0.0.0         UG    0      0        0             eth0


Soweit so gut, nur ins Internet bringt mich das leider auch nicht. Ich kann weiterhin keine Internetseiten aufrufen. Den Router (Konfiguration, etc.) erreiche ich jedoch.

Wo liegt der Fehler?

[1] http://www.linux-club.de/viewtopic.php?t=21559
[2] http://www.linux-club.de/viewtopic.php?p=123837

Antworten

Ähnliche Artikel

  • Netzwerk in der Shell
  • Netzwerkdiagnose-Tools
    Linux hat die richtigen Tools an Bord, um Fehler im Netz aufzuspüren und den Datenpaketen den Weg wieder frei zu machen.
  • Linux im LAN
    Ob man einmal einen Rechner in ein Netzwerk einbindet oder dies wie bei einem Laptop – mal zu Hause, mal im Büro – öfter tut; die dahinter steckenden Mysterien bleiben dieselben.
  • PPPoE mit 2.4er Kernel
    Seit fast zwei Jahren ist DSL verfügbar. Wer aber unter Linux in den Genuss des breitbandigen Surfens kommen will, muss selbst Hand anlegen. Wenn die eigene Distribution auf einem Kernel der 2.4er Serie aufbaut, gilt es dabei andere Wege zu beschreiten als mit Kernel 2.2.x.
  • Dr. Linux

Aktuelle Fragen

WLAN lässt sich nicht einrichten
Werner Hahn, 21.03.2017 14:16, 0 Antworten
Dell Latitude E6510, Ubuntu 16.4, Kabelbox von Telecolumbus. Nach Anklicken des Doppelpfeiles (o...
"Mit Gwenview importieren" funktioniert seit openSuse 42.2 nicht mehr
Wimpy *, 20.03.2017 13:34, 2 Antworten
Bisher konnte ich von Digitalkamera oder SD-Karte oder USB-Stick Fotos mit Gwenview importieren....
Ich habe eine awk Aufgabe und bekomme es nicht so Recht hin
Dennis Hamacher, 10.03.2017 18:27, 1 Antworten
Ich hoffe Ihr könnt mir dabei helfen oder mir zeigen wie der Befehl richtig geschrieben wird. Ich...
Unter Linux Open Suse Leap 42.1 einen Windows Boot/ ISO USB Stick erstellen...
Tim Koetsier, 07.03.2017 15:26, 1 Antworten
Hallo, weiß jemand wie ich oben genanntes Vorhaben in die Tat umsetzen kann ? Wäre echt dankba...
Druckertreiber installieren OpenSuse42.1
Tim Koetsier, 07.03.2017 15:22, 1 Antworten
hallo, kann mir BITTE jemand helfen ich verzweifel so langsam. Habe einen Super Toner von Canon...

Jetzt auf den Mailinglisten

[EasyLinux-Ubuntu] Kodibuntu (Lubuntu) 14.04 auf Sony Vaio: Kein Sound via HDMI
Rainer, 30.03.2017 19:22
Hallo zusammen, schon eine Weile her, dass ich Kodibuntu auf dem Notebook installiert und es anschließend a...
[EasyLinux-Ubuntu] Samsung-Decryption
Gerhard Blaschke, 30.03.2017 16:38
Hallo Liste, nachdem sich in meiner Umgebung herumgesprochen hat, dass ich mit Linux zu tun habe, kommen au...
Re: [EasyLinux-Ubuntu] Videoplayer_für_Ubuntu
Heiko, 28.03.2017 20:23
Am Dienstag, 28. März 2017, 19:22:00 CEST schrieb Willi Zelinka: Hallo Uwe,hallo Willi > > vl...
Re: [EasyLinux-Ubuntu] Videoplayer_für_Ubuntu
Willi Zelinka, 28.03.2017 19:22
Hallo Uwe, Am Dienstag, 28. März 2017, 10:17:29 CEST schrieb Uwe Herrmuth: > Hallo Willi, > >...
Re: [EasyLinux-Ubuntu] Downloads von Windowsprogrammen unter Linux
Karl-Heinz, 28.03.2017 17:55
Am Tue, 28 Mar 2017 09:19:49 +0200 schrieb Uwe Herrmuth : Hallo Uwe, :-))))) > Für FF gibt es ein Ad...