Speicherzugriffsfehler

Autor

Sonntag, 13. September 2009 09:39:59

Ich habe neuerdings ein paar Probleme, die darauf schließen lassen, dass ich Einstellungen nicht mehr abspeichern kann. Ich habe diese [<A href="http://www.linux-community....!/Speicherzugriffsfehler" mce_href="http://www.linux-community....!/Speicherzugriffsfehler" target="_blank">] hier [/A] kurz beschrieben.

YaST gibt mir folgende Fehlermeldung aus, wenn ich z.B. auf Audio, Tastaturbelegungen oder Kernel-Einstellungen klicke: [b]YaST got signal 11 at YCP file Arch.ycp:46
/sbin/yast2: line 440: 19768 Speicherzugriffsfehler $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS[/b]

Leider ist diese Fehlermeldung für mich doch sehr kryptisch. Dazu kommt, dass ich LINUX-Einsteigerin bin und erst seit ungefähr ein/zwei Wochen OpenSuse 11.1 mit KDE 4.3 benutze.

Sandy Magasch

4 Antworten


Antworten
Speicherzugriffsfehler .. dieses Mal aber lesbar ohne HTML
Sandy Magasch, Sonntag, 13. September 2009 09:46:24
Ein/Ausklappen

Hm, dann nochmal in verständlicherer Form:

Ich habe neuerdings mehrere Problem"chen":
* Meine Einstellungen im Opera werden nicht übernommen.
* Der Sound funktioniert nicht überall, wo er funktionieren soll.
* Seit kurzem lassen sich die Längen der Abstandshalter in den Kontrollleisten nicht mehr abspeichern.
* Die Passwörter müssen immer neu eingegeben werden, obwohl das Kästchen "Passwort merken" aktiviert ist (Häkchen ist vorhanden).
* Der Nummernblock meiner Tastatur muss jeden Tag neu aktiviert werden.

Ich schätze mal, dass sämtliche Auffälligkeiten einen gemeinsamen Ursprung haben. Wenn ich in YaST sowohl auf Audio, Kernel-Einstellungen, Hardware-Informationen und Tastaturenbelegungen klicke, erscheint eine für mich kryptische Fehlermeldung, die sich immer auf dieselbe Datei bzw. auf dasselbe Verzeichnis bezieht (Fehlermeldung: YaST got signal 11 at YCP file Arch.ycp:46
/sbin/yast2: line 440: 19825 Speicherzugriffsfehler $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS) und meine derzeitige Situation passenderweise mit einem zweideutigen ARGS kommentiert.

Ich kann euch leider nicht sagen, was in den letzten Tagen anders gelaufen sein soll, was diese Probleme eventuell nach sich gezogen hat. Meiner Meinung nach nichts.

Weiß einer von euch Rat? Ich brauche mal wieder eure Unterstützung ;)

P.S.: Ich benutze OpenSuse 11.1 mit KDE 4.3.


Bewertung: 83 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Speicherzugriffsfehler .. dieses Mal aber lesbar ohne HTML
Uwe Koziolek, Sonntag, 13. September 2009 10:35:18
Ein/Ausklappen

Signal 11 kommt üblicherweise bei Programmierfehlern. Es treten Situationen auf die im Programm nicht berücksichtigt wurden.

Ein Problem kann sein, es wurde einmal mit root Rechten gearbeitet und ein oder mehrere Dateien im Home Verzeichnis des Nutzers haben jetzt keine Rechte für den ursprünglichen Eigentümer.
Einen Versuch ist es wert die Eigentümerschaft für alle Dateien im Home Verzeichnis des Nutzers zu setzen.

sudo chown -R <Nutzer> /home/<Nutzer>

oder

su -c "chown -R <Nutzer> /home/<Nutzer>"





Bewertung: 50 Punkte bei 19 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Speicherzugriffsfehler .. dieses Mal aber lesbar ohne HTML
Claus S. (unangemeldet), Sonntag, 13. September 2009 13:25:17
Ein/Ausklappen

Zu dem Opera-Problem:
Wenn das nicht hilft mit der Rechtevergabe, könntest Du folgenden Weg gehen:
- Opera beenden
- verstecktes Operaverzeichnis umbenennen (die versteckten Dateien siehst Du über: Ansicht - versteckte Dateien anzeigen)
- Opera neu starten

Damit zwingst Du Opera eine neue Konfiguration anzulegen und eventuel gesperrte Dateien freizugeben.

Leider verlierst Du dabei alle bisher getätigten Einstellungen, die sind aber noch in dem umbenannten Verzeichnis.

Zu Numlock:
Ist es im Bios entsprechend eingestellt? (meistens kannst Du das Bios öffnen wenn Du die "entf" Taste beim Rechnerstart drückst. Nicht erschrecken, da kommt dann ein Menue, mit vielen Punkten. Falls Du hast kannst Du das in der Anleitung für Dein Motherboard nachlesen.

Zu den anderen Dingen kann ich nichts sagen....

Grüße


Bewertung: 142 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Speicherzugriffsfehler .. dieses Mal aber lesbar ohne HTML
Sandy Magasch, Montag, 14. September 2009 06:34:55
Ein/Ausklappen

Mittlerweile haben sich einige der Probleme lösen lassen:

* Opera: Der Tipp hat geholfen. Thx, Claus S. :)
* Nummernblock: Dieser lässt sich über Systemeinstellungen > Tastatur & Maus > Tastatur aktivieren, so dass er bei jedem KDE-Start automatisch eingeschaltet ist.
* Sound & Passwörter: Ja, bei dieser Problemlösung hat mein Freund fast einen Anfall bekommen als ich ihm erzählt habe, WAS ich gemacht habt, um diese Probleme zu lösen. Deswegen sag ich dazu lieber nicht viel, weil es im Nachhinein vermutlich eine völlig unnötige Harakiri-Aktion war. Deswegen geb ich hier nur den Link an, der auf die Lösung verweist, die aber tatsächlich geholfen hat *pfeif*
http://forums.opensuse.org/...ast2-kde4-opensuse-11-0-a.html
Der Tipp mit den Zugriffsrechten, den merke ich mir. Die Probleme waren damit leider nicht bezulegen. Thx, Uwe Koziolek, den Tipp werde ich in Zukunft dennoch gut gebrauchen können ... da bin ich mir sicher ;)

Mein einziges Problem"chen" bleiben somit die Abstandshalter, die nun nicht mehr das machen wollen, was ich will.


Bewertung: 116 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 2 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 4 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...
Linux und W7 im Netz finden sich nicht
Oliver Zoffi, 06.02.2015 11:47, 3 Antworten
Hallo! Ich verwende 2 PCs, 1x mit W7prof 64 Bit und einmal mit Linux Mint 17 64 Bit, welches ich...
Rootpasswort
Jutta Naumann, 29.01.2015 09:14, 1 Antworten
Ich habe OpenSuse 13.2 installiert und leider nur das Systempasswort eingerichtet. Um Änderungen,...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Claws
Frank, 04.03.2015 12:54
Hi Uwe, > In den Einstellungen bei Claws unter externe Programme steht aber > hinter dem Firefox noch...
Re: [EasyLinux-Ubuntu] Claws
Uwe Herrmuth, 04.03.2015 12:47
Hallo Frank, Frank schrieb am 04.03.2015 um 12:38: > wenn ich in Claws bei einer Nachricht einen Link an...
[EasyLinux-Ubuntu] Claws
Frank, 04.03.2015 12:38
Hallo Liste, wenn ich in Claws bei einer Nachricht einen Link anklicke, geht nur noch Firefox auf, ohne de...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Rainer, 04.03.2015 09:57
Hallo Alfred, Am Wed, 04 Mar 2015 02:38:56 +0100 schrieb Alfred Zahlten : > > > > 100% Leis...
Re: [EasyLinux-Ubuntu] Bildschirmschoner einschalten
Heiko, 04.03.2015 07:55
Am Mittwoch, 4. März 2015, 07:23:39 schrieb Gerhard Blaschke: Hallo. > Am 03.03.2015 um 21:06 schrieb Ka...