Samba: Roaming Profiles tun nicht!

Autor

Sonntag, 08. Februar 2004 11:09:41



Hallo!

Ich versuche gerade verzweifelt auf meinem Debian (Sid) Samba (3.0.1) zum laufen zu bringen. Eigentlich tut es schon super gut, aber mit den Profiles hab ich noch Probleme.

Wenn ich mich mit meinem Win2k-Client anmelde, dann wird auch brav im profiles-share ein Verzeichnis mit dem Benzuternamen angelegt (hat user und Gruppe des Benutzer), dann ist aber Schluß, das Verzeichnis bleibt leer!

Es gibt keine Fehlermeldung!

Hier mal ein kurzer Ausschnitt der in meinen Augen wesentlichen Teilen aus meiner smb.conf:

   security = user
   domain master = yes
   preferred master = yes
   local master = yes
   domain logons = yes
   os level = 65

   logon path = \frodo\profiles\%U
   logon drive = L:
   logon script = logon.cmd

[profiles]
   path=/var/lib/samba/profiles
   admin users = root
   read only = no
   write able = yes
   create mask = 0600
   directory mask = 0700
   profile acls = yes
   browseable = no

Was mach ich nur falsch? Tschüß
   Marcus

Anonymous User

8 Antworten


Antworten
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 14:25:17
Ein/Ausklappen

hallo markus

auf ersten blick fällt mir auf,
dass "writeable" muss man zusammenschreiben, also

writeable = yes

gruss
christoph


Bewertung: 158 Punkte bei 16 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 14:33:56
Ein/Ausklappen

falls immer noch kein erfolg ein sehr gutes HOWTO findest du unter:

[1] http://hr.uoregon.edu/davidrl/samba.html/



Bewertung: 161 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Sonntag, 08. Februar 2004 14:56:00
Ein/Ausklappen

Hiho!

Das mit 'writeable' hat auch nicht geholfen. seufz

Die HOWTO kenn ich schon, die ist wirklich gut.

Was mir noch auffällt: Unter Win2k wird der User in der Liste der Profile mit

SERVERNAME\User

und nicht mit

DOMAINNAME\User

angezeigt... ich hab echt keine Ahnung, woran es liegt.

Trotzdem Danke!

Tschüß
Marcus


Bewertung: 157 Punkte bei 13 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 17:06:58
Ein/Ausklappen

hallo marcus

kannst du überhaupt von einem window client auf samba user share
mit schreibrechten zugreifen ?

probiere noch folgendes bitte:

unter [global]

netbios name = "dein-linux-machine-name"
workgroup = "dein-domain-name"
security = user
encrypt passwords = yes
log file = /var/log/samba.log
log level = 1
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
wins support = yes
domain logons = yes
logon home = \\frodo\%U
os level = 65
prefered master = yes
domain master = yes
local master = yes
logon path = \\frodo\profiles\%U
logon drive = L:
logon script = logon.cmd

und unter [profiles] zusätzlich
valid users = root @smbusers

einzutragen.

quck mal bitte auch im samba log und poste es.

gruss
christoph


Bewertung: 178 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Montag, 09. Februar 2004 19:20:33
Ein/Ausklappen

Hiho!

Ich kann wunderbar lesend und schreibend auf die Shares zugreifen, das Logon-Script wird auch abgearbeitet, das Home-Laufwerk wird gemappt. Soweit klappt alles.

Die Settings waren alle schon so gemacht, nur die "valid users" im "[profiles]" haben gefehlt, und seit dem ich die drin habe, sagt mir Win2k, daß es nicht auf das Profil zugreifen kann.

Das Log-File sagt (ohne die "valid users") folgendes: [2004/02/09 19:12:43, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1371) failed to decode PDU [2004/02/09 19:12:43, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605) process_request_pdu: failed to do schannel processing. [2004/02/09 19:12:55, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service profiles initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service tiggr initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service netlogon initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 0] rpc_server/srv_util.c:get_domain_user_groups(372) get_domain_user_groups: primary gid of user [tiggr] is not a Domain group ! get_domain_user_groups: You should fix it, NT doesn't like that [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service tiggr initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service daten initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service daten initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service zope3 initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service zope3 initially as user tiggr (uid=1000, gid=1000) (pid 742)

Mein komplettes "smb.conf" hab ich mal nach http://www.larp-welt.de/privat/smb.conf gestellt.

Ob das ganze eher ein Problem von meinem Win2k ist?

Bin gerade am überlegen, ob ich mir wegen der Pofiles weiter so Gedanken machen sollte, eigenlich brauch ich die ja eh nicht. Gehören aber irgendwie dazu, und ich wüßt schon gern, woran es liegen könnte!

Tschüß
Marcus


Bewertung: 120 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Montag, 09. Februar 2004 22:38:23
Ein/Ausklappen

hallo marcus

ich vermute dein samba config ist OK jetzt, was du aber noch ändern muss
sind win2k clients.
mach bitte folgendes:

1.) SP4 und updates installieren
2.) starte regedit und ändere bitte
"requiresignorseal"
"signsecurechannel"
dword attributes auf "0"
3.) starte gpedit.msc und enable 4 polices:
"Do not check for ownership of Roaming Profiles Folders"
"Add the Administrators security group to roaming users profiles"
"Wait for remote user profile"
"Delete cached copies of roaming profiles"
4.) wenn noch nicht gemacht, erfasse linux und samba user
5.) wenn du versuchst jetzt dein windows client einzuloggen,
fehlermeldung OK,
es wird kein profile auf dem PDC kreiert, sondern lokal auf dem client
6.) mache alle dateien sichtbar und kopiere das ganze default profile und alle
user profile ordner manuell
von windows client zu dem PDC profile ordner
7.) restarte die windows kiste und log ein als Administrator
8.) lösche auf dem windows das ganze lokale user profile
9.) restarte und log ein als user
das profile sollte vom PDC zum windows lokal kopiert werden
beim ausloggen sollte aber das profile auf dem PDC updatet werden
und lokal gelöscht werden.

gruss und viel erfolg
christoph


Bewertung: 166 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Montag, 16. Februar 2004 11:04:37
Ein/Ausklappen

Hallo,

ich habe ebenfalls das Problem, dass die Profiles nicht richtig gespeichert werden können. ( Meldung:"Datei \\server\profiles\root\xyz konnte nicht nach c:\abc gespeichert werden. Das Handle ist ungültig"

Bei mir Zuhause funktioniert es einwandfrei mit der gleichen Software+Betriebssysteme, In der Firma geht es nicht.

Die Rechte der Ordner habe ich alle auf 777 gesetzt. Daran kanns also nicht liegen. Die smb.conf ist genau die gleiche wie bei mir zuhause. Müsste also eigentlich funktionieren.

Hat jemand etwas herausgefunden ?

Gruß

Chrischn


Bewertung: 144 Punkte bei 11 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Donnerstag, 19. Februar 2004 13:33:54
Ein/Ausklappen

hallo Chrischn

dann probiere bitte eben so, wie ich beschrieben habe !
bei mir hat es nur so funktioniert.

gruss
christoph


Bewertung: 121 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Schnell Multi-Boot-Medien mit MultiCD erstellen
Schnell Multi-Boot-Medien mit MultiCD erstellen
Tim Schürmann, 24.06.2014 12:40, 0 Kommentare

Wer mehrere nützliche Live-Systeme auf eine DVD brennen möchte, kommt mit den Startmedienerstellern der Distributionen nicht besonders weit: Diese ...

Aktuelle Fragen

Videoüberwachung mit Zoneminder
Heinz Becker, 10.08.2014 17:57, 0 Antworten
Hallo, ich habe den ZONEMINDER erfolgreich installiert. Das Bild erscheint jedoch nicht,...
internes Wlan und USB-Wlan-Srick
Gerhard Blobner, 04.08.2014 15:20, 2 Antworten
Hallo Linux-Forum: ich bin ein neuer Linux-User (ca. 25 Jahre Windows) und bin von WIN 8 auf Mint...
Server antwortet mit falschem Namen
oin notna, 21.07.2014 19:13, 1 Antworten
Hallo liebe Community, Ich habe mit Apache einen Server aufgesetzt. Soweit, so gut. Im Heimnet...
o2 surfstick software für ubuntu?
daniel soltek, 15.07.2014 18:27, 1 Antworten
hallo zusammen, habe mir einen o2 surfstick huawei bestellt und gerade festgestellt, das der nic...
Öhm - wozu Benutzername, wenn man dann hier mit Klarnamen angezeigt wird?
Thomas Kallay, 03.07.2014 20:30, 1 Antworten
Hallo Team von Linux-Community, kleine Zwischenfrage: warum muß man beim Registrieren einen Us...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
Richard Kraut, 28.08.2014 18:25
Am Mittwoch, den 27.08.2014, 21:15 +0200 schrieb flecralf: > Linpus.... Es gab auch Red Flag Linux [1]....
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
"H.-Stefan Neumeyer", 28.08.2014 17:00
Am Donnerstag, 28. August 2014, 16:16:37 sprach Heiko Ißleib (und nicht Zarathustra): Hallo Heiko >...
Re: [EasyLinux-Suse] openSuse 12.3 - Installation von Drucker-Treibern
Bernhard Platz, 28.08.2014 16:26
Am Donnerstag, 28. August 2014, 16:03:46 schrieb H.-Stefan Neumeyer: > > So ein Satz ist dann - je n...
Re: [EasyLinux-Ubuntu] Flame Aktualisierung vs Neuinstallation
Heiko, 28.08.2014 16:16
Am Donnerstag, 28. August 2014, 15:49:43 schrieb H.-Stefan Neumeyer: > Am Donnerstag, 28. August 2014, 12:...
Re: [EasyLinux-Suse] openSuse 12.3 - Installation von Drucker-Treibern
"H.-Stefan Neumeyer", 28.08.2014 16:03
Am Donnerstag, 28. August 2014, 11:42:23 sprach Bernhard Platz (und nicht Zarathustra): Hallo Bernhard &...