Samba: Roaming Profiles tun nicht!

Anonymous User - Sonntag, 08. Februar 2004 11:09:41 - 8 Antworten



Hallo!

Ich versuche gerade verzweifelt auf meinem Debian (Sid) Samba (3.0.1) zum laufen zu bringen. Eigentlich tut es schon super gut, aber mit den Profiles hab ich noch Probleme.

Wenn ich mich mit meinem Win2k-Client anmelde, dann wird auch brav im profiles-share ein Verzeichnis mit dem Benzuternamen angelegt (hat user und Gruppe des Benutzer), dann ist aber Schluß, das Verzeichnis bleibt leer!

Es gibt keine Fehlermeldung!

Hier mal ein kurzer Ausschnitt der in meinen Augen wesentlichen Teilen aus meiner smb.conf:
   security = user
   domain master = yes
   preferred master = yes
   local master = yes
   domain logons = yes
   os level = 65

   logon path = \frodo\profiles\%U
   logon drive = L:
   logon script = logon.cmd

[profiles]
   path=/var/lib/samba/profiles
   admin users = root
   read only = no
   write able = yes
   create mask = 0600
   directory mask = 0700
   profile acls = yes
   browseable = no

Was mach ich nur falsch? Tschüß
   Marcus

Antworten
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 14:25:17
Ein/Ausklappen

hallo markus

auf ersten blick fällt mir auf,
dass "writeable" muss man zusammenschreiben, also

writeable = yes

gruss
christoph


Bewertung: 223 Punkte bei 58 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 14:33:56
Ein/Ausklappen

falls immer noch kein erfolg ein sehr gutes HOWTO findest du unter:

[1] http://hr.uoregon.edu/davidrl/samba.html/



Bewertung: 261 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Sonntag, 08. Februar 2004 14:56:00
Ein/Ausklappen

Hiho!

Das mit 'writeable' hat auch nicht geholfen. seufz

Die HOWTO kenn ich schon, die ist wirklich gut.

Was mir noch auffällt: Unter Win2k wird der User in der Liste der Profile mit

SERVERNAME\User

und nicht mit

DOMAINNAME\User

angezeigt... ich hab echt keine Ahnung, woran es liegt.

Trotzdem Danke!

Tschüß
Marcus


Bewertung: 256 Punkte bei 36 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Sonntag, 08. Februar 2004 17:06:58
Ein/Ausklappen

hallo marcus

kannst du überhaupt von einem window client auf samba user share
mit schreibrechten zugreifen ?

probiere noch folgendes bitte:

unter [global]

netbios name = "dein-linux-machine-name"
workgroup = "dein-domain-name"
security = user
encrypt passwords = yes
log file = /var/log/samba.log
log level = 1
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=8192 SO_SNDBUF=8192
wins support = yes
domain logons = yes
logon home = \\frodo\%U
os level = 65
prefered master = yes
domain master = yes
local master = yes
logon path = \\frodo\profiles\%U
logon drive = L:
logon script = logon.cmd

und unter [profiles] zusätzlich
valid users = root @smbusers

einzutragen.

quck mal bitte auch im samba log und poste es.

gruss
christoph


Bewertung: 290 Punkte bei 42 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Montag, 09. Februar 2004 19:20:33
Ein/Ausklappen

Hiho!

Ich kann wunderbar lesend und schreibend auf die Shares zugreifen, das Logon-Script wird auch abgearbeitet, das Home-Laufwerk wird gemappt. Soweit klappt alles.

Die Settings waren alle schon so gemacht, nur die "valid users" im "[profiles]" haben gefehlt, und seit dem ich die drin habe, sagt mir Win2k, daß es nicht auf das Profil zugreifen kann.

Das Log-File sagt (ohne die "valid users") folgendes: [2004/02/09 19:12:43, 0] rpc_server/srv_pipe.c:api_pipe_netsec_process(1371) failed to decode PDU [2004/02/09 19:12:43, 0] rpc_server/srv_pipe_hnd.c:process_request_pdu(605) process_request_pdu: failed to do schannel processing. [2004/02/09 19:12:55, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service profiles initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service tiggr initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service netlogon initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:12:58, 0] rpc_server/srv_util.c:get_domain_user_groups(372) get_domain_user_groups: primary gid of user [tiggr] is not a Domain group ! get_domain_user_groups: You should fix it, NT doesn't like that [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service tiggr initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service daten initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service daten initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service zope3 initially as user tiggr (uid=1000, gid=1000) (pid 742) [2004/02/09 19:13:01, 1] smbd/service.c:make_connection_snum(705) gandalf (192.168.1.240) connect to service zope3 initially as user tiggr (uid=1000, gid=1000) (pid 742)

Mein komplettes "smb.conf" hab ich mal nach http://www.larp-welt.de/privat/smb.conf gestellt.

Ob das ganze eher ein Problem von meinem Win2k ist?

Bin gerade am überlegen, ob ich mir wegen der Pofiles weiter so Gedanken machen sollte, eigenlich brauch ich die ja eh nicht. Gehören aber irgendwie dazu, und ich wüßt schon gern, woran es liegen könnte!

Tschüß
Marcus


Bewertung: 182 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Montag, 09. Februar 2004 22:38:23
Ein/Ausklappen

hallo marcus

ich vermute dein samba config ist OK jetzt, was du aber noch ändern muss
sind win2k clients.
mach bitte folgendes:

1.) SP4 und updates installieren
2.) starte regedit und ändere bitte
"requiresignorseal"
"signsecurechannel"
dword attributes auf "0"
3.) starte gpedit.msc und enable 4 polices:
"Do not check for ownership of Roaming Profiles Folders"
"Add the Administrators security group to roaming users profiles"
"Wait for remote user profile"
"Delete cached copies of roaming profiles"
4.) wenn noch nicht gemacht, erfasse linux und samba user
5.) wenn du versuchst jetzt dein windows client einzuloggen,
fehlermeldung OK,
es wird kein profile auf dem PDC kreiert, sondern lokal auf dem client
6.) mache alle dateien sichtbar und kopiere das ganze default profile und alle
user profile ordner manuell
von windows client zu dem PDC profile ordner
7.) restarte die windows kiste und log ein als Administrator
8.) lösche auf dem windows das ganze lokale user profile
9.) restarte und log ein als user
das profile sollte vom PDC zum windows lokal kopiert werden
beim ausloggen sollte aber das profile auf dem PDC updatet werden
und lokal gelöscht werden.

gruss und viel erfolg
christoph


Bewertung: 249 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
(unangemeldet), Montag, 16. Februar 2004 11:04:37
Ein/Ausklappen

Hallo,

ich habe ebenfalls das Problem, dass die Profiles nicht richtig gespeichert werden können. ( Meldung:"Datei \\server\profiles\root\xyz konnte nicht nach c:\abc gespeichert werden. Das Handle ist ungültig"

Bei mir Zuhause funktioniert es einwandfrei mit der gleichen Software+Betriebssysteme, In der Firma geht es nicht.

Die Rechte der Ordner habe ich alle auf 777 gesetzt. Daran kanns also nicht liegen. Die smb.conf ist genau die gleiche wie bei mir zuhause. Müsste also eigentlich funktionieren.

Hat jemand etwas herausgefunden ?

Gruß

Chrischn


Bewertung: 257 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Samba: Roaming Profiles tun nicht!
Christoph , Donnerstag, 19. Februar 2004 13:33:54
Ein/Ausklappen

hallo Chrischn

dann probiere bitte eben so, wie ich beschrieben habe !
bei mir hat es nur so funktioniert.

gruss
christoph


Bewertung: 203 Punkte bei 41 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Tanzschule
    Wer parallel Windows 7 und Linux in einem Netz einsetzt, möchte meist allen Nutzern Daten zentral zur Verfügung stellen. Mit Samba ist das kein Problem.
  • Mit Samba ein kleines Netz einrichten
    Wer zu Hause ein Netzwerk mit heterogenen Clients betreibt, wünscht sich zentrale Dienste zum einfachen Zugriff auf Dateien und Peripheriegeräte. Samba bietet in diesem Fall genau das Richtige, und zudem lässt sich die Lösung mit allen gängigen Distributionen aufsetzen.
  • Windows 8 und Linux im Netz
    Der Datenaustausch via LAN zwischen Windows 8 und Linux lässt sich mit wenigen Handgriffen einrichten. Dabei gilt es jedoch die ein oder andere Stolperstelle zu vermeiden.
  • Nächste Alpha-Version von Samba 4
  • Erstmals auf Squeeze-Basis

    Skolelinux, die Debian-Ausgabe für Schulen und weitere Bildungseinrichtungen, ist in Version 6.0.4 erhältlich.

Aktuelle Fragen

Mit Firewire Videos improtieren?
Werner Hahn, 09.06.2016 11:06, 5 Antworten
Ich besitze den Camcorder Panasonic NV-GS330, bei dem die Videos in guter Qualität nur über den 4...
lidl internetstick für linux mint
rolf meyer, 04.06.2016 14:17, 3 Antworten
hallo zusammen ich benötige eure hilfe habe einen lidl-internetstick möchte ihn auf linux mint i...
thema ändern
a b, 29.05.2016 16:34, 0 Antworten
Hallo Linuxer zuerst alle eine schönen Sonntag, bevor ich meine Frage stelle. Ich habe Ubuntu 1...
Ideenwettbewerb
G.-P. Möller, 28.05.2016 10:57, 0 Antworten
Liebe User, im Rahmen eines großen Forschungsprojekts am Lehrstuhl für Technologie- und Innova...
Welche Drucker sind Linux-mint kompatibel?
Johannes Nacke, 20.05.2016 07:32, 6 Antworten
Hallo Ihr Lieben, ich bitte um mitteilung welche Drucker Kompatibel sind mit Linux-Mint. LG Joh...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] [OT] AMUSEMENT: KLIRREN DIESEN LINK... Fw: FEDEX DELIEVERY
Rainer, 30.06.2016 19:25
Am Thu, 30 Jun 2016 18:53:14 +0200 schrieb Alexander McLean : > > Einige, die sich erst kürzlich h...
Re: [EasyLinux-Ubuntu] [OT] AMUSEMENT: KLIRREN DIESEN LINK... Fw: FEDEX DELIEVERY
Alexander McLean, 30.06.2016 18:53
Am Donnerstag, den 30.06.2016, 18:24 +0200 schrieb Rainer: Ich mache TOFU, weil es mir die Zeit zu kanpp ist...
Re: [EasyLinux-Ubuntu] [OT] AMUSEMENT: KLIRREN DIESEN LINK... Fw: FEDEX DELIEVERY
Rainer, 30.06.2016 18:24
Am Thu, 30 Jun 2016 17:01:48 +0200 schrieb Alexander McLean : > > Auf der Liste von Easy-Linux Sus...
Re: [EasyLinux-Ubuntu] [OT] AMUSEMENT: KLIRREN DIESEN LINK... Fw: FEDEX DELIEVERY
Gerhard Blaschke, 30.06.2016 17:31
Danke Am 30.06.2016 um 17:01 schrieb Alexander McLean: > Am Donnerstag, den 30.06.2016, 09:41 +0200 schr...
Re: [EasyLinux-Ubuntu] [OT] AMUSEMENT: KLIRREN DIESEN LINK... Fw: FEDEX DELIEVERY
Alexander McLean, 30.06.2016 17:01
Am Donnerstag, den 30.06.2016, 09:41 +0200 schrieb Rainer: > Am Thu, 30 Jun 2016 09:14:00 +0200 > sch...