SDL-Anwendungen im Vollbildmodus dunkel

Autor

Samstag, 12. Juli 2008 04:44:27

Ich habe gerade auf einem Macbook erster Generation SuSE 11 mit KDE4-Desktop und Realtime-Kernel installiert. Starte ich ein SDL-basiertes Spiel im Vollbildmodus, so sieht man nur schwarz, hört aber den Ton. Im Fenster laufen die Spiele einwandfrei.
Bei Videos gibt es mit allen Playern ähnliche Probleme. Als Ausgabemedium taugt nur OpenGL. Ist XV oder Sonstiges eingestellt, crashen zumindest Kaffeine und VLC beim Versuch, das Video zu starten. Im OpenGL-Modus findet dennoch ebenfalls keine Vollbildausgabe statt, sondern überblendet einen zugewiesenen Teil des Desktops.

Hat jemand eine Idee, wie dieses Phänomen zustande kommt? Kaffeine behauptet, die CPU kommt nicht mit, die Frames zu verarbeiten (absurd), die SDL-Anwendungen schreiben nichts ins Log.

GoaSkin

0 Antworten


Antworten

Ähnliche Artikel

  • Digitales Entertainment
    Fürs digitale Fernsehen bieten verschiedene Linux-Anwendungen ihre Dienste an; ein komfortables Tool, das die Programme auch aufzeichnen kann und zudem ein kompletter Multimedia-Player ist, ist KDEs Kaffeine.
  • Multimedia ohne Ende mit Sabayon 5.4 Gnome
    Mit Italien verbinden viele Menschen die Toskana, das Kolosseum und Pizza. Weniger bekannt ist die Multimedia-Distribution Sabayon – zu unrecht.
  • Ubuntus Fenster bekommen Indikatoren
    Als Argument für die verschobenen Fensterknöpfchen von Ubuntu 10.04 führte Ubuntu-Gründer Mark Shuttleworth neulich an, man habe für diesen Platz noch andere Pläne. Die konkretisierte er nun in einem Blogeintrag.
  • Der Fernseher – unbekannte Breiten
    HDTV-fähige Fernseher sind inzwischen erschwinglich und bieten in Verbindung mit einem Computer bisher ungeahnte multimediale Möglichkeiten. Wir zeigen, wie Sie Linux und HDTV zusammenbringen.
  • Den Sternenhimmel erkunden mit Stellarium
    Was nachts am Himmel funkelt, bleibt oft hinter Wolken verborgen. Stellarium sorgt für klare Sicht und liefert obendrein viele astronomische Informationen.

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 0 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] [Jessie] DVBcut - Navigation in Aufnahme
Wolfgang Völker, 30.03.2015 12:28
Hallo Stefan, Heinz-Stefan Neumeyer schrieb am 30.03.2015: >Hallo an alle Mitlesser > >ME-TV 1...
[EasyLinux-Ubuntu] [Jessie] DVBcut - Navigation in Aufnahme
Heinz-Stefan Neumeyer, 30.03.2015 10:16
Hallo an alle Mitlesser ME-TV 1.3.7 DVBcut 0.5.4 Ich habe hier einen per me-tv gemachten Mitschnitt einer...
Re: [EasyLinux-Ubuntu] Gforce 7650 GS
Heinz-Stefan Neumeyer, 30.03.2015 10:04
Am Montag, den 30.03.2015, 09:57 +0200 schrieb Heinz-Stefan Neumeyer: > Am Sonntag, den 29.03.2015, 18:44...
Re: [EasyLinux-Ubuntu] Gforce 7650 GS
Heinz-Stefan Neumeyer, 30.03.2015 09:57
Am Sonntag, den 29.03.2015, 18:44 +0200 schrieb Gerhard Blaschke: Moin > > Hat jemand noch eine Id...
[EasyLinux-Suse] GRUB::error: file '/boot/grub2/i386-pc/crypto.mod' not found
Achim Pabel, 30.03.2015 07:50
Hallo Christoph, ist das o.k. für Dich wenn Du einen neuen Thread für Dein neues Problem erstellst? Viel...