Problem mit Sound unter Debian Sarge

Autor

Sonntag, 30. Oktober 2005 01:40:21

Hallo Linux-Wissende,

nach dem grafischen Login als normaler User an meinem frisch installierten
Debian-Sarge-System erscheint die Meldung:

sound server informational message:
Error while initializing the sound driver:
device/dev/dsp can't be opened (permission denied)
The sound server will continue, using the null output device

(Die installierte Soundkarte ist eine ganz normale PCI-Soundblaster-Karte)
Startet man z.B. unter KDE das Programm KsCD, läuft es munter los, aber
wie nach der Meldung zu erwarten, ist nichts zu hören.

Wie im Online-debiananwenderhandbuch unter Sound beschrieben habe ich in
einer Konsole als root modprobe sb eingegeben und KsCD erneut gestartet.
Und siehe da . . . die Musi spielt!

Melde ich mich unter einem anderen Account am System an, oder starte das
System neu, kommt dieselbe Sound-Fehlermeldung wieder . . .

Als Newbie interpretiere ich das so:

Hardware-Erkennung bei der Installation grundsätzlich ok.
Richtiger Sound-Server wird vom System gestartet.
Aber dem Sound-Server wird der Zugriff auf das device dsp verweigert.
Deshalb schickt er alles anstatt an dsp in den Daten-Orcus
Als root habe ich mit modprobe das Problem nicht.
Nach Eingabe von modprobe bleibt der Zugriff (und die Musi) aber auch dem
jeweils angemeldeten User erhalten?!

So sehen die Rechte für das Device dsp aus:

/dev# ls -la dsp
crw-rw---- 1 root audio 14, 3 2005-02-26 07:39 dsp

in etc/group steht für audio:

audio:x:29omglaf

Müsste doch bedeuten, daß zumindest der Benutzer olaf als Mitglied der
Gruppe audio dauerhaft auch Zugriff auf dsp (und damit auf die Musi) hat?
Vielleicht hab ich da auch eine kleine Denkblockade?

Jedenfalls möchte ich nicht ohne größere Not an den Rechten rumfummeln.
Was kann ich tun, daß trotzdem alle Benutzer des Systems in den Genuss von
Geräuschen und Musi happy über die Soundkarte kommen?

Grüsse

Olaf

Olaf Böttcher

9 Antworten


Antworten
Re: Problem mit Sound unter Debian Sarge
Markus Schwaab, Montag, 07. November 2005 17:00:31
Ein/Ausklappen

Hi,
ok, das Problem scheint ja jetzt gelöst. Das generelle Werkzeug der Wahl um solche Probleme zu beheben ist eigentlich "alsaconf".
Einfach als root-user anmelden und "alsaconf" eintippen. Was dann kommt ist -dank Ncursesoberfläche- selbsterklärend.
Alsaconf hat eine autodetection was den vorteil mit sich bringt, dass man seine Soundkarte nicht unbedingt kennen muss.
Und es unterstützt auch noch ganz alte (ISA)Karten aus den OSS-Treibern. Mein Rechner hier hat z.B. noch ne alte CS4236-ISAKarte die von alsaconf erkannt und konfiguriert wird.

Viele Grüße

Markus


Bewertung: 81 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Problem mit Sound unter Debian Sarge
Anonymous Anonymous, Montag, 31. Oktober 2005 11:19:36
Ein/Ausklappen

Ich denke dein Problem ist, dass das 'modprobe sb' nicht beim hochfahren ausgeführt wird!

Einfach sb in die /etc/modules eintragen, dann müsste es funzen!

Gruß Cornell


Bewertung: 126 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Problem mit Sound unter Debian Sarge
Ugglan , Montag, 31. Oktober 2005 18:03:11
Ein/Ausklappen

> Einfach sb in die /etc/modules eintragen, dann müsste es funzen!

Mal eine Frage von jemandem, der dieses Problem auch hatte: Wie genau sieht denn dieser einfache Eintrag aus? Die Syntax der /etc/modules entzieht sich meinem Verständnis. In meiner stehen eigentlich nur Abhängigkeiten drin; ob und welche Module mit welchem Befehl jetzt explizit geladen werden, konnte ich nicht herausfinden. Oder steht das in einer anderen Datei?

BTW: Da Gnome mit OSS nicht kann, mußte ich ALSA installieren. alsaconf brachte die Karte auch zum laufen, aber um nach dem nächsten Reboot nicht wieder neu konfigurieren zu müssen, war noch ein exotischer Befehl von Alsa nötig; den habe ich aber jetzt leider nicht zur Hand.

Ugglan


Bewertung: 135 Punkte bei 15 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Problem mit Sound unter Debian Sarge
Olaf Böttcher, Dienstag, 01. November 2005 19:18:05
Ein/Ausklappen

Hallo Ugglan

bei mir steht nichts geheimnisvolles drin in der Datei.
Allerdings hab ich auch "nur" die ganz simple Soundblaster-Karte.
Für die musste ich außer dem Eintrag sb keine weiteren Klimmzüge machen:

# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

ide-cd
ide-detect
ide-disk
psmouse
sb

Dass iss alles!

Gruß

Olaf


Bewertung: 87 Punkte bei 16 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Problem mit Sound unter Debian Sarge
Ugglan , Mittwoch, 02. November 2005 15:44:39
Ein/Ausklappen

Danke, jetzt weiß ich wenigstens, wie man ein Modul "verankert", wenn die Konfiguration das nicht selber macht.

Gruß,

Ugglan


Bewertung: 51 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Problem mit Sound unter Debian Sarge
Olaf Böttcher, Dienstag, 01. November 2005 18:58:21
Ein/Ausklappen

Hallo Cornell,

Du hattest recht.
In der Datei /etc/modules weit und breit kein Eintrag zur Soundkarte.
sb hinzugefügt, es funzt . . . und die Musi spielt!

Danke und Grüße

Olaf


Bewertung: 53 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Problem mit Sound unter Debian Sarge
Olaf Böttcher, Dienstag, 01. November 2005 19:11:26
Ein/Ausklappen

Hallo Cornell,

Du hattest recht.
In der Datei /etc/modules weit und breit kein Eintrag zur Soundkarte.
sb hinzugefügt, es funzt . . . und die Musi spielt!

Danke und Grüße

Olaf



Bewertung: 213 Punkte bei 19 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Problem mit Sound unter Debian Sarge
Stephan Sonntag, Sonntag, 30. Oktober 2005 10:17:22
Ein/Ausklappen

Ich kenne 2 Methoden um die Zugriffsrechte neu zu setzen.

1. mit adduser Benutzer audio den Benutzer in die Gruppe audio aufnehmen, was ja bei deinem Benutzer olaf ja anscheinend nicht klappt.

2. Die Rechte in /dev neu setzen, was man allerdings aus Sicherheitsgründen nur machen sollte wenn man keine andere Option mehr hat.

Welche Devices es waren weis ich nicht mehr ganz genau, deshalb solltest du lieber noch mal im Handbuch oder Internet nachsehen

Ich meine

chmod 0666 /dev/mixer
chmod -R 0666 /dev/snd (-R weil es ein Ordner ist)
chmod 0666 /dev/sndstat

Wie schon gesagt diese Methode kann so Sicherheitsproblemen führen, weil jeder Benutzer in der Lage ist die Devices zu löschen.


Bewertung: 85 Punkte bei 18 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Problem mit Sound unter Debian Sarge
Olaf Böttcher, Dienstag, 01. November 2005 19:08:46
Ein/Ausklappen

Hallo Stephan,

die Meldung "permission denied" hat anscheinend etwas auf die falsche Fährte
gelockt. Ich wollte eben genau die Probleme mit Sicherheitslöchern umgehen. Da
war der Tip von Cornell genau der Richtige.
Trotzdem Dank, daß Du Dich auf mein Problem eingelassen hast.

Gruß

Olaf


Bewertung: 98 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Sound-Systeme unter Linux
    Um Linux optimale Töne zu entlocken, müssen eine ganze Reihe von Software-Komponenten zusammenspielen. Wir zeigen, welche.
  • Drei USB-Soundkarten im Test
    Immer mehr Notebooks bringen einen Breitbildschirm im Format 16:9 mit, der zum Anschauen von DVD-Filmen geradezu verlockt. Was fehlt, ist hingegen der Support für satten 5.1 Surround-Sound. Den bieten USB-Soundkarten.
  • 1.0 erschienen
    Gestern veröffentlichten die Entwickler von Rosegarden-4 die erste stabile Version des beliebten Allround-Musik-Programms. Rosegarden ist eins der weitest entwickelten Musikwerkzeuge unter Linux und auch im professionellen Umfeld für viele Musiker das Werkzeug der Wahl.
  • Pulseaudio: Neue Version und Support für KDE 4.4
    In KDE 4.4 unterstützt Phonon auch Pulseaudio. Nutzer von Ubuntu 9.10 können per PPA eine neue Version des Sound-Servers einspielen.
  • Pulseaudio wird 1.0
    Der freie Soundserver Pulseaudio hat die Versionsnummer 1.0 genommen.

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 0 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Nach Ubdates alles weg ...
Maria Hänel, 15.11.2014 17:23, 4 Antworten
Ich brauche dringen eure Hilfe . Ich habe am wochenende ein paar Ubdates durch mein Notebook von...
Brother Drucker MFC-7420
helmut berger, 11.11.2014 12:40, 1 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu 14.04-Nutzer...
Treiber für Drucker brother MFC-7420
helmut berger, 10.11.2014 16:05, 2 Antworten
Hallo, ich habe einen Drucker, brother MFC-7420. Bin erst seit einigen Tagen ubuntu12.14-Nutzer u...
Can't find X includes.
Roland Welcker, 05.11.2014 14:39, 1 Antworten
Diese Meldung erhalte ich beim Versuch, kdar zu installieren. OpenSuse 12.3. Gruß an alle Linuxf...
DVDs über einen geeigneten DLNA-Server schauen
GoaSkin , 03.11.2014 17:19, 0 Antworten
Mein DVD-Player wird fast nie genutzt. Darum möchte ich ihn eigentlich gerne abbauen. Dennoch wür...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Trojanerbefall
Maik Lehmberg, 27.11.2014 06:31
Am 26.11.2014 um 17:21 h schrieb Joachim Puttkammer: > diese CD sagt mir zu, > nur dauert es etwas, b...
Re: [EasyLinux-Ubuntu] Mint17 auf einem Stick
Alfred Zahlten, 27.11.2014 00:04
Am 26.11.2014 um 23:28 schrieb Nguyen Dong Loan: > Am Mittwoch, 26. November 2014, 00:33:58 schrieb Alfred...
Re: [EasyLinux-Ubuntu] Mint17 auf einem Stick
Nguyen Dong Loan, 26.11.2014 23:28
Am Mittwoch, 26. November 2014, 00:33:58 schrieb Alfred Zahlten: Wenn ich fragen darf, was soll das jetzt so...
Re: [EasyLinux-Suse] OS_13.2_mate_caja_multiple_Instanzen_(hier_erstmal_gelöst)
"H.-Stefan Neumeyer", 26.11.2014 21:18
Am Mittwoch, 26. November 2014, 19:24:06 schrieb Heiko Ißleib: Hallo Heiko > > Klar.;-) >...
Re: [EasyLinux-Suse] OS_13.2_mate_caja_multiple_Instanzen_(hier_erstmal_gelöst)
Heiko, 26.11.2014 19:24
Am Mittwoch, 26. November 2014, 16:31:56 schrieb Mahmud Al-Ahmed: Hallo Mahmud. > On Wed, 26 Nov 2014 12...