Problem beim ReadyNas 102 (Netgear) „aufbohren“ (ssh)

Autor

Montag, 02. Dezember 2013 19:42:04

Hallo Gemeinde,

in der Diskussion zu meiner letzten Frage hat „Teetris“ mir sehr geholfen und mich inspiriert, meine ReadyNAS 102 sagen wir „aufzubohren“.

Sorry, aber ich glaube, dass ich etwas weiter ausholen muss.

Mein Ur-Anliegen war es, den mysql-Dienst auf dem NAS für das Heimnetz (ODBC o.ä.) verfügbar zu machen. Meine erste Aktion war es demnach in der /etc/mysql/my.cnf des NAS die Zeile „skip-external-locking“ auszukommentieren.

Dann habe ich noch die /etc/hosts.deny:

ALL: ALL

und die /etc/hosts.allow

nmbd: 192.168.178.
smbd: 192.168.178.
mysqld: 192.168.178.
….

geändert.

Ich denke, bis hierher hat das NAS-System alles geschluckt.

Ach ja, ich hatte dafür in der smb.conf des NAS /etc freigegeben, weil „vi“ nun mal nicht mein Ding ist … und die files mit gedit bearbeitet..

Dummerweise hatte ich dann noch die Idee, die /etc/hosts zu manipulieren, obwohl meine Fritzbox doch als DNS-Server sehr gut fungiert. Dort (Box) habe ich für alle Maschinen den Haken hinter … stets mit derselben IP … für alle gesetzt ..

Ich schrieb die Win- und Linux-PCs in die hosts und auch das NAS selbst (!!!???).

(Die Gurus mögen schmunzeln  - loopback ausgehebelt?)

Das muss den ssh-Server auf dem NAS durcheinandergebracht haben.
… Identität hat sich geändert .. und ab diesem Augenblick hatte und habe ich von dieser Linux –Maschine (Debian 7.2 Wheezy) keinen ssh-Zugriff mehr auf das NAS.

Ich habe die /root/.ssh/known_hosts auf der Linux-Maschine (nicht dem NAS) gelöscht (x-mal) … und vermutete das Problem auf dem NAS, habe dessen HDDs ausgebaut, an einer anderen Maschine mit gparted platt gemacht, wieder in das NAS gesteckt und von CD neu installiert, weil ein Rücksetzen auf Werksstatus per Knopfdruck keinen Erfolg brachte.

Nun läuft das NAS wieder, habe ssh wieder aktiviert und von meinen WinPCs kann ich per ssh zugreifen, mit dem noch vorhandenen Debian-Lenovo (auch Deb 7.2) auch, nur mit der Linux-Kiste, von der aus ich zuerst per ssh auf dem NAS herum gerührt habe: egal was ich tue: Permission denied…

Habe auch per usermod dem „admin“ und dem noch eingerichteten user auf dem NAS eine bash zugeordnet, aber auch „ssh egalwer@RDN AS-4000 „cmd“ führt nur zur Zugriffsverweigerung.

Ich komme zu dem Schluss, dass das ssh-Problem nicht auf dem NAS sondern auf der Linux-Maschine zu finden sein muss, mit der ich zuerst das NAS per ssh bearbeitet/kontaktiert habe.

Nur WAS & WO ???

Ich bin absolut ahnungslos.

Hat wer eine Idee??

Beste Grüße

Grundi

Gerd Grundmann

3 Antworten


Antworten
RTFM :-)
Teetris (unangemeldet), Montag, 02. Dezember 2013 21:14:57
Ein/Ausklappen

Moin!

Man pages helfen ;-)
Was wirft denn folgendes aus: ssh -vvv <user>@<deine nas>



Bewertung: 50 Punkte bei 43 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: RTFM :-)
Gerd Grundmann, Montag, 02. Dezember 2013 21:50:43
Ein/Ausklappen

hallo Teetris,,
ja eben nix von der einen Linux-Maschine, weil das NAS von dieser keine ssh-Kontakte mehr akzeptiert - habe die aber eben platt gemacht - und Neuinstall auf ssd vor habe, Umzug per rsync und so würde wohl nicht weniger Zeit benötigen

Ich glaube, ich habe das NAS schon wieder zerschossen,
keine Reaktion auf Ping oder Web-Frontend.

nur die Partitionierung während der Installation von Debian lässt aus meiner Sicht gegenüber Suse sehr zu wünschen übrig, oder ich sehe mal wieder den Wald vor Bäumen nicht..

Gruß + Dank







Bewertung: 100 Punkte bei 14 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: RTFM :-)
Gerd Grundmann, Montag, 09. Dezember 2013 12:52:26
Ein/Ausklappen

Es läuft wieder alles, auch ssh von jeder zu jeder Maschine.
Woran's gelegen hat, wird für mich auf ewig ein Geheimnis bleiben.

Just schlage ich mich mit Samba herum. Obwohl ich Sambe seit ca. 10 Jahren auf div. PC laufen hatte/habe, gibt es immer wieder neue Probleme.


mfg


Bewertung: 28 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Zu wenig Speicherplatz auf /boot unter MATE
Patrick Obenauer, 25.05.2015 14:28, 1 Antworten
Hallo zusammen, ich habe Ubuntu 14.10 mit MATE 1.8.2 (3.16-37) mit Standardeinstellungen aufgese...
Konsole / Terminal in Linux Mint 17.1 deutsch
Dirk Resag, 09.05.2015 23:39, 12 Antworten
Hallo an die Community, ich habe vor kurzem ein älteres Notebook, Amilo A1650G, 1GB Arbeitsspe...
Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Durcheinander mit 32/64-Bit
Matthias Müller, 27.05.2015 23:10
Hallo, Am Dienstag, 26. Mai 2015 schrieb Gerhard Blaschke: snip > > "dpkg --add-architecture i...
Re: [EasyLinux-Suse] Yast
Heiko, 27.05.2015 23:07
Am Mittwoch, 27. Mai 2015, 22:58:58 schrieb Daniel Hegenbarth: > Das kann ich nicht alles ab tippen (Smart...
Re: [EasyLinux-Suse] Yast
Daniel Hegenbarth, 27.05.2015 22:58
Das kann ich nicht alles ab tippen (Smartphone). Es endet aber mit Medienquelle 'http://download.opensuse.o...
Re: [EasyLinux-Suse] Yast
Heiko, 27.05.2015 22:34
Am Mittwoch, 27. Mai 2015, 22:05:43 schrieb Daniel Hegenbarth: Hallo Daniel. > Ich tippen es vom Bildsch...
Re: [EasyLinux-Suse] Yast
Daniel Hegenbarth, 27.05.2015 22:05
Ich tippen es vom Bildschirm ab linux-l4nv:/home/daniel # zypper in yast2 Daten des Repositories laden......