Problem beim ReadyNas 102 (Netgear) „aufbohren“ (ssh)

Gerd Grundmann - Montag, 02. Dezember 2013 19:42:04 - 3 Antworten

Hallo Gemeinde,

in der Diskussion zu meiner letzten Frage hat „Teetris“ mir sehr geholfen und mich inspiriert, meine ReadyNAS 102 sagen wir „aufzubohren“.

Sorry, aber ich glaube, dass ich etwas weiter ausholen muss.

Mein Ur-Anliegen war es, den mysql-Dienst auf dem NAS für das Heimnetz (ODBC o.ä.) verfügbar zu machen. Meine erste Aktion war es demnach in der /etc/mysql/my.cnf des NAS die Zeile „skip-external-locking“ auszukommentieren.

Dann habe ich noch die /etc/hosts.deny:

ALL: ALL

und die /etc/hosts.allow

nmbd: 192.168.178.
smbd: 192.168.178.
mysqld: 192.168.178.
….

geändert.

Ich denke, bis hierher hat das NAS-System alles geschluckt.

Ach ja, ich hatte dafür in der smb.conf des NAS /etc freigegeben, weil „vi“ nun mal nicht mein Ding ist … und die files mit gedit bearbeitet..

Dummerweise hatte ich dann noch die Idee, die /etc/hosts zu manipulieren, obwohl meine Fritzbox doch als DNS-Server sehr gut fungiert. Dort (Box) habe ich für alle Maschinen den Haken hinter … stets mit derselben IP … für alle gesetzt ..

Ich schrieb die Win- und Linux-PCs in die hosts und auch das NAS selbst (!!!???).

(Die Gurus mögen schmunzeln  - loopback ausgehebelt?)

Das muss den ssh-Server auf dem NAS durcheinandergebracht haben.
… Identität hat sich geändert .. und ab diesem Augenblick hatte und habe ich von dieser Linux –Maschine (Debian 7.2 Wheezy) keinen ssh-Zugriff mehr auf das NAS.

Ich habe die /root/.ssh/known_hosts auf der Linux-Maschine (nicht dem NAS) gelöscht (x-mal) … und vermutete das Problem auf dem NAS, habe dessen HDDs ausgebaut, an einer anderen Maschine mit gparted platt gemacht, wieder in das NAS gesteckt und von CD neu installiert, weil ein Rücksetzen auf Werksstatus per Knopfdruck keinen Erfolg brachte.

Nun läuft das NAS wieder, habe ssh wieder aktiviert und von meinen WinPCs kann ich per ssh zugreifen, mit dem noch vorhandenen Debian-Lenovo (auch Deb 7.2) auch, nur mit der Linux-Kiste, von der aus ich zuerst per ssh auf dem NAS herum gerührt habe: egal was ich tue: Permission denied…

Habe auch per usermod dem „admin“ und dem noch eingerichteten user auf dem NAS eine bash zugeordnet, aber auch „ssh egalwer@RDN AS-4000 „cmd“ führt nur zur Zugriffsverweigerung.

Ich komme zu dem Schluss, dass das ssh-Problem nicht auf dem NAS sondern auf der Linux-Maschine zu finden sein muss, mit der ich zuerst das NAS per ssh bearbeitet/kontaktiert habe.

Nur WAS & WO ???

Ich bin absolut ahnungslos.

Hat wer eine Idee??

Beste Grüße

Grundi

Antworten
RTFM :-)
Teetris (unangemeldet), Montag, 02. Dezember 2013 21:14:57
Ein/Ausklappen

Moin!

Man pages helfen ;-)
Was wirft denn folgendes aus: ssh -vvv <user>@<deine nas>



Bewertung: 100 Punkte bei 143 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: RTFM :-)
Gerd Grundmann, Montag, 02. Dezember 2013 21:50:43
Ein/Ausklappen

hallo Teetris,,
ja eben nix von der einen Linux-Maschine, weil das NAS von dieser keine ssh-Kontakte mehr akzeptiert - habe die aber eben platt gemacht - und Neuinstall auf ssd vor habe, Umzug per rsync und so würde wohl nicht weniger Zeit benötigen

Ich glaube, ich habe das NAS schon wieder zerschossen,
keine Reaktion auf Ping oder Web-Frontend.

nur die Partitionierung während der Installation von Debian lässt aus meiner Sicht gegenüber Suse sehr zu wünschen übrig, oder ich sehe mal wieder den Wald vor Bäumen nicht..

Gruß + Dank







Bewertung: 108 Punkte bei 113 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: RTFM :-)
Gerd Grundmann, Montag, 09. Dezember 2013 12:52:26
Ein/Ausklappen

Es läuft wieder alles, auch ssh von jeder zu jeder Maschine.
Woran's gelegen hat, wird für mich auf ewig ein Geheimnis bleiben.

Just schlage ich mich mit Samba herum. Obwohl ich Sambe seit ca. 10 Jahren auf div. PC laufen hatte/habe, gibt es immer wieder neue Probleme.


mfg


Bewertung: 88 Punkte bei 140 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Samba-Server für Win-Daten & Linux-Dateirechte
Gerd Grundmann, 12.01.2017 18:25, 0 Antworten
Hallo Gemeinde, ich habe ewig gegooo.. aber nicht wirklich gefunden, was ich suche. Auf mei...
LM Cinnamon 18.1Serena 64 bit
Herwig Ameisbichler, 11.01.2017 13:02, 6 Antworten
Hallo an alle. Bin Linux Neuling.Habe auf meiner SSD neben W10 (finde ich nicht mehr)LM17.2 auch...
Bilder in E-Mail einbinden?
Werner Hahn, 23.12.2016 12:18, 4 Antworten
Dell Latitude E6510, Ubuntu 16.04, Mozilla Firefox Ich bitte um eine leicht verständliche Anle...
Linux Mint 17.2
Herwig Ameisbichler, 17.12.2016 11:19, 4 Antworten
Wer kann mir helfen? Hab seit gestern Linux am Pc.Wie kann ich diese Miniaturschrift im Menü,Lei...
Linux 17.2 Treiber f. PC Drucker installieren
Ernst Malitzki, 11.12.2016 13:04, 7 Antworten
Habe einen PC Drucker von HP. Möchte diesen PC Drucker an meinen PC anschließen. Hierzu benötige...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] adobe_flash_player_für_android
Wolfgang Voelker, 19.01.2017 18:34
Hallo Hartmut, daß du im Playstore dazu was findest, liegt daran, daß es Flash ja mal bis Android Gingerbread...
Re: [EasyLinux-Ubuntu] adobe_flash_player_für_android
Hartmut Haase, 19.01.2017 16:23
Hallo Wolfgang, > klares nein. Hat Google schon lange verboten. verstanden. Spaßig ist nur: wenn man im...
Re: [EasyLinux-Ubuntu] Streams_übertragen
Frank von Thun, 19.01.2017 05:54
Am 18.01.2017 um 19:53 schrieb alfred: > Am 18.01.2017 um 18:02 schrieb Frank von Thun: >> Am 18.0...
Re: [EasyLinux-Ubuntu] Streams_übertragen
Heiko, 18.01.2017 22:48
Am Mittwoch, 18. Januar 2017, 19:53:08 CET schrieb alfred: Hallo Alfred. > > OK, geht und holt die...
Re: [EasyLinux-Ubuntu] adobe_flash_player_für__android
Karl-Heinz, 18.01.2017 18:54
Am Wed, 18 Jan 2017 17:09:23 +0100 schrieb Hartmut Haase : Hallo Hartmut, such einfach mal nach "Fla...