Powersaved

Autor

Sonntag, 02. Januar 2005 00:46:46

Hi,
Ich habe ein Problem mit meinem Centrino Notebook (1,4 Ghz).
Ich habe Probehalber mal die Suse 9.2 auf meinem Notebook installiert.
Solange ich an der Steckdose hänge ist alles klar aber wenn ich mit Akku
arbeiten will ist es ein Drama.
In unregelmäsigen abständen, so ca. alle 60-180 Sek., bleibt die Kiste so
für 15 Sek. hängen, auch in der console und es macht wirklich keinen Spaß
so zu arbeiten.
Das Prob. verschwindet wenn ich "powersaved" stoppe. Mit "lsmod" habe ich
geschaut ob irgend ein Modul entladen wird, das scheint aber nicht der
Fall zu sein.
Es ist eine Standart-Installation mit aktuellen Onlineupdates und an
"powersaved" habe ich noch nichts eingestellt.
An welcher Einstellung/en könnte es liegen??

martin

Martin Zeller

9 Antworten


Antworten
Re: Powersaved
Fred Stein, Sonntag, 02. Januar 2005 14:48:40
Ein/Ausklappen

Hallo Martin,
folgende Absaetze habe ich aus dem "http://www.tldp.org/HOWTO/ACPI-HOWTO/daemons.html" herauskopiert. Da wird Dein Problem soweit ich es sehen kann beschrieben.
Uebrigens sind IMHO dort mit die besten Howto's zu finden, aber leider nur in englisch.

"Lost Touchpad and Keyboard Interrupts
Karl Hegbloom emailed me to say that "keyboard keys sticking, touchpad pointer jumping suddenly across the screen, lockups under heavy network I/O [was] caused by polling the battery state via ACPI and the proc file system." This problem caused, in part, by a delay between the initial request for information about the battery's status and the response. In that delay interrupts may be locked out and synchronization with the keyboard and touch pad may be lost. "The overnight solution is to either turn off the battery applet, or reduce its polling frequency." Karl also notes that a BIOS update was also able to solve the problem. Thanks Karl!

I did not find this to be a problem for me in the 2.4.x kernels, however, it was a problem when I upgraded to 2.6.5. I use wmacpi to monitor my battery status. By setting the polling frequency to 1 (the lowest possible number), I seem to have eliminated the touchpad lockups. In my .xinitrc file I use:

/usr/bin/wmacpi -s 1

The -s 1 represents the polling frequency (sample rate) of "once per minute." The default is 20."

mfg Fred

[1] http://www.tldp.org/HOWTO/ACPI-HOWTO/daemons.html



Bewertung: 223 Punkte bei 48 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Christoph , Sonntag, 02. Januar 2005 17:02:46
Ein/Ausklappen

und was sagen die logfiles ?

alternativ:

[1] http://portal.suse.com/sdb/...04/05/hmeyer_91_powersave.html



Bewertung: 231 Punkte bei 35 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Martin Zeller, Sonntag, 02. Januar 2005 21:43:48
Ein/Ausklappen

hi,
in den logfiles, in bezug auf acpi, habe ich nichts auffälliges gesehn . bei
der suche nach
powersave habe ich folgendes entdeckt, ich kann aber nichts damit anfangen.

messages:Jan 1 21:22:23 mobil rcpowersaved: enter 'speedstep-centrino' into
POWERSAVE_CPUFREQD_MODULE in /etc/sysconfig/powersave/cpufreq.

messages:Jan 1 21:22:23 mobil rcpowersaved: this will speed up starting
powersaved and avoid unnecessary warnings in syslog.

warn:Jan 1 16:45:28 mobil [powersave][4584]: ERROR in Function
handleSocketRequest; line 353: User is not allowed to connect to daemon.

ich ich habe in /var/log mit "grep -i powersave *" gesucht

wmacpi gibt es bei mir nicht.

martin


Bewertung: 192 Punkte bei 39 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Powersaved
Martin Zeller, Sonntag, 02. Januar 2005 17:13:57
Ein/Ausklappen

hi fred,
na, da mein englisch wohl etwas mehr als besch... ist wird das wohl mein
erstes prob sein.

mit biosupdate ist nix habe ich schon geschaut. nun kläre ich mal das mit
wmacpi und der .xinitrc

martin


Bewertung: 182 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Christoph , Montag, 03. Januar 2005 00:22:33
Ein/Ausklappen

warn:Jan 1 16:45:28 mobil [powersave][4584]: ERROR in Function
handleSocketRequest; line 353: User is not allowed to connect to daemon.

probiere mal bitte zu wechseln
POWERSAVED_DEBUG in /etc/sysconfig/powersave/common auf 15

tritt diese Fehlermeldung auch auf ?
was sagt der Log jetzt ?

stellt auch ab wenn du deinen notebook ohne KDE z.B im runlevel 3 startest ?
es kann auch problem mit Resource Manager (resmgr) geben.
normalerweise ist im runlevel 3 nicht aktiv.

trifft das Phänomen auch auf wenn du z.B mit der option Safe Settings (falls SUSE 9.2 auch hat ) bootest ?
wenn nicht, dann probiere es mit apm=off zu booten.

sollte alles fehlschlagen würde ich unbedingt ein BUG Report [1] an SUSE schicken, dann wird vielleicht irgendwann durch ein online update behoben.


[1] http://www.suse.de/cgi-bin/feedback.cgi



Bewertung: 179 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Martin Zeller, Montag, 03. Januar 2005 11:02:48
Ein/Ausklappen

hi,
die fehlermeldung scheint davon zu kommen das ich powersaved nichtmehr beim
booten starte, ich habe die links aus den rcx.d verzeichnissen gelöscht.

das prob. tritt im allen runlevel auf in denen powersaved gestartet ist.

im failsave scheint er irgend was nicht zu vertragen und hängt sich auf.
ein apm=off hilft nix.
was mir noch aufgefallen ist das wieder der hw_random.ko error da ist.

ich habe mal mit tail -f die logdatei längere zeit beobachtet, es war aber nix
auffälliges zu sehn.

martin


Bewertung: 178 Punkte bei 38 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Christoph , Montag, 03. Januar 2005 13:10:17
Ein/Ausklappen

hw_random.ko error ist nicht schlimm und man kann gemäss SUSE einfach ignorieren [1]

trifft das problem auch auf wenn du powersaved abstellst ?

und was passiert wenn du nur ACPI abstellst

# insserv -r acpid

und powersaved aktiv bleibt ?

[1] http://portal.suse.com/sdb/...04/06/hmeyer_91_hw_random.html



Bewertung: 204 Punkte bei 38 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Martin Zeller, Montag, 03. Januar 2005 15:31:54
Ein/Ausklappen

hi,
acpid ist nicht aktiv.
wenn powersaved gestopt wird läuft das notebook ganz normal.
wenn ich acpid mit "rcacpid start" starte läuft die kiste normal.
beide zusammen geht nicht, wird zumindest so gemeldet.

martin


Bewertung: 158 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Powersaved
Christoph , Montag, 03. Januar 2005 18:26:11
Ein/Ausklappen

beides zusammen geht auf jeden Fall nicht !

dann probiere

# insserv acpid

und powersaved total abstellen

löst dies dein problem ?

gruss


Bewertung: 202 Punkte bei 40 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Zu wenig Speicherplatz auf /boot unter MATE
Patrick Obenauer, 25.05.2015 14:28, 1 Antworten
Hallo zusammen, ich habe Ubuntu 14.10 mit MATE 1.8.2 (3.16-37) mit Standardeinstellungen aufgese...
Konsole / Terminal in Linux Mint 17.1 deutsch
Dirk Resag, 09.05.2015 23:39, 12 Antworten
Hallo an die Community, ich habe vor kurzem ein älteres Notebook, Amilo A1650G, 1GB Arbeitsspe...
Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Anwendungsmenü_für_Ubuntu
Hartmut Haase, 26.05.2015 20:28
Hallo Karl, > Das nächste Problem zeigt sich schon, wenn ich meinen >>Drucker (den ich zwar nur se...
Re: [EasyLinux-Ubuntu] Anwendungsmenü_für_Ubuntu
Gerhard Blaschke, 26.05.2015 20:18
Am 26.05.2015 um 18:03 schrieb Karl Opitz: > Hallo Richard > > Lange Rede, kurzer Sinn: >...
Re: [EasyLinux-Ubuntu] Anwendungsmenü_für_Ubuntu
Richard Kraut, 26.05.2015 20:15
Am Dienstag, den 26.05.2015, 18:03 +0200 schrieb Karl Opitz: > Lange Rede, kurzer Sinn: Das ist mir alles...
Re: [EasyLinux-Ubuntu] Xfce 4.10: Starter anders anordnen
Hartmut Haase, 26.05.2015 18:24
Hallo Gerhard, > Hast Du schon probiert (wie in einer früheren Mail angeregt), das Ganzer > bei einem...
Re: [EasyLinux-Ubuntu] Anwendungsmenü_für_Ubuntu
Karl Opitz, 26.05.2015 18:03
Hallo Richard Lange Rede, kurzer Sinn: Das ist mir alles viel zu umständlich und aufwendig. Das nächste Pro...