Postfix outgoing Pipe filtern - wie?

Hendrik Timmermann - Mittwoch, 17. Dezember 2008 08:56:15 - 2 Antworten

Hallo,

bin von Sendmail auf postfix umgestiegen. Nutzt UUCP als Transportweg. Habe nun Mails, die via qmgr via pipe zu UUCP outbound gehen. Genau dort möchte ich nochmal alle Meldungen durch einen Content-Filter schieben. Am liebsten Procmail.

Wie kann ich das konfigurieren?

Steel-Cat

Antworten
Postfix content filter vor Queing ausführen - wie?
Hendrik Timmermann, Donnerstag, 18. Dezember 2008 12:14:23
Ein/Ausklappen

# See the Postfix UUCP_README file for configuration details.
#
#uucp unix - n n - - pipe
uucp unix - n n - - pipe -v -o content_filter=procmail:
flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)

procmail unix - n n - - pipe -v
flags=R user=uucp argv=/usr/bin/procmail -t -m /var/spool/uucp/.procmailrc ${sender} ${user} ${recipient}

Aber leider sehe ich im Log immer nur, dass er aussendet via service uucp, aber nicht in den Content_filter reingeht!

Warum nicht?

Selbstantwort: könnte es daran liegen (Zitat aus Doku):

"the name of a mail delivery transport that filters mail after it is queued. "

Wie bekomme ich es denn hin, das er davor filtert und nicht after ?

Steel-Cat


Bewertung: 283 Punkte bei 47 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Postfix content filter vor Queing ausführen - wie?
Harald Geiger, Donnerstag, 18. Dezember 2008 13:29:43
Ein/Ausklappen

Hallo Hendrik!

> "the name of a mail delivery transport that filters mail after it is queued. "
> Wie bekomme ich es denn hin, das er davor filtert und nicht after ?

Zum Verständnis: "queued" heißt bei Postfix (und auch allgemein bei MTAs), dass eine Email angenommen und auf der Platte gespeichert ist.

Das "content_filter" Feature von Postfix filtert ankommende Emails, nicht ausgehende. Deshalb ist die Option in der master.cf auch nur für "smtpd" und "pickup" gültig, nicht aber für "pipe", "smtp" oder "lmtp", wie Du es verwendet hast.

Mehr zum Content_filter siehe:
http://www.postfix.org/FILTER_README.html

Wenn Du die Mails wirklich beim Weiterleiten filtern willst, lass Postfix die Mails über eine pipe an Deinen Filter (procmail) senden und sorg dort dafür, dass procmail die Mails an uucp weiter gibt.

Harald



Bewertung: 286 Punkte bei 53 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

thema ändern
a b, 29.05.2016 16:34, 0 Antworten
Hallo Linuxer zuerst alle eine schönen Sonntag, bevor ich meine Frage stelle. Ich habe Ubuntu 1...
Ideenwettbewerb
G.-P. Möller, 28.05.2016 10:57, 0 Antworten
Liebe User, im Rahmen eines großen Forschungsprojekts am Lehrstuhl für Technologie- und Innova...
Welche Drucker sind Linux-mint kompatibel?
Johannes Nacke, 20.05.2016 07:32, 4 Antworten
Hallo Ihr Lieben, ich bitte um mitteilung welche Drucker Kompatibel sind mit Linux-Mint. LG Joh...
MS LifeCam HD-5000 an Debian
Kay Michael, 13.04.2016 22:55, 0 Antworten
Hallo, ich versuche die oben erwähnte Cam an einem Thin Client mit Debian zu betreiben. Linux...
Import von Evolution nach KMail erzeugt nur leere Ordner
Klaus-Christian Falkner, 06.04.2016 12:57, 3 Antworten
Hallo, da ich vor einiger Zeit von Ubuntu auf Kubuntu umgestiegen bin, würde ich gerne meine E...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] OT Werden keine eigenen Emails mehr empfangen von Ubuntu/Suse-Liste
Heiko, 31.05.2016 10:17
Am Sonntag, 29. Mai 2016, 22:53:34 schrieb Oliver: Hallo Oliver, > > > http://picpaste.de/liste...
Re: [EasyLinux-Ubuntu] grosses Problem?
Jens Nürnberger, 30.05.2016 21:09
Hallo Frank, > > brauche ich nochmals eure Hilfe.> > Ich habe ein Asus Motherboard M5 A 78L-M US...
Re: [EasyLinux-Ubuntu] grosses Problem?
Jens Nürnberger, 30.05.2016 20:55
Hallo Wolfgang, > Hallo, > nachdem ich nun herausbekommen habe, dass meine Festplatte bald den >...
Re: [EasyLinux-Ubuntu] grosses Problem?
Frank von Thun, 30.05.2016 20:46
Am 30.05.2016 um 19:24 schrieb W.Tiedemann: > > > Hallo, > nachdem ich nun herausbekommen h...
Re: [EasyLinux-Ubuntu] grosses Problem?
Wolfgang Tiedemann, 30.05.2016 19:24
???????????????????????????????????????????????????????????????????????????????????????????????????????????????...