PC schaltet nicht ab

Autor

Freitag, 06. März 2009 10:12:37

Hallo,
Nicht immer, aber öfters wenn ich "Rechner ausschalten" wähle, geht der Schalter mit hörbarem Klack aus, aber bevor die Festplatte mit dem letztem Schwung ausgelaufen ist, schaltet er wieder ein und bootet neu. Ich kann das dann nur mit dem Ausschalten an der Steckerleiste beenden, wo der PC und die Peripheriegeräte dran sind.
Das Mainboard ist MSI K9NU Neo-V (MS-7270) Sockel AM2.
Das Problem ist schon länger, schon vor SUSE 11.1, auch die KDE-Version ist egal, momentan 4.1.3, vorher 3.5.
Ist vielleicht im BIOS was fasch? Oder steht eine Abschaltsoftware auf "Auto" und sollte auf "Shutoff" stehen?

Wimpy *

9 Antworten


Antworten
Endgültige Lösung gefunden
Wimpy *, Montag, 17. August 2009 14:18:59
Ein/Ausklappen

Es ist jetzt lange her, und ich weiß nicht, ob noch jemand reinschaut, aber ich habe im BIOS bei Power-Management Wake-up-Event Setup:
> PCI Device
> PCIE Device und
> RTC Alarm
> abgeschaltet. Seitdem ist Ruhe.


Bewertung: 159 Punkte bei 16 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
PnP OS = YES
Marcel Hilzinger, Freitag, 06. März 2009 17:39:21
Ein/Ausklappen

Schau mal im BIOS, ob es eine Einstellung PnP OS gibt (unter Powermanagement) und schalte die ein,


Bewertung: 181 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: PnP OS = YES
Wimpy *, Samstag, 07. März 2009 09:29:12
Ein/Ausklappen

Das habe ich icht gefunden, aber ACPI=Enabled, Power Button Function=Power off,
Wake up Event Setup:
Resume by PCI Device Enabled
Resume by PCIE Device Enabled
RTC-Alarm Disabled



Bewertung: 224 Punkte bei 30 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: PnP OS = YES
Marcel Hilzinger, Montag, 09. März 2009 13:59:38
Ein/Ausklappen

Es gibt in der Konfigurationsdatei /etc/sysconfig/shutdown drei mögliche Einträge. Teste die mal durch.


Bewertung: 181 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: PnP OS = YES
Wimpy *, Donnerstag, 12. März 2009 12:59:06
Ein/Ausklappen

hallo,
Danke für den Tip mit etc/sysconfig.
Änderung von Halt="auto" auf "poweroff" brachte noch nichts,
Änderung von Halt_Network="yes" ist wahrscheinlich erfolgreich.
Ich bin nicht jeden Tag am PC, drum dauerte es etwas mit der Antwort,
aber jetzt hat er drei Mal ordentlich abgeschaltet.
Es bewirkt, daß es kein Wake-Up-on-LAN gibt.
komischerweise war es aber, obwohl ich vor dem Herunterfahren immer mit KInternet die Eth0-Leitung zur FritzBox trenne. Aber irgend ein Signal muß es wohl gegeben haben, das den PC wieder einschaltet.
Ich hoffe, daß es das wirklich war, man merkt es erst wenn es längere Zeit nicht mehr passiert.



Bewertung: 159 Punkte bei 21 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: PnP OS = YES
Wimpy *, Dienstag, 17. März 2009 09:11:34
Ein/Ausklappen

Das Problem scheint gelöst zu sein.
in etc/sysconfig:
Halt_Network="yes"
Seither schaltet der PC ordentlich ab.
Danke für den Tip.


Bewertung: 156 Punkte bei 21 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: PnP OS = YES
Wimpy * (unangemeldet), Dienstag, 17. März 2009 13:09:20
Ein/Ausklappen

Was soll ich sagen?
Weil ich das geschrieben habe, hat er wieder mal nicht ordentlich abgeschaltet.
Hardware-Fehler? Hängt der Abschaltknopf?
Oder gibts noch etwas in den unendlichen Weiten des Systems?


Bewertung: 89 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Bei mir geht es jetzt
Sven Münzenberger, Freitag, 20. März 2009 11:25:16
Ein/Ausklappen

Bis eben hatte ich mit SuSe 11.1 das gleiche Problem.

Beim Herunterfahren/Neustarten hat er mir zwar angezeigt, daß er Runlevel 0 bzw 6 erreicht hat, aber an der Stelle blieb er dann auch hartnäckig stecken.

Anscheinend bin ich wohl nicht der Einzige, der mit diesem Problem zu kämpfen hat(te) und eine wirkliche Lösung habe ich noch in keinem Forum gefunden. Vielleicht hilft ja mein Tip.

Ganz trivial: Mir ist aufgefallen, daß beim Systemstart plötzlich gemeldet wurde, daß Fehler beim Laden der v4l-libs aufgetreten sind. Nach der Deinstallation selbiger schaltete der Rechner nach dem Herunterfahren auch wieder brav ab.

Mein Verdacht:
Beim shutdown konnte - warum auch immer - mindestens ein Prozeß nicht gekillt werden. In meinem Fall war es wahrscheinlich ein Prozeß, der mit v4l zu tun hatte.

Wenn ich mich recht entsinne, war soetwas bei früheren SuSen kein Problem. Das System ist auch dann heruntergefahren, wenn sich ein Prozeß mal nicht sauber beenden ließ.

Kann es sein, daß daran etwas geändert wurde und beim shutdown jetzt prinzipiell auf das saubere Beenden aller gekillten Prozesse gewartet wird?

In den einschlägigen log-files habe ich leider nichts auffälliges bei mir finden können.




Bewertung: 56 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Bei mir geht es jetzt
Wimpy *, Samstag, 21. März 2009 09:35:39
Ein/Ausklappen

Ich habe in YaST nach v4l gesucht und 9 Progs/Tools/Libs gefunden, die aber alle nicht installiert waren. Aber ich werde in den Logs nach Prozessen suchen, die nicht ordentlich runterfahren. Das ist ein guter Tip.


Bewertung: 100 Punkte bei 36 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 2 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Neue SuSE-Literatur
Roland Welcker, 14.01.2015 14:10, 1 Antworten
Verehrte Linux-Freunde, seit Hans-Georg Essers Buch "LINUX" und Stefanie Teufels "Jetzt lerne ich...
DVD abspielen unter openSUSE 13.1
Michael Pfaffe, 12.01.2015 11:48, 6 Antworten
Hallo Linuxer, Bisher habe ich meine DVD´s mit linDVD unter openSUSE abgespielt. Mit der Versi...
Kontrollleiste SuSE 12.3 gestalten
Roland Welcker, 31.12.2014 14:06, 1 Antworten
Wie bekomme ich das Icon eines beliebigen Programms (aktuell DUDEN) in die Kontrollleiste und kan...
flash-player
roland reiner, 27.12.2014 15:24, 7 Antworten
Mein Flashplayer funktioniert nicht mehr-Plug in wird nicht mehr unterstütz,auch über google chro...
PCLinuxOS Version 2014.08 "FullMonty" Umstellung auf deutsch
Karl-Heinz Welz, 19.12.2014 09:55, 10 Antworten
Hallo, liebe Community, ich bin 63 Jahre alt und möchte jetzt nach Jahrzehnten Windows zu Linux...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Trinity was:KMail2 / fetchmail
Heiko, 28.01.2015 16:13
Am Mittwoch, 28. Januar 2015, 11:46:51 schrieb Gerhard Blaschke: Hallo. > Am 28.01.2015 um 11:22 schrieb...
Re: [EasyLinux-Ubuntu] Trinity was:KMail2 / fetchmail
Heinz-Stefan Neumeyer, 28.01.2015 12:25
Am Mittwoch, den 28.01.2015, 12:08 +0100 schrieb Gerhard Blaschke: Hallo Gerhard doch noch eine Anmerkung...
Re: [EasyLinux-Ubuntu] Trinity was:KMail2 / fetchmail
Gerhard Blaschke, 28.01.2015 12:08
Am 28.01.2015 um 12:04 schrieb Heinz-Stefan Neumeyer: > Am Mittwoch, den 28.01.2015, 11:46 +0100 schrieb G...
Re: [EasyLinux-Ubuntu] Trinity was:KMail2 / fetchmail
Heinz-Stefan Neumeyer, 28.01.2015 12:04
Am Mittwoch, den 28.01.2015, 11:46 +0100 schrieb Gerhard Blaschke: Hallo Gerhard > > Alles gut und...
Re: [EasyLinux-Ubuntu] FAT32_Stick_ist_plötzlich_____nur_noch_lesbar.
Heinz-Stefan Neumeyer, 28.01.2015 11:49
Am Mittwoch, den 28.01.2015, 08:32 +0100 schrieb Uwe Herrmuth: Hallo Uwe > > Fragezeichen in den A...