OpenSuse 11.1 & Radeon X1900Xt

Autor

Samstag, 06. Juni 2009 15:56:16

System: Pentium D 2.8GHZ, 2GB RAM + ATi Radeon X1900XT, Kernel 2.6.27.19

Servus,

habe aus der aktuellen Open Source Spezial, wo ja schon ATI treiber enthalten, sind auf meinem System installiert. Allerdings bekomme ich, anders als in der Zeitschrift beschrieben, keinerlei 3d-Unterstützung. Woran mag das liegen? Auf einem ähnlichen System mit ATi X850 Karte hat das Setup schon während der Hardwareerkennung 3d-Support zum ein- und ausschalten angeboten. Bei meinem aktuellen System wird während des Setup zwar die X1900 als Grafikkarte erkannt, ich kann aber keinen 3D-Support auswählen. Woran mag das liegen.

Das Linux hat den Treiber RadeonHD ja automatisch mitinstalliert. Ich kann allerdings auch noch die ATI proprietären Treiber installieren (ATI-FGLRX) - Mache ich dies, und starte den Rechner neu, wars das und der PC hängt sich beim X11 laden auf. Auch beim Failsafer boot.

Also nochma zusammenfassen: Was muss ich tun um unter OpenSuse 11.1 mit der Radeon X1900XT 3D-Support zu bekommen?

Vielen Dank,
Markus

Markus Kneip

1 Antworten


Antworten
mehr infos
Dieter Drewanz, Samstag, 06. Juni 2009 23:10:17
Ein/Ausklappen

Verwendest Du Suse 11 32bis oder 64bit?

Und welche Version des aktuellen Treibers hattest Du verwendet?

"ATI Catalyst™ 9.3 Proprietary Linux x86 Display Driver Size 80.9 Version 9.3 Date 3/26/2009
Automated installer and Display Drivers for X.Org 6.7, 6.8, 6.9, 7.0, 7.1, 7.2, 7.3, or 7.4"

"The display driver requires POSIX shared memory to be enabled on the system. Kernal Sources package is no longer required if Kernel Header package is installed. 32-Bit packages must be installed for 64-Bit Linux drivers to install or work."

Lief dieser Installer auch komplett durch? Und die Hinweise berücksichtigt?
Vorher solltest Du die xorg.config sichern und auch vergleichen, ob diese angepasst wurde.

Geht als bootoption der runlevel 1 (konsolenebene ohne X11)? Mit startx läßt sich X11 starten und die Fehlermeldungsausgabe könnte noch Hinweise geben.




Bewertung: 170 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 21.04.2015 09:21
Hallo Rainer, > HPLIP ist hier in Betrieb. dann würde ich mal hp-setup ausführen, um zu sehen, ob alle b...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 21.04.2015 01:08
Nachtrag: Am 21.04.2015 um 00:34 schrieb Gerhard Blaschke: > Am 20.04.2015 um 19:59 schrieb Richard Krau...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 21.04.2015 00:34
Am 20.04.2015 um 19:59 schrieb Richard Kraut: > Am Sonntag, den 19.04.2015, 15:59 +0200 schrieb Gerhard Bl...
Re: [EasyLinux-Ubuntu] wie_als_root_ausführen?
Gerhard Blaschke, 20.04.2015 23:03
Am 20.04.2015 um 19:04 schrieb Heiko Ißleib: > Hallo Gerhard. > > Ich vermute,Du weißt schon,wi...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 20.04.2015 23:01
Am 20.04.2015 um 19:59 schrieb Richard Kraut: > Am Sonntag, den 19.04.2015, 15:59 +0200 schrieb Gerhard Bl...