NFS Export - Softwarelocks funktionieren nicht

Autor

Dienstag, 28. Februar 2012 13:02:45

Hallo,

habe einen Linux Debian Server 6.0.2 Squeeze. Darauf läuft der NFS-Kernel-Server in der Version 1.2.2-4. Clients sind Ubuntu 10.04, 11.04 jeweils x64.

Nun habe ich Verzeichnisse exportiert (homes), welche von den Clients erfolgreich gemountet werden.

Dennoch habe ich folgendes Problem: Starte ich firefox oder akonadi, so wollen diese eine Lockdatei erstellen... Firefox mit der .parents.lock und Akonadi mit der mysql.lock jeweils im gemounteten Homeordner.

Vom Server dementsprechend exportiert:
/media/daten/home 192.168.0.0/24(rw,async,no_root_squash,no_subtree_check)

Eingebunden wurden diese vom Client folgendermaßen:
server:/media/daten/home /home nfs

Zudem haben wir einen anderen Server mit dem NFS-Kernel-Server inder Version 1.2.0-0 und hier wird das auch so gemountet - und funktioniert auch. Habe ich was falsch gemacht bzw. kann mir wer einen Tipp geben, welcher mir evtl. weiterhelfen kann?

Gruß,
Ludwig

Ludwig jun. B.

2 Antworten


Antworten
*** B I T T E - Rückmeldung ***
Ulf B., Samstag, 03. März 2012 17:07:42
Ein/Ausklappen

Hallo Ludwig,

und hat es geklappt? Wie sieht es aus?

Ohne Rückmeldung weiß ich ja nicht ob ich mit meiner Analyse richtig gelegen habe! Wenn Du nicht antwortest - kann ich Dir das nächste mal leider nicht mehr helfen (bringt mir dann ja nichts).

Gruß
Ulf


Bewertung: 102 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
NFS Server
Ulf B., Dienstag, 28. Februar 2012 20:29:44
Ein/Ausklappen

Hallo Ludwig,

ich habe schon vielen seit Jahren (allerdings unter openSUSE) mein Home auf meinem NFS-Server laufen. Meine Daten:

*** Server@192.168.1.1 ***
# cat /etc/exports
/home *(rw,root_squash,sync,no_subtree_check)

#rpm -qa | grep -i nfs
nfs-kernel-server-1.2.3-11.16.1.x86_64

*** client@192.168.1.11 ***
#cat /etc/fstab
192.168.1.1:/home /home nfs4 defaults 0 0

#rpm -qa | grep -i nfs
nfs-client-1.2.5-4.3.1.x86_64

*** Wichtig: ***
Also wichtig für Dich ist zum einen, dass auf deinem Server auch ein entsprechender Verzeichnisdienst läuft (Server) bzw. verwendet wird (Client). Bei mir ist es NIS/YP - heute würde ich aber eher LDAP verwenden (lief damals als ich den ersten Server aufgesetzt habe, leider noch nicht sauber).

Zudem verwendest Du die Option "no_root_squash", womit alle root anfragen (also z.B. vom lokalen mysql Server) auf nobody gemapt werden. Dieser darf aber fast gar nichts, womit dieses misslingt. Bei mir lief Akonadi erst wieder stabil, nachdem ich auf dem Server das Home Verzeichnis mit "root_squash" exportiert habe. Aber Achtung, dieses ist meiner Ansicht nach maximal für /home zulässig, aber keines falls für Systemverzeichnisse die Programme, Bibliotheken oder Konfigurationen enthalten. Da mit dieser Option, ohne weitere Prüfung, jeder Client volle root Rechte auf die Verzeichnisse erhält.

Tschö
Ulf


Bewertung: 110 Punkte bei 19 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Netzwerkdateisystem NFS
    Wenn mehrere Linux- oder Unix-Rechner via Netzwerk Daten tauschen sollen, gelingt das am einfachsten mit NFS.
  • Fein vernetzt
    Wer zu Hause ein kleines Linux-Netzwerk betreibt, möchte vermutlich darüber auch Dateien austauschen. Für eine dauerhafte und stabile Verbindung bietet sich dazu das Netzwerkdateisystem NFS an.
  • System getankt
    Via PXE lassen sich auch Live-Systeme booten: Sie schalten einen plattenlosen Rechner einfach ein und er holt sein komplettes OS beim Server ab.
  • Das Network File System (NFS)
  • Linux-PCs miteinander verknüpfen
    Für viele PC-Benutzer stellt bereits die Administration eines einzigen Rechners eine große Herausforderung dar. Gehören Sie nicht dazu, lesen Sie in diesem Artikel, wie Sie ein komplettes Linux-Netzwerk erstellen.

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 2 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 1 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:35
und sogar mit Opera :-) -- Viele Grüße, Hartmut Hungerhilfe: http://www.thehungersite.com Ohne Zensu...
Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:32
Hallo Heiko, > Da Du ein anderes Java (proprietär) verwendest nebst anderem Plugin > fehlt natürlich...
Re: [EasyLinux-Ubuntu] QR-Code Generator
Alexander McLean, 05.07.2015 10:12
Am Freitag, 3. Juli 2015, 18:58:52 schrieb Richard Kraut: Hallo Richi > Auf die Schnelle habe ich no...
Re: [EasyLinux-Ubuntu] Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:33
Am Freitag, 3. Juli 2015, 10:42:53 schrieb Hartmut Haase: Hallo Hartmut, > > > Man kann aberdas...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:28
Am Donnerstag, 2. Juli 2015, 11:01:20 schrieb Hartmut Haase: Hallo Hartmut, > > > Ist denn iced...