Mysteriöse Probleme bei externem USB-Boot

Autor

Samstag, 26. November 2005 18:00:32

Hallo zusammen,

ich habe jetzt seit Tagen den Kampf, mein Linux auf einer externen USB-HDD zum automatischen Starten zu bringen. Hier mal das Szenario:

Distribution: SuSE 10.0

Hardware: 3,5 USB-HDD in externem USB 2.0 Gehäuse

Getestet auf: Desktop-PC mit Unterstützung für USB-HDD-Boot, Notebook ohne diese Unterstützung

Ziel: Linux soll ohne CD (wenn vom BIOS unterstützt) selbständig starten

Problem:
Wenn ich im Bootmenü des BIOS auswähle, dass er von USB-HDD booten soll, mact er keinerlei Regung und startet von der IDE-HDD. Auch wenn diese ausgesteckt ist geschieht nichts und er verlangt nach einem Boot-Medium. Ich muss dann jedes Mal die 1. SuSE CD einlegen, auf Installation wechseln und dann bei "Vorhandenes System starten" meine Root-Partition auswählen.

Bei dem Laptop, der scheinbar diese Unterstützung nicht hat, funktioniert es interessanterweise einfacher. Dort lege ich auch die CD ein und gebe am Anfang an "Von Festplatte starten". Manchmal macht er da zwar Probleme bei der Zuordnung für die Adressen, aber wenn es dann, nach ein paar Neustarts erstmal läuft, geht es.
Bei dem Desktop PC erkennt er mir die USB-HDD überhaupt nicht, wenn ich "Von Festplatte starten" auswähle, obwohl dieser doch sogar die USB-Boot-Funktion unterstützt!?
Nun ist hier die Frage: Was mache ich falsch?

Zur Information:
/etc/sysconfig/kernel hat folgende Einträge hinzu bekommen:
sbp2 sd_mod usb-storage ehci-hcd uhci-hcd sr_mod scsi_mod

lilo.conf sieht wie folt aus:

menu-scheme = Wb:kw:Wb:Wb
timeout = 80
lba32
change-rules
reset
read-only
prompt
default = Standard
message = /boot/message
boot = /dev/sda
disk = /dev/sda
bios = 0x80

image = /boot/vmlinuz
label = Standard
append = "showopts resume=/dev/sda2 splash=verbose"
vga=742
initrd = /boot/initrd
root = /dev/sda3

image = /boot/vmlinuz
vga = normal
initrd = /boot/initrd
label = Abgesichert
root = /dev/sda3
append = "showopts ide=nodma apm=off acpi=off noresume selinux=0 nosmp noapic maxcpus=0 edd=off 3"


Hat irgendjemand eine Idee?

ThommySTGT

2 Antworten


Antworten
Re: Mysteriöse Probleme bei externem USB-Boot
Philipp Vogt, Dienstag, 29. November 2005 12:41:02
Ein/Ausklappen

Hallo!

Nachdem ich mal sowas aehnliches versuchte, hier mal meine Sicht der Dinge:

Ich habe wie Du versucht ein Linux von einer USB-Festplatte zu starten. Das klappte bei meinem Board nur, wenn die Platte klein war (6 GB) und nicht, wenn die Platte groesser war (20 GB).

Mit einem USB-Stick ist das booten kein Problem (bei mir auf dem Desktop, in der Firma geht USB-Boot auf Grund der fehlenden Biosoption nicht).

Ich wuerde also folgendermassen Vorgehen:
- Mainboardhomepage bzw. Internetforen nach Erfahrungen mit USB-Boot von HDDs durchsuchen (vielleicht geht das nur mit bestimmten Biosversionen etc.) bzw. dort Fragen dazu stellen.
- Wenn moeglich eine kleinere Festplatte versuchen (falls vorhanden).
- Ein (billigen) USB-Stick testen (formatieren und mit syslinux bootbar machen). Vielleicht kann man ja ein USB-Stick-bootet-und-bindet-dann-USB-Festplatte-ein basteln ;-)

Generell wuerde ich sagen, dass es mal voerst nicht mit dem Kernel zusammenhaengt, da dieser ja noch nicht zum Zug kommt. Das kann dann spaeter ein Problem werden, wenn das Bios die USB-Platte richtig erkennt.

"Von Festplatte starten" sollte die falsche Option sein. Bei mir kann ich z.B. mit F8 ein Bootmenu aufmachen. Dort kann ich dann Floppy,USB,IDE1,IDE2,CDROM1/2 aussuchen. Vielleicht hat ja Dein Bios eine aehnliche Funktion. Ich habe festgestellt, dass wenn die USB-Option im Menu fehlt, das Bios die USB-Platte nicht erkannt hat.

Ich hoffe Dir damit irgendwie geholfen zu haben ;-)

mfG

Philipp


Bewertung: 136 Punkte bei 17 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Re: Mysteriöse Probleme bei externem USB-Boot
Florian E.J. Fruth, Sonntag, 27. November 2005 02:10:36
Ein/Ausklappen

hi,
genau kann ich dir nicht weiterhelfen jedoch ist evtl. einer der folgenden Tips hilfreich:

1. bios = 0x80


Bewertung: 209 Punkte bei 18 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Fruchtig und spritzig
    Sie möchten eine flinke OpenSuse-Variante für die Hosentasche? Kein Problem: Kiwi macht's möglich.
  • Der "Grand Unified Boot Loader" GRUB
    Der für GNU/Hurd entwickelte Boot-Manager GRUB stellt dank vieler Features eine wirkliche Alternative zum Linux-Standard-Boot-Manager LILO dar. Wir zeigen, wie der Umstieg funktioniert.
  • Kernel-Neubau ohne Expertenwissen
    Einen eigenen Kernel zu kompilieren gilt als schwierig – mehrere hundert Konfigurationsoptionen schrecken ab. Doch Sie müssen nicht alle verstehen, um einen neuen Kernel selbst zu übersetzen.
  • Starthilfe
    Wer Vista nicht nicht das Monopol auf seinem Rechner zugesteht, braucht adäquate Möglichkeiten, mehrere Systeme zu booten.
  • Suse 9.1 von unnötigem Ballast befreien
    Mehr Feature, mehr Software – mehr Ballast: Nicht nur Nutzer älterer Hardware wünschen sich ein schlankeres System, als Suse 9.1 es standardmäßig bietet. Beim Abspecken der einmal installierten Distribution gewinnt man zudem ganz nebenbei ein Mehr an Sicherheit und Stabilität.

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 4 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 21.04.2015 09:21
Hallo Rainer, > HPLIP ist hier in Betrieb. dann würde ich mal hp-setup ausführen, um zu sehen, ob alle b...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 21.04.2015 01:08
Nachtrag: Am 21.04.2015 um 00:34 schrieb Gerhard Blaschke: > Am 20.04.2015 um 19:59 schrieb Richard Krau...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 21.04.2015 00:34
Am 20.04.2015 um 19:59 schrieb Richard Kraut: > Am Sonntag, den 19.04.2015, 15:59 +0200 schrieb Gerhard Bl...
Re: [EasyLinux-Ubuntu] wie_als_root_ausführen?
Gerhard Blaschke, 20.04.2015 23:03
Am 20.04.2015 um 19:04 schrieb Heiko Ißleib: > Hallo Gerhard. > > Ich vermute,Du weißt schon,wi...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Gerhard Blaschke, 20.04.2015 23:01
Am 20.04.2015 um 19:59 schrieb Richard Kraut: > Am Sonntag, den 19.04.2015, 15:59 +0200 schrieb Gerhard Bl...