Linux Scripting unter OpenSuSE

Autor

Mittwoch, 17. März 2010 10:01:29

Hallo Community,
wenn ich unter dem angemeldeten User Scripte erstelle und in einem KDE-Terminalfenster testweise laufen lasse, ist die Ausgabe von auf gerufenen Bash-Befehlen des Scripts in deutsch.
Die Scripte sollen dann aber per cron gestartet werden. Dies ist auch nicht das Problem. Nur liefern die Scripte, wenn sie per cron gestartet werden, nicht das erwartete Ergebnis. Das Problem ist, die Bash-Befehle geben ihre Ergebnisse in englisch aus und somit werden meine Abfragen im Script nicht richtig ausgewertet.

Was mach ich da falsch, wo muss ich was ändern ?

System: OpenSuSe 11.2
Systemsprache: deutsch ist eingestellt, auch für root

Vielleicht kann mir da jemand weiterhelfen.

Grüße
Paul

Paul Göbel

10 Antworten


Alles Ausklappen

Antworten
LANG in Benutzerscripten
Philipp Klaus, Mittwoch, 17. März 2010 14:23:24
Ein/Ausklappen
-
Re: LANG in Benutzerscripten
Paul Göbel, Mittwoch, 17. März 2010 14:41:07
Ein/Ausklappen
-
Re: wieso ignoriert das Betriebssystem die eingestellte Sprache?
Eilert Eilig, Donnerstag, 18. März 2010 12:06:34
Ein/Ausklappen
-
Re: wieso ignoriert das Betriebssystem die eingestellte Sprache?
Paul Göbel (unangemeldet), Donnerstag, 18. März 2010 14:04:53
Ein/Ausklappen
-
Re: wieso ignoriert das Betriebssystem die eingestellte Sprache?
Eilert Eilig, Donnerstag, 18. März 2010 22:57:55
Ein/Ausklappen
script sprache
Roland M. Egloff, Mittwoch, 17. März 2010 12:23:05
Ein/Ausklappen
-
Re: script sprache
Paul Göbel, Mittwoch, 17. März 2010 13:58:34
Ein/Ausklappen
Deutsch
BS (unangemeldet), Mittwoch, 17. März 2010 10:21:32
Ein/Ausklappen
-
Re: Deutsch
Paul Göbel, Mittwoch, 17. März 2010 10:59:30
Ein/Ausklappen
-
Re: Deutsch im cron script
Michael (unangemeldet), Mittwoch, 17. März 2010 14:34:00
Ein/Ausklappen

Ähnliche Artikel

Tipp der Woche

Ubuntu 14.10 und VirtualBox
Ubuntu 14.10 und VirtualBox
Tim Schürmann, 08.11.2014 18:45, 2 Kommentare

Wer Ubuntu 14.10 in einer virtuellen Maschine unter VirtualBox startet, der landet unter Umständen in einem Fenster mit Grafikmüll. Zu einem korrekt ...

Aktuelle Fragen

Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 4 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...
Treiber für Canon Laserbase MF5650
Sven Bremer, 10.02.2015 09:46, 1 Antworten
Hallo ich weiß mittlerweile das Canon nicht der beste Drucker für ein Linux System ist. Trotzd...
Linux und W7 im Netz finden sich nicht
Oliver Zoffi, 06.02.2015 11:47, 3 Antworten
Hallo! Ich verwende 2 PCs, 1x mit W7prof 64 Bit und einmal mit Linux Mint 17 64 Bit, welches ich...
Rootpasswort
Jutta Naumann, 29.01.2015 09:14, 1 Antworten
Ich habe OpenSuse 13.2 installiert und leider nur das Systempasswort eingerichtet. Um Änderungen,...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Speedport W 700V
Rainer, 02.03.2015 12:04
Hallo Alfred, Am Sun, 01 Mar 2015 23:36:36 +0100 schrieb Alfred Zahlten : > >> > > Nur m...
Re: [EasyLinux-Ubuntu] [SuSE 13.2] fetchmail lock
Uwe Herrmuth, 02.03.2015 09:03
Hallo Stefan, H.-Stefan Neumeyer schrieb am 01.03.2015 um 19:13: > Ich fahre meinen Haupt-Arbeitsrechner...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Alfred Zahlten, 01.03.2015 23:36
Am 01.03.2015 um 20:58 schrieb Rainer: Hallo Rainer, > [..] > >> Ich bin sicher, die Teleko...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Rainer, 01.03.2015 20:58
Hallo Alfred, Am Sun, 01 Mar 2015 20:42:14 +0100 schrieb Alfred Zahlten : [..] > Ich bin sicher, die...
Re: [EasyLinux-Ubuntu] Speedport W 700V
Alfred Zahlten, 01.03.2015 20:46
Am 01.03.2015 um 18:56 schrieb Matthias Müller: Hallo Matthias, siehe meine Mail an Gerhard. Der Chromium...