"Kein Betriebssystem gefunden"

Hanno Wiese - Samstag, 10. Januar 2009 15:50:08 - 8 Antworten

Die Meldung "Kein Betriebssystem gefunden" läßt schlimmes befürchten.
Besonders schlimm, wenn das gleich bei zwei völlig unterschiedlichen
Rechnern auftritt, und das jeweils einige Tage nach Neuinstallation von
SuSE 11.1.
Als der Laptop nicht mehr wollte, dachte ich noch an einen Plattencrash
und baute eine neue ein. Danach Komplettneuinstallation von XP und SuSE
11.1, die sich zunächst auch normal benahmen, wie bereits seit 3 Jahren
auf demselben Gerät.
Die gleiche Konfiguration hatte ich auf unserem neuen Familien-Spiele-PC
eingerichtet (einem x86-64-Rechner).
Nach zwei Tagen passierte die Katastrophe zum zweiten Mal: es erschien
zunächst "Kein Betriebssystem gefunden." auf dem Laptop, und am 30.12.
dann auf dem Spiele-PC.
Mit Knoppix waren alle Partitionen ansprechbar, und die Avira-Rescue-CD fand keinen Virus, aber defekte Bootsektoren. Der MBR des Laptops ließ sich mit der SuSE-Reparatur wiederherstellen, für den Spiele-PC gab es eine zweite Neuinstallation. Nach weiteren 3 Tagen das gleiche Spiel ...
Offenbar zerschießt SuSE 11.1 die Bootsektoren.
Jetzt läuft bei mir wieder SuSE 11.0, problemlos, und wird das
auch sicherlich noch eine Weile tun.
Wem ist sowas auch schon passiert, und woran kann's liegen?

Antworten
Supergrubdisk
paulinchen (unangemeldet), Dienstag, 13. Januar 2009 16:27:28
Ein/Ausklappen

Schau dir mal den Link an

http://www.supergrubdisk.org/

Damit kannst du dir ohne eine Neuinstallation behelfen.

T ja das Opensuse solche Probleme hat, ist für mich sehr erstaunlich, aber wenn ich die Probleme nicht auch schon auf mehreren Rechner bei bekannten gesehen hätte würde ich das nicht glauben.


Bewertung: 156 Punkte bei 143 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kein Betriebssystem gefunden
Max (unangemeldet), Dienstag, 13. Januar 2009 13:55:16
Ein/Ausklappen

Du hast sicher unter Yast den Bootloader geöffnet?
Dieser hat einen Bug. Wird dieser geöffnet, auch ohne was zu ändern, zerschiesst es den MBR.
Besser 11.0 noch brauchen, nichts am Bootloader machen und warten bis es einen Patch gibt.


Bewertung: 237 Punkte bei 76 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Kein Betriebssystem gefunden
Hanno (unangemeldet), Dienstag, 13. Januar 2009 19:07:24
Ein/Ausklappen

Ich installiere SuSE seit 7.0 ohne jegliche Eingriffe. Allerdings sortiere ich danach die Bootreihenfolge um, das allerdings auch schon seit einigen Jahren, bisher ohne Probleme. Der Bug muß also wohl neu sein. Immerhin hat sich mein Verdacht bestätigt.
Danke für die Info!



Bewertung: 221 Punkte bei 87 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
kein Betriebssystem gefunden
Dieter (unangemeldet), Sonntag, 11. Januar 2009 23:06:45
Ein/Ausklappen

Wenn kein Betriebssystem gefunden wurde, bedeutet dass, das der MBR/Vektor des Bootlaoders (vermutlich Grub) nicht mehr der auf die Startadresse des Betriebssystems auf der Festplatte zielt.

Das kann eigentlich nur passieren, wenn die Festplatte vollkommen in Ordnung ist, bei einem Update, dass Dateien im Verzeichnis /boot angefaßt hat. Ist vielleicht ein automatisches Update durchgelaufen?



Bewertung: 241 Punkte bei 78 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: kein Betriebssystem gefunden
Hanno Wiese (unangemeldet), Montag, 12. Januar 2009 08:48:43
Ein/Ausklappen

Antwort an Dieter: Der MBR zielte offenbar auf keines der installierten Betriebssysteme mehr. Ich installiere regelmäßig die von SuSE angebotenen Updates. Da das Problem auf zwei völlig unterschiedlichen Rechnern aufgetreten ist, auf dem zweiten sogar 2x, vermute ich den Fehler bei SuSE 11.1 bzw. fehlerhaften Updates und frage mich deshalb, ob das auch bei anderen aufgetreten ist ?!?!?


Bewertung: 227 Punkte bei 91 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: kein Betriebssystem gefunden
Dieter (unangemeldet), Montag, 12. Januar 2009 19:04:16
Ein/Ausklappen

Ich vermute, dass im Verzeichnis /boot bei den Änderungen die Option des Packens von kleinen Dateien beim Dateisystem nicht korrekt abgeschaltet wurde. Ich habe z.B. eine Suse 9.3 und auch 10.1, bei denen genau das im graphischen Mode von yast falsch gemacht wurde und daher kann ich Grub dort nur im Textmode (ohne X11), d.h. nur auf der Konsole gestartet reperieren.

Wenn Du mehrere Partitionen auf der Festplatte hast, dann könntest Du eines der Minilinuxe DSL, Puppy, DeliLinux installieren auf eine der Partitionen, in Zukunft dessen Bootloader verwenden und dort die menu.lst (wenn Du GRUB verwendest) um die anderen Betriebssysteme erweitern.

Das wäre ein Workaround um das Problem. Bei einem anderen Posting vermute ich ein ähnliches Problem. Für Linux-Anfänger ist so etwas nach meiner Ansicht schon ein Show-Stopper und sollte beim internen Softwaretesting eigentlich bereits endeckt werden.




Bewertung: 223 Punkte bei 81 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
"Kein Betriebssystem gefunden"
Dieter (unangemeldet), Sonntag, 11. Januar 2009 23:05:20
Ein/Ausklappen

Wenn kein Betriebssystem gefunden wurde, bedeutet dass, das der MBR/Vektor des Bootlaoders (vermutlich Grub) nicht mehr der auf die Startadresse des Betriebssystems auf der Festplatte zielt.

Das kann eigentlich nur passieren, wenn die Festplatte vollkommen in Ordnung ist, bei einem Update, dass Dateien im Verzeichnis /boot angefaßt hat. Ist vielleicht ein automatisches Update durchgelaufen?






Bewertung: 227 Punkte bei 84 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kein Betriebssystem gefunden
nhv-linux (unangemeldet), Samstag, 10. Januar 2009 18:07:54
Ein/Ausklappen

Bei der Installation musst Du schön aufpassen, dass die Boot-Reihenfolge der Platten im Bios von SuSE bei der Installation des Bootladers auch richtig wiedergibt.
Nach dem 1. Neustart hast Du wahrscheinlich noch eine Chance die Datei /boot/grub/device.map anzusehen, etv. dann mit yast korrigiert.


Bewertung: 177 Punkte bei 154 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Drucker Epson XP-332 unter ubuntu 14.04 einrichten
Andrea Wagenblast, 30.11.2016 22:07, 2 Antworten
Hallo, habe vergeblich versucht mein Multifunktionsgerät Epson XP-332 als neuen Drucker unter...
Apricity Gnome unter Win 10 via VirtualBox
André Driesel, 30.11.2016 06:28, 2 Antworten
Halo Leute, ich versuche hier schon seit mehreren Tagen Apricity OS Gnome via VirtualBox zum l...
EYE of Gnome
FRank Schubert, 15.11.2016 20:06, 2 Antworten
Hallo, EOG öffnet Fotos nur in der Größenordnung 4000 × 3000 Pixel. Größere Fotos werden nic...
Kamera mit Notebook koppeln
Karl Spiegel, 12.11.2016 15:02, 2 Antworten
Hi, Fotografen ich werde eine SONY alpha 77ii bekommen, und möchte die LifeView-Möglichkeit nu...
Linux auf externe SSD installieren
Roland Seidl, 28.10.2016 20:44, 1 Antworten
Bin mit einem Mac unterwegs. Mac Mini 2012 i7. Würde gerne Linux parallel betreiben. Aber auf e...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] WLAN Adressenbereich
"Michael R. Moschner", 02.12.2016 17:54
Am Samstag, 26. November 2016, 00:54:07 schrieb Richard Kraut: Hallo Richard und alle anderen Danke für die...
Re: [EasyLinux-Ubuntu] [erledigt?] xubuntu 16.04: unvollständige_Aktualisierung
Hartmut Haase, 30.11.2016 18:16
Hallo Liste, > 0% [Verbindung mit security.ubuntu.com (2001:67c:1560:8001::11)] wenn man das Ganze lang...
Re: [EasyLinux-Ubuntu] xubuntu_16.04:_unvollständige_Aktualisierung
Hartmut Haase, 30.11.2016 16:28
Hallo Frank, > Habe ich auch gerade? > Root hat noch 3GB frei. ich habe noch knapp 10GB frei. Dara...
Re: [EasyLinux-Ubuntu] Kernel_löschen
Heiko, 30.11.2016 15:26
Am Mittwoch, 30. November 2016, 10:13:05 schrieb Rainer: Hallo , > > Am Wed, 30 Nov 2016 09:54:19...
Re: [EasyLinux-Ubuntu] xubuntu_16.04:_unvollständige_Aktualisierung
Frank von Thun, 30.11.2016 15:05
Am 30.11.2016 um 10:02 schrieb Hartmut Haase: > Hallo Loste, > > wenn ich sudo apt-get update au...