"Kein Betriebssystem gefunden"

Hanno Wiese - Samstag, 10. Januar 2009 15:50:08 - 8 Antworten

Die Meldung "Kein Betriebssystem gefunden" läßt schlimmes befürchten.
Besonders schlimm, wenn das gleich bei zwei völlig unterschiedlichen
Rechnern auftritt, und das jeweils einige Tage nach Neuinstallation von
SuSE 11.1.
Als der Laptop nicht mehr wollte, dachte ich noch an einen Plattencrash
und baute eine neue ein. Danach Komplettneuinstallation von XP und SuSE
11.1, die sich zunächst auch normal benahmen, wie bereits seit 3 Jahren
auf demselben Gerät.
Die gleiche Konfiguration hatte ich auf unserem neuen Familien-Spiele-PC
eingerichtet (einem x86-64-Rechner).
Nach zwei Tagen passierte die Katastrophe zum zweiten Mal: es erschien
zunächst "Kein Betriebssystem gefunden." auf dem Laptop, und am 30.12.
dann auf dem Spiele-PC.
Mit Knoppix waren alle Partitionen ansprechbar, und die Avira-Rescue-CD fand keinen Virus, aber defekte Bootsektoren. Der MBR des Laptops ließ sich mit der SuSE-Reparatur wiederherstellen, für den Spiele-PC gab es eine zweite Neuinstallation. Nach weiteren 3 Tagen das gleiche Spiel ...
Offenbar zerschießt SuSE 11.1 die Bootsektoren.
Jetzt läuft bei mir wieder SuSE 11.0, problemlos, und wird das
auch sicherlich noch eine Weile tun.
Wem ist sowas auch schon passiert, und woran kann's liegen?

Antworten
Supergrubdisk
paulinchen (unangemeldet), Dienstag, 13. Januar 2009 16:27:28
Ein/Ausklappen

Schau dir mal den Link an

http://www.supergrubdisk.org/

Damit kannst du dir ohne eine Neuinstallation behelfen.

T ja das Opensuse solche Probleme hat, ist für mich sehr erstaunlich, aber wenn ich die Probleme nicht auch schon auf mehreren Rechner bei bekannten gesehen hätte würde ich das nicht glauben.


Bewertung: 173 Punkte bei 166 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kein Betriebssystem gefunden
Max (unangemeldet), Dienstag, 13. Januar 2009 13:55:16
Ein/Ausklappen

Du hast sicher unter Yast den Bootloader geöffnet?
Dieser hat einen Bug. Wird dieser geöffnet, auch ohne was zu ändern, zerschiesst es den MBR.
Besser 11.0 noch brauchen, nichts am Bootloader machen und warten bis es einen Patch gibt.


Bewertung: 232 Punkte bei 106 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Kein Betriebssystem gefunden
Hanno (unangemeldet), Dienstag, 13. Januar 2009 19:07:24
Ein/Ausklappen

Ich installiere SuSE seit 7.0 ohne jegliche Eingriffe. Allerdings sortiere ich danach die Bootreihenfolge um, das allerdings auch schon seit einigen Jahren, bisher ohne Probleme. Der Bug muß also wohl neu sein. Immerhin hat sich mein Verdacht bestätigt.
Danke für die Info!



Bewertung: 215 Punkte bei 118 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
kein Betriebssystem gefunden
Dieter (unangemeldet), Sonntag, 11. Januar 2009 23:06:45
Ein/Ausklappen

Wenn kein Betriebssystem gefunden wurde, bedeutet dass, das der MBR/Vektor des Bootlaoders (vermutlich Grub) nicht mehr der auf die Startadresse des Betriebssystems auf der Festplatte zielt.

Das kann eigentlich nur passieren, wenn die Festplatte vollkommen in Ordnung ist, bei einem Update, dass Dateien im Verzeichnis /boot angefaßt hat. Ist vielleicht ein automatisches Update durchgelaufen?



Bewertung: 261 Punkte bei 97 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: kein Betriebssystem gefunden
Hanno Wiese (unangemeldet), Montag, 12. Januar 2009 08:48:43
Ein/Ausklappen

Antwort an Dieter: Der MBR zielte offenbar auf keines der installierten Betriebssysteme mehr. Ich installiere regelmäßig die von SuSE angebotenen Updates. Da das Problem auf zwei völlig unterschiedlichen Rechnern aufgetreten ist, auf dem zweiten sogar 2x, vermute ich den Fehler bei SuSE 11.1 bzw. fehlerhaften Updates und frage mich deshalb, ob das auch bei anderen aufgetreten ist ?!?!?


Bewertung: 226 Punkte bei 115 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: kein Betriebssystem gefunden
Dieter (unangemeldet), Montag, 12. Januar 2009 19:04:16
Ein/Ausklappen

Ich vermute, dass im Verzeichnis /boot bei den Änderungen die Option des Packens von kleinen Dateien beim Dateisystem nicht korrekt abgeschaltet wurde. Ich habe z.B. eine Suse 9.3 und auch 10.1, bei denen genau das im graphischen Mode von yast falsch gemacht wurde und daher kann ich Grub dort nur im Textmode (ohne X11), d.h. nur auf der Konsole gestartet reperieren.

Wenn Du mehrere Partitionen auf der Festplatte hast, dann könntest Du eines der Minilinuxe DSL, Puppy, DeliLinux installieren auf eine der Partitionen, in Zukunft dessen Bootloader verwenden und dort die menu.lst (wenn Du GRUB verwendest) um die anderen Betriebssysteme erweitern.

Das wäre ein Workaround um das Problem. Bei einem anderen Posting vermute ich ein ähnliches Problem. Für Linux-Anfänger ist so etwas nach meiner Ansicht schon ein Show-Stopper und sollte beim internen Softwaretesting eigentlich bereits endeckt werden.




Bewertung: 237 Punkte bei 99 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
"Kein Betriebssystem gefunden"
Dieter (unangemeldet), Sonntag, 11. Januar 2009 23:05:20
Ein/Ausklappen

Wenn kein Betriebssystem gefunden wurde, bedeutet dass, das der MBR/Vektor des Bootlaoders (vermutlich Grub) nicht mehr der auf die Startadresse des Betriebssystems auf der Festplatte zielt.

Das kann eigentlich nur passieren, wenn die Festplatte vollkommen in Ordnung ist, bei einem Update, dass Dateien im Verzeichnis /boot angefaßt hat. Ist vielleicht ein automatisches Update durchgelaufen?






Bewertung: 247 Punkte bei 106 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Kein Betriebssystem gefunden
nhv-linux (unangemeldet), Samstag, 10. Januar 2009 18:07:54
Ein/Ausklappen

Bei der Installation musst Du schön aufpassen, dass die Boot-Reihenfolge der Platten im Bios von SuSE bei der Installation des Bootladers auch richtig wiedergibt.
Nach dem 1. Neustart hast Du wahrscheinlich noch eine Chance die Datei /boot/grub/device.map anzusehen, etv. dann mit yast korrigiert.


Bewertung: 189 Punkte bei 179 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Aktuelle Fragen

Lieber Linux oder Windows- Betriebssystem?
Sina Kaul, 13.10.2017 16:17, 2 Antworten
Hallo, bis jetzt hatte ich immer nur mit
IT-Kurse
Alice Trader, 26.09.2017 11:35, 2 Antworten
Hallo liebe Community, ich brauche Hilfe und bin sehr verzweifelt. Ih bin noch sehr neu in eure...
Backup mit KUP unter Suse 42.3
Horst Schwarz, 24.09.2017 13:16, 3 Antworten
Ich möchte auch wieder unter Suse 42.3 mit Kup meine Backup durchführen. Eine Installationsmöglic...
kein foto, etc. upload möglich, wo liegt mein fehler?
kerstin brums, 17.09.2017 22:08, 5 Antworten
moin, zum erstellen einer einfachen wordpress website kann ich keine fotos uploaden. vom rechne...
Arch Linux Netzwerkkonfigurationen
Franziska Schley, 15.09.2017 18:04, 0 Antworten
Moin liebe Linux community, ich habe momentan Probleme mit der Einstellung des Lan/Wlan in Arc...

Stellenmarkt

Jetzt auf den Mailinglisten

[EasyLinux-Ubuntu] Ubuntu_17.10_hängt_nach_der_Anmeldung
Gerd Pfannenstiel, 20.10.2017 12:22
Hallo, ich wollte mir Ubuntu in der aktuellen Ausgabe 17.10 anschauen. Live startet normal, in der installie...
[EasyLinux-Ubuntu] [OT]_Download_von_Webseiten_ändern_den_Quellcode
Uwe Herrmuth, 20.10.2017 09:29
Hallo Miteinander, ja das Thema ist OT, weil es nicht direkt Linux/Ubuntu betrifft. Da ich aber weder auf e...
Re: [EasyLinux-Ubuntu] Frage_außer_Konkurrenz_zu_Vectoring
Rainer, 19.10.2017 20:16
Hallo Gerhard, Am Thu, 19 Oct 2017 15:04:02 +0200 schrieb Gerhard Eilers : > Hier steht für das 3. Qua...
Re: [EasyLinux-Ubuntu] Frage_außer_Konkurrenz_zu_Vectoring
Frank von Thun, 19.10.2017 19:28
Am 19.10.2017 um 19:12 schrieb Gerhard Eilers: > Hallo Karl-Heinz > Und dem Herrn von der Telekom fie...
Re: [EasyLinux-Ubuntu] Frage_außer_Konkurrenz_zu_Vectoring
Gerhard Eilers, 19.10.2017 19:12
Hallo Karl-Heinz Irgend wie reden wir aneinander vorbei? Nicht das Ergebnis ist für mich von Interesse. Kla...