IMAPAdmin-Modul für Webmin

Autor

Donnerstag, 25. August 2005 16:50:04

Hallo zusammen,

ich habe gerade das IMAP-Admin Modul [1] in der Version 0.8.2 auf einem Webmin 1.220 [2] installiert, zusammen mit dem erforderlichen IMAP::Admin Modul.Für all jene, die dieses Modul nicht kennen: Es erlaubt mir die komfortable Verwaltung der Benutzer des IMAP-Servers, alternativ müßte ich auf der Kommandozeile mit cyradm arbeiten.

Im Konfigurationsdialog habe ich die folgenden Werte eingegeben:

IMAP Server Hostname 192.168.0.106
IMAP Server Port (normally 143)
IMAP Server Admin User cyrus
IMAP Server Admin Password cyrus
Hierarchy Separator .

Der Cyrus-Server läuft, ebenso der Saslauthd, für den Benutzer cyrus habe ich das Passwort mit saslpasswd2 -c cyrus angelegt.

Trotzdem erhalte ich im Webmin stets lediglich die Meldung "Unknown
Mailbox:", /var/log/mail und /var/log/messages enthalten leider keine
Hinweise auf die Ursache des Problems.

Hat einer von Euch dieses Modul erfolgreich installiert und kann mir einen Tipp geben?
Alternativ würde ich auch eine andere Software einsetzen, mit der ich die IMAP-User über einen Browser administrieren kann, nach Möglichkeit ohne die Installation einer zusätzlichen Datenbank.

Danke für jeden Tipp/Hinweis.

Stefan

[1] http://www.nwe.de/develop/
[2] http://www.webmin.com/

Stefan Günther

2 Antworten


Antworten
Re: IMAPAdmin-Modul für Webmin
Stefan Glükler, Donnerstag, 25. August 2005 21:44:35
Ein/Ausklappen

Hallo,

ja, ich verwende diese Kombination auf mehreren Server-Installationen. Das IMAP-Admin Modul ist tückenhaft. Folgendes musst du durchführen, dass es klappen sollte:

Richte mindestens ein User manuell mit dem cyradm ein.
Wichtig: Du musst ihn mit folgendem Schema erstellen (beispiel fuer User stefan)

createmailbox user.stefan

Danach versuche es nochmals mit dem IMAP-Admin Modul. Du wirst zuerst nur eine Mailbox "user" sehen. Drauf klicken, und die User werden angezeigt. Danach funktionieren auch alle Funktionen vom IMAP-Admin Modul, wie erstellen, umdefinieren usw...

Desweiteren würde ich noch in deiner konfiguration folgendes ändern:

Ersetze
IMAP Server Hostname 192.168.0.106

durch
IMAP Server Hostname localhost

Die IP-Adresse 192.168.0.106 ist ehh nicht eine gute Wahl. Sie sollte kein 0 enthalten. Besser waere 192.168.1.106

Viel Spass



Bewertung: 158 Punkte bei 37 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: IMAPAdmin-Modul für Webmin
Stefan Günther, Freitag, 26. August 2005 10:48:29
Ein/Ausklappen

Hallo Stefan,

Danke für die Hinweise, aber das hat bei mir noch nicht funktioniert.
Ich habe das Logging über der Syslog-ng ein wenig aufgebohrt und schon hatte ich Fehlermeldungen, daß die Anmeldung mit den Benutzernamen cyrus nicht funktionierte. Natürlich war das Passwort richtig, aber die Anmeldung klappte erst, nachdem ich für den Benutzer cyrus auch in /etc/shadow ein Passwort angelegt hatte (passwd cyrus) und in der /etc/sysconfig/saslauthd den Parameter

SASLAUTHD_AUTHMECH=pam

auf

SASLAUTHD_AUTHMECH=shadow

umgestellt hatte (Neustart vom saslauthd nicht vergessen).
Insofern ist die Fehlermeldung des Moduls sehr irreführend. "Unknown Mailbox" teilt einem nicht gerade mit, daß die Anmeldung fehlgeschlagen ist.

Gruß,

Stefan



Bewertung: 144 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Suse] Desktop Ordner
"d.blanke@gmx.net", 27.04.2015 17:14
Matthias Müller schrieb: > Am Sonntag, 26. April 2015 schrieb d.blanke@gmx.net: >> Die Frage ist m...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 27.04.2015 12:43
Hallo zusammen, hallo Hartmut, Am Mon, 27 Apr 2015 08:57:18 +0200 schrieb Hartmut Haase : > > >...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 27.04.2015 08:57
Hallo Rainer, > Beim Löschen und der Neuinstallation habe ich (flüchtig) beobachtet, > dass sich hpli...
Re: [EasyLinux-Suse] Desktop Ordner
Matthias Müller, 26.04.2015 23:48
Am Sonntag, 26. April 2015 schrieb d.blanke@gmx.net: > Die Frage ist mir zwar peinlich, aber was solls :)...
[EasyLinux-Suse] Desktop Ordner
"d.blanke@gmx.net", 26.04.2015 21:56
Die Frage ist mir zwar peinlich, aber was solls :) Mein Sohnemann hat mir den Desktop Order gelöscht. Nun hab...