IMAPAdmin-Modul für Webmin

Autor

Donnerstag, 25. August 2005 16:50:04

Hallo zusammen,

ich habe gerade das IMAP-Admin Modul [1] in der Version 0.8.2 auf einem Webmin 1.220 [2] installiert, zusammen mit dem erforderlichen IMAP::Admin Modul.Für all jene, die dieses Modul nicht kennen: Es erlaubt mir die komfortable Verwaltung der Benutzer des IMAP-Servers, alternativ müßte ich auf der Kommandozeile mit cyradm arbeiten.

Im Konfigurationsdialog habe ich die folgenden Werte eingegeben:

IMAP Server Hostname 192.168.0.106
IMAP Server Port (normally 143)
IMAP Server Admin User cyrus
IMAP Server Admin Password cyrus
Hierarchy Separator .

Der Cyrus-Server läuft, ebenso der Saslauthd, für den Benutzer cyrus habe ich das Passwort mit saslpasswd2 -c cyrus angelegt.

Trotzdem erhalte ich im Webmin stets lediglich die Meldung "Unknown
Mailbox:", /var/log/mail und /var/log/messages enthalten leider keine
Hinweise auf die Ursache des Problems.

Hat einer von Euch dieses Modul erfolgreich installiert und kann mir einen Tipp geben?
Alternativ würde ich auch eine andere Software einsetzen, mit der ich die IMAP-User über einen Browser administrieren kann, nach Möglichkeit ohne die Installation einer zusätzlichen Datenbank.

Danke für jeden Tipp/Hinweis.

Stefan

[1] http://www.nwe.de/develop/
[2] http://www.webmin.com/

Stefan Günther

2 Antworten


Antworten
Re: IMAPAdmin-Modul für Webmin
Stefan Glükler, Donnerstag, 25. August 2005 21:44:35
Ein/Ausklappen

Hallo,

ja, ich verwende diese Kombination auf mehreren Server-Installationen. Das IMAP-Admin Modul ist tückenhaft. Folgendes musst du durchführen, dass es klappen sollte:

Richte mindestens ein User manuell mit dem cyradm ein.
Wichtig: Du musst ihn mit folgendem Schema erstellen (beispiel fuer User stefan)

createmailbox user.stefan

Danach versuche es nochmals mit dem IMAP-Admin Modul. Du wirst zuerst nur eine Mailbox "user" sehen. Drauf klicken, und die User werden angezeigt. Danach funktionieren auch alle Funktionen vom IMAP-Admin Modul, wie erstellen, umdefinieren usw...

Desweiteren würde ich noch in deiner konfiguration folgendes ändern:

Ersetze
IMAP Server Hostname 192.168.0.106

durch
IMAP Server Hostname localhost

Die IP-Adresse 192.168.0.106 ist ehh nicht eine gute Wahl. Sie sollte kein 0 enthalten. Besser waere 192.168.1.106

Viel Spass



Bewertung: 155 Punkte bei 38 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: IMAPAdmin-Modul für Webmin
Stefan Günther, Freitag, 26. August 2005 10:48:29
Ein/Ausklappen

Hallo Stefan,

Danke für die Hinweise, aber das hat bei mir noch nicht funktioniert.
Ich habe das Logging über der Syslog-ng ein wenig aufgebohrt und schon hatte ich Fehlermeldungen, daß die Anmeldung mit den Benutzernamen cyrus nicht funktionierte. Natürlich war das Passwort richtig, aber die Anmeldung klappte erst, nachdem ich für den Benutzer cyrus auch in /etc/shadow ein Passwort angelegt hatte (passwd cyrus) und in der /etc/sysconfig/saslauthd den Parameter

SASLAUTHD_AUTHMECH=pam

auf

SASLAUTHD_AUTHMECH=shadow

umgestellt hatte (Neustart vom saslauthd nicht vergessen).
Insofern ist die Fehlermeldung des Moduls sehr irreführend. "Unknown Mailbox" teilt einem nicht gerade mit, daß die Anmeldung fehlgeschlagen ist.

Gruß,

Stefan



Bewertung: 141 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Zu wenig Speicherplatz auf /boot unter MATE
Patrick Obenauer, 25.05.2015 14:28, 0 Antworten
Hallo zusammen, ich habe Ubuntu 14.10 mit MATE 1.8.2 (3.16-37) mit Standardeinstellungen aufgese...
Konsole / Terminal in Linux Mint 17.1 deutsch
Dirk Resag, 09.05.2015 23:39, 12 Antworten
Hallo an die Community, ich habe vor kurzem ein älteres Notebook, Amilo A1650G, 1GB Arbeitsspe...
Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Google Chorme
Heiko, 25.05.2015 19:06
Am Montag, 25. Mai 2015, 16:17:10 schrieb Richard Kraut: Hallo Richard. > Am Montag, den 25.05.2015, 11:...
Re: [EasyLinux-Ubuntu] Google Chorme
Heiko, 25.05.2015 18:28
Am Montag, 25. Mai 2015, 16:17:10 schrieb Richard Kraut: > Am Montag, den 25.05.2015, 11:50 +0200 schrieb...
Re: [EasyLinux-Ubuntu] OT - etwas Mathematik
Richard Kraut, 25.05.2015 18:07
Am Montag, den 25.05.2015, 17:54 +0200 schrieb Rainer: > Warum musst Du > sowas eigentlich hier loswe...
Re: [EasyLinux-Ubuntu] OT - etwas Mathematik
Gerhard Blaschke, 25.05.2015 18:01
Hallo Rainer, jetzt sei mir nicht böse, aber im Augenblick betreibst Du intolerante Prinzipienreiterei. N...
Re: [EasyLinux-Ubuntu] OT - etwas Mathematik
Gerhard Blaschke, 25.05.2015 17:58
Am 25.05.2015 um 17:55 schrieb flecralf: > Am 25.05.2015 um 17:49 schrieb flecralf: >> Am 25.05.20...