Homeverzeichnis auf Server, Probleme mit KDE

Jörg Dreffein - Freitag, 23. November 2012 20:51:22 - 3 Antworten

Ich habe unter OpenSuse 12.2 (x86_64 mit aktuellen Patchen) die home-Verzeichnisse der User auf den Server (läuft mit debian lenny) gelegt.

Server /etc/exports: /home *.meinedomain(rw,sync,no_root_squash,no_subtree_check)
Client /etc/fstab: meinserver:/home /home nfs acl,rsize=8192,wsize=8192,hard,intr 0 0

Das Mounten funktioniert einwandfrei, beim Erstellen von neuen Usern wird aus dem Skeleton das Homeverzeichnis erstellt und auch kopierte home-Verzeichnisse mit korrekter uid werden genutzt. Die User haben in ihrem jew. home-Verzeichnis auch die Berechtigung auf die Dateien zuzugreifen.
Das Problem: Die Desktops unter KDE zeigen nicht die richtigen Symbole an.
Bei neu angelegten Usern wird für die Default-Symbole überall nur das Zahnrad-Symbol verwendet. Ändere ich das Symbol, oder auch mehrere, wird das zuletzt verwendete Symbol bei allen anderen Einträgen der Arbeitsfläche angezeigt.

Ich hoffe, es hat jemand eine Idee, was hier falsch läuft.

Antworten
Ähnliches Setup
Ulf B., Mittwoch, 19. Dezember 2012 12:25:40
Ein/Ausklappen

Hallo Jörg,

ich habe seit ca. 10 Jahren ein ähnliches Setup, was aber insbesondere bei Problemen immer wieder verbessert und angepaßt wurde.

Server (openSUSE 12.2) /etc/exports:
/mnt/nfs4 *(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_check)

Wobei ich neuerdings NFS V4 verwende => dort ist dann unter /mnt/nfs4 das Home Laufwerk (raid mirrored) direkt eingehängt.

Auf dem openSUSE 12.2 Clients habe ich in /etc/fstab:
server:/home /home nfs4 defaults 0 0

Wichtig ist noch, dass auf dem NFS Server auch der NIS/YP oder LDAP server mit den Benutzern läuft. Die Benutzer dürfen dann natürlich nur auf dem Server verwaltet werden.

Ich habe aber streng darauf geachtet, das auf beiden Systemen zudem noch die gleichen Pakete installiert (gleichen Repositories) sind, da es insbesondere bei den Großen Desktops KDE und GNOME immer mal wieder zu Konfigurationsumstellungen kommt. Diese werden aber nur sauber migriert, wenn auf dem Server ebenfalls die gleichen Pakete vorliegen.

Dieses System läuft jetzt eigentlich recht gut, solange keine lokalen Datenbanken verwendet werden (Akonadi, AmaroK, DigiKam, ...). Insbesondere bei KDE können nicht alle Anwendungen mit ~/.config/ und ~/.local/ auf dem Server umgehen. Hier bin ich noch auf der Suche nach einer besseren Lösung. Akonadi läuft jetzt zwar mittlerweile wieder (erfordert aber den Parameter "root_squash" in der /etc/exports). Bei AmaroK läuft die Datenbank deshalb direkt auf dem Server. Nur bei DigiKam habe ich noch keine Richtige Lösung gefunden, da dort eine Datenbank auf einem externen Server noch nicht offiziell unterstützt wurde.

Frohes Fest
Ulf


Bewertung: 209 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Vielleicht ein Problem mit den Rechten bzw. Gruppen
Dieter (unangemeldet), Samstag, 01. Dezember 2012 17:35:23
Ein/Ausklappen


Vermute das könnte ein Problem mit den Rechten bzw. Gruppenzugehörigkeit des Symbole sein. Du könntest die Einträge in den Log-Dateien von KDE nachsehen, ob dort etwas steht.

Im Terminal bzw. auf der Konsole mal eingeben:
id
und im Dateimanager mal alle Rechte nachsehen, auch user und group name.

Diese solltest Du mit den funktionierenden Symbolen vergleichen.

Ich hatte mal eine externe Festplatte als anderer user (dieter2) gemounted und dann hatte ich bei allen Dateien das Zahnradsymbol im Dateimanager (als user dieter1). Das dürfte hier ähnlich sein.



Bewertung: 210 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Vielleicht ein Problem mit den Rechten bzw. Gruppen
AndiDos (unangemeldet), Sonntag, 09. Dezember 2012 20:06:42
Ein/Ausklappen

Hallo,

ich habe das gleiche Problem. Nur sind die home Verzeichnisse auch auf einem openSuse 12.2 Server. Wenn ich mich als User physikalisch am Server anmelde ist mit den Ikons in KDE alles in Ordnung. Wenn ich mich an einem Klient anmelde, sind es Zahnräder. Zumindest auf dem Dashbord und in der Ordneransicht. Direkt auf dem Deskton funktioniert es aber nur wenn als Layout "Arbeitsfläche" eingestellt ist. Die Ordneransicht wäre mir allerdings lieber. Die Dateirechte habe ich kontrolliert, da gibt es keine Probleme, da ich auch NIS verwende. Alle patches habe ich eingespielt und auch schon KDE 4.9 ausprobiert. Wenn ich mich mit einem klient anmelde auf dem openSuse11.3 läuft funktionieren die Ikons.


Bewertung: 201 Punkte bei 24 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Besser arbeiten mit KDE
    Die folgenden Tipps und Tricks helfen Ihnen, auf fremde Dateiserver zuzugreifen oder einen eigenen zu starten. Außerdem gibt es Hinweise zu Konqueror und dem Archivprogramm Ark.
  • Do it yourself
    Wer einen Desktop-PC besitzt, möchte an ihm ungestört arbeiten, statt sich mit der Administration herumzuschlagen. Dass dies nicht immer funktioniert, wissen nicht nur Linux-Nutzer, und so kommt man früher oder später nicht umhin, sich mit den Untiefen des Systems auseinanderzusetzen.
  • Gnome-Tipps
    Gnome ist neben KDE die zweite große Desktopumgebung für Linux. In den Gnome-Tipps stellen wir regelmäßig Nützliches und Praktisches für die alternative grafische Oberfläche vor.
  • Linux-PCs miteinander verknüpfen
    Für viele PC-Benutzer stellt bereits die Administration eines einzigen Rechners eine große Herausforderung dar. Gehören Sie nicht dazu, lesen Sie in diesem Artikel, wie Sie ein komplettes Linux-Netzwerk erstellen.
  • Netzwerk im Gleichschritt
    Zentrales Backup, gemeinsam genutzte Dateien und Drucker – es gibt viele Argumente für einen Samba-Server im lokalen Netzwerk. Wie schnell und einfach Sie diesen aufsetzen, zeigt dieser Artikel.

Aktuelle Fragen

Samba-Server für Win-Daten & Linux-Dateirechte
Gerd Grundmann, 12.01.2017 18:25, 0 Antworten
Hallo Gemeinde, ich habe ewig gegooo.. aber nicht wirklich gefunden, was ich suche. Auf mei...
LM Cinnamon 18.1Serena 64 bit
Herwig Ameisbichler, 11.01.2017 13:02, 6 Antworten
Hallo an alle. Bin Linux Neuling.Habe auf meiner SSD neben W10 (finde ich nicht mehr)LM17.2 auch...
Bilder in E-Mail einbinden?
Werner Hahn, 23.12.2016 12:18, 4 Antworten
Dell Latitude E6510, Ubuntu 16.04, Mozilla Firefox Ich bitte um eine leicht verständliche Anle...
Linux Mint 17.2
Herwig Ameisbichler, 17.12.2016 11:19, 4 Antworten
Wer kann mir helfen? Hab seit gestern Linux am Pc.Wie kann ich diese Miniaturschrift im Menü,Lei...
Linux 17.2 Treiber f. PC Drucker installieren
Ernst Malitzki, 11.12.2016 13:04, 7 Antworten
Habe einen PC Drucker von HP. Möchte diesen PC Drucker an meinen PC anschließen. Hierzu benötige...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Ubuntu 16.04: seltsames Verhalten beim Zugriff auf ftp-Server
Rainer, 24.01.2017 16:22
Am Tue, 24 Jan 2017 15:09:10 +0100 schrieb Frank von Thun : > > > >>> Richtig ist: &g...
Re: [EasyLinux-Ubuntu] Ubuntu 16.04: seltsames Verhalten beim Zugriff auf ftp-Server
Frank von Thun, 24.01.2017 15:09
Am 24.01.2017 um 14:44 schrieb Frank von Thun: > Am 24.01.2017 um 13:20 schrieb Rainer: >> Hallo F...
Re: [EasyLinux-Ubuntu] Ubuntu 16.04: seltsames Verhalten beim Zugriff auf ftp-Server
Frank von Thun, 24.01.2017 14:44
Am 24.01.2017 um 13:20 schrieb Rainer: > Hallo Frank, > > Am Tue, 24 Jan 2017 12:14:39 +0100 &...
Re: [EasyLinux-Ubuntu] Ubuntu 16.04: seltsames Verhalten beim Zugriff auf ftp-Server
Rainer, 24.01.2017 13:20
Hallo Frank, Am Tue, 24 Jan 2017 12:14:39 +0100 schrieb Frank von Thun : > > ftp://@irgendwas.de/...
Re: [EasyLinux-Ubuntu] Ubuntu 16.04: seltsames Verhalten beim Zugriff auf ftp-Server
Rainer, 24.01.2017 13:15
Hallo Uwe, Am Tue, 24 Jan 2017 11:59:12 +0100 schrieb Uwe Herrmuth : > > > > geht alles üb...