Homeverzeichnis auf Server, Probleme mit KDE

Jörg Dreffein - Freitag, 23. November 2012 20:51:22 - 3 Antworten

Ich habe unter OpenSuse 12.2 (x86_64 mit aktuellen Patchen) die home-Verzeichnisse der User auf den Server (läuft mit debian lenny) gelegt.

Server /etc/exports: /home *.meinedomain(rw,sync,no_root_squash,no_subtree_check)
Client /etc/fstab: meinserver:/home /home nfs acl,rsize=8192,wsize=8192,hard,intr 0 0

Das Mounten funktioniert einwandfrei, beim Erstellen von neuen Usern wird aus dem Skeleton das Homeverzeichnis erstellt und auch kopierte home-Verzeichnisse mit korrekter uid werden genutzt. Die User haben in ihrem jew. home-Verzeichnis auch die Berechtigung auf die Dateien zuzugreifen.
Das Problem: Die Desktops unter KDE zeigen nicht die richtigen Symbole an.
Bei neu angelegten Usern wird für die Default-Symbole überall nur das Zahnrad-Symbol verwendet. Ändere ich das Symbol, oder auch mehrere, wird das zuletzt verwendete Symbol bei allen anderen Einträgen der Arbeitsfläche angezeigt.

Ich hoffe, es hat jemand eine Idee, was hier falsch läuft.

Antworten
Ähnliches Setup
Ulf B., Mittwoch, 19. Dezember 2012 12:25:40
Ein/Ausklappen

Hallo Jörg,

ich habe seit ca. 10 Jahren ein ähnliches Setup, was aber insbesondere bei Problemen immer wieder verbessert und angepaßt wurde.

Server (openSUSE 12.2) /etc/exports:
/mnt/nfs4 *(fsid=0,crossmnt,rw,root_squash,sync,no_subtree_check)

Wobei ich neuerdings NFS V4 verwende => dort ist dann unter /mnt/nfs4 das Home Laufwerk (raid mirrored) direkt eingehängt.

Auf dem openSUSE 12.2 Clients habe ich in /etc/fstab:
server:/home /home nfs4 defaults 0 0

Wichtig ist noch, dass auf dem NFS Server auch der NIS/YP oder LDAP server mit den Benutzern läuft. Die Benutzer dürfen dann natürlich nur auf dem Server verwaltet werden.

Ich habe aber streng darauf geachtet, das auf beiden Systemen zudem noch die gleichen Pakete installiert (gleichen Repositories) sind, da es insbesondere bei den Großen Desktops KDE und GNOME immer mal wieder zu Konfigurationsumstellungen kommt. Diese werden aber nur sauber migriert, wenn auf dem Server ebenfalls die gleichen Pakete vorliegen.

Dieses System läuft jetzt eigentlich recht gut, solange keine lokalen Datenbanken verwendet werden (Akonadi, AmaroK, DigiKam, ...). Insbesondere bei KDE können nicht alle Anwendungen mit ~/.config/ und ~/.local/ auf dem Server umgehen. Hier bin ich noch auf der Suche nach einer besseren Lösung. Akonadi läuft jetzt zwar mittlerweile wieder (erfordert aber den Parameter "root_squash" in der /etc/exports). Bei AmaroK läuft die Datenbank deshalb direkt auf dem Server. Nur bei DigiKam habe ich noch keine Richtige Lösung gefunden, da dort eine Datenbank auf einem externen Server noch nicht offiziell unterstützt wurde.

Frohes Fest
Ulf


Bewertung: 220 Punkte bei 34 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
Vielleicht ein Problem mit den Rechten bzw. Gruppen
Dieter (unangemeldet), Samstag, 01. Dezember 2012 17:35:23
Ein/Ausklappen


Vermute das könnte ein Problem mit den Rechten bzw. Gruppenzugehörigkeit des Symbole sein. Du könntest die Einträge in den Log-Dateien von KDE nachsehen, ob dort etwas steht.

Im Terminal bzw. auf der Konsole mal eingeben:
id
und im Dateimanager mal alle Rechte nachsehen, auch user und group name.

Diese solltest Du mit den funktionierenden Symbolen vergleichen.

Ich hatte mal eine externe Festplatte als anderer user (dieter2) gemounted und dann hatte ich bei allen Dateien das Zahnradsymbol im Dateimanager (als user dieter1). Das dürfte hier ähnlich sein.



Bewertung: 238 Punkte bei 35 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: Vielleicht ein Problem mit den Rechten bzw. Gruppen
AndiDos (unangemeldet), Sonntag, 09. Dezember 2012 20:06:42
Ein/Ausklappen

Hallo,

ich habe das gleiche Problem. Nur sind die home Verzeichnisse auch auf einem openSuse 12.2 Server. Wenn ich mich als User physikalisch am Server anmelde ist mit den Ikons in KDE alles in Ordnung. Wenn ich mich an einem Klient anmelde, sind es Zahnräder. Zumindest auf dem Dashbord und in der Ordneransicht. Direkt auf dem Deskton funktioniert es aber nur wenn als Layout "Arbeitsfläche" eingestellt ist. Die Ordneransicht wäre mir allerdings lieber. Die Dateirechte habe ich kontrolliert, da gibt es keine Probleme, da ich auch NIS verwende. Alle patches habe ich eingespielt und auch schon KDE 4.9 ausprobiert. Wenn ich mich mit einem klient anmelde auf dem openSuse11.3 läuft funktionieren die Ikons.


Bewertung: 224 Punkte bei 33 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Besser arbeiten mit KDE
    Die folgenden Tipps und Tricks helfen Ihnen, auf fremde Dateiserver zuzugreifen oder einen eigenen zu starten. Außerdem gibt es Hinweise zu Konqueror und dem Archivprogramm Ark.
  • Do it yourself
    Wer einen Desktop-PC besitzt, möchte an ihm ungestört arbeiten, statt sich mit der Administration herumzuschlagen. Dass dies nicht immer funktioniert, wissen nicht nur Linux-Nutzer, und so kommt man früher oder später nicht umhin, sich mit den Untiefen des Systems auseinanderzusetzen.
  • Gnome-Tipps
    Gnome ist neben KDE die zweite große Desktopumgebung für Linux. In den Gnome-Tipps stellen wir regelmäßig Nützliches und Praktisches für die alternative grafische Oberfläche vor.
  • Linux-PCs miteinander verknüpfen
    Für viele PC-Benutzer stellt bereits die Administration eines einzigen Rechners eine große Herausforderung dar. Gehören Sie nicht dazu, lesen Sie in diesem Artikel, wie Sie ein komplettes Linux-Netzwerk erstellen.
  • ISOliert? Von wegen!
    Einmal erstellte ISO-Images – egal ob selbst gebaut oder aus dem Internet herunter geladen – lassen sich nicht mehr verändern. Oder doch? ISO Master löst das Problem.

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Virtualbox krieg ich nicht hin
Nguyen Dong Loan, 17.09.2017 17:12
Am Sonntag, den 17.09.2017, 12:58 +0200 schrieb Werner und Dagmar Engelhardt: > Hallo Liste, > &...
[EasyLinux-Ubuntu] Virtualbox krieg ich nicht hin
Werner und Dagmar Engelhardt, 17.09.2017 12:58
Hallo Liste, ich verwende Mint 18. Die V-Box hab ich aus der Anwendungsverwaltung installiert. Extensions P...
Re: [EasyLinux-Ubuntu] Claws Mail: Chaos bei den Regeln
Rainer, 16.09.2017 09:42
Hallo Roman, Am Sat, 16 Sep 2017 00:23:11 +0200 schrieb Roman Brusa : > > Da hast du wohl eine u...
Re: [EasyLinux-Ubuntu] Claws Mail: Chaos bei den Regeln
Roman Brusa, 16.09.2017 00:23
Hi, Rainer schrieb am Fri, 15 Sep 2017 17:12:05 +0200: >Passiert ist nun, dass eingehende Mails weder im P...
[EasyLinux-Ubuntu] Claws Mail: Chaos bei den Regeln
Rainer, 15.09.2017 17:12
Hallo zusammen, die Struktur bei den Regeln von CM war schon immer ziemlich verwirrend für mich, aber jetzt...

Aktuelle Fragen

Backup mit KUP unter Suse 42.3
Horst Schwarz, 24.09.2017 13:16, 1 Antworten
Ich möchte auch wieder unter Suse 42.3 mit Kup meine Backup durchführen. Eine Installationsmöglic...
kein foto, etc. upload möglich, wo liegt mein fehler?
kerstin brums, 17.09.2017 22:08, 5 Antworten
moin, zum erstellen einer einfachen wordpress website kann ich keine fotos uploaden. vom rechne...
Arch Linux Netzwerkkonfigurationen
Franziska Schley, 15.09.2017 18:04, 0 Antworten
Moin liebe Linux community, ich habe momentan Probleme mit der Einstellung des Lan/Wlan in Arc...
WLan mit altem Notebook funktioniert nicht mehr
Stefan Jahn, 22.08.2017 15:13, 0 Antworten
Ich habe ein altes Compaq-6710b Notebook mit Linux Mint Sonya bei dem WLan neulich noch funktioni...
Würde gerne openstreetmap.de im Tor-Browser benutzen, oder zu gefährlich?
Wimpy *, 21.08.2017 13:24, 2 Antworten
Im Tor-Netzwerk (Tor-Browser) kann ich https://www.openstreetmap.de/karte.html# nicht nutzen....