Gestörter Sound am Mikrofoneingang

Autor

Mittwoch, 08. Januar 2014 13:28:50

Hallo zusammen,

Nachdem ich vor einiger Zeit einen meiner ThinClients (Futro A240, mit AMD Geode Chipsatz CS5536) von Debian Lenny auf Wheezy geupgraded habe, habe ich ein größeres Problem am sound system des Gerätes. Dies äußert sich darin, dass ein Signal welches vom MIC eingang aufgenommen wird keine Tiefen enthält sind und der Rest mehr an das quietschen eines A/D wandlers erinnert aber nicht an eine Stimme die etwas spricht. Selbst ohne eingestecktes Mikrofon ist etwas zu hören und auch wenn ich alle Regler im alsamixer auf 0 drehe (Capture, MIC, PCM usw.; MIC BOOST ist sowieso deaktiviert).

Was ich dann nach dem Update erst mal getan habe ist das geupdatete System in einen Baugleichen (hab ja ein paar von den Rechnern rumstehn) Rechner zu stecken um zu sehen ob der Rechner zufällig hops gegangen ist. Im zweiten Rechner hatte ich aber das gleiche Problem. Nach noch einem Test in einem dritten Rechner kann ich jetzt mit ziemlicher Sicherheit ausschließen, dass es an der Hardware liegt.

Später habe ich den alten Kernel wieder installiert (welcher duch das update deinstalliert wurdem, es wurde 3.2 installiert). Bei diesem Kernel handelte es sich um 2.6.32-39 in der version für ohne PAE (wird in debian unter 486 geführt). Dieser Kernel lief vorher ohne probleme. Systeme mit Kernel > 2.6.32-39 liefen allerdings schon nicht mehr. Die installation dieses Kernels brachte jedoch leider keine Lösung des Problems. Da ich keine zusätzlichen sound server wie Pulse oder ESD installiert habe wird der Sound nur von Alsa und den Kerneltreibern verarbeitet.

Meine Frage ist nun woran kann es liegen, dass nach einem update plötzlich dieses Problem auftrit, es jedoch auf Systemen welche nicht geupdatet wurden das Problem nicht vorhanden ist. Welche Software außer Alsa und dem Kernel haben noch mit der Soundverarbeitung zu tun?

Falls noch infos fehlen bitte ich diese zu erfragen, ansonsten bin ich über jeden Tipp der zur Lösung des Problems führt dankbar.

Mit freundlichen Grüßen

Martin

Martin Burkhardt

1 Antworten


Antworten
Re: Gestörter Sound am Mikrofoneingang
GoaSkin , Sonntag, 19. Januar 2014 17:50:51
Ein/Ausklappen

In deinem Falle gibt es keine weiteren Schnittstellen neben dem Kernel und ALSA, die etwas mit der Soundverarbeitung zu tun haben.

Von der Fehlerbeschreibung sieht mir das einwenig so aus, als ob die Soundkarte anders parametrierte Audio-Daten benötigt, als ihr die Software liefert. Dies ist häufig darauf zurückzuführen, dass der Audio-Treiber falsche Tatsachen ausgibt (z.B. Soundkarte läuft im 48KHZ-Modus und der Treiber bereitet aber 44.1KHz; denkbar ist auch, dass die Eigenschaften zum Signalpegel inkorrekt dargestellt werden).

Du solltest vielleicht einmal ALSA aus einer alternativen Quelle installieren oder die Betriebsdaten, die Analyse-Tools anzeigen, zwischen einer funktionierenden und einer nicht funktionierenden Umgebung vergleichen.


Bewertung: 130 Punkte bei 25 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

  • Multitracker im Eigenbau mit Linux
    Zahlreiche Nachwuchs-Bands geben täglich Unmengen an Geld aus, um an halbwegs brauchbare Demo-Aufnahmen zu kommen. In diesem Artikel möchten wir zeigen, wie Sie unter Linux preiswerter produzieren können.
  • Multitracker im Eigenbau mit Linux
    Zahlreiche Nachwuchs-Bands geben täglich Unmengen an Geld aus, um an halbwegs brauchbare Demo-Aufnahmen zu kommen. In diesem Artikel möchten wir zeigen, wie Sie unter Linux preiswerter produzieren können.
  • Sound-Systeme unter Linux
    Um Linux optimale Töne zu entlocken, müssen eine ganze Reihe von Software-Komponenten zusammenspielen. Wir zeigen, welche.
  • Mehrkanalton mit Linux
    Wer sein Linux liebt, gönnt ihm teure Hardware. Nicht so bei Soundkarten: Hier funktionieren die günstigen Modelle meistens besser.
  • Drei USB-Soundkarten im Test
    Immer mehr Notebooks bringen einen Breitbildschirm im Format 16:9 mit, der zum Anschauen von DVD-Filmen geradezu verlockt. Was fehlt, ist hingegen der Support für satten 5.1 Surround-Sound. Den bieten USB-Soundkarten.

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 2 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 1 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:35
und sogar mit Opera :-) -- Viele Grüße, Hartmut Hungerhilfe: http://www.thehungersite.com Ohne Zensu...
Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:32
Hallo Heiko, > Da Du ein anderes Java (proprietär) verwendest nebst anderem Plugin > fehlt natürlich...
Re: [EasyLinux-Ubuntu] QR-Code Generator
Alexander McLean, 05.07.2015 10:12
Am Freitag, 3. Juli 2015, 18:58:52 schrieb Richard Kraut: Hallo Richi > Auf die Schnelle habe ich no...
Re: [EasyLinux-Ubuntu] Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:33
Am Freitag, 3. Juli 2015, 10:42:53 schrieb Hartmut Haase: Hallo Hartmut, > > > Man kann aberdas...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:28
Am Donnerstag, 2. Juli 2015, 11:01:20 schrieb Hartmut Haase: Hallo Hartmut, > > > Ist denn iced...