GRUB, S-ATA und Linux

Autor

Sonntag, 16. Juli 2006 18:34:32

Hallo ,
ich weiss nicht genau, ob ich hier richtig bin, aber ich versuch`s mal
Ich habe ein Problem und bitte um eure Hilfe..
Ein Freund hat mir einen neuen Rechner gebaut. Bisher hatte ich normale Festplatten (eine für Windows und eine für Suse 9.3) Das klappte auch alles hervorragend. Im neuen Rechner (Athlon 64) wollte ich jedoch etwas fortschriftliches haben und es wurden S-ATA Platten eingebaut (eine WD Caviar SE WD 400 JD mit 4o GB für Win und die gleiche für Linux 10.0) Leider hat er die eine Festplatte verkauft und dafür eine Seagate eingebaut.Da mir die Seagate zu klein war, habe ich eine WD Caviar SE 1200 JD gekauft und stattdessen eingebaut. Und nun kommst: Beim Installieren von Linux öffnete sich ein Fenster mit der Meldung: Broken Raid 1 . Also wieder die Seagate eingebaut. Da gibt es jetzt folgendes Problem: Windows XP (32-bit Version) kann auf der ersten Festplatte , Linux (64-bit-Version) auf die zweite Festplatte installiert werden. Nachdem Linux komplett installiert wurde, kommt die Frage: Rechner herunterfahren Ja/Nein. Ich bestätige:ja. Beim Hochfahren des Rechners ist ein schwarzer Bildschirm wo angezeigt wird, welches Board im Rechner ist, wieviel RAM usw. Als vorletzte Zeile steht dort: Veryfing............Data Und darunter steht: GRUB Loader Stage 1.5 Und dort bleibt der Rechner stehen. Es passiert rein garnichts. Wieso GRUB 1.5?? Ich denke es gibt nur GRUB 1 und GRUB 2 ? Windows kann ohne die 2.Festplatte gestartet werden. Linux nur mit eingelegter DVD. Werden die S-ATA Festplatten in einen anderen Rechner, mit einem anderen Board eingebaut läuft alles so wie es sein soll. Schliessen wir an meinen Rechner die normalen (Eide-)Platten an, klappt es auch.
Es haben sich schon mehrer Fachleute daran die Zähne ausgebissen. Nun wollen wir als letzte Möglichkeit das Board wechseln.Vielleicht ist doch der RAID Controller defekt ? Wobei es ein Problem gibt. Es können nur (von der Grösse her) bestimmte Boards eingebaut werden, da wir ein G5-Gehäuse umgebaut haben (Sieht einfach geil aus !!) Kennt jemand dieses Problem und kann mir helfen ??
Mein Rechner ist bestückt mit:
64-bit DFI Board mit Via drauf
2 S-ATA Platten : WD Caviar SE 400 und Seagate
1 DVD-Brenner
Danke
Wolfgang

Wolfg. Tiedemann

2 Antworten


Antworten
Re: GRUB, S-ATA und Linux
Ugglan , Montag, 17. Juli 2006 10:33:34
Ein/Ausklappen

Hallo,

> [...] öffnete sich ein Fenster mit der Meldung: Broken Raid 1

Kann es sein, daß Dein Mainboard die zwei Festplatten als Raid-Verbund betrachtet oder betrachten will?

Ein Raid ist eine virtuelle Festplatte, die physikalisch aus mehreren besteht und die Daten zwischen diesen aufteilt, um entweder höhere Performanz und Kapazität oder Ausfallsicherheit durch Spiegelung der Daten zu erreichen. Dem Betriebssystem gegenüber verhält sich so ein Raid wie eine einzige Festplatte.

Die meisten Mainboards bringen so eine Raid-Funktion als Schmankerl mit, allerdings läuft es meist nur unter Windows.

Schau mal nach, ob im Bios (beim SATA-Controller) irgendwelche Raid-Einstellungen gesetzt sind.

*Vorsicht!* Wenn Du die Raid-Einstellungen änderst, könnten Deine Dateisysteme nicht mehr erkannt werden. Also nicht mit ungesicherten Nutzdaten ausprobieren!

Falls es die Raid-Einstellungen waren, machst Du am besten ein Backup auf Dateisystem-Ebene, formatierst die Platten ohne Raid neu, spielst das System zurück und installierst den Bootloader neu (Deine Installations-CD sollte eine entsprechende Funktion bieten).

Ob und wie eine Sicherung auf Dateisystem-Ebene unter Windows funktionert, weiß ich aber nicht, da mußt Du einen Windows-Experten fragen.

Viele Grüße,

Ugglan


Bewertung: 185 Punkte bei 22 Stimmen.
Den Beitrag bewerten: Gut / Schlecht
-
Re: GRUB, S-ATA und Linux
Wolfg. Tiedemann, Freitag, 21. Juli 2006 20:24:06
Ein/Ausklappen

Hallo Ugglan,
herzlichen Dank für deine Antwort!
Wir haben das Problem jetzt anders (und erfolgreich!) gelöst! Neues Motherboard
DFI Infinity RS 482 eingebaut, die 120GB-Festplatte mit WinXP NTFS formatiert und schon hat Suse 10.1 das Teil als 120GB Festplatte erkannt! Bei der Installation manuell die 120 GB Platte als für Linux bestimmt und lief es! XP auf der 40 GB und Suse auf der 120 GB und ich habe meinen GRUB Loader! Einfach herrlich wenns funktioniert!!
Bis zu nächsten Frage
Tschau aus Hamburg
Wolfgang


Bewertung: 128 Punkte bei 23 Stimmen.
Den Beitrag bewerten: Gut / Schlecht

Ähnliche Artikel

Stellenanzeigen

System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)


Senior-System–Administrator (m/w)
IT-Systemadministrator

Mehr erfahren...
(Vollständige Anzeige auf Linux-Magazin Online)

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Fernwartung oder wartung im haus
heide marie voigt, 29.06.2015 10:37, 2 Antworten
gerne hätte ich jemanden in Bremen nord, der mir weiter hilft - angebote bitte mit preis HMVoigt
Druckeranschluss DCP-195C
heide marie voigt, 29.06.2015 10:35, 1 Antworten
installiert ist linux ubuntu 15.04 offenbar auch der treiber für den Drucker DCP-195C. Die Konta...
keine arbeitsleiste beim einloggen
heide marie voigt, 27.06.2015 13:31, 0 Antworten
seit der neu-installierung von linux ubuntu 15.04 erscheint die arbeitsleiste rechts oben erst na...
raid platte an linux mint 17.1
andreas schug, 23.06.2015 19:44, 1 Antworten
folgende thematik NAS Iomega Storage Center wird auf einmal nicht mehr im netzwerk erkannt .....
SUSE 13.2 - Probleme mit kmail
kris kelvin, 03.06.2015 13:26, 2 Antworten
Hallo, nach dem Umstieg auf 13.1 hatte ich das Problem, daß kmail extrem langsam reagierte. Nun...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:35
und sogar mit Opera :-) -- Viele Grüße, Hartmut Hungerhilfe: http://www.thehungersite.com Ohne Zensu...
Re: [EasyLinux-Ubuntu] []gelöst_Opera_öffnet_Seite_nicht
Hartmut Haase, 05.07.2015 10:32
Hallo Heiko, > Da Du ein anderes Java (proprietär) verwendest nebst anderem Plugin > fehlt natürlich...
Re: [EasyLinux-Ubuntu] QR-Code Generator
Alexander McLean, 05.07.2015 10:12
Am Freitag, 3. Juli 2015, 18:58:52 schrieb Richard Kraut: Hallo Richi > Auf die Schnelle habe ich no...
Re: [EasyLinux-Ubuntu] Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:33
Am Freitag, 3. Juli 2015, 10:42:53 schrieb Hartmut Haase: Hallo Hartmut, > > > Man kann aberdas...
Re: [EasyLinux-Ubuntu] [erledigt]_Opwera_öffnet_Seite_nicht
heiko, 03.07.2015 19:28
Am Donnerstag, 2. Juli 2015, 11:01:20 schrieb Hartmut Haase: Hallo Hartmut, > > > Ist denn iced...