Firewire Audio-Interface mit ALSA statt FFADO nutzbar?

Autor

Sonntag, 17. Juni 2012 21:28:20

Hallo,

da ich mich auch mit Musikproduktion beschäftige, hatte ich mir einmal eine ALESIS IO|26 zugelegt.

Das Firewire-Audio Interface wird durch den FFADO-Treiber zwar wunderbar unterstützt, doch ist die Nutzung dieser Treiberschnittstelle eigentlich ein ziemlicher Krampf, da der Treiber einzig mit Jack nutzbar ist.

Um die Karte auch zur Standard-Ausgabe zu nutzen, nutze ich derzeit die unelegante Methode, nach dem Login im Window-Manager ein Skript auszuführen, dass Pulseaudio beendet, Jack startet, dann Pulse-Audio mit einer Jack-Bridge als Backend neu startet und diese als Standard-Soundkarte einrichtet.

Aber zum einen schlägt diese Prozedur aufgrund von Timing-Problemen oder besonderer Systemzustände in Einzelfällen schief. Und zum anderen gibt es unter WINE dank jüngster Änderungen keine Chance mehr, für die Tonausgabe der Windows-Programme eine andere Treiberschnittstelle als ALSA zu nutzen (lediglich Windows-Programme, die die ASIO-Schnittstelle nutzen können auf JACK zugreifen).

Ich habe im Netz einwenig recherchiert und einen wagen Hinweis darauf gefunden, dass mittlerweile auch ALSA Firewire Interfaces unterstützen soll, wenn man es aus dem GIT Repository heraus neu compiliert.

Weiss da jemand näheres dazu? Mich würde vor allem interessieren, ob ALSA alle Karten unterstützt, die FFADO auch unterstützt oder die Firewire-Unterstützung eher rudimentär ist.

Schließlich würde eine ziemliche Bastelei bevorstehen, die ich lieber sein lasse, falls es keine berechtigten Erfolgsaussichten gibt.

GoaSkin

0 Antworten


Antworten

Ähnliche Artikel

Tipp der Woche

Grammatikprüfung in LibreOffice nachrüsten
Grammatikprüfung in LibreOffice nachrüsten
Tim Schürmann, 24.04.2015 19:36, 0 Kommentare

LibreOffice kommt zwar mit einer deutschen Rechtschreibprüfung und einem guten Thesaurus, eine Grammatikprüfung fehlt jedoch. In ältere 32-Bit-Versionen ...

Aktuelle Fragen

Admin Probleme mit Q4os
Thomas Weiss, 30.03.2015 20:27, 6 Antworten
Hallo Leute, ich habe zwei Fragen zu Q4os. Die Installation auf meinem Dell Latitude D600 verl...
eeepc 1005HA externer sound Ausgang geht nicht
Dieter Drewanz, 18.03.2015 15:00, 1 Antworten
Hallo LC, nach dem Update () funktioniert unter KDE der externe Soundausgang an der Klinkenbuc...
AceCad DigiMemo A 402
Dr. Ulrich Andree, 15.03.2015 17:38, 2 Antworten
Moin zusammen, ich habe mir den elektronischen Notizblock "AceCad DigiMemo A 402" zugelegt und m...
Start-Job behindert Bootvorgang, Suse 13.2, KDE,
Wimpy *, 20.02.2015 10:32, 4 Antworten
Beim Bootvorgang ist ein Timeout von 1 Min 30 Sec. weil eine Partition sdb1 gesucht und nicht gef...
Konfiguration RAID 1 mit 2 SSDs: Performance?
Markus Mertens, 16.02.2015 10:02, 6 Antworten
Hallo! Ich möchte bei einer Workstation (2x Xeon E5-2687Wv3, 256GB RAM) 2 SATA-SSDs (512GB) al...

Jetzt auf den Mailinglisten

Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 23.04.2015 18:08
Hallo Rainer, mit meinem xubuntu 14.04 benutze ich simple scan 3.12.1 und hplip 3.15.4. Diese Version beko...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 23.04.2015 12:05
Hallo Hartmut, Am Wed, 22 Apr 2015 10:10:51 +0200 schrieb Hartmut Haase : > > > Also ohne auc...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Hartmut Haase, 22.04.2015 10:10
Hallo Rainer, > Also ohne auch nur den Hauch einer Idee, was hier faul sein könnte, > bleibt es ein r...
Re: [EasyLinux-Ubuntu] Xsane und Simple Scan: Probleme bei mehrseitigen Dokumenten
Rainer, 21.04.2015 20:14
Hallo Hartmut, Am Tue, 21 Apr 2015 09:21:48 +0200 schrieb Hartmut Haase : > > HPLIP ist hier in Bet...
Re: [EasyLinux-Ubuntu] Nvidia X740XL
Richard Kraut, 21.04.2015 19:02
Am Dienstag, den 21.04.2015, 01:08 +0200 schrieb Gerhard Blaschke: > Irrtum. Kam allerdings nicht gleich,...